locked
How can I get an app Id for a windows service application RRS feed

  • Question

  • The problem is when I try to get an application id for my windows service application.
    First, to make test on my localhost, and then to run in a server machine.
    What kind of domain name and final url is suposed i must type??

    Thanx to all.
    Thursday, March 27, 2008 1:04 PM

Answers

All replies

  • More data...
    I've get an appId typing "http://localhost" in the final url input, and leaving empty the domain name.
    But, but, but... when I test the application the result is: "Invalid value for AppID in request"!!!!

    Is it because I make the request from a service/console application??

    Thanx again!!
    Thursday, March 27, 2008 2:37 PM
  • Hi.

     

    What kind of app id do you want? If you want to get an application id for Live Search API, you can get at here,

    http://search.msn.com/developer (but, now can't access)

     

    Sunday, March 30, 2008 12:03 PM
  •  

    Hi,

     

    I will ad my vote to the frustration: how do we register for app-id's ? Both http://search.msn.com/developer and http://search.live.com/developer pages (referenced by the Getting Started article) does not exist!

     

    I'm talking about the appid key required to do requests to the Live Search api.

    Tuesday, April 1, 2008 1:21 PM
  • ok, I figured it out. Had to make sure I was signed out from Live and then go to http://search.live.com/developer. Weirdest thing...

    Tuesday, April 1, 2008 7:51 PM
  • First of all, thanx for answer...

    Both url are currently unavailable for me (maybe people from usa can acces, but I don't <<http://www.bokebb.com/dev/english/2034/posts/203418604.shtml>>). I've tryied even to change my IE configuration, etc, but still being imposible.

    The other cuestion, is: what kind of app id's I'm getting?
    To get the app id's commented before, I go to the 'Live Id Page' <<
    https://msm.live.com/app/manage.aspx>> and click on "Register an application" from the 'Application Center' group menu.

    Are these id's valids to conect to live search api??

    Well, that's all at the moment. Sorry the color change, and I apologise my English.

    Regards &... thanx again!
    Wednesday, April 2, 2008 7:15 AM
  • I accessed the pages from Norway so it should'nt be restricted to the US (why would they??). Have you tried my "sign out from Live" trick? Go to for instance www.live.com and make sure you sign out, then go to http://search.live.com/developer. Weird as it sounds, this solved the problem for me.

     

    And for the id's, you should not confuse appid for Live ID API and Live Search API. These are two different services and have separate types of appids.

    Wednesday, April 2, 2008 7:30 AM
  • Koperniko,

     

    The URL, http://msn.live.com/app, is for Live ID SDKs. Those application IDs can't use for Live Search API.

     

    I can't access a developer site for Live Search, too.

    Wednesday, April 2, 2008 11:32 AM
  • Thanx to solve the problem about the difference between Live Id and Live search.

    But, I'm still 'closed' in getting the app id accesing to <<http://search.live.com/developer>> because the url doesn't work, neither trying the 'sign out' trick, neither the 'change ie language' trick.

    Has somebody a 'definitive' trick???


    Thursday, April 3, 2008 4:20 PM
  • I'm also having trouble accessing http://search.live.com/developer. Got through briefly once, but then it put me into a loop of failed logins before giving up. Now I just get page not found.

    Any idea if this is a transient problem or is it permanently bust? Need to knock something up quick and don't want to waste time F5ing this page.

    Cheers

    Dave
    Friday, April 4, 2008 9:08 AM
  • Try to use http://search.live.com/developer?mkt=en-us - there is a bug with the non-US market detection
    Friday, April 4, 2008 6:13 PM
  • Thank you!!

    At least a solution!
    Monday, April 7, 2008 1:22 PM
  • hi I have the same problem with me here.i got app Id from http://search.live.com/developer but it not working.i get an error Invalid value for AppID in request.hope some one can help me out.thanks in advance
    Wednesday, December 17, 2008 4:21 AM