none
Configure AAD Sync: Element 'ma-run-data' was not found

    Question

  • Configure AAD Sync

    "An error occurred executing Configure AAD Sync task: Element 'ma-run-data' was not found. Line 1, position 2."

    I get this error when I try to configure AAD connect client on my domain controller.  It was working before but when I tried to configure SSO it began to give me this error.  I tried step back and disable SSO again but it keeps giving me this error and the sync service doesn't work.  It seems to be referring to some log file that has no data.

    Any ideas?

    Tuesday, August 8, 2017 12:25 PM

Answers

All replies

  • You may refer to this similar discussion and check the Andreas Kjellman's response here and you may also refer to the diagnostic cmdlet to see if it helps, the cmdlet is available here
    --------------------------------------------------------------------------------------------------- 
    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.
    Tuesday, August 8, 2017 2:34 PM
    Moderator
  • I did a little debugging work and found out that password sync is still working but new objects (tested adding a new user) do not sync to Azure AD.

    I checked the Synchronization Service Manager on the sync server and in the "Search Connector Space" for the local AD Connector I do not see the user I created in the "DN or Anchor" scope.  It is also not in the "pending import" scope.

    As suggested in vijisankar's answer I did check Andreas Kjellman's post and they mostly describe trouble shooting password sync problems.

    I can still run the sync service in PowerShell by running this command "Start-ADSyncSyncCycle -PolicyType Delta".  It does not give me any errors.

    ---------------------------------

    Just as I was writing the above, I ran the AD Connect wizard again and deselected "Password Sync" and "Password writeback", clicked configure and then the error did not show up.  I ran the AD Connect wizard again and just selected the "Password sync" option and clicked configure.  The error did not show up now either.

    Now i thougt my sync was back to normal but new users are still not syncing.  I think there is some problems with the Synchronization Service Manager for my local AD.  When I run the sync from that connector I get the error "Unable to run the Connector.  The run could not start because there are no steps in the run profile".

    I then looked at the Run Profiles and found that they where empty.  I guess this might be the problem.  Any advice on how to fix this?

    Tuesday, August 8, 2017 6:24 PM
  • Did you check to see if the directory partitions are still selected on Sync Service Manager (Old UI)?

    -----------------------------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you and vote it as helpful, this can be beneficial to other community members.

    Thursday, August 10, 2017 4:17 AM
    Moderator
  • Thanks for your reply Sadiqh Ahmed.

    There is a check mark in front of the DC=***,DC=local directory partition.  Also there is a check mark in front of "Only use preferred domain controllers".  I only have this one domain controller so I don't think that matters.

    Is this the correct configuration?

    Thursday, August 10, 2017 9:06 AM
  • This looks correct, but we need to dig this further technically to find the root cause of the issue. Suggest you to contact Azure technical support for further assistance on this issue.

    Here is the link https://docs.microsoft.com/en-in/azure/azure-supportability/how-to-create-azure-support-request to create support case.

    -----------------------------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you and vote it as helpful, this can be beneficial to other community members.

    Monday, August 14, 2017 5:41 AM
    Moderator
  • Monday, August 14, 2017 1:51 PM
  • Thanks Andreas Kjellman!  This was exactly what I needed to do.
    Tuesday, August 15, 2017 12:51 PM
  • I got the same error and fixed it by just clicking "Try again" and it fixed in two attempts.
    Friday, February 16, 2018 6:21 PM
  • Glad to know that your issue got fixed.

    -------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you and vote it as helpful, this can be beneficial to other community members. 

    Friday, February 16, 2018 9:20 PM
    Moderator
  • Hi,

    I ran into the same issue and configuring the runprofiles worked until i wanted to change something within Azure AD Connect. That broke everything and I had to reconfigure the RunProfiles.

    Can i just set up a new Sync-Server (can´t set the old in staging mode)?

    Thursday, September 13, 2018 6:03 AM
  • You can set up a new sync server with new domain synching to the existing Azure AD tenant. Cannot have multiple sync servers with the same domain synching to a single Azure AD tenant. Refer to the supported topologies for Azure AD Connect

    -----------------------------------------------------------------------------------------------------------------------------------
    If this answer was helpful, click “Mark as Answer” and Up-Vote. To provide additional feedback on your forum experience, click here 

    Thursday, September 13, 2018 8:47 AM
    Moderator
  • i would uninstall the old sync-server of course before configuring the new one, would that work?

    (i can´t set the old one to be a staging, cause azure ad connect stops working)

    Thursday, September 13, 2018 8:49 AM
  • If you uninstall the old server, you would loose the configuration and sync to Azure AD. It is just like a fresh installation. If you do not want to loose the sync server configuration and want to stand up a new server with the same configuration as old server, the only option is to use staging mode.

    -----------------------------------------------------------------------------------------------------------------------------------
    If this answer was helpful, click “Mark as Answer” and Up-Vote. To provide additional feedback on your forum experience, click here 

    Thursday, September 13, 2018 8:54 AM
    Moderator
  • Just checking in if you have had a chance to see our previous response. If this answers your query, do click “Mark as Answer” and Up-Vote for the same. And, if you have any further query do let us know.
    Saturday, September 15, 2018 8:07 PM
    Moderator