none
How can I fix "The DRA server is already registered" ERROR of Azure Site Recovery Provider Setup ?

    Question

  • How can I fix DRA error of Azure Site Recovery Provider Setup ?
    I want to setup Azure Site Recovery Configurator to my Hyper-V host server.

    ERROR:
     "The DRA server is already registered in valut xxxxx.
      Either select the reegistration key associated with this vault,
      or unregister the server from xxxxx
      and then register it with a different vault"

    a week ago, I tested Azure Site Recovery by my Hyper-V host server.
    and after test, I deleted all Azure Site Recovery setup from Azure Management site and my Hyper-V host server. 

    Now I want to test Azure Site Recovery by my Hyper-V host server.
    But Azure Site Recovery Configurator make error at Credential vault setup,
    The error reason already registor DRA server to credential vault.

    But I already delete all setup of a week ago Azure Site Recovery from Azure and my Hyper-V host server.
    I cannot download a week ago key file.

    I tried to uninstall Azure Site Recovery Provider from my Hyper-V host server, But still happen ERROR.

    Regards,
    Yoshihiro Kawabata





    • Edited by Yoshihiro Kawabata Thursday, December 25, 2014 4:32 AM change to english from japanese
    Wednesday, December 24, 2014 5:02 PM

Answers

  • Hello Yoshihiro-san,

    I am assuming that you are using the Azure Site Recovery Provider for Hyper V here. In this case you need to do one more step

    1) Uninstall the existing Azure Site Recovery Provider from your system.

    1) Open the registry editor tool (regedit)

    2) Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft

    3) Find a Key named Azure Site Recovery

    4) Delete it the entire folder

    5) Install the Azure Site Recovery Provider for Hyper-V

    Now your registration will work.

    Thanks

    Anoop

    Monday, December 29, 2014 6:01 AM

All replies

  • Hi,

    Have you installed the VMM?

    If yes, please try to use the script below to clean up the ASR provider.

    https://gallery.technet.microsoft.com/Cleanup-Script-for-Windows-95101439

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Sunday, December 28, 2014 3:56 PM
  • Hello Yoshihiro-san,

    I am assuming that you are using the Azure Site Recovery Provider for Hyper V here. In this case you need to do one more step

    1) Uninstall the existing Azure Site Recovery Provider from your system.

    1) Open the registry editor tool (regedit)

    2) Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft

    3) Find a Key named Azure Site Recovery

    4) Delete it the entire folder

    5) Install the Azure Site Recovery Provider for Hyper-V

    Now your registration will work.

    Thanks

    Anoop

    Monday, December 29, 2014 6:01 AM
  • Thank you, Anoop for nice response.

    I fix "The DRA server is already registered" ERROR at Azure Site Recovery Configurator.

    and, but happen next problem.

    After I delete all Azure Recovery item Group / Site / Vault / Storage,
    I create new Azure Recovery item Storage / Vault / Site / Group.

    But ERROR happen at "ADD VIRTUAL MACHINES".

    ERROR message is:

    "Either the protection group doesn't contain any virtual machines,
     
    or protection is already enabled for all virtual machines in the protection group."

    of Dialog "Enable Virtual Machine Protection".

    So, I cannot add my virtual machine to Group of Azure Site Recovery.

    There are no server "HYPER-V SITES" in my site of "SERVERS" in my Vault.

    After reconfigure by Azure Site Revoery Configurator,
    There are my virtual machine on Group, and "STATUS" is "Conneted",
    But my Virtual machine dose not replecate on my Hyper-V Manager.
    and I cannot add my virtual machine to my group at "PROTECTION GROUPS".

    Regards,
    Yoshihiro Kawabata


    Thursday, January 8, 2015 7:30 AM
  • I fix  ERROR - "Either the protection group doesn't contain any virtual machines,
       or protection is already enabled for all virtual machines in the protection group"

    After 10 hours, I can add my virtual machine to Group of Azure Site Recovery.

    I don't the reason of fix ERROR

    Regards,
    Yoshihiro Kawabata

    Thursday, January 8, 2015 1:15 PM
  • Hi Yoshihiro-san,

    After we register the Hyper-V Server into a Hyper-V site, it usually goes thru a process called 'Initial Sync'. This is the step where the Hyper-V Server sends the metadata about all VMs running on it to the Site Recovery Service. Usually this takes about 2-5 minutes depending on the bandwidth you have and the number of VMs that are present on the Hyper-V Site. Only after this step is completed will the VMs show up in the 'Enable Protection Wizard'.

    Looks like in your case this operation was delayed. Can you send me the logs from <Program Files>\Microsoft Azure Site Recovery Provider\dra.log.

    Regards,

    Anoop KV

    Friday, January 9, 2015 5:43 AM
  • Thank you, Anoop KV.

    There are not dra.log on C:\Program Files\Microsoft Azure Site Recovery Provider.
    I'm repeated install/uninstall  Microsoft Azure Site Recovery Provider after that ERROR.

    So, Next time ERROR, I'm looking forward dra.log.

    Regards,
    Yoshihiro Kawabata

    Friday, January 9, 2015 7:16 AM
  • Hello, Anoop KV,

    There does not exist DRA.log file in C:\Program Files\Microsoft Azure Site Recovery Provider folder,
    when the issue
      "I fix  ERROR - "Either the protection group doesn't contain any virtual machines,
        or protection is already enabled for all virtual machines in the protection group".

    1/21/2015, I setup Azure Site Recovery for same Hyper-V by deleting registory,create new recovery vault, install agent/provider.

    After it, "Either the protection group doesn't ..." issue happened.
    But DRA.log file does not exist,
    I wait DRA.log file for 3 hours.

    Regards,
    Yoshihiro Kawabata

    Wednesday, January 21, 2015 4:50 PM
  • Hi Yoshihiro-san,

    I have answer this question on the new thread you started.

    Regards,

    Anoop KV

    Friday, January 23, 2015 2:41 PM
  • Thank you, Anoop KV for answer at new thread.

    Regards,
    Yoshihiro Kawabata

    Friday, January 23, 2015 2:52 PM