none
Deply my Model RRS feed

  • Question

  • Hi,

    i created my ANN model and want to deploy that from ML Azure Studio, but in deploy screen it is asking for:

    1) Python driver file

    2) Conda dependencies file

    I am not sure what they mean, and where do I get them. is it the import files???

    Let me know please

    Thanks

    Friday, January 10, 2020 2:12 PM

Answers

  • Hi,

    Seems like you are using the new studio interface, so, you need to select Designer if you want the visual interface for designing your experiment. Your experiment (including log details) will show up under the “Experiments”. Similarly, in “Designer”, you can add a script bundle zipped file and connect to the "Execute Python Script" module for deploying an existing model. Alternatively, you can follow this guide for deploying an existing model. Here's another example , although you will be implementing the solution via "Designer" and not "Classic". Please share what your deploy screen looks like if you continue to experience issues. Hope this helps. Thanks.

    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Monday, January 13, 2020 10:20 PM
    Moderator

All replies

  • Hi,

    Are you using Azure ML Studio (Classic) or (Designer)? Did you create the experiment in AML Studio and now trying to deploy the experiment, or are you deploying an existing model? It seems to be asking for an inference configuration file. Please share more details about your experiment and environment. Thanks.

    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Friday, January 10, 2020 10:33 PM
    Moderator
  • Hi, I am using classic.  and this is another issue. it wont let me create an experiment. I don't know why. is it because I ma in trail version.

    this is a existing model, The python file runs fine on my local machine. trains a model and everything.

    Thanks

    Saturday, January 11, 2020 4:56 PM
  • Hi,

    From the ‘Experiments’ tab, you should see the ‘add’ button at the bottom of the page as shown below. Furthermore, to deploy your existing model via Studio Classic, you need to import the python file as zipped file and connect it to the 'Execute Python Script' module as described in this documentation. Please share what step you’re stuck on. Thanks.

    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Monday, January 13, 2020 11:54 AM
    Moderator
  • Thanks for your reply:,

    See, the issue is that my portal is different than others online!!. as you can see there is no place I can add experiment:

    Monday, January 13, 2020 5:22 PM
  • Hi,

    Seems like you are using the new studio interface, so, you need to select Designer if you want the visual interface for designing your experiment. Your experiment (including log details) will show up under the “Experiments”. Similarly, in “Designer”, you can add a script bundle zipped file and connect to the "Execute Python Script" module for deploying an existing model. Alternatively, you can follow this guide for deploying an existing model. Here's another example , although you will be implementing the solution via "Designer" and not "Classic". Please share what your deploy screen looks like if you continue to experience issues. Hope this helps. Thanks.

    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Monday, January 13, 2020 10:20 PM
    Moderator
  • Thank you.  I have seen the Designer but needed to upgrade, which I was reluctant to do so. but I went a head and upgraded anyway.  Let me play with it and if I have any question I'll post it again.

    Thanks for your time

    Dean

    Tuesday, January 14, 2020 12:50 PM