locked
shcore.lib causing -1073741515 (0xc0000135) 'A dependent dll was not found' RRS feed

  • Question

  • So our code that was running fine under 8.1 preview and VisStudio 2013 preview now refuses to run under 8.1RTM + Visual Studio 2013 RC.  It was originally based on the Direct3d Shooting game sample.  The only new lib that was added was shcore.lib which has worked fine until now.  Turns out if you take that sample "direct3d shooting game" and add that one lib in the linker inputs, it has the same issue when you try to run it.  We went back to another machine with that sample that had Consumer preview + Visual Studio 2013 preview, added that lib, and it runs just fine.  So we can't quite figure out what the issues is, and are stuck in a holding pattern on the app we hope to launch at 8.1's release.

    Any ideas?

    Sunday, September 29, 2013 9:35 PM

All replies

  • If you run depends on that dll between RP and RTM, is there any difference?

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Monday, September 30, 2013 7:59 PM
    Moderator
  • We can install and run the app built with the preview atop RTM, but have not tried the opposite direction.
    Monday, September 30, 2013 11:53 PM
  • What API in shcore.lib are you trying to use from a Windows Store app?
    Wednesday, October 2, 2013 7:22 PM
  • The same one the Postcard windows store sample app does..  CreateStreamOverRandomAccessStream . 

    http://msdn.microsoft.com/en-us/library/hh846258(v=vs.85).aspx

    Odd thing to report as well.  On a new tablet that did not have any previous version of vis studio installed, we installed 8.1 RTM, and the VS RC. It had no issues building or running the app or the altered windows store sample.  We then did a reinstall of 8.1 RTM on the surface that had these issues while saving no personal files, and reinstalled VS RC, but the problem persists.

    Would skydrive be saving and restoring anything that would impact vis studio between clean installs of the OS? 



    • Edited by Silicon Bender Friday, October 4, 2013 2:49 PM Append with a question
    Friday, October 4, 2013 2:44 PM
  • Do you mean a 'Surface Pro' or a 'Surface RT'? The Windows RT 8.1 RTM build is not available on MSDN subscriber downloads, so did you actually install the Windows RT 8. Preview?

    It is important to note that w.r.t. to Windows Store app development, you cannot use VS 2013 RC and run it on Windows 8.1 Preview or Windows RT 8.1 Preview.

    Saturday, October 5, 2013 4:33 AM
  • Nope, the machine having issues is a surface pro with Win 8.1 Pro RTM and VS 2013 RC.
    Saturday, October 5, 2013 12:18 PM