none
Create OLAP Cube error - Encryption not supported on the client. RRS feed

  • Question

  • Hi All,

    We have a new multi server SP 2016(1DB SQL2016 sp2+, 1 APP and 1 WFE) farm and are trying to configure the OLAP cube and keep getting a failure Encryption not supported on the client (full error below). I've found references to this online but none of the fixes seem to be our issue. The datasource to the PWA database is getting created and I can click test connection and it works and I can see it's using v11 of the SQL client which should be using TLS 1.2 capable. We also have the SQL 2014 installed on the App tier and WFE and restarted both as per the installation guide. Any other ideas or suggestions what we could try?

    Thanks,

    John.

    ===== Initiating OLAP database build process =====
    [4/10/2020 7:50 PM] Cube build request message has been added to the Project Server queue
    ===== Verifying and running pre-build server event handler =====
    [4/10/2020 7:50 PM] Verifying and running pre-build server event handler
    ===== Determining database and OLAP database structure =====
    [4/10/2020 7:50 PM] Cube build initialization started
    ===== Building database and cubes =====
    [4/10/2020 7:50 PM] Cube build session started
    [4/10/2020 7:50 PM] Analysis Services server failed to build OLAP database. Error: Error Adding DataSourceView 'Project Reporting data source' to database 'ProjectServerDMS'. Error: Error Adding Table 'MSP_TimeByDay_OlapView_00007829_4392_48B3_B533_5A5A4797E3C9' to database. Error: A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.
    Client unable to establish connection
    Encryption not supported on the client.
    ===== Process Completed =====
    [4/10/2020 7:50 PM] Failed to build the OLAP cubes. Error: Error Adding DataSourceView 'Project Reporting data source' to database 'ProjectServerDMS'. Error: Error Adding Table 'MSP_TimeByDay_OlapView_00007829_4392_48B3_B533_5A5A4797E3C9' to database. Error: A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.
    Client unable to establish connection
    Encryption not supported on the client.

    Friday, April 10, 2020 7:09 PM

All replies

  • The error is not able to establish a connection to SQL server. It is not found or accessible.

    This occurs when service accounts associated with the olap cube, sql server and pwa are different.    I dont have information in front of me, but best way to resolve my have many of the process to use the same AD account

    1) Test first by connecting all the PWA services and OLAP service as the same.

    2) CHeck that the OLAP server allows the account and give them admin rights in OLAP server.

    3) Make sure OLAP server can access the databases as well with at least READ access.


    Michael Wharton, Past MVP, MBA, PMP and a Great Guy <br/> Website http://www.WhartonComputer.com <br/> Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Saturday, April 11, 2020 1:05 AM
    Moderator
  • Thanks for your help and support Michael. We tried giving accounts god access temporarily but nothing seemed to fix it but we had some of the security hardening removed and manually added the reg keys to enable TLS 1.2 and it's working now. Now the job of unpicking what security changes we can roll back on. 

    Thanks again,

    John.

    Monday, April 27, 2020 7:58 PM