none
SignTool Error: No certificates were found that met all the given criteria. RRS feed

  • Question

  • I have just installed VS2015. I opened a solution (that I frequently open and develop on in VS2010) and try to build and I get the following error:


    Severity


    Code


    Description


    Project


    File


    Line


    Error


    An error occurred while signing: Failed to sign bin\Debug with Imaging\app.publish\MyApp.exe. SignTool Error: No certificates were found that met all the given criteria.


    MyApp

    In the "Signing" tab of the project properties the "Sign the ClickOnce manifests" checkbox is clicked and there is a certificate displayed. The certificate has expired, which I am guessing is the source of this error message. However, I am wondering why I am able to build in both VS2010 and VS2012 with the exact same certificate and I do not get this error message and am able to build and run my solution.

    Is there a setting somewhere that will let me ignore this error is VS2015 so that I can still build and run my project?

    Thanks!


    • Edited by jfk59102 Monday, October 26, 2015 10:07 PM
    • Moved by Jiayi Li Wednesday, October 28, 2015 6:35 AM
    Monday, October 26, 2015 10:06 PM

All replies

  • Hi jfk59102,

    Thank you for posting in MSDN forum.

    For your this issue, please check the following two methods to see if it helps:

    (1) Uncheck the "Sign the ClickOnce manifests" checkbox

    (2) If uncheck doesn't help, I think this issue is related to your *.pfx file , I suggest you to remove it from project ,and re-create it in project property ->Signing tab.

    And you can also try to use Sign Tool sign project manually, here is the detailed specifications on how to use the SignTool.exe:

    SignTool.exe (Sign Tool):

    http://msdn.microsoft.com/en-us/library/8s9b9yaz.aspx

    You can't verify the application since you failed to sign the application.

    The examples in the link above will show you the way to sign your application. And you should make sure that whether the signatures has paswords or not. And whether the time-stamps files is correct or not.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    • Edited by Jiayi Li Tuesday, October 27, 2015 6:52 AM
    Tuesday, October 27, 2015 6:52 AM
  • I cannot uncheck the "Sign the ClickOnce Manifest" as that will affect our publish. I also cannot replace the key. This exact same setup works just fine in VS2010 and VS2012 and I am able to build and run fine, so I am wondering why this is different VS2015 and how I can get VS2015 to run this project WITHOUT unchecking "Sign the ClickOnce Manifest" or replacing the certificate. I don't have to do either of those things in VS2010 or VS2012 to get it to work, I shouldn't have to in 2015 either.
    Tuesday, October 27, 2015 3:29 PM
  • Hi jfk59102,

    I help you move this case to Clickonce forum for dedicated support. Thank you for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, October 28, 2015 6:34 AM
  • Great, thank you.
    Wednesday, October 28, 2015 3:21 PM
  • Hi jfK59102,

    According to your description, your certificate may has expired. You need to renew it. Follow the steps described in below article.
    https://robindotnet.wordpress.com/2010/01/26/how-to-extend-an-existing-certificate-even-if-it-has-expired/

    Best Regards,
    Li Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, October 30, 2015 7:36 AM
  • This is not the solution as we are using a Vendor certificate and cannot convert to a test certificate. Once again, it works just fine in VS 2010 and VS2012 so I should not have to jump through hoops to get it to work in VS 2015.
    Tuesday, May 10, 2016 3:52 PM
  • I have the same issue. The certificate is valid until 12/31/2018 and works with VS 2013, but not with 2015.

    Please advise.

    Tuesday, April 3, 2018 7:24 PM
  • Hello! I have same problem too! No news about it? Thank you
    Friday, June 8, 2018 2:37 PM
  • OK, just had this problem with vs 15.7.6 (after updating from 15.7.4)



    Solution was to go in ClickOnce settings, click select from file, select the pfx, load it, enter pass as needed.  -That fixed it.



    I have had similar problems on other machines, with a different error, where i have to reload the pfx in Sign the assembly option or just click change password and enter the same pass again.


    Saturday, August 4, 2018 6:38 PM
  • Thanks. This works for me

    Tuesday, September 18, 2018 4:26 AM
  • If someone finds this helpful someday...

    Background story: I was newly employed and got a machine of someone else's, which i have been using for an year now. I was asked to re-publish an age-old application, changing all the connection settings... which is fine until i tried to publish. Boom... it gave me the same error as yours. It was referring to some expired .pfx file and all. 

    I then went to run->mmc-> add certificates -> open up certificates --> delete that expired certificate.

    Now go to project properties -> signing -> select from store --> (usually picks up valid cert from personal store).

    Thats it! 

    Rebuild and Publish... you are done!!! :D

    Thanks!

     

    Thursday, October 25, 2018 11:56 PM
  • I had a similar issue and found a solution. Please check this answer
    Monday, September 16, 2019 6:12 AM