none
Does autoscale not work? RRS feed

  • Question

  • I've setup autoscale on my web role to trigger on high CPU usage but this does not seem to work. It never triggers even if my web role is at 99% CPU utilization. Has anyone else come across this issue?
    Monday, November 18, 2013 1:59 AM

Answers

  • Hello,

    Also, note that CPU has to be high for a sustained period of time -- if CPU is high for only 15 minutes, a scale up action will not be triggered. You should have at least 45 minutes of sustained CPU to see a scale up. Also, you can get the exact JSON that represents your autoscale rules by looking in the Operation Log (the operation is called PutAutoscaleSetting I believe). If you paste that here we could look at exactly what your settings are.

    Thanks,
    -Stephen

    Wednesday, November 20, 2013 3:28 AM

All replies

  • Hi TheNimble,

    Thanks for posting!

    Do you check your CPU usage in MONITOR or DASHBOARD? Base on my experience, if CPU usage is over your setting level, it may trigger auto scale (http://www.windowsazure.com/en-us/manage/services/cloud-services/how-to-monitor-a-cloud-service/). I suggest you could view the log form the Management Service (Click Management Service =>Operation Log => select date and so on) . Also I suggest you could use the "Alert" (http://msdn.microsoft.com/en-us/library/windowsazure/dn306639.aspx). When your setting trigged, the azure will send you email about the state changed. 

    Hope it helps.

    Regards,

    Will


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, November 18, 2013 8:55 AM
    Moderator
  • Hello,

    Also, note that CPU has to be high for a sustained period of time -- if CPU is high for only 15 minutes, a scale up action will not be triggered. You should have at least 45 minutes of sustained CPU to see a scale up. Also, you can get the exact JSON that represents your autoscale rules by looking in the Operation Log (the operation is called PutAutoscaleSetting I believe). If you paste that here we could look at exactly what your settings are.

    Thanks,
    -Stephen

    Wednesday, November 20, 2013 3:28 AM
  • 45 minutes of sustained CPU for scaling to kick in seems crazy. We had a big spike in traffic today where requests were timing out due to excessive CPU utilisation. The auto scale didn't kick in despite having a 70% threshold for up scale and we had to disable auto scaling and manually scale up an extra instance to cater for the load.

    45 minutes is way too long in my opinion for responding to increases in load. One of the main appeals of Azure is the ability to quickly scale up and down to handle increased loads so having to wait about an hour for auto scale to respond (including firing up a new instance) is not good enough. At the very least this should be configurable within the autoscale dashboard.

    Monday, December 9, 2013 6:40 AM
  • I totally agree on this. 45 minutes - no configuration - makes the autoscaling feature via web portal totally useless. A lot of money can be lost in 45 minutes, with the lure of saving some money using autoscaling.

    I am not happy to admit it, but AWS CloudWatch (and monitoring portal) is light years ahead.

    Wednesday, February 18, 2015 2:51 PM