none
Application for Win CE 6.0 RRS feed

  • Question

  • Hi,

    I wanna create application for Siemens TP700 Comfort Panel with os Windows CE 6.0  using Visual Studio 2008. 
    If I connect device to PC via enternet cabel, I can see device in "device management". 
    I can check connection via Command line using function ping (IP address of device). Device comunicate and I have conection, Command line- ping nothing lost. 


    In visual Studio 2008, I create C# project for Smart Device-Windows CE with .NET Compact Framework Version 3.5. After that I  configure IP address of device in Studio (IP address is same as is in Command Line).

    If I clik on Debug, MS studio give me error message "Connect to device failed."


    How I can debug my project, if the connection in visual studio always crashes, but in command line I have connection ?
    Is possible create Windows CE 6.0 form app with out connection to device ?

    Thank you 
    Richard 

    Tuesday, November 13, 2018 12:34 PM

All replies

  • You will need to run conmanclient2.exe and cmaccept.exe on the device if you want to enable a debug connection to VS. You can of course create a CE application without a debug connection. Just code, build, then transfer your exe to the device and execute there.

    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: https://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    NXP Proven Partner
    https://guruce.com
    Consultancy, training and development services.

    Interested in WEC on i.MX6?
    Get the only 100% stable and best performing i.MX6 BSP for WEC7 and WEC2013 here: https://guruce.com/imx6

    Wednesday, November 14, 2018 12:15 AM
    Moderator
  • Hi Michael,

    thank you for reply.
    I copy file (CMAccept.exe, ConmanClient2.exe) from "C:\Program Files\Common Files\Microsoft Shared\CoreCon\1.0\Target\wce400\[armv4i]" folder. I try run conmanclient2.exe and cmaccept.exe as you wrote, but Win CE 6.0 wrote always error "*.exe is not a valid Windows CE application." I try copy this exe from other folder, but the same message. I make something wrong ?


    I build project in VS 2008, but if I copy debug folder to TP700 Comfort Panel and execute there, nothing happened. I add code from Visual Studio:


    using System;
    using System.Collections.Generic;
    using System.Text;


    namespace TP700_withoutCFW
    {
        class Program
        {
            static void Main(string[] args)
            {
                Console.WriteLine("Hello world");
                Console.ReadLine();
            }
        }
    }


    Can produce this problem  .Net Compact Framework 2.0, when I create project in VS 2008? I thnik that I dont use function from NCF2.0.

    Thank you 

    Richi

    Thursday, November 15, 2018 2:35 PM
  • Ah, CE 6.0, sorry I missed that.

    You need to target .NET CF 2.0 as that is the latest version available on CE 6.0 IIRC.

    CE 6.0 is too long ago for me to remember off the top of my head. I hope somebody else can jump in?


    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: https://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    NXP Proven Partner
    https://guruce.com
    Consultancy, training and development services.

    Interested in WEC on i.MX6?
    Get the only 100% stable and best performing i.MX6 BSP for WEC7 and WEC2013 here: https://guruce.com/imx6

    Thursday, November 15, 2018 11:56 PM
    Moderator
  • Debugging over network is complicated.  The easiest way to debug is to also use a USB cable and connect ActiveSync.  Then VS and the device will negotiate the debugging and set up the network so that it can be used.


    Bruce Eitman
    Senior Enginer
    Bruce.Eitman AT Synopsys DOT com
    My BLOG http://geekswithblogs.net/bruceeitman
    I work for
    Synopsys

    Tuesday, November 20, 2018 4:47 PM
    Moderator
  • Hi,

    Thank you for reply.


    I tried it but it looks like SIEMENS TP700 can not connect to PC via usb cable. If I connect it nothing happens in OS ActiveSync doesnt show any device.

    I tried install app like Opera for Win CE 6.0, but after installation Win CE write message: Invalid Win CE app. Probably the TP700 is blocked or Im wrong ?

    Thx Richi



    • Edited by SKT-Richard Friday, December 7, 2018 9:03 AM
    Friday, December 7, 2018 9:02 AM
  • Could you resolve this? And how did you do? I'm in the same situation

    Thursday, September 19, 2019 7:19 AM
  • After doing some Googling, I don't really think that the TP700 is designed for you to add applications to.  I think (but don't know) that the TP700 supports a configurable HMI, but not so much adding applications.  

    To answer Richi's question, Windows CE is a configurable OS.  Invalid Win CE app could mean one of the following:

    1. Wrong processor family is targeted (x86 instead of ARM for example)
    2. A DLL is missing from the device


    Bruce Eitman
    Senior Enginer
    Bruce.Eitman AT Synopsys DOT com
    My BLOG http://geekswithblogs.net/bruceeitman
    I work for
    Synopsys

    Thursday, September 19, 2019 9:27 PM
    Moderator