The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Azure DevTest Labs!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
Mandatory Artifacts blade hangs and won't let me edit the Windows Artifacts RRS feed

  • Question

  • Open the Configuration and policies - Mandatory artifacts blade

    Just sits there with the Windows Artifacts Edit and Linux Artifacts Edit buttons disabled.

    Thursday, September 12, 2019 8:45 AM

All replies

  • Hi Sebastion,

    I am not able to duplicate the issue at this time. Can you confirm that you are still unable to access the blade after clearing cache? It is possible this was a transient issue that has resolved itself.

    If the portal is still freezing you can hit CTRL+ALT+A to download a diagnostics log. Please send it to AzCommunity(at)microsoft.com along with a link to this thread so I can pass it along to the relevant team to troubleshoot the issue.

    Thursday, September 12, 2019 4:53 PM
    Moderator
  • Cleared the cache and still not working.

    In the console log I get:

    iDL6JSh8uBBq.js:9 [Microsoft_Azure_DevTestLab]  10:15:33 PM MsPortalFx.Base.Diagnostics.ErrorReporter 1 MsPortalFx.Base.Diagnostics.ErrorReporter: message: n.properties(...).mandatoryArtifactsResourceIdsWindows is not a function
    stack: TypeError: n.properties(...).mandatoryArtifactsResourceIdsWindows is not a function
        at t._loadDataAndPopulateUI (https://afd.hosting.portal.azure.net/devtestlab/Content/Dynamic/hESVGJEUiCjd.js:1:1797)
        at https://afd.hosting.portal.azure.net/devtestlab/Content/Dynamic/hESVGJEUiCjd.js:1:1609
        at o (https://portal.azure.com/Content/Dynamic/5Q5-IYVRErbk.js:4:72)
        at https://portal.azure.com/Content/Dynamic/5Q5-IYVRErbk.js:4:5156

    Sending the diagnostic log

    Thursday, September 12, 2019 9:18 PM