none
Not Able to install R library

    Question

  • Hi,

    I am trying to install a new library along with dependencies, however every time I run the AML execute R script to install, it errors out.

    The R code in execute R script module is :

    #############################


     install.packages("src/ltsa_1.4.6.zip", lib = ".", repos = NULL, verbose = TRUE)
     install.packages("src/tscount_1.4.1.zip", lib = ".", repos = NULL, verbose = TRUE)
     library(ltsa, lib.loc=".", verbose=TRUE)
    # require(ltsa)
    library(tscount)

    #############################

    the Error is :

    [ModuleOutput] The following files have been unzipped for sourcing in path=["src"]:
    [ModuleOutput] 
    [ModuleOutput]                Name  Length                Date
    [ModuleOutput] 
    [ModuleOutput] 1    ltsa_1.4.6.zip  505120 2019-01-04 14:58:00
    [ModuleOutput] 
    [ModuleOutput] 2 tscount_1.4.1.zip 1003880 2019-01-03 18:24:00
    [ModuleOutput] 
    [ModuleOutput] Loading objects:
    [ModuleOutput] 
    [ModuleOutput] package 'ltsa' successfully unpacked and MD5 sums checked
    [ModuleOutput] 
    [ModuleOutput] package 'tscount' successfully unpacked and MD5 sums checked
    [ModuleOutput] 
    [ModuleOutput] Warning messages:
    [ModuleOutput] 
    [ModuleOutput] 1: In strptime(x, format, tz = tz) :
    [ModuleOutput] 
    [ModuleOutput]   unable to identify current timezone 'C':
    [ModuleOutput] 
    [ModuleOutput] please set environment variable 'TZ'
    [ModuleOutput] 
    [ModuleOutput] 2: In strptime(x, format, tz = tz) : unknown timezone 'localtime'
    [ModuleOutput] 
    [ModuleOutput] 3: package 'ltsa' was built under R version 3.4.4 

    This is basically have something to do with timezone but I am not able to resolve this, it took me considerable time trying to resolve this but to no avail.

    Regards,

    Anuj


    • Edited by Anuj8187 Friday, January 4, 2019 10:48 AM
    Friday, January 4, 2019 10:48 AM

All replies

  • Hi, 

    Could you check to see if you can run your code in the Jupyter notebook environment as shown below?

    Regards,
    Jaya

    Sunday, January 6, 2019 9:27 PM
  • Hi Jaya,

    First of all, thank you for the response.

    As a rule of thumb I always test my R code in R studio before migrating it to AML environment. Hence each and every piece of R related part of the code is pre-tested. 

    I am not sure if it is necessary to execute it in Jupyter notebook.

    Regards,

    Anuj

    Monday, January 7, 2019 8:54 AM
  • Hi, 

    Good rule of thumb, you can continue to try debugging your Azure ML Studio experiment if that is how you want to proceed. 

    Regards,
    Jaya

    Monday, January 7, 2019 8:18 PM
  • Hi,

    Can you please check if you are using R 3.4.4 environment? Just click your Execute R Script module and check the R version in right panel. Thanks.

    

    Regards,

    Yutong

    Tuesday, January 8, 2019 6:53 PM
    Owner
  • Thank you Jaya for the response.

    However last remark was quit uncalled for and was not really helpful.

    Wednesday, January 9, 2019 9:11 AM
  • Hi Yutong,

    Thank you for the reply,

    The version is 3.1.0 for CRAN R. 

    Wednesday, January 9, 2019 9:14 AM