none
BizTalk 2016 SFTP, Winscp- Temp Log Files RRS feed

  • Question

  • Hi All, 

    I am using BizTalk 2016, CU6. I am using sftp adapter alogn with Winscp on the server. whenever we are enabling the receive location which is using sftp , It looks like WinSCP is creating huge log files on temp location. 

    Winscp is not purging the log files , hence this is causing space issue on C Drive. 

    We tried following 

    1. Changing the temp file location for log file using Winscp GUI, but this is not working, it looks like it is using the default path for the log files all the time ? Unless we are doing something wrong. 
    2. Written a script to delete the temp files but this requires restarting the host instance which is not right solution. 

    Any points will be appreciated here. 

    Thanks

    Naushad 


    Cheers,HTH

    Naushad Alam http://alamnaushad.wordpress.com/

    When you see answers and helpful posts, please click Vote As Helpful , Propose As Answer , and/or Mark As Answer

    Tuesday, November 12, 2019 11:03 AM
    Moderator

All replies

  • Have you tried changing the TMP path for the BizTalk host user?   
    Tuesday, November 12, 2019 7:58 PM
  • Thanks for you reply, We tried that but it did not work , Could you please tell me how to do that?

    Thanks

    Naushad 


    Cheers,HTH

    Naushad Alam http://alamnaushad.wordpress.com/

    When you see answers and helpful posts, please click Vote As Helpful , Propose As Answer , and/or Mark As Answer

    Wednesday, November 13, 2019 1:51 PM
    Moderator
    • Create a new folder on the other drive
    • Give the BizTalk in-process host user full access to the folder
    • Run Command Prompt as the BizTalk in-process host user-Windows button
    • At the command prompt enter SystemPropertiesAdvanced and press enter
    • Click on the button near the bottom labelled Environment Variables.
    • In the Variable value Edit box specify the path as new tempfolder for both TMP and TEMP.
    • Click Ok Twice
    • Restart all the in process hosts.


    Wednesday, November 13, 2019 8:23 PM
  • Thanks for the steps, its working. 

    Is there any way to stop the logging ?


    Cheers,HTH

    Naushad Alam http://alamnaushad.wordpress.com/

    When you see answers and helpful posts, please click Vote As Helpful , Propose As Answer , and/or Mark As Answer

    Thursday, November 14, 2019 10:27 AM
    Moderator
  • The logging?  Or the temporary files?
    Thursday, November 14, 2019 8:22 PM
  • I would recommend to to test to increase polling interval to higher value than 2 minutes (e g 130 seconds) to get less logs and also it may stop connection pooling which may release the temp files when connections are released. If you need lower polling interval I would recommend to do purge as scheduled task on regular intervals. Many customers use very low polling intervals where they don't need it. Handshake/logon can be quite slow and listing of files also so if you have lower polling interval you end up looping continuously. Since it lists all files in the polled folder during dir listing to locate relevant files to receive, having 1000 extra files that you will never receive in same folder is not a good idea as the listing is slow and the temp files are big. Try to use separate folders with less files if possible. (not always possible of course)

    I would also recommend to have a dedicated SFTP receive host with maxed .NET max worker threads setting (500) to avoid running out of threads. Since you only receive with SFTP in this host it should not be a problem with high thread setting. 

    Friday, December 6, 2019 3:02 PM
  • "Many customers use very low polling intervals where they don't need it"

    Partially  caused by the default polling on the SFTP being so low and not being changed by those setting up the port.

    Friday, December 6, 2019 7:10 PM