locked
Connecting agent gives HTTP error 12044L RRS feed

  • Question

  • Trying to setup the agent fails on some machines for me. The machines where it fails are running in Azure in a VNET and are domain joined.

    Error in eventlog :

    HTTP operation failed with error "12044L" (12044L).  The query will be retried later.  URL for Operation: https://myworkspaceguid.oms.opinsights.azure.com/AgentService.svc/AgentTopologyRequest

    Double checked correct workspace ID and access key are set.

    It works well for other, standalone machines in the same VNET and for the same OpsInsight workspace.

    I suspect it may be some issue with certificate handling, since the agent seems to use client-cert for auth towards the workspace. Possibly there is some mandatory trusted root certificate missing, but can't verify, don't find enough information how this works.

    Any hints?

    Wednesday, March 4, 2015 8:15 AM

All replies

  • Hi perpetualKid,

    For the Azure virtual machines, how are you doing the agent install?

    There are 3 options:

    1. Downloading the MSI, running setup and entering the workspace ID and key
    2. Using the Azure portal (selecting enable op insights on the servers tab of your operational insights workspace in the Azure portal)
    3. Using PowerShell to install the extension

    For Azure virtual machines, options 2 and 3 are the easiest.

    In each case, the setup flow for agents involves using the workspace id and key to do the initial authentication with the service. Once the initial auth is done the client and server negotiate a certificate and the certificate is used for subsequent authentication.

    I'll also follow up with some engineers on what the cause of the 12044L error could be.

    Regards

    Richard


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, March 6, 2015 5:19 PM
  • Following up as Richard and myself got some info from the developers about this.

    That error code means ERROR_INTERNET_CLIENT_AUTH_CERT_NEEDED.  That’s a very odd error given
    that we always put a client certificate on the request! It would be useful if you could collect agent traces - use the procedure here
    https://support.microsoft.com/kb/942864/ using VERbose level i.e.

    • StopTracing.cmd
    • StartTracing.cmd VER
    • <wait for repro>
    • StopTracing.cmd
    • FormatTracing.cmd

    If you cross-post this on the feedback forum http://aka.ms/opinsightsfeedback you can leave your email over there and we can contact you - might be easier to look at verbose trace logs...

    Monday, March 9, 2015 11:36 PM
  • It could also be a transient condition from which the module could recover (i.e. network packets being malformed in transit, etc) on next attempt.

    At what point do you see the failure? Have you tried installing with the alternative methods that Richard mentioned? Do you actually see any data from those?

    Tuesday, March 10, 2015 2:47 AM
  • I've tried multiple times setting up the agent both manually and using Powershell. Option 2 is out of range as VM extensions are not enabled on the machines.

    Also the error kept occurring for couple days, while the other standalone machine in same Azure region and subscription just worked fine, so I don't think it's some network packet error or similar. Right now trying again and activating the tracing, I'll cross-post results to the feedback forum.

    thanks


    Update, posted the log in the feedback area http://feedback.azure.com/forums/267889-azure-operational-insights/suggestions/7193034-service-connector-fails-with-http-error-12044l
    • Edited by perpetualKid Tuesday, March 10, 2015 6:27 PM log information added
    Tuesday, March 10, 2015 5:14 PM
  • I have tried the following steps given above but no luck, any other suggestions please.
    Monday, December 24, 2018 5:46 PM