none
Unable to deploy a model to a web service

    Question

  • Hi I am new to ML and I am trying to deploy a web service in ML Studio. I received the following error message when I tried to deploy. Would anyone know how to fix this error. thanks

    AADSTS50076: Due to a configuration change made by your administrator, or because you moved to a new location, you must use multi-factor authentication to access '797f4846-ba00-4fd7-ba43-dac1f8f63013'. Trace ID: 03ba5949-906b-4efa-855a-248c183b1600 Correlation ID: bde5d802-0d9d-4838-99ce-ab636fe8c35f Timestamp: 2019-01-25 03:09:16Z

    Friday, January 25, 2019 3:30 AM

All replies

  • Hi,

    For the multi-factor authentication, please refer to following instruction: https://docs.microsoft.com/en-us/azure/active-directory/authentication/concept-mfa-howitworks

    After configuring the authentication right, you should be good. Thank you.

    Regards,

    Yutong

    Monday, January 28, 2019 6:49 PM
    Moderator
  • I deleted the workspace and recreated a new one.

    I went in according to the documentation created a MFA policy and excluded myself from the MFA policy.

    I went into the ALS by clicking on the MLS link in the azure portal.

    I created a new experiment Now I am getting a different error

    Error Message: Web Service deployment failed. This account does not have sufficient access to the Azure subscription that contains the Workspace. In order to deploy a Web Service to Azure, the same account must be invited to the Workspace and be given access to the Azure subscription that contains the Workspace.
    Site Path: /webservices/deployExperiment
    Activity ID: dbe7d222-99a9-4a6b-98c0-4577aabb0cfa
    Request ID: 02213684-7654-45da-b444-22d7b592df79
    Workspace ID: f5763dec730341ec8dbe7e1a06331188
    Subscription ID: cd2295c8-0239-4c61-8f3c-ed736276082a
    Workspace Type: PaidStandard
    User Role: Owner
    Tenant ID: f8cdef31-a31e-4b4a-93e4-5f571e91255a 

    Thursday, January 31, 2019 9:44 PM