none
SSMS 2016 - License Prerelease software This License has expired RRS feed

  • Question

  • I just downloaded and installed the June 2016 SSMS and installed it. I get an error of

    License Prerelease software

    This License has expired

    I have run repair with and it does not solve the issue.


    • Edited by Corey Webber Tuesday, July 12, 2016 3:07 PM Updateds the title to remove release month
    Friday, June 3, 2016 2:03 PM

All replies

  • Hello,

    If you have an old Version of SQL Server 2016 CTP installed, then you have to uninstall the old CTP Version completly; an update Installation CTP => RTM is not supported and therefore you get the error message.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    • Proposed as answer by Enric Vives Wednesday, August 24, 2016 1:41 PM
    Friday, June 3, 2016 2:12 PM
  • Hello,

    The following KB article is related to this issue:

    https://support.microsoft.com/en-us/kb/971268

    Please back up the registry first, then open the Registry and set CommonFiles registry value to 3 in HKLM\SOFTWARE\\Microsoft\Microsoft SQL Server\130\ConfigurationState. The article was intended for SQL Server 2008 initially.  Take note about the “130” (SQL Server 2016 = 130) on the registry path.

    Hope this helps.



    Regards,



    Alberto Morillo
    SQLCoffee.com

    Friday, June 3, 2016 2:30 PM
    Moderator
  • Hello Alberto,

    I had installed SQL Server Management Studio June 2016 generally available release - https://msdn.microsoft.com/en-in/library/mt238290.aspx . I get same error "Visual Studio License: Prerelease software this license has expired". Tried to follow above steps but 130 is missing in HKLM\SOFTWARE\\Microsoft\Microsoft SQL Server. Also, I haven't installed any earlier versions on my local windows 8.1 machine.

    Please advise if any other ways to get this fixed.

    Thanks & Regards,

    Satish

    Tuesday, June 7, 2016 4:48 AM
  • Satish, this is same situation I am in. Also I never installed the Pre-Release of 2016 (that I am aware of).

    I also had a Co-Worker install it on a Windows 7 box and it call a missing DLL error, found the KB to install, and tthen got the same error I got.

    Still looking for a fix.

    Wednesday, June 8, 2016 1:05 AM
  • Yes.  I am having the same issue as well.  Clean OS install + this software = failure due to "license expired" issue.

    Thursday, June 9, 2016 1:28 PM
  • Just installed the July 2016 release and still the same issue. Tried installing it on a clean system and still the getting the same error.
    Tuesday, July 12, 2016 3:06 PM
  • I run the repair for Microsoft Visual C++ 2015 Redistributable and Microsoft Visual 2015 Isolated and it worked

    SQL Server DBA

    • Proposed as answer by uli536 Thursday, October 13, 2016 12:56 PM
    Thursday, July 14, 2016 4:41 PM
  • Tried the repair, no dice. Still have issue. This is a new clean install of OS (Win 7) and SSMS 2016 July hotfix.

    Monday, July 18, 2016 2:42 PM
  • Same issue, clean Win 7 install, all the updates, SSMS 2016 16.3 downloaded from microsoft (after searching for SSMS download) and I get license prerelease software, license has expired. What a joke.
    Monday, August 22, 2016 12:32 AM
  • i believe error is

    Visual Studio License: Prerelease software this license has expired

    I think there is some VS component which is causing failure.


    Balmukund Lakhani
    Please mark solved if I've answered your question, vote for it as helpful to help other users find a solution quicker
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog | Team Blog | @Twitter | Facebook
    Author: SQL Server 2012 AlwaysOn - Paperback, Kindle

    Monday, August 22, 2016 12:45 AM
    Moderator
  • I downloaded SSMS Release 16.3 and had the same issue. After reading some of the replies and comments, I ran a repair on "Microsoft Visual Studio 2015 Shell (Isolated)" and it resolved the issue.

    Hope this helps someone.

    Wednesday, August 24, 2016 1:26 PM
  • "I ran a repair on "Microsoft Visual Studio 2015 Shell (Isolated)" and it resolved the issue"

    Helped me, thanks!

    Friday, December 9, 2016 12:38 PM
  • "I ran a repair on "Microsoft Visual Studio 2015 Shell (Isolated)" and it resolved the issue"

    Helped me too, thanks!

    Thursday, December 22, 2016 1:58 AM
  • This worked for me too. In my case I had other initial problems which I documented here:

    http://scribblingsage.com/2017/01/19/vclruntime140-dll-missing-after-installing-ssms/

    Thursday, January 19, 2017 1:21 PM
  • I have the same issue but i cannot simply repair as i am trying to put SSMS into a app stack VMware and deploy it to multiple VM's. So if i run the repair it does fix it but as soon as i deploy it to another VM its broken.... Why is visual studio barking at me for installing a free piece of software this makes no sense.... Does anyone know the registry key that causes this in visual studio? I figure i can fix it there then push the reg key via UEM... Why is the software used to build a piece of software barking about license i dont want visual studio? this is obviously a bug of some sort.... 

    Sorry for the ramble wasted 2 days on this ridiculousness.... 

    Tuesday, July 18, 2017 9:06 PM
  • OK so for anyone that wants to virtualize SSMS 17.1 with VMware products app volumes and VDI here is the trick to not have the license expired debacle... 

    Once you create your app stack and you are going to provision dont use your normal provisioning machine you will have to provision with your golden image / base image as from what i can tell MS decided to put some kind of SID check on the visual studio portion of ssms and if you capture from a different machine then the base it will see the sid difference once you attach the app stack and boom you get the expired license issue. (also make sure you use quick prep on your base image instead of sys prep) 

    I hope that helps someone out trying to use SSMS in VDI with app stacks as i wasted 3 days on this madness :( 

    Best Regards 

    Thursday, July 20, 2017 7:01 PM
  • I confirm the solution of installing SSMS 17.x on APPVolumes using the golden image vm instead of the package machine that Stephen jP suggested. Our our case, the package machine was a direct clone of the golden image vm, so you would say, SIDs were equal, but still it did not work.

    This procedure also works when you try to package Visual Studio 2017 Community Edition. It uses the same sort of SID checking, apart from the fact you also have to log on using a MS account to activate the license.

    So, Stephen j P, thank you very much for your solution!

    Friday, September 1, 2017 11:46 AM
  • This fixed the issue for me. Thanks!
    Wednesday, September 20, 2017 2:14 AM
  • Rather than installing the full SMSS in the gold master, it appears that you can just install the Visual Studio Shell (Isolated) in the gold master.

    https://msdn.microsoft.com/en-us/library/bb685691.aspx

    This tool answers the licensing requests and is much smaller than the full Studio.  From there, you can install SMSS in an App Stack and all should work well.

    Tuesday, October 3, 2017 8:12 PM
  • I ran a repair on "Microsoft Visual Studio 2015 Shell (Isolated)" and it resolved the issue.

    This worked for me with version 17.2 of SSMS as well.



    • Edited by krmarshal Monday, October 9, 2017 6:41 PM
    Monday, October 9, 2017 6:40 PM
  • you can just install the Visual Studio Shell (Isolated)


    It's not neccessary to install VS Shell before, it's automatically installed with SSMS when no full Version of VS is installed.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Tuesday, October 10, 2017 6:23 AM
  • I run the repair for Microsoft Visual 2015 Isolated and it worked
    Wednesday, August 29, 2018 6:16 AM
  • Did you ever find an answer to your problem? I am having the same issue with Visual Studio 2019 Community. 
    Monday, February 3, 2020 4:00 PM