locked
MEF fails when running locally RRS feed

  • Question

  • I dont even know how to phrase my question.

    I have developed an application in VS2010 using MEF in several locations.  It has been working flawlessly.  I began working on a side project for the last couple weeks and have not touched my MEF application.

    Today, on my development machine, I tried debugging it in VS2010 and MEF fails to compose plugins.  The solution is stored on my desktop on my dev machine.

    HOWEVER, on my other machine I used explorer to navigated to my solution debug folder on my dev machine.  I can run the exe file and it works as expected.

    ALSO, I copied the debug folder to my other machine, and while on my dev machine I navigated to the other machine where the debug folder was copied.  I ran the exe, while on the dev machine, and it ran as expected.

    Two weeks ago this was working just fine!  I'm assuming i have some permission/trust issues, but I dont know how it can fail to run locally from my desktop and succeed to run over the network??

    Edit: When logged on the dev machine and run the debug exe from the desktop, I get a "Publisher could not be verified...".  But while logged on the dev machine and run the exe on my other pc (copied the debug folder) I do not get any publisher warnings.

    • Edited by c_manboy Tuesday, December 4, 2012 1:04 AM
    Tuesday, December 4, 2012 12:53 AM

All replies

  • What are the errors associated with the failure to compose plugins?  Do you have something like this in your app.config file:

      <system.diagnostics>
        <sources>
          <source name="System.ComponentModel.Composition" switchValue="All">
            <listeners>
              <add name="fileListener" type="System.Diagnostics.TextWriterTraceListener" initializeData="composition.log" />
            </listeners>
          </source>
        </sources>
        <trace autoflush="true" indentsize="4" />
      </system.diagnostics>

    To generate output for debugging MEF? 

    Wednesday, December 19, 2012 10:27 PM