none
My site keeps going down

    Question

  • I run my blog (http://blog.gauffin.org) in your wordpress template (paid subscription).

    I get this error now and then:

    The page cannot be displayed because an internal server error has occurred.

    Remote Address:94.245.104.73:80
    Request URL:http://blog.gauffin.org/
    Request Method:GET
    Status Code:500 Internal Server Error

    Request Headers
    Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
    Accept-Encoding:gzip, deflate, sdch
    Accept-Language:en-US,en;q=0.8,sv;q=0.6
    Cache-Control:max-age=0
    Connection:keep-alive
    Host:blog.gauffin.org
    User-Agent:Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.89 Safari/537.36
    Content-Length:75
    Content-Type:text/html
    Date:Thu, 19 Mar 2015 05:41:12 GMT
    Server:Microsoft-IIS/8.0
    X-Powered-By:ASP.NET

    Request Headers
    Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
    Accept-Encoding:gzip, deflate, sdch
    Accept-Language:en-US,en;q=0.8,sv;q=0.6
    Cache-Control:max-age=0
    Connection:keep-alive
    User-Agent:Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.89 Safari/537.36

    Then if I wait a while and then try again everything works again. I got to the same IP 94.245.104.73:80 when it worked again.


    • Edited by jgauffin__ Thursday, March 19, 2015 6:43 AM removing cookies
    Thursday, March 19, 2015 6:33 AM

Answers

  • Hi,

    In FREB logs for jgauffin-blog,  we see Fast CGI Process crashing  during the timeframe that was provided

    |#329 FASTCGI_START @0ms |#331 FASTCGI_UNEXPECTED_EXIT @266ms |#332 SET_RESPONSE_ERROR_DESCRIPTION @266ms Details: D:\Program Files (x86)\PHP\v5.6\php-cgi.exe - The FastCGI process exited unexpectedly |#333 MODULE_SET_RESPONSE_STATUS_ERROR @266ms Module: FastCgiModule, Notification: EXECUTE_REQUEST_HANDLER, Status: 500, SubStatus: 0, HttpReason: Internal Server Error, Win32ErrorCode: 0xc0000005, ConfigException:

    In this case, we would need to identify what is causing the Fast CGI process to crash due to 0xc0000005  ( Access Violation exception)

    Our suggestion will be to collect a memory dump for the Fast CGI process

    Collecting Memory Dumps

    Procdump Instructions:

    Download Procdump  tool from :  https://technet.microsoft.com/en-us/sysinternals/dd996900.aspx

    Connect to your Azure website using FTP Client and create a folder in your root folder named “memorydumps”

    Upload prodcump.exe to the “memorydumps” folder

    Creating memory dumps: 

    Access “Debug Console” from Kudu : https://jgauffin-blog.scm.azurewebsites.net/DebugConsole 

    In the console, please go to “memorydumps” folder

    Then, paste this command : procdump.exe -e -ma -w php-cgi.exe –accepteula

    The next time we see the issue, we will see a dump file getting created in the “memorydumps” folder. Please download this site and send it across to us.

    Once we have the memory dumps, please remove the “memorydumps” folder from your site root.

    Please let me know if you have any questions.

    Regards,

    Shirisha Paderu

    Tuesday, March 31, 2015 4:57 PM
    Moderator
  • Just checking: Are you still seeing the WinCache 212 error?

    With the upgrade to WinCache 1.3.7.4, you should no longer see this issue.

    Thx!

        --E.

    Sunday, May 03, 2015 11:55 PM

All replies

  • Hi,

    I have tried accessing your website many times by now and haven't seen any Page cannot display or 500 Internal server errors.

    I see that your website is running in North Europe with Basic mode. Is your database in the same datacenter ?  I have noticed a sql database down time in North Europe From 00:00 UTC on 16 Mar, 2015 to 09:30 UTC on 18 Mar, 2015 but unsure if this relates to your website issue.

    What is the exact time with time zone of the issue ?

    Have you faced the issue after posting the issue here ?

    Have you made any changes to the website before noticing the issue ?

    Recommend you to see Wordpress troubleshooting techniquies that might be helpful.

    If the issue persists again, recommend you to upgrade the webhosting plan to Standard and recheck if the issue persists again.

    Regards,

    Shirisha Paderu


    Thursday, March 19, 2015 3:08 PM
    Moderator
  • My timezone is UTC+1

    I just got the same error this morning around 07:30 UTC+1.

    Why would it help to upgrade to standard?

    Here is an error from the PHP log

    [19-Mar-2015 15:58:18 America/Los_Angeles] PHP Fatal error:  Failure in PHP_MINIT_FUNCTION(Wincache): 212 in Unknown on line 0

    That error started on [23-Oct-2014 18:11:47 America/Los_Angeles]

    Just got the same HTTP error:

      1. Remote Address:
        10.25.15.4:8080
      2. Request URL:
        http://blog.gauffin.org/2013/01/ado-net-the-right-way/
      3. Request Method:
        GET
      4. Status Code:
        500 Internal Server Error
    1. Response Headersview source
      1. Age:
        0
      2. Connection:
        Keep-Alive
      3. Content-Length:
        75
      4. Content-Type:
        text/html
      5. Date:
        Fri, 20 Mar 2015 07:55:29 GMT
      6. Proxy-Connection:
        Keep-Alive
      7. Server:
        Microsoft-IIS/8.0
      8. X-Powered-By:
        ASP.NET
    2. Request Headersview source
      1. Accept:
        text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
      2. Accept-Encoding:
        gzip, deflate, sdch
      3. Accept-Language:
        en-US,en;q=0.8,sv;q=0.6
      4. Cache-Control:
        max-age=0
      5. Host:
        blog.gauffin.org
      6. Proxy-Connection:
        keep-alive
      7. User-Agent:
        Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.89 Safari/537.36
    • Edited by jgauffin__ Friday, March 20, 2015 7:57 AM
    Friday, March 20, 2015 7:06 AM
  • Hi,

    Thanks for the response. I am currently researching on it and would get back to you at the earliest.

    Regards,

    Shirisha Paderu

    Friday, March 20, 2015 9:40 AM
    Moderator
  • Got the same error again. It helped to restart the website. But seriously, why is that necessary? 

    Edit 1:

    got the same error again:

      1. Remote Address:
        94.245.104.73:80
      2. Request URL:
        http://blog.gauffin.org/wp-admin/
      3. Request Method:
        GET
      4. Status Code:
        500 Internal Server Error
    1. Response Headersview source
      1. Content-Length:
        75
      2. Content-Type:
        text/html
      3. Date:
        Sun, 22 Mar 2015 18:50:09 GMT
      4. Server:
        Microsoft-IIS/8.0
      5. X-Powered-By:
        ASP.NET
    2. Request Headersview source
      1. Accept:
        text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
      2. Accept-Encoding:
        gzip, deflate, sdch
      3. Accept-Language:
        en-US,en;q=0.8,sv;q=0.6
      4. Cache-Control:
        max-age=0
      5. Connection:
        keep-alive
      6. Host:
        blog.gauffin.org
      7. Referer:
        http://blog.gauffin.org/
      8. User-Agent:
        Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36


    Edit 2

    .. and again..

      1. Remote Address:
        94.245.104.73:80
      2. Request URL:
        http://blog.gauffin.org/
      3. Request Method:
        GET
      4. Status Code:
        500 Internal Server Error
    1. Response Headersview source
      1. Content-Length:
        75
      2. Content-Type:
        text/html
      3. Date:
        Mon, 23 Mar 2015 05:06:25 GMT
      4. Server:
        Microsoft-IIS/8.0
      5. X-Powered-By:
        ASP.NET

    • Edited by jgauffin__ Monday, March 23, 2015 5:07 AM
    Saturday, March 21, 2015 4:46 AM

  • Hi,

    I am checking on this with senior engineers to gather more information with regards to your request. I shall revert back to you with an update at the earliest.

    Sincerely appreciate your patience.

    Regards,

    Shirisha Paderu

    Monday, March 23, 2015 1:56 PM
    Moderator
  • Hi,

    Could you confirm if your azure subscription id begins with 9b and ends with 1d2. Just to make sure we are analyzing the correct logs. 

    Regards,

    Shirisha Paderu 

    Tuesday, March 24, 2015 9:34 AM
    Moderator
  • confirmed.
    Tuesday, March 24, 2015 3:06 PM
  • Hi,

    Please enable WordPress Debug logging and check the /wp-content/debug.log to see what matches the 500 errors:

    Example wp-config.php for Debugging

    The following code, inserted in your wp-config.php file, will log all errors, notices, and warnings to a file called debug.log in the wp-content directory. It will also hide the errors so they do not interrupt page generation. 

     // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings 
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define('SCRIPT_DEBUG', true);
    If you still have questions copy and paste the errors that you are seeing.
    Thank you,

    Cristhian Uribe Microsoft MSFT)

    Tuesday, March 24, 2015 4:34 PM
    Moderator
  • I just got the error but the debug.log didn't show any errors.

    However, as I've mentioned earlier. The php_errors.log got this fatal entry:

    [25-Mar-2015 10:47:22 America/Los_Angeles] PHP Fatal error:  Failure in PHP_MINIT_FUNCTION(Wincache): 212 in Unknown on line 0

    Is Wincache something that you have created? It doesn't seem to be configured properly. Might be the reason to the 500 error?


    • Edited by jgauffin__ Wednesday, March 25, 2015 8:37 PM
    Wednesday, March 25, 2015 7:52 PM
  • The PHP WinCache module was filed to initialize. How frequent is your problem?

    Thursday, March 26, 2015 1:11 AM
    Moderator
  • During February and May it have happened 3837 times. that's 1500 lost visitors per month.

    I currently get back an empty page without any message at all.

    • Edited by jgauffin__ Friday, March 27, 2015 8:22 AM
    Friday, March 27, 2015 7:17 AM
  • Hi,

    Could you send us your php_errors.log to wsazureforumsupport at Microsoft dot com along with your Azure subscription ID? We'll investigate this further to see what's happening.

    Regards,

    Cristhian Uribe Microsoft MSFT)

    Monday, March 30, 2015 2:26 PM
    Moderator
  • Hi,

    In FREB logs for jgauffin-blog,  we see Fast CGI Process crashing  during the timeframe that was provided

    |#329 FASTCGI_START @0ms |#331 FASTCGI_UNEXPECTED_EXIT @266ms |#332 SET_RESPONSE_ERROR_DESCRIPTION @266ms Details: D:\Program Files (x86)\PHP\v5.6\php-cgi.exe - The FastCGI process exited unexpectedly |#333 MODULE_SET_RESPONSE_STATUS_ERROR @266ms Module: FastCgiModule, Notification: EXECUTE_REQUEST_HANDLER, Status: 500, SubStatus: 0, HttpReason: Internal Server Error, Win32ErrorCode: 0xc0000005, ConfigException:

    In this case, we would need to identify what is causing the Fast CGI process to crash due to 0xc0000005  ( Access Violation exception)

    Our suggestion will be to collect a memory dump for the Fast CGI process

    Collecting Memory Dumps

    Procdump Instructions:

    Download Procdump  tool from :  https://technet.microsoft.com/en-us/sysinternals/dd996900.aspx

    Connect to your Azure website using FTP Client and create a folder in your root folder named “memorydumps”

    Upload prodcump.exe to the “memorydumps” folder

    Creating memory dumps: 

    Access “Debug Console” from Kudu : https://jgauffin-blog.scm.azurewebsites.net/DebugConsole 

    In the console, please go to “memorydumps” folder

    Then, paste this command : procdump.exe -e -ma -w php-cgi.exe –accepteula

    The next time we see the issue, we will see a dump file getting created in the “memorydumps” folder. Please download this site and send it across to us.

    Once we have the memory dumps, please remove the “memorydumps” folder from your site root.

    Please let me know if you have any questions.

    Regards,

    Shirisha Paderu

    Tuesday, March 31, 2015 4:57 PM
    Moderator
  • Hi,

    Awaiting your response.

    Regards,

    Shirisha Paderu

    Friday, April 03, 2015 1:51 PM
    Moderator
  • Just checking: Are you still seeing the WinCache 212 error?

    With the upgrade to WinCache 1.3.7.4, you should no longer see this issue.

    Thx!

        --E.

    Sunday, May 03, 2015 11:55 PM
  • The error is back.
    Wednesday, June 10, 2015 9:45 AM
  • Hi,

    Could you send us your php_errors.log to wsazureforumsupport at Microsoft dot com along with your Azure subscription ID and name of the Web App having the issue? We'll investigate this further to see what's happening.

    Thank you,


    Cristhian Uribe Microsoft MSFT)

    Wednesday, June 17, 2015 2:27 PM
    Moderator
  • I tried, mail bounced.

    wsazureforumsupport[at]Microsoft[dot]com

    Your message couldn't be delivered because the group you're sending to needs to know who you are before it will accept your message.

    To fix this problem, ask the email admin for the group to configure the group to accept messages from you.


    • Edited by jgauffin_ Thursday, June 18, 2015 8:15 PM
    Thursday, June 18, 2015 8:14 PM