none
ClickOnce application does not start from from desktop shortcut but start from a command line RRS feed

  • Question

  • Hello,

    I am facing a very odd problem with 2 ClickOnce application at a customer site.

    The application install fine and they refuse to launch when double clicking the Desktop Shortcut.

    The only thing that happens is briefly the dialog showing the computer connecting to the internet to check program requirements.

    The dialog closes afterwards and nothing else happens

    I have also tried to start the exe file by navigating with Windows Explorer to %userprofile%\AppData\Local\Apps\2.0\.....\...\app.exe

    The result is the same, nothing besides the online check

    But if I open a Command Prompt (cmd.exe) and cd to the directory where app.exe resides (%userprofile%\AppData\Local\Apps\2.0\.....\...\) I can start App.exe from the command line.

    Any suggestion about what is preventing the app to be started from Windows Explorer / Desktop?

    Thanks

    Friday, June 14, 2019 12:22 PM

All replies

  • Hi,

    Maybe you can try to check the ClickOnce Trust Prompt Behavior. Here is the document you can refer to.

    How to: Configure the ClickOnce Trust Prompt Behavior.

    Regards,

    Kyle


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, June 17, 2019 9:59 AM
  • Thanks Kyle,

    It sounds like it could be the reason.

    I will take a look at the registry keys

    Monday, June 17, 2019 10:15 AM
  • Maybe you can try to check the ClickOnce Trust Prompt Behavior. Here is the document you can refer to.

    How to: Configure the ClickOnce Trust Prompt Behavior.

    I tried but as far as I can see the registry settings mentioned in the link only control the installation but not the executions.

    I could prevent the installation using certain combinations, and then open up again for the installation.

    But once installed, the app won't start.

    I have found a work around related to a Windows 8 problem here Work around

    Wednesday, June 19, 2019 8:40 AM
  • Hi bespawler,

    Have you tried to set security setting?

    Regards,

    Kyle


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, June 20, 2019 6:39 AM
  • Have you tried to set security setting?

    Hi Kyle,

    not sure what you mean, but if it requires changes in the application itself is not something I can do since the application is dowloaded from the internet https://worksofbarry.com/ileditor/

    Thursday, June 20, 2019 9:50 AM
  • Hi bespawler,

    If you can't change the properties, you'd better contact the software vendor and ask them for help.

    Regards,

    Kyle


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, June 21, 2019 5:52 AM