Running the xamarin.UWP project causes Unhandled exception at 0x6671B076 (twinapi.appcore.dll) RRS feed

  • Question

  • User292354 posted

    I created a new cross platform app using Xamarin.Forms in Visual Studio 2017 on windows 10. The project can get built but when I run it, I get 'Unhandled exception at 0x6671B076 (twinapi.appcore.dll)' exception. Any one has any idea to solve this issue?!

    Saturday, January 27, 2018 1:36 AM

All replies

  • User96159 posted

    Sounds like something is wrong with the store cache on your machine. From an command prompt running as an admistrator run the command wsreset.exe. This will attempt to repair the store.

    Saturday, January 27, 2018 11:35 AM
  • User292354 posted

    I ran wsreset.exe and it ran app store but it didn't solve the issue.

    Saturday, January 27, 2018 12:45 PM
  • User96159 posted

    Go to the microsoft store on the computer and try and install a new app from the store. Does it install?

    Sunday, January 28, 2018 1:40 PM
  • User292354 posted

    Thanks Kentucker,

    The other apps worked fine, I even had another Xamarin app and was able to debug it. However I eventually had to reset my windows and after that it got fixed.

    Thursday, February 1, 2018 2:15 AM
  • User242865 posted

    Hoping someone can help me. I've created a Xamarin Forms project in VS 2017 Community version and trying to run UWP (Universal Windows) app on a Winodws 10 machine. I keep getting this error too?

    My error is: *Unhandled exception at 0x6D15B076 (twinapi.appcore.dll) in AppName.UWP.exe: Fatal program exit requested. * I've tried to set the debugger type of Native Only, Mixed and Managed but none of the option works. I even uninstalled VS 2017 and re-installed, still no luck. I've ran update on the software and machine.

    Any idea how I could solve this issue. I'm really at a lost here.

    Wednesday, May 23, 2018 9:12 PM
  • User242865 posted

    Coming back to this, I actually got this working successful on a clean VM. Not sure why I could not run it on my physical device? For now I can use the VM for building UWP project.

    Sunday, May 27, 2018 10:54 PM
  • User399931 posted

    I never believed that this kind of problem would cause me problems in 2021 on my PC for the missing DLL file named twinapi.appcore.dll. I found it on some websites it seems legit site like Dllinstaller.com should I download the file from the site or there is another way to fix it.

    Saturday, March 13, 2021 9:07 PM
  • User399931 posted

    I download the missing twinapi.appcore.dll file but the error steal is popping up appears on my PC, what is the problem now?

    Wednesday, March 17, 2021 6:22 PM