locked
Unable to see Availability Set Option under Load Balancer RRS feed

  • Question

  • All VMs, Availability Set and Load balancer are in same Resource Group and in same region.
    All Public IP for VMs and Load Balancer are using Basic sku. 
    when I am trying to configure this availability set in Load Balancer then I am not seeing any Availability Set as option.

    
    Tuesday, May 19, 2020 2:23 AM

All replies

  • There are now 2 different SKUs for Azure Load Balancers, and one of the differences is how you add machines to the backend pools.

    Basic SKU Load Balancers add Availability Sets to the backend poos

    Standard SKU Load Balancers add individual VMs or VMSS to the backend pools. 

    You are currently using a Standard SKU Load Balancer. If you need a Basic SKU load balancer, you will need to delete the Load Balancer and recreate it as Basic. 

    Wednesday, May 20, 2020 11:46 PM
  • I have already tried it creating with Basic sku Load balancer and also specified same statement in my initial question "All Public IP for VMs and Load Balancer are using Basic sku.".
    Friday, May 22, 2020 1:54 AM
  • My apologies, I missed that in the initial statement. 

    This is the first time that I have seen this change! Basic LBs have changed how VMs are added in the portal. Instead of adding backend items by availability set , they are added VM by VM. The VMs you add must be in the same availability set, and this is stated in the text when you add VMs. 

    This is a recent change, and should not affect the functionality of the load balancer. If you need assistance in how to add items to the backend pool VM by VM, please let me know!

    Wednesday, May 27, 2020 6:21 AM