none
<code> - Element in Reports - stopped working in CTP3 - Why?

    Question

  • We developed some Reports using Azure Reporting CTPs with custome Code. Functionality was just easy: Format some Strings in functions before putting the value into the cells.

     

    Now deploying this Reports in CPT3 we get the error (during deployment) "The report server has RDLSandboxing enabled and the report contains custom code. Remove the Code element from the report definition."

     

    This behaviour is documented in (http://msdn.microsoft.com/en-us/library/gg430132): "Deploying the following items to a SQL Azure report server is not supported: ...  Code in a Code element in a report definition.

    Is there any reason for this new restriction?


    Dan Danneberg
    Tuesday, October 11, 2011 8:57 PM

Answers

  • Hi Dan,

    Currently it is just SQL Azure Reporting CTP, this feature is not supported in this version, hope the coming RTM will contain this feature.

    Thanks,
    Challen Fu

    Forum Support
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, October 13, 2011 2:12 AM

All replies

  • Hi Dan,

    Currently it is just SQL Azure Reporting CTP, this feature is not supported in this version, hope the coming RTM will contain this feature.

    Thanks,
    Challen Fu

    Forum Support
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, October 13, 2011 2:12 AM
  • Tanks for this information. Lets see what hope means.

     

    Dan


    Dan Danneberg
    Thursday, October 13, 2011 7:18 AM