none
應用程式中發生伺服器錯誤

    一般討論

  • 作業系統版本- Windows XP
  • 開發工具版本-Visual Studio 2005
  • ASP.NET 版本-ASP.NET 2.0
  • 我寫好程式放在Server端時,在Server上開啟Visual Studio 2005按執行時,是可以成功執行
    但是打開網頁輸入Server端網址時,出現"應用程式中發生伺服器錯誤"
    錯誤訊息如下
     描述: 處理服務此要求所需的組態檔時發生錯誤。請檢視下列的特定錯誤詳細資訊,並適當修改您的組態檔。

    剖析器錯誤訊息: 已經定義過區段或群組名稱 'system.web.extensions'。您只能在定義它的組態層級中更新它。

    原始程式錯誤:

    行 3:  	<configSections><!--一般設定結構描述-->
    行 4:      <!--在組態區段處理常式和組態區段之間定義關聯-->
    行 5:      <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    行 6:       
    行 7:        <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">

    原始程式檔: C:\Inetpub\wwwroot\query\web.config    行: 5



    已經定義過區段或群組名稱 'scripting'。您只能在定義它的組態層級中更新它。 (C:\Inetpub\wwwroot\query\web.config line 7)
    已經定義過區段或群組名稱 'scriptResourceHandler'。您只能在定義它的組態層級中更新它。 (C:\Inetpub\wwwroot\query\web.config line 8)
    已經定義過區段或群組名稱 'webServices'。您只能在定義它的組態層級中更新它。 (C:\Inetpub\wwwroot\query\web.config line 9)
    已經定義過區段或群組名稱 'jsonSerialization'。您只能在定義它的組態層級中更新它。 (C:\Inetpub\wwwroot\query\web.config line 10)
    已經定義過區段或群組名稱 'profileService'。您只能在定義它的組態層級中更新它。 (C:\Inetpub\wwwroot\query\web.config line 11)
    已經定義過區段或群組名稱 'authenticationService'。您只能在定義它的組態層級中更新它。 (C:\Inetpub\wwwroot\query\web.config line 12)

    版本資訊: Microsoft .NET Framework 版本:2.0.50727.3053; ASP.NET 版本:2.0.50727.3053

    '/query' 應用程式中發生伺服器錯誤。

    組態錯誤

     


    請問我該怎麼做才能解決問題。謝謝

  • 已變更類型 Lolota Lee 2009年8月10日 上午 02:38 發問者未繼續回覆
2009年7月28日 上午 08:16

所有回覆

  • 看起來像是網站的ASP.NET版本選錯的訊息,請遊IIS管理員>本機電腦>網站>您設定好的網站>內容>ASP.NET>ASP.NET版本。 以Windows 2003 Server為例,建立站台時ASP.NET版本預設為1.1.4322,請將之改為2.0.50727試試看。
    2009年7月28日 上午 08:54
  • 我有去IIS管理員>本機電腦>網站>您設定好的網站>內容>ASP.NET>ASP.NET版本看過了,建立站台時ASP.NET版本預設是為2.0.50727
    還有可能有另外的情況發生嗎?謝謝

    2009年7月28日 上午 09:20
  • 在Web.config"只" 加入下列片段看看 :
    <httpHandlers>
          <remove verb="*" path="*.asmx"/>
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
        </httpHandlers>

        <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        </httpModules>


    微軟技術支援中心(CSS) - http://www.dotblogs.com.tw/lolota/
    2009年7月28日 上午 09:26
  • 你有把放 web.config 的目錄設為虛擬應用程式嗎?


    論壇是網友平等互助 保證解答請至 微軟技術支援服務
    2009年7月28日 上午 09:29
  • 你說的
    <httpHandlers>
          <remove verb="*" path="*.asmx"/>
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
        </httpHandlers>

        <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        </httpModules>
    我原本就有了,我把我Web.config內容放上來好了,謝謝
    ----------------------------------------------------------------------------
    <?xml version="1.0"?>
    <configuration>
     <configSections>
         <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
        
          <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
            <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
              <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere" />
              <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
            </sectionGroup>
          </sectionGroup>
        </sectionGroup>
     </configSections>
     <connectionStrings>
      <add name="XXX" connectionString="Data Source=XXX;Initial Catalog=XXX;User ID=XX ;Password=XXX" providerName="System.Data.SqlClient"/>
     </connectionStrings>
     <system.web>
     <customErrors mode="Off"/>

      <pages>
       <controls>
        <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
       </controls>
      </pages>
      <!--
              Set compilation debug="true" to insert debugging
              symbols into the compiled page. Because this
              affects performance, set this value to true only
              during development.
        -->
      <compilation debug="true">
       <assemblies>
            <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Windows.Presentation, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
          </assemblies>
      </compilation>
      <httpHandlers>
          <remove verb="*" path="*.asmx"/>
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>

        </httpHandlers>
      <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

       </httpModules>
     </system.web>

      <system.web.extensions>
        <scripting>
          <webServices>
            <!-- Uncomment this line to customize maxJsonLength and add a custom converter -->
            <!--
          <jsonSerialization maxJsonLength="500">
            <converters>
              <add name="ConvertMe" type="Acme.SubAcme.ConvertMeTypeConverter"/>
            </converters>
          </jsonSerialization>
          -->
            <!-- Uncomment this line to enable the authentication service. Include requireSSL="true" if appropriate. -->
            <!--
            <authenticationService enabled="true" requireSSL = "true|false"/>
          -->

            <!-- Uncomment these lines to enable the profile service. To allow profile properties to be retrieved
               and modified in ASP.NET AJAX applications, you need to add each property name to the readAccessProperties and
               writeAccessProperties attributes. -->
            <!--
          <profileService enabled="true"
                          readAccessProperties="propertyname1,propertyname2"
                          writeAccessProperties="propertyname1,propertyname2" />
          -->
          </webServices>
          <!--
          <scriptResourceHandler enableCompression="true" enableCaching="true" />
          -->
        </scripting>
      </system.web.extensions>
           
     <system.webServer>
      <validation validateIntegratedModeConfiguration="false"/>
      <modules>
       <add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      </modules>
      <handlers>
       <remove name="WebServiceHandlerFactory-Integrated" />
       <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode"
               type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
       <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode"
               type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
       <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      </handlers>
     </system.webServer>
    </configuration>

    2009年7月28日 上午 09:34
  • 請問怎麼知道web.config 的目錄是設為虛擬應用程式? 謝謝
    我只知道這一個目錄要執行之前的程式(未加入AJAX)是可以執行的

    2009年7月28日 上午 09:38
  • HI,

    您的web.config檔案中, 以下的區段:
    <sectionGroup name="system.web.extensions" .../>
    
    是否有重複一次以上?
    2009年7月29日 上午 11:12
  • 我是用C:\Program Files\Microsoft ASP.NET\ASP.NET 2.0 AJAX Extensions\v1.0.61025裡的web.config檔改的
    也就是原本的Web.config加上上面路徑的檔案比較原本檔沒有的程式加上去的
    然後我也比較過你說的<sectionGroup name="system.web.extensions" .../>沒有重覆
    至於
    Web.config的內容我有放上來在上面。謝謝

    2009年7月30日 上午 01:33
  • 後來我把web.config一些程式給註解掉,但是會發生(伺服器標記 'asp:ScriptManager' 模稜兩可)
    我註解掉的程式如下
    (1)
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
        <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
              <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
        <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
              <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere" />
              <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
        </sectionGroup>
        </sectionGroup>
        </sectionGroup>
    (2)
       <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </httpModules>
    我看過公司安裝的軟体,有NET Framework 3.5和NET Framework 3.0 至於C:\WINDOWS\assembly裡的System.Web.extensions有二個(3.5.0.0和1.0.61025.0
    至於作業系統版本是Windows XP,開發工具版本是Visual Studio 2005 ,ASP.NET 版本是ASP.NET 2.0,安裝的AjaxControlToolkit.dll版本是1.0.61025.0的
    請問這也是有相關的影響嗎?謝謝
    2009年7月30日 上午 02:57
  • 用 IIS 管理員點選該目錄,滑鼠右鍵,就可以看到是否設為虛擬應用程式。


    論壇是網友平等互助 保證解答請至 微軟技術支援服務
    2009年7月30日 上午 03:10
  • 你有看過 C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config 裡的 <configSections></configSections> 區塊是否
    有重複的內容?我這邊測試只有在 machine.config 加入同樣的 <sectionGroup> 組態才會出現類似的錯誤...
    2009年7月30日 上午 03:48
  • 我沒有看到重覆的 <sectionGroup>組態,不過我發現一個奇怪的現象
    我寫了二個程式,一個有用ajax一個沒有用ajax
    沒有用ajax的可以執行(在主機端可以執行,在網頁輸入網址也可以執行)
    有用ajax的確不能執行(在主機端可以執行,但在網頁輸入網址確執行錯誤),它的錯誤說明如下
    剖析器錯誤
    描述: 當剖析服務此要求所需的資源時發生錯誤。請檢閱下列的特定剖析錯誤詳細資訊,並且適當地修改您的原始程式檔。

    剖析器錯誤訊息: 伺服器標記 'asp:ScriptManager' 模稜兩可。請修改造成模稜兩可的相關登錄,並選取新的標記前置詞。
    原始程式錯誤:

    [沒有相關的原始程式碼]

    原始程式檔:    行: 0

    版本資訊: Microsoft .NET Framework 版本:2.0.50727.3053; ASP.NET 版本:2.0.50727.3053
    請問這是代表什麼
    2009年8月3日 上午 01:07
  • 剛剛回頭看了一下你貼的 web.config 發現:

    <compilation debug="true">
       <assemblies>
            <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

        <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Windows.Presentation, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
          </assemblies>
      </compilation>

    不知道會不會是這原因?
    2009年8月3日 上午 01:21
  • 我改了好多次Web.config,我再貼一次是我最後的版本,如下
    ------------------------------------------------------------------------
    <?xml version="1.0"?>
    <configuration>
      <configSections>   
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
              <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
    <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
              <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere" />
              <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
    </sectionGroup>
    </sectionGroup>
    </sectionGroup>
      </configSections>
      

      <connectionStrings>
        <add name="XXX" connectionString="Data Source=XXX;Initial Catalog=XXX;User ID=XX ;Password=XXX" providerName="System.Data.SqlClient"/>
      </connectionStrings>

      
      <system.web>
        <customErrors mode="Off"/>
        <pages>
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          </controls>
        </pages>
        <!--
              Set compilation debug="true" to insert debugging
              symbols into the compiled page. Because this
              affects performance, set this value to true only
              during development.
        -->
        <compilation debug="true">
          <assemblies>
            <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          </assemblies>
        </compilation>

        <httpHandlers>
          <remove verb="*" path="*.asmx"/>
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
        </httpHandlers>

        <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </httpModules>
      </system.web>

      <system.web.extensions>
        <scripting>
          <webServices>
          <!-- Uncomment this line to customize maxJsonLength and add a custom converter -->
          <!--
          <jsonSerialization maxJsonLength="500">
            <converters>
              <add name="ConvertMe" type="Acme.SubAcme.ConvertMeTypeConverter"/>
            </converters>
          </jsonSerialization>
          -->
          <!-- Uncomment this line to enable the authentication service. Include requireSSL="true" if appropriate. -->
          <!--
            <authenticationService enabled="true" requireSSL = "true|false"/>
          -->

          <!-- Uncomment these lines to enable the profile service. To allow profile properties to be retrieved
               and modified in ASP.NET AJAX applications, you need to add each property name to the readAccessProperties and
               writeAccessProperties attributes. -->
          <!--
          <profileService enabled="true"
                          readAccessProperties="propertyname1,propertyname2"
                          writeAccessProperties="propertyname1,propertyname2" />
          -->
          </webServices>
          <!--
          <scriptResourceHandler enableCompression="true" enableCaching="true" />
          -->
        </scripting>
      </system.web.extensions>

      <system.webServer>
        <validation validateIntegratedModeConfiguration="false"/>
        <modules>
          <add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        </modules>
        <handlers>
          <remove name="WebServiceHandlerFactory-Integrated" />
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode"
               type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode"
               type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </handlers>
      </system.webServer>
    </configuration>

    2009年8月3日 上午 03:04
  • 那現在錯誤訊息有變嗎?

    [asp:ScriptManager' 模稜兩可] , 您有去檢查畫面上是否有下列System.Web.Extensions...宣告? 然後它的tagPrefix跟web.config設定不同? :

    <% @ Page Language = "VB" AutoEventWireup = "false" CodeFile = "Default.aspx.vb" Inherits = "_Default" %>

     

    <% @ Register Assembly = "System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

        Namespace = "System.Web.UI" TagPrefix = "asp" %>

     

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd" >

     

    <html xmlns = "http://www.w3.org/1999/xhtml" >

    <head runat = "server" >

        <title> Untitled Page</title>

    </head>


    微軟技術支援中心(CSS) - http://www.dotblogs.com.tw/lolota/
    2009年8月3日 上午 08:48
  • Hi,

    您的問題解決了嗎?


    B.R.
    Lolota

    http://www.dotblogs.com.tw/lolota/
    2009年8月4日 上午 03:09
  • sorry 最近公司在趕一個案子(使用Delphi),我沒有辦法去try看看程式,我會盡快的找出時間來try看看 謝謝
    2009年9月9日 上午 02:58