none
Unable to get CRM business units

    问题

  • I cant seem to figure this out. I can create the CRM Organization fine and delete and recreate. It resolves DNS, can login, see my admin account as a user (one selected when I create the site). When I go to CRM Users it gives me this error when I try to create a new user (and the admin user is not listed).

    All my IFD settings seem fine based on forums etc. It is using http it is just the same error. To me it seems like the original user that created the site doesnt have rights to look up the user list in the new organization. Am I missing something on setting up the user? User is:

    WPServer User for Anonymous and AppPool

    WPServer User is in local adminisrtators of CRM and SQL Server

    WPServer User is in PrivUser Group created by CRM

    WPServer User is a deployment administrator

    WPServer User is a System Administrator of the Default Organization Site (Only way I am able to create a new site)

    I have verified that WPServer is authenticating to CRM NTLM not IFD.

    This is the only error in the event log:

    [9/5/2010 11:25:50 AM] ERROR: HostedSolution

    System.Net.WebException: The request failed with HTTP status 401: Unauthorized.

    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)

    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

    at CrmService.Execute(Request Request)

    at WebsitePanel.Providers.HostedSolution.CRMProvider.GetOrganizationBusinessUnitsInternal(Guid organizationId, String orgName)

    Please help.

    2010年9月5日 16:04
    版主

答案

  • Hi Omar,

     

    Thank you for your kindly words and assistance.

     

    So, I’m closing your support request.

     

    Thanks.


    Best regards, Dmitry Fitsner Support@ExpertServices.us | WebsitePanel Installations, Support & Consulting | Enterprise Solutions Planning & Deployment & Support
    2010年9月8日 14:57
    答复者

全部回复

  • Hi Omar,

    Sorry for delay with my reply.

    You should be able to resolve CRM machine name etc.

    Check if Microsoft CRM Asynchronous Processing Service is started

    Check WSP Server AD user account membership

    Check panel Added Server > Active Directory Settings

     

    BTW, it looks like CRM organization was removed via the panel and now, you are trying to add CRM organization from the scratch.

    http://help.dotnetpanel.com/DotNetPanel%20Hosted%20CRM%20Solution/Home/Troubleshooting.aspx

     In order to completely delete CRM organization (that may be needed for creating new CRM organization under the same Organization in WSP)Remove

    1.   Remove CRM Organization via the panel

    2.       Force MSCRM_CONFIG.HardDelete (in case of error, start again) and MSCRM_CONFIG.SiteWideCleanup jobs on CRM SQL Server, then backup customer_ID_MSCRM database and then delete it.

    3.       You need to wait about 10 minutes for internal CRM structure synchronization before creating new CRM organization with the same name.

     

    ***In some cases (for example, you don’t wait for CRM synchronization. It can takes more than 10 min) try to Restart Microsoft CRM Asynchronous Processing Service.

    4.      Try to create CRM organization from the scratch.

    Please keep me informed.

    Thanks.


    Best regards, Dmitry Fitsner Support@ExpertServices.us | WebsitePanel Installations, Support & Consulting | Enterprise Solutions Planning & Deployment & Support
    2010年9月7日 23:04
    答复者
  • Thank you Dmitry for your help. I had tried these steps myself but with your help I have been able to get past this problem. It is great that people like you are roaming these forums, you will be a resource I will reach out to moving forward for sure.

    Thanks.

    2010年9月8日 12:14
    版主
  • Hi Omar,

     

    Thank you for your kindly words and assistance.

     

    So, I’m closing your support request.

     

    Thanks.


    Best regards, Dmitry Fitsner Support@ExpertServices.us | WebsitePanel Installations, Support & Consulting | Enterprise Solutions Planning & Deployment & Support
    2010年9月8日 14:57
    答复者