none
Live tile not updating after the 7.8 update (for some of my users)

    Question

  • Hi,

    I've had 4 of my users now write to me to say that applying the 7.8 update caused the live tile of my app to stop updating. 2 of them noticed that their other live tile apps have stopped updating too. I have many thousands of users so I'm guessing it's not everyone who has 7.8 has the problem (or my inbox would probably be full) but it's still four too many for my liking, and I need to be able to advise them what to do. Some other people on the web (e.g. here, and here) seem to be experiencing live tiles breaking after applying 7.8. The tile works fine for me in the 7.8 emulator (and all the other ones), wp8, and on my own 7.8 handset (and also on my spare 7.5 handset).  

    Has anyone any ideas on how I can help them? Or any news from Microsoft on problems (for some) with the 7.8 update? I would appreciate it. Thanks!

    I'm guessing it's not something I will be able to fix (e.g. by releasing a new version), i.e. that it is a glitch in the 7.8 update (as other apps are affected too) but any suggestions would be welcomed. I wondered about implementing 7.8 wide tile support to see if that would fix the standard tile but it seems a long shot.

    Thanks,

    Ian

    Extra Info:

    They have tried uninstalling and reinstalling the app. They are understandably hesitant to try a hard-reset. One of them restored back to 7.5 and the tile started working again (for my app and others). My app has had a reliable live tile for over two years now and so I feel I know what I'm doing with the push system.

    I have tried resending the tiles to them multiple times - and the push system tells me the message was either connected/ok or I also saw connected/supressed. They have the tile pinned, and full battery charge.


    Author of the live-tiled multi-league football app "Premier Leagues +"

    Monday, February 11, 2013 4:35 PM

Answers

  • Hi Oliver,

    An update: this issue has been recorded and the problem is understood. 

    There are actually two issues:

    1. Live tile causing continuous web requests (and side effects such as battery drain)

    2. Live tile failing to update.

    The fixes will be considered for inclusion in an update to the phone operating system.

    In the forum post above, several posters have been able to get around the problem by unpinning and repinning the live tiles. This might be a temporary workaround.

    Thank you for your diligence and feedback!
    Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Monday, February 25, 2013 3:41 PM

All replies

  • Hi Ian,

    Is it possible that you can you find out from the four users, what phone model and OS version they are using?

    Perhaps the problem is hardware or OS specific.

    The second link you posted reports the issue in the Nokia Lumia 900. I am curious if it is limited to that model, several, or all.

    Searching around the web, the issue of live tiles not updating has been corrected sometimes by blocking all the background tasks in Settings->applications->background tasks and setting the checkbox for those apps that you wish to restart the next time you start the app.

    Another solution that worked for some is to reset the phone (as a last resort).

    Thanks,
    Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Tuesday, February 12, 2013 2:58 AM
  • Hi Mark,

    Thanks for getting back to me.

    The phone models for the four users: Lumia 800, HTC Radar, Lumia 710, Lumia 800

    The background tasks suggestion had no effect amongst my affected users for fixing it (either indirectly for my app - which doesn't use background tasks - or on other tile apps that do).

    Hard resetting was tried by one of my users and worked (all tiled apps including mine working again) although of course it's not an easy one to recommend to users.

    Thanks,

    Ian


    Author of the live-tiled multi-league football app "Premier Leagues +"

    Tuesday, February 12, 2013 2:50 PM
  • You are saying none of their live tiles worked at all? Sounds a lot like this

    http://forum.xda-developers.com/showthread.php?t=2140496

    Tuesday, February 12, 2013 6:56 PM
  • Hi Mark,

    have a look at this.
    http://answers.microsoft.com/en-us/winphone/forum/wp7-wpapps/wp-78-live-tile-update-problem/9b564f11-4c68-4057-afdc-8e0e62295236#LastReply

    The problem may not be fixed by a reset or going back to 7.5.
    After a short Time (5 days on my Lumia800) the tiles doesn't get any updates again.

    Monday, February 18, 2013 10:35 AM
  • Thanks Oliver,

    We have this general topic on our radar and are monitoring, to learn how wide spread it is.

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Tuesday, February 19, 2013 6:38 PM
  • The problem might be much more spread than expected.
    I guess, you have read this?
    http://www.wpcentral.com/windows-phone-live-tiles-more-problematic-than-first-assumed

    Btw. after a reset on friday evening, the tiles stuck again since yesterday...
    Does it make any sense a MVP escalate this to MS?

    Monday, February 25, 2013 1:59 PM
  • Hi Oliver,

    An update: this issue has been recorded and the problem is understood. 

    There are actually two issues:

    1. Live tile causing continuous web requests (and side effects such as battery drain)

    2. Live tile failing to update.

    The fixes will be considered for inclusion in an update to the phone operating system.

    In the forum post above, several posters have been able to get around the problem by unpinning and repinning the live tiles. This might be a temporary workaround.

    Thank you for your diligence and feedback!
    Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Monday, February 25, 2013 3:41 PM
  • Thanks for looking into this Mark. Some extra info for you...

    Here are the things my affected users tried:

    • Restoring back to 7.5. This worked (the tile started updating again); but of course they lost the 7.8 benefits. It reinforces, however, the idea that it's the 7.8 update at fault.
    • Restoring back to 7.5 and then re-applying the 7.8 update. Two of my users tried this and it worked so it’s perhaps the best recommendation.
    • Hard-resetting the phone. This worked – but one user said the problem came back.

    Note that 'unpinning and repining' worked for none of them. Neither did uninstalling / reinstalling.

    One of the users who wrote to me with the problem updated to 7.8 using the cab method (as opposed to an official update from their mobile operator) which of course is not a recommended route - but others (also affected) did it the official way so it's certainly not a definitive reason.

    Hope that's of help.

    Ian


    Author of the live-tiled multi-league football app "Premier Leagues +"

    Monday, February 25, 2013 9:17 PM
  • Hi Mark,

    thanks for this Information.

    Tuesday, February 26, 2013 6:54 AM
  • Hi Mark,

    I noticed your response has been published to the world and has been receiving criticism for the words "fixes will be considered for inclusion". You may want to rephrase in a more committal manner?  

    Thursday, February 28, 2013 7:07 PM
  • Hi Mark,

    I posted it that way because I currently don't have further information. I will post updates when available.

    Thanks,
    Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Thursday, February 28, 2013 7:18 PM
  • The problem may not be fixed by a reset or going back to 7.5.
    After a short Time (5 days on my Lumia800) the tiles doesn't get any updates again.

    I'm a new user of a Nokia Lumia 800 with Windows Phone 7.8 out of the box... The first impression about phone it's wow but after 2 day it's WTF!!! The battery it's drained so fast I cant's see it with my eyes, the GSM signal lines are so poor (and it's like iPhone signal problem when you hold the phone the signal go down) and the audio volume it's to low and if I set it up to the 20 percent when I restart the phone it's going back to 10 or 13 by himself :( ..and another surprise THERE IS NO Bluetooth considering the Nokia release an app Bluetooth Share well when I try to download it or install from the market surprise "You r phone it's not supporting this app" ...

    I rely don't know why it's a top phone when it's get soooo many bad point's, and the general impression, after a week it's that I miss my Motorola Android phone... :(

    PLS MS+NOKIA DO SOMETHING or reverse it back to the 7.5. The phone it's rely shaking things down, and the internet it's full with bugs and peoples trying to solve the new 7.8 OS problems.

    PS I stopped all the data services that are running in background, kill all the data transfer and in Xbox Game hub at Settings I turned OFF "Connect with Xbox Live " and I see that the battery got the juice a little longer than before I got 2 days of live phone, not only 7 h like before.

    Monday, March 04, 2013 7:53 AM
  • Hi Mark,

    Some more (hopefully helpful) information for you. I tried sending some variations of tile xml to an affected user. This is what I found:

    - I was able to successfully clear images from his tile, e.g <wp:BackgroundImage Action="Clear">

    - I was able to successfully show images local to the app e.g. <wp:BackgroundImage IsRelative="true">

    - I was able to successfully put text on the tile (BackContent, WideBackContent).

    but note that the when I included a remote url image in the tile message it did not work.

    So it looks like things work apart from asking the tile to download images. Unfortunately of course that factor is pretty important to my app and others.

    Good luck with the fix.

    All the best,

    Ian


    Author of the live-tiled multi-league football app "Premier Leagues +"


    • Edited by Ian Percival Tuesday, March 05, 2013 10:51 AM
    • Proposed as answer by theOriginalFu Sunday, April 28, 2013 7:11 PM
    • Unproposed as answer by theOriginalFu Sunday, April 28, 2013 7:11 PM
    Tuesday, March 05, 2013 10:48 AM
  • Phone: LG Quantum (C900B)

    OS: 7.10.8862.144

    Firmware: 1.0.8.10

    Hardware: 1.1.0.0

    Two days ago my 3rd party live tiles stopped updating. Unpinning/repinning nor uninstalling/reinstalling resumes live tile updates. Only opening the app will update the live tile. Curious thing: unpinning the live tile and then after immediately soft resetting, the affected live tiles show up in the same spot and size on the start screen prior to the unpin. In most cases only uninstalling the app wil consistently remove the live tile. But upon reinstalling the non-update issue remains. Turning the app on in Background Tasks has no effect.

    Sunday, April 28, 2013 7:21 PM