none
WP8: Emulator has no Internet access

    Question

  • Hi everyone,

    the emulator works for me but get's no Internet access. I've read the troubleshooting document but it doesn't worked for me or I've overlooked something.

    That I have>

    1. A FritzBox as my router
    2. My desktop PC running the emulator, connected on the router by Ethernet cable (1GBit to be excactlz)
    3. The emulator get's it's own IP from the router and on the router admin web interface I can see that the desktop pc and the emulator have two different IPs.
    4. I've tried to deactivate the proxy detection settings (no proxy configured) but it doesn't change anything.

    I hope someone can point how to configure the settings correctly.
    As a side note: This is terrible! The emulator from the WP 7.1 SDK did the things and it just worked! I'm a developer and not an IT administrator to configure and understand Hyper-V in it's glory to get this easy task working.


    Ralf Ehlert MCPD | MCTS | MCAS | MCP

    Wednesday, October 31, 2012 10:44 PM

Answers

  • I figured my Win 8 + WP8 SDK connectivity problem out!(After 6 hours of trying everything I can)

    I was originally using a class B static IP in my windows 8 network connection.

    I tried everything with this setup and still couldnt get the emulator connectivity to work.

    Ten minutes ago I plugged my PC into a wireless router with DHCP enabled.

    And all of a sudden voila! The emulator internet connection works!

    Hope this helps!

    Thursday, November 01, 2012 5:18 PM
  • I don't know that was wrong. But I deleted the VM in the Hyper-V Manager and let Visual Studio create a new one and Internet Access works.

    Strange Thing...


    Ralf Ehlert MCPD | MCTS | MCAS | MCP

    • Marked as answer by Ralf Ehlert Thursday, November 01, 2012 7:50 PM
    Thursday, November 01, 2012 7:50 PM

All replies

  • Hei,

    I have this problem as well. No internet connectivity. Networking with virtual machines is always a headache. I tried everything in the trouble shooting document. Nothing helped.

    HyperV is going to be a pain in the future. bad idea to use a full blown vm.

    Wednesday, October 31, 2012 10:51 PM
  • Have you set a fixed IP address for your PC in router?
    Thursday, November 01, 2012 12:34 PM
  • Hello, this issue is troubling me and I can't get it to work.
    Computer setup.
    CPU:AMD Phenom x4 9550
    Motherboard:M2A-VM
    Memory:4G DDR2

    OS:Windows 8 Enterprise x64
    installed all windows 8 updates

    Hyper-v installed and enabled

    pc IPv4 setting:static ip(140.123.106.xxx)

    network settings:
    ==================
    vEthernet(Internal Ethernet Port Windows Phone Emulator Internal Switch)
    IP:169.254.80.80
    Mask:255.255.0.0
    no default gateway
    dns:8.8.8.8
    ================================
    vEthernet(Realtek PCIe GBE Family Controller Virtual Switch)
    IP:140.123.106.xxx
    Mask:255.255.255.0
    default gateway:140.123.106.249
    dns:8.8.8.8
    =================================
    Ethernet(Realtek PCIe GBE Family Controller)
    No settings here, I only see a Hyper-v switch service installed in this ethernet controller
    ================================
    these three things exist in my win 8 network settings part

    really frustrating...seems people on the WP8 dev official forum many have the same problem
    Thursday, November 01, 2012 3:25 PM
  • Yes for a port forwarding rule. Does that matter?

    Ralf Ehlert MCPD | MCTS | MCAS | MCP

    Thursday, November 01, 2012 4:25 PM
  • I figured my Win 8 + WP8 SDK connectivity problem out!(After 6 hours of trying everything I can)

    I was originally using a class B static IP in my windows 8 network connection.

    I tried everything with this setup and still couldnt get the emulator connectivity to work.

    Ten minutes ago I plugged my PC into a wireless router with DHCP enabled.

    And all of a sudden voila! The emulator internet connection works!

    Hope this helps!

    Thursday, November 01, 2012 5:18 PM
  • I don't know that was wrong. But I deleted the VM in the Hyper-V Manager and let Visual Studio create a new one and Internet Access works.

    Strange Thing...


    Ralf Ehlert MCPD | MCTS | MCAS | MCP

    • Marked as answer by Ralf Ehlert Thursday, November 01, 2012 7:50 PM
    Thursday, November 01, 2012 7:50 PM
  • I figured my Win 8 + WP8 SDK connectivity problem out!(After 6 hours of trying everything I can)

    I was originally using a class B static IP in my windows 8 network connection.

    I tried everything with this setup and still couldnt get the emulator connectivity to work.

    Ten minutes ago I plugged my PC into a wireless router with DHCP enabled.

    And all of a sudden voila! The emulator internet connection works!

    Hope this helps!

     Thanks. I had an IP-reservation in my router when I removed it suddenly started working!
    Saturday, November 03, 2012 1:25 PM
  • Mine, I type "ipconfig /renew" as admin. Everything just works!
    Friday, January 25, 2013 4:33 AM
  • Since the original post I have refined and corrected the procedure. Here it is for future reference.

    Windows Phone 8 emulator running on a desktop machine

    To capture all outgoing traffic from the phone emulator

    1. In Fiddler, go to command line (Alt+Q) and set fiddler.network.proxy.registrationhostname to the desktop machine name (not the IP address)
      • execute prefs set fiddler.network.proxy.registrationhostname mycomputer

    To capture traffic from a phone app running inside the WP8 emulator to an Azure worker running inside the Azure emulator on the desktop machine on 127.0.0.1:80

    1. Configure Fiddler as the reverse proxy (redirect all incoming requests on the Fiddler's IP address to another address)
    2. Run ipconfig and note the dynamic IP address of the desktop machine (e.g. 192.168.0.44), not the emulator's internal switch IP address
    3. In Fiddler, open the Fiddler rules by executing Customize Rules (Ctrl+R)
      • At the end of the OnBeforeRequest method add the rule (code) that performs the redirection from the Fiddler's address to the Azure worker instance's address
      • if (oSession.host.toLowerCase() == "192.168.0.44:8888") { oSession.host = "127.0.0.1:80"; }
      • inside the phone app, make calls to the Azure worker on 192.168.0.44:8888

    To capture SSL traffic (e.g. LiveAuthClient) calls, install Fiddler root certificate

    1. Inside the emulator, open IE
    2. Navigate to http://mycomputer:8888/fiddlerroot.cer and accept certificate installation


    Windows Phone emulator running inside a virtual machine (e.g. VMware)


    In this case the name of the host machine (i.e. the virtual machine) cannot be used because it is not visible on the network. All setup must be done with the IP address of the virtual machine (e.g. 192.168.0.55).

    1. In Fiddler, go to command line (Alt+Q) and set fiddler.network.proxy.registrationhostname to the VM IP address (not the the name)
      • execute prefs set fiddler.network.proxy.registrationhostname 192.168.0.55

    To capture traffic from a phone app running inside the WP8 emulator to an Azure worker running inside the Azure emulator inside the VM on 127.0.0.1:80

    • Requests for the Fiddler root certificates must be done using the IP address, so a rule must be added to redirect those requests to Fiddler using the VM name
      • At the end of the OnBeforeRequest method add a rule that redirects root certificate requests to Fiddler and everything else to the Azure worker
      • if (oSession.url.toLowerCase() == "192.168.0.55:8888/fiddlerroot.cer") { oSession.host = "myvm:8888"; } else if (oSession.host.toLowerCase() == "192.168.0.55:8888") { oSession.host = "127.0.0.1:80"; }

    To capture SSL traffic (e.g. LiveAuthClient) calls, install Fiddler root certificate

    1. Inside the emulator, open IE
    2. Navigate to http://192.168.0.55:8888/fiddlerroot.cer and accept certificate installation (notice the direct IP address)
    • Edited by vkdev Saturday, February 16, 2013 9:52 AM
    • Proposed as answer by Fros Kouri Friday, April 26, 2013 11:40 PM
    Thursday, February 14, 2013 9:03 PM
  • 1. Once you get Hyper-V installed via Turn Windows features On or Off, make sure the emulator is Off.

    2. Open Network and Sharing center in your Win7/Win8.  You'll have your current internet connection which is either WiFi or LAN which i assume it is enabled and connected to Internet and has DHCP enabled.

    3. Another ethernet connection created by Hyper-V will be available but without internet connection and DHCP Off.

    4. Hold Control Key in keyboard and select both current internet connection ethernet and Hyper-V ethernet connections.  Right click on one item when both are selected. In the appearing menu click "Bridge connections".

    5. You should see a new Network Bridge being created and IP being assigned to it.  This should have IPv4 connected to Internet.

    6. Run your Windows Phone app from Visual Studio. This should start your WP 8 emulator in Hyper-V.  Once your app gets installed, go to browser in the emulator.  You should see internet.


    Raja Venkatesh

    Sunday, October 06, 2013 6:31 PM
  • Same here, disabling DHCP Reservation (close to static IP) fixed the connectivity issue. I hope emulator had told me this -_-

    Sunday, December 22, 2013 1:50 PM