none
Windows Phone 8.0 SDK Emulator (VM failure) issue

    Question

  • I've installed the SDK without a problem. My setup is

    Windows 8 Enterprise RTM
    VS2012 Premium RTM

    When I create a sample phone app en press debug on emulator I get the following error from the emulator.

    The Windows Phone Emulator wasn't able to create the virtual machine.

    Something happened while creating a switch: Xde
    couldn't find an IPv4 address for the host machine.


    Tuesday, October 30, 2012 9:09 PM

Answers

  • I think I found the answer:

    Go into Hyper V. Go into the Virtual Switch Manager. Create a virtual switch called "Windows Phone Emulator Internal Switch" Make it's connection type Internal.

    Now launch the emulator. It should work.

    • Proposed as answer by TheGeekNextDoor Tuesday, October 30, 2012 10:56 PM
    • Marked as answer by Oguz Mazlum Wednesday, October 31, 2012 12:17 AM
    Tuesday, October 30, 2012 10:55 PM
  • I was able to solve the problem by uninstalling VPN client, which is an older VPN client which seems to have compatibility issues with Windows 8. After uninstalling it, I was able to run the emulator without issues (of course after installing and making sure Hyper-V was enabled). 

    Anthony Baker - Creative Development

    Monday, April 29, 2013 1:03 PM
  • Creating just a new virtual switch only, did not work for me. There is additional step needed:

    Open “Network Connections”. Right click “vEthernet Windows Phone Emulator Internal Switch” and select Properties. Deselect “Deterministic Network Enchancer” and click Ok.

    I did the same for all vEthernet interfaces.

    After that, Emulator started without errors.

    Saturday, February 01, 2014 7:55 PM

All replies

  • Do you have any products installed which use the [old] "Virtual Machine Network Services" from Virtual PC? 


    -Eric.

    • Proposed as answer by Paul Willson Tuesday, October 30, 2012 9:28 PM
    Tuesday, October 30, 2012 9:25 PM
    Owner
  • Nothing like that. Hyper V installation was a fresh install for the SDK. Also no other VM's are installed or ever used on this install.
    Tuesday, October 30, 2012 9:27 PM
  • I had the same issue while Oracle VirtualBox 4.2 was installed. I uninstalled and it worked fine.
    Tuesday, October 30, 2012 9:36 PM
  • I don't have the VirtualBox installed that's weird. My main network card is managed by the hyper-v switch nic. So my main nic doesn't receive any ip address is that not the issue?

    An my Hyper-V switch settings looks like:

    • Edited by Oguz Mazlum Tuesday, October 30, 2012 9:43 PM
    Tuesday, October 30, 2012 9:39 PM
  • Can confirm this. I had the exact same error and after i uninstalled VirtualBox i works fine.

    Please fix this, i need VirtualBox for over development stuff!

    Tuesday, October 30, 2012 9:43 PM
  • This looks like a bug in the SDK.

    When i finished installing, it told me i can't use the emulator because my hardware does not have virtualization enabled. The fact is, my PC's CPU has virtualization enabled, so this kinda has to be a bug in your SDK.

    Both my Android and WP SDK 7.1 emulators work fine. This is a problem on your end, Microsoft.
    I've got literally no virtual machines, other than Java and .NET, but i can't go without these so......
    • Edited by mcosmin Tuesday, October 30, 2012 9:49 PM
    Tuesday, October 30, 2012 9:44 PM
  • To make sure what the error is another screenshot.

    Tuesday, October 30, 2012 9:48 PM
  • I have the exact same error. Can't find any solutions for that. I've no other virtualisation software (like Virtualbox) installed
    Tuesday, October 30, 2012 9:58 PM
  • You could try this: manually disable the “Virtual Machine Network Service” on ALL host adapters connected to a virtual switch. (If the virtual switches were created by the emulator they will all have “Virtual Switch” in the name.)

      Note that there should be one virtual switch for every physical adapter on the host PC, plus one additional virtual switch labeled “Internal Ethernet Port Windows Phone Emulator Internal Switch”. (... This may need to be repeated any time new virtual switches are created.)


    -Eric.

    Tuesday, October 30, 2012 10:35 PM
    Owner
  • I can't change anything on my NIC. It seems the setting are all managed by the virtual adapter of hyper-v. When I try to check/uncheck something it won't set. I can see a new adapter being created when I start the emulator. After the error its gone.



    • Edited by Oguz Mazlum Tuesday, October 30, 2012 10:47 PM
    Tuesday, October 30, 2012 10:40 PM
  • I think I found the answer:

    Go into Hyper V. Go into the Virtual Switch Manager. Create a virtual switch called "Windows Phone Emulator Internal Switch" Make it's connection type Internal.

    Now launch the emulator. It should work.

    • Proposed as answer by TheGeekNextDoor Tuesday, October 30, 2012 10:56 PM
    • Marked as answer by Oguz Mazlum Wednesday, October 31, 2012 12:17 AM
    Tuesday, October 30, 2012 10:55 PM
  • I see you have a Cisco VPN client... some versions of Cisco VPN client have also been known to cause this problem.  Check to see if there is a version available that has been updated for compatibility Windows 8.

    -Eric.

    Tuesday, October 30, 2012 10:57 PM
    Owner
  • I can almost confirm it is the solution. However I have a new error message :( damn.



    • Edited by Oguz Mazlum Tuesday, October 30, 2012 10:59 PM
    Tuesday, October 30, 2012 10:57 PM
  • I also have the Cisco VPN client. It works, and I hate it. I don't want to mess with it. But my solution above works fine for me now.
    Tuesday, October 30, 2012 10:58 PM
  • I also have the Cisco VPN client. It works, and I hate it. I don't want to mess with it. But my solution above works fine for me now.

    Can you please screenshot for me the network setting on the running Hyper-V windows phone emulator.

    • Edited by Oguz Mazlum Tuesday, October 30, 2012 11:04 PM
    Tuesday, October 30, 2012 11:03 PM
  • Tuesday, October 30, 2012 11:08 PM
  • Thank you for the screenshot. I think the settings are the same. I still have the same error. Also the buttons ont he emulator phone and keyboard text input is not working.
    Tuesday, October 30, 2012 11:18 PM
  • Wish I could have found your problem. I can only assume you aren't currently VPN'd in some place while you do this.

    Eric put me on the right path when he talked about the name of the switch. It happened to not be the name my computer was using,  but it was just enough to steer me in that path.

    I assume this is what your "man-made" switch looks like:

    Tuesday, October 30, 2012 11:22 PM
  • Indeed I am not on the VPN connection. My Virtual Switch manager settings are exactly the same as yours.
    Tuesday, October 30, 2012 11:25 PM
  • What IP address is assigned to your Windos Phone Emulator Internal Switch if you run ipconfig?

    I've got a 169.254.28.147 address.

    I can also only assume that you have rebooted once you hit that last problem. Reboots are miracle cures.

    • Proposed as answer by OnboardTest Wednesday, March 13, 2013 11:13 AM
    Tuesday, October 30, 2012 11:29 PM
  • On Ipconfig I only see besides my main NIC Hyper-V Virtual Ethernet Adapter #2. The other (Windos Phone Emulator Internal Switch ) is not shown. I am currently uninstalling the SDK to install it again. I post in couple mins.
    Tuesday, October 30, 2012 11:38 PM
  • That must have something to do with it. The Windows Phone Emulator Internal Switch shows up as an adapter in the IPConfig for me even when the emulator is not running. Get that switch to show up all the time, and you should be good.

    What I don't understand is why it fails to create on the fly for us. It seems like that is what is supposed to happen. I'm not about to destroy my Cisco client to find out just how bad it is messing me up. I wouldn't doubt that it is a problem. They don't even support the one I use any more. Wish my client would just use the Microsoft VPN client!

    Tuesday, October 30, 2012 11:42 PM
  • Not sure the Internal switch name matters much. I got it working on my last year's Build tablet. It doesn't have Cisco on it, and it has a permanent name in my ipconfig now of "Internal Ethernet Port Windows Phone Emulator Internal Switch" as Eric described. I didn't have to do anything other than what was in the original instructions with adding the Hyper V feature.

    So perhaps Cisco is the culprit in all of this.

    I'm using Cisco VPN Client - Version 5.0.07.0240. It's old and it is junk, but it works for what I gotta do.

    Wednesday, October 31, 2012 12:03 AM
  • TheGeekNextDoor thank you for all the help. I've uninstalled the SDK first. Then rebooted. Installed the SDK again and watch the Hyper-V switch manager if the installer will create a new internal switch. This was not the case. So I've created one my self just like you told me. Then rebooted the pc again. After I logged in there was no network connection at all. So I first disabled and then re-enabled the switch that I;ve created and second one the virtual switch from the Hyper-V also disabled and re enabled it all network was restored.

    When I watch in cmd with ipconfig I can indeed see all the adapters. I;ve launched VS2012 and bam. All works as it supposed to work. Thanks again!!!!


    • Edited by Oguz Mazlum Wednesday, October 31, 2012 12:18 AM
    Wednesday, October 31, 2012 12:17 AM
  • You are very welcome. Glad I could contribute to the forum. You helped me as well. I saw your post also over on Neowin. Eric, thanks for directing me to Oguz's thread and for talking about the network adapter name...that is what tipped this whole thing over.  Have a great night!

    Wednesday, October 31, 2012 12:22 AM
  • Hi,

    FYI more emulator troubleshooting info is available here.

    This discussion touches on some known issues with some 3rd party products installed under Windows 8 that includes include networking drivers/protocols that are not fully compatible with the Hyper-V networking stack.

    In general, it will be up to the developers of those products to update their software to be compatible with Win8/Hyper-V.

    These products that may require upgrading for Windows 8 compliance include virtualization systems, Virtual PC 7, VMWare, some VPN clients, software firewalls, and some versions of the Cisco VPN clients.
     
    Short of uninstalling the product(s) in question (and requesting the product developer to release an updated version), here is a possible workaround:

    1. Launch the “Network Connections” manager (from the home screen, type in “View Network Connections”, It will be listed under Settings)

    2. Right click on the adapter named: “vEthernet (Internal Ethernet Port Windows Phone Emulator Internal Switch)”

    3. For that adapter, the only items that should be checked under “This connection uses the following items:” should be:

    • Client for Microsoft Networks
    • QoS Packet Scheduler
    • File and Printer Sharing for Microsoft Networks
    • Microsoft LLDP Protocol Driver
    • Link-Layer Topology Discovery Mapper I/O Driver
    • Link-Layer Topology Discovery Responder
    • Internet Protocol Version 6 (TCP/IPv6)
    • Internet Protocol Version 4 (TCP/IPv4)

    4. All other items should be unchecked.

    The downside to this technique is that any time a new 3rd party product installs unsupported drivers, or any time the emulator is installed, these steps will need to be repeated.

    Hope this helps,
    Mark

     

     


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7


    Wednesday, October 31, 2012 3:30 PM
  • Oğuz merhaba , aynı sorunu 1-2 gündür bende yaşamaktayım acaba çözümü türkçe olarak yazabilirmisin ?
    • Proposed as answer by Merve KOÇER Tuesday, December 11, 2012 2:43 PM
    • Unproposed as answer by Merve KOÇER Tuesday, December 11, 2012 2:43 PM
    Wednesday, November 21, 2012 7:03 PM
  • I tried different possible workarounds, but nothing helped. In one of experiments, when I installed Cisco VPN after testing WP Emulator, it had worked until I rebooted. Alternatve VPN client from Shrew Inc did not work reliably with our network. The only thing that helped - switching to Cisco AnyConnect.
    Saturday, November 24, 2012 8:04 PM
  • The client appears to be incompatible with various VPN clients.  I had to uninstall the SonicWALL global VPN client before I could get it working.  It took an awful lot of digging to discover this as the cause.
    • Proposed as answer by Zaxxonal Wednesday, January 30, 2013 4:38 AM
    Wednesday, January 30, 2013 4:38 AM
  • I'm strugling already for 3 days to get the emulator (XDE) working. I've contacted HP, the supplier of my 8770W notebook to verify the Hyper-V BIOS settings. Seems all OK.

    When I start a WP8 app in the debugger, the emulator shows "The Windows Phone OS is starting..". After about 5 minutes the emulator disappears and VS2012 reports "Unable to deploy". When I have the Hyper-V manager open during the debugging session I can see that the VM (in Hyper-V Manager) is started correctly.

    So I need any help to get this working, it's driving me nuts ;)


    Nico Dekker

    Thursday, January 31, 2013 2:08 PM
  • Hi,

    Do you get this symptom even after doing a formatted, clean install of Windows 8, and then avoid installing other third party software in order to eliminate said software as a possible cause?

    If worried about losing data in your existing system drive, you could remove the drive, set it aside and install a new drive.  Or copy the entire system drive to a backup drive first.

    Your symptom is indicative of third party software or a virus interfering with Visual Studio's session with the emulator.

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Thursday, January 31, 2013 3:04 PM
  • Hi Mark,

    A fresh install is not possible as my notebook is "controlled" by our ICT department. McAfee and Windows Defender are both turned of, but without result.

    I will have a look at the running services if I can find something special. Could it be that the network card(s) are causing the problem. It seems as if two networkcards are installed. A Intel 82579LM and Intel Centrino Advanced-N 6205. Perhaps because the notebook is in a docking station?


    Nico Dekker


    • Edited by NicoDekker2 Friday, February 01, 2013 6:50 AM
    Friday, February 01, 2013 6:48 AM
  • Wow, what a complete idiot I am. I checked everything regarding Anti Virus programs and suspected Services.

    But what did I overlooked? Windows 8 Firewall! Switching that off solved the problem! Now carefully try to re-enable McAfee to secure my system.

    Update: OK, also with McAfee enabled everything is still working. 


    Nico Dekker


    • Edited by NicoDekker2 Friday, February 01, 2013 8:01 AM typo and update
    Friday, February 01, 2013 7:02 AM
  • Good news.

    You might want to check with your ICT department regarding unique firewall policies that they may have, and tweak the settings for your machine instead of completely turning it off.

    Otherwise your machine could be vulnerable to external attacks (and violating your own ICT department rules).

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Friday, February 01, 2013 4:03 PM
  • @TheGeekNextDoor

    Great reply. Thanks!

    It worked!!!

    Wednesday, March 13, 2013 10:56 AM
  • I was able to solve the problem by uninstalling VPN client, which is an older VPN client which seems to have compatibility issues with Windows 8. After uninstalling it, I was able to run the emulator without issues (of course after installing and making sure Hyper-V was enabled). 

    Anthony Baker - Creative Development

    Monday, April 29, 2013 1:03 PM
  • Thanks , was very helpful 
    Wednesday, June 05, 2013 3:59 AM
  • Nico,

    I'm having the same problem..... it's driving me nutssssss as well, I have spend 1 week on this... Why do they make is so hard.... kinda let down.....

    Just wondering if you managed to get this to work? Please help me out here......

    Thursday, September 26, 2013 6:57 AM
  • Creating just a new virtual switch only, did not work for me. There is additional step needed:

    Open “Network Connections”. Right click “vEthernet Windows Phone Emulator Internal Switch” and select Properties. Deselect “Deterministic Network Enchancer” and click Ok.

    I did the same for all vEthernet interfaces.

    After that, Emulator started without errors.

    Saturday, February 01, 2014 7:55 PM