none
Change remote desktop port number on Windows Server 2008

    Question

  • I have always been able to change the port number with Windows server 2003 by editing the registry key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

    With Server 2008 however this does not seem to work. Does anyone know what else I need to do to make this work? I know server 2008 is more secure so I am not sure if there is another security setting I need to do.

    This just my home server so the security setting is very basic.


    Thursday, April 03, 2008 3:12 PM

Answers

All replies

  • This forum is for developers working with Windows Forms in the .NET Framework.

     

    You should try asking in the TechNet Windows Server 2008 forums.

    Thursday, April 03, 2008 3:21 PM
  • Found this thread at the top of google, and thought I would post the solution for any future visitors.

    On Server 2008, in addition to changing the registry key above, you also need to create a new Inbound TCP rule in your windows firewall to allow connections on your new port.  You can then disable the existing remote desktop inbound rule (which is hardcoded to port 3389)
    Tuesday, April 07, 2009 9:20 AM
  • Don't forget to restart the RDP services after you change the port number.
    Wednesday, October 28, 2009 7:26 PM
  • Reboot the server, but make sure you disable the windows firewall on the server and then this will work.
    Tuesday, January 18, 2011 1:08 AM
  • After Changing RDP Port from regedit to any other No. u have to add remote desktpop Program to allow access list in ur Server 2008 List Firewall

     

     

     

     

    Ehab El Aswany

    MCITP /CCNP

    Friday, November 11, 2011 4:09 PM
  • Check out this page:

    http://www.iteezy.com/change-rdp-3389-port-on-windows-2008-server/qc/10098

    It describes both regedit changes and Firewall rule creation!

    • Proposed as answer by Mat Banik Tuesday, December 27, 2011 3:49 PM
    Tuesday, December 27, 2011 3:47 PM
  • You just need to go under your firewall and add a rule for RDP to coincide with the new port Number
    Monday, May 28, 2012 10:42 PM