none
Sound on Virtual Machines

    Question

  • I have installed Win Svr 2008 R2 on three Dell machines (two Latitude 830's and a new PowerEdge R710); I have not been able to get sound working on the guest operating systems, even though sound works on the Host. I was wondering if this is supported, or if it is a driver issue between my Dell hardware and the virtualized drivers. I have tried VISTA and Windows 7 as the guest operating systems.

    On the D830, I was using Win 2008 Svr Standard R1, Virtual PC 2007 with a Vista guest, and sound was working ok. But I need to get the box using Hyper-V so I reinstalled it.

    Maybe this is silly, but this is so I can listen to music during development. Well, it is not silly to me - I think it is quality of life :-) Anyone had any luck with Guest OS sound working on Win 2008 R2/Hyper-V? Thanks.
    BR,
    Mark
    Wednesday, September 16, 2009 1:02 PM

Answers

  • Issue solved. Yes, remote desktop from Win 2008 Server R2 to a Windows 7 virtual machine on same box, and sound card magically works. Go Figure.
    • Marked as answer by MarkEStory2 Tuesday, September 22, 2009 6:57 AM
    Tuesday, September 22, 2009 6:57 AM

All replies

  • So updated the Dell 830 to the VISTA64 sound card drivers (Sigma), and that seemed to work OK. But the Windows 7 virtual machine does not have a sound device installed, and "scanning" for hardware does not pick it up. I understand that the sound drivers for the Dell D830 won't work in the virtual machine. But if I wanted to add a sound card to the virtual machine, how is this done? Can it even be done ?

    So far I have not seen ANY sound from a Hyper-V R2 based Host computer. I am downloading and trying XP pro now. But am I wasting my time ? Does Win Svr 2008 R2 Hyper-V support sound in the virtual machines at all ? So far, I have not seen it work.
    BR,
    Mark
    Friday, September 18, 2009 6:11 AM
  • Installed XP machine - same behavior. No Sound device installed. This sure is annoying. Oh well...
    Friday, September 18, 2009 11:01 AM
  • OK, more googling... I get it. The bridge is out and you can't get there from here.
    • Marked as answer by MarkEStory2 Tuesday, September 22, 2009 6:55 AM
    • Unmarked as answer by MarkEStory2 Tuesday, September 22, 2009 6:56 AM
    Friday, September 18, 2009 11:41 AM
  • Issue solved. Yes, remote desktop from Win 2008 Server R2 to a Windows 7 virtual machine on same box, and sound card magically works. Go Figure.
    • Marked as answer by MarkEStory2 Tuesday, September 22, 2009 6:57 AM
    Tuesday, September 22, 2009 6:57 AM