none
How to disable Autoconfiguration IPv4 Address in Windows Server 2008 R2 running in HyperV

    Question

  • I have two virtual Windows Server 2008 R2 machines running in HyperV and I use static IP addresses to configure both networks. The first server works fine and connects to the Internet with the specified static IP addresses. However, when I try to connect to the network with the second server, some autoconfiguration IPv4 comes up and assigns a different (additional) IP address to my virtual adapter and I get multiple IPs assigned error.

    I read in previous forums that the problem is caused by IPv6 but I got the same problem even when I disabled IPv6 on the virtual network adapter. 

    The actual physical adapter used by both of the virtual servers acts as a switch. 

    How should I fix this?

    Friday, September 17, 2010 10:37 PM

All replies

  • I have two virtual Windows Server 2008 R2 machines running in HyperV and I use static IP addresses to configure both networks. The first server works fine and connects to the Internet with the specified static IP addresses. However, when I try to connect to the network with the second server, some autoconfiguration IPv4 comes up and assigns a different (additional) IP address to my virtual adapter and I get multiple IPs assigned error.

    I read in previous forums that the problem is caused by IPv6 but I got the same problem even when I disabled IPv6 on the virtual network adapter. 

    The actual physical adapter used by both of the virtual servers acts as a switch. 

    How should I fix this?

    I am having the same problem !! - any resolve to this yet ??

    please help !

     

    Tuesday, February 15, 2011 8:26 PM
  • Saturday, May 28, 2011 12:50 PM