none
Outlook 2007 search problem

    Question

  • OK, now I have seen everything. I have tried every remedy suggested to get my search to work. NOTHING!! Then, as a desparate last try I did unselect the data file to be searched. I couldn't believe it. IT WORKED. I had to do this a few times to believe it.

    Tools >> Instant Search >> Search Options >> "uncheck" the data file you want to be searched

    Friday, February 23, 2007 7:26 PM

All replies

  • You are partially right but thanks. 
    
    I would like to share my version of the same problem that I think it is complicated and serious. 
    I am also using Outlook 2007 and waited a long time for it to index all items.
    I use Notes Item a lot and have been collecting information there for a long 
    time but now everytime I do a search it it´s contents brings back nothing. I 
    try select indexing options from there but it hangs for 3 to 4 minutes and 
    then it comes back but it says that no files need to be indexed.
    I have a lot of important information on Notes but now I can´t find anything.
    Using Windows Vista Business (Upgrade) + Outlook 2007 (from a 2003 version) - 2 GB of 
    RAM and a Readyboost pen drive of 4 GB to speed things up.
    PST files are all over 4 GB.
    From what I have read on almost every post, forum and support files here is 
    what I have tried and have not solved a SEVERE problem (I think):
    - Rebuild Index;
    - Fixmapi stuff;
    - Repair Office 2007 (Final);
    - Moving the PST to another PC and tried the same thing;
    - Archive almost every e-mail to make my PST smaller although Outlook states 
    it can be bigger than 2GB;
    - Do a All Items search;
    - Done an advanced search in contents of Notes and Tasks;
    - Tried searching in All Notes Item Search and hangs ofr 30 minutes;
    - Compacting PST;
    - Left it to Index 2 days in a row;
    - Used the Inbox Repair tool on my PST;
    - Not using exchange
    
    Well I can´t remember more things I have done from the searches I have taken.
    
    I think that if I can´t rely on Instant Search for Outlook 2007 then for 
    Windows Vista I am starting to give it a doubt. 
    
    I really appreciate some help on this. And ask for someone to take this 
    message to microsoft please if necessary.
    
    PARTIAL SOLUTION!!

    Hi again and again.

    After taking all the steps above and rebuilding index like 50 times and testing on 5 or 6 different computers.

    I decided to take the funny solution that a user called: "mar7aib" suggested and I unchecked all the Data files and it worked!

    I call it a partial solution because searches are slower and I think it does not use Windows Desktop Search this way but until it gets corrected I am going to leave it this way.

    I suggest everyone to do this also because a search option is VITAL in any application and we must trust it but if it does not work properly then we must wait for better days.

    A good search option is important and it should return all results correct even if it is simple or advanced search.

    Thanks for the help by now...if anyone has another solution to try please tell so we can try it.

    René 

    Friday, February 23, 2007 8:46 PM
  • Here are a few more troubleshooting steps you can take....

    First, re-enable indexing of your mailbox.  Go to Control Panel -> Indexing Options -> Modify -> Click the mailbox that you want indexed.

    Next, boot Outlook to begin indexing your mail.  Take a look at the Tools -> Instant Search -> Indexing Status dialog to see if the count goes up.  (The dialog does not refresh automatically, so you'll have to close it and reopen it every so often.)  Normal behavior is for this count to quickly increase as Outlook discovers all your mail that needs to be indexed, then the count should drop slowly as mails get indexed.  For large mailboxes, it can take overnight for them to be fully indexed.

    While you're waiting for indexing to complete, open the Indexing Options control panel and monitor the indexer's current status (second line).  If it says indexing is paused (such as due to disk or CPU activity), then no indexing will take place until the other application relaxes its resource usage.

    If the Outlook pending indexing counts do not drop after an hour, even though the control panel says it's indexing, then there's a problem.  Likewise, if the count drops or stays at 0, then the items are immediately failing to be indexed, which indicates a separate problem.  Another thing to check is the Application Event log to see if there are any errors from Outlook or WIndows Search.

    A few more questions: Are you running XP or Vista?  Using Instant Search (with your stores selected to be indexed), can you find e-mails in any of your other mailboxes, or is mail indexing completely broken across the board?

    If this still doesn't help, reply back, and I have some more suggestions.

     

     - Michael Hilsdale

       Outlook Search Test Team

    Saturday, February 24, 2007 1:17 AM
  • Sorry to say but did you read the last post carefully?

    - Checked mailbox to see if it is indexed

    - The CPU always keeps indexing and already tried to rebuild index a couple of times.

    I can finde e-mails but you should read my post to know. How can I trust finding e-mails if my Notes, Task...don´t even get accurate results?

    I am trying new approaches that I found tonight and I am going to test them. 

    René

    Saturday, February 24, 2007 3:04 AM
  • Ok, let's take this a step further....

    1.  Turn on Outlook logging (Tools -> Options -> Other -> Advanced Options -> Check "Enable logging" -> Reboot Outlook

    2.  Go to your Notes folder and modify a note.  This will re-trigger indexing for that item.

    3.  Use Outlook's Indexing Status to wait for the count to get back to 0.

    4.  Go to "%temp%\outlook logging" and look at the log file for your store.  It will have a recent timestamp and will have a name in the form "store.pst.log."  Take a look at that log file, and reply back with any lines including URLs with the "Notes" folder in them.

    5.  Try to search for the modified item.  From what you're describing, it doesn't sound like it will work, but it's good to be sure.

    6.  Turn off Outlook logging (since it has a performance impact) and restart Outlook.

    It sounds like the items are failing to be indexed.  If so, this should give us a clue to what's happening.

    Saturday, February 24, 2007 9:07 AM
  • Ok Michael,

    When I started to try out your steps and let it index again until zero, I gave it a try again and did a search and Bingo! It works again.

    What I suspect fixed the problem was the checking and unchecking in Outlook options. Maybe it fixes the index again in some other way other than manually rebuilding.

    Ahh...or maybe it was this post that solved the problem and believe me people...if you are having problems with the Instant Search I suggest you try this.

    It is rather long but read carefully:

    "Hi,

    Thanks for using Microsoft TechNet Managed Newsgroup. I'm Leon who will
    assist you on this issue.

    I have reviewed your post log carefully and concluded your issue as this:

    When you perform a search in Microsoft Office Outlook 2007, the search
    returns no e-mail messages that contain the search criteria.

    Is that correct?

    There are two main causes that this issue may occur. I've listed both for
    your reference:

    * Cause 1
    ========

    This issue occurs if the following conditions are true:

    1. You upgraded to Windows Vista from Microsoft Windows XP. 
    2. Then, you upgraded to a 2007 Microsoft Office suite from an earlier
    version of Microsoft Office. 
    3. Outlook 2007 is configured to use the Rich Text Format (RTF) file type
    for e-mail messages. Alternatively, you received many RTF e-mail messages. 

    When these conditions are true, the RTF file type is no longer registered
    in Windows Vista. This behavior prevents Outlook 2007 from searching in any
    RTF e-mail message.

    To resolve this issue, follow these steps:

    1.  Click Start, and then click Control Panel. 
    2.  In the view pane, click Classic View. 
    3.  Double-click Indexing Options. 
    4.  In the Indexing Options dialog box, click Advanced.
    5.  On the File Types tab, locate rtf in the Extensions list. 
    6.  If the Filter Description for rtf is either Plain Text filter or Null
    filter, the RTF filter must be registered. To do this, follow these steps:
    a.  Click Start, click All Programs, click Accessories, right-click
    Command Prompt, and then click Run as administrator.
    b.  Type regsvr32 rtffilt.dll, and then press ENTER. 
    c.  When you receive the following message, click OK: DllRegisterServer
    in rtffilt.dll succeeded. 

    Here is a KB article describes this:

    927595 You cannot search RTF e-mail messages in Outlook 2007
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;927595

    * Cause 2
    =======

    This cause is a known issue that this problem occurs if the following
    conditions are met:

    1. A computer that is running Microsoft Windows Vista has User Account
    Control (UAC) turned on.
    2. You run Microsoft Office Outlook 2007 by using elevated user rights.

    In this scenario, you cannot index e-mail messages or search e-mail
    messages because the SearchProtocolHost.exe process cannot open the same
    handle to the personal folders (.pst) file that Outlook 2007 uses. Outlook
    2007 uses this handle when you run Outlook 2007 by using elevated user
    rights.

    Microsoft has confirmed that this is a problem in the Microsoft products.
    If this is your situation, then I¡¯m afraid to say, this scenario won¡¯t be
    fixed.

    The reason why we don't fix this scenario is that in general, users should
    never, ever be running Outlook "more elevated" than the rest of the
    desktop; if they are (and they're using it for searching and other
    day-to-day tasks), they're doing something that's now unsupported and has
    reduced functionality as a result.

    There is also a KB article which describes this:

    923937 You cannot index e-mail messages or search e-mail messages when you
    run Outlook 2007 by using elevated user rights on a computer that is
    running Windows Vista
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;923937

    Hope this helps!


    Regards,

    Leon Hao"

    Thanks to Leon Hao.

    Maybe trying this solved the problem.

    Thanks again

     

    Saturday, February 24, 2007 4:57 PM
  • Thanks Mik! and whoever figured out this complete retarded problem and counterintuitive solution. 

     

    Monday, March 05, 2007 4:14 AM
  • I was unable to find any emails (even ones sitting right before my eyes failed to be found via search).  I tried the unchecking bit and that does allow me to find stuff now, which helps.  Before I did this, however, I tried this logging setting and looked through the log file.  Every line has a FAIL status...  It came back with log entries like the following:

    2007/03/07|09:47:39:935|OnIndexStatusChange - Gatherer|2|2819332|Add||mapi://{removed}/Mailbox - mymailbox($70299a6)/0/Inbox/곯가가가걒건겤걝겊겴겔걁겟갷곸곎갾걲걳갮간갅갫가||||||0x80041206|FAIL

    2007/03/07|09:47:45:447|Doc Not Found|2|531|||||||||0x8004010f|FAIL

    2007/03/07|09:48:21:880|Exceeded retry count - DOC WILL NOT BE INDEXED|2|2819716|||||||||0x80040861|FAIL

    I've tried forcing it to reindex everything, but the same results on the search side.

    My system is XP SP2, Outlook 2007 (clean install - not upgraded), Exchange, Desktop Search 3.01

    Ideas?

    Wednesday, March 07, 2007 3:21 PM
  • Yes - many many thanks to TheMik for figuring out something I never would have even TRIED!  I can stop relying on Google Desktop now for emails.
    Wednesday, March 07, 2007 6:27 PM
  • This worked for me too.
    Monday, March 26, 2007 4:02 AM
  • Could one of you summarize the problem that you were having and what seemed to be the solution?

    Were you trying to search multiple PSTs and failing?

    Tuesday, March 27, 2007 6:05 PM
  • I have one MS Exchange mailbox and one IMAP mailbox.  I was attempting to search my Exchange inbox for any messages.  With the default configuration for the search in Outlook, I was unable to find any messages in my inbox.  As an experiment, I took a message I had with Vista in the subject and in the body of the message which was in my Exchange inbox and searched for it.  Search was unable to find it. I then changed the settings for Instant Search to remove my Exchange mailbox from the list of "Index messages in these data files" and was then able to find it.  This was on my XP SP2 system.  On my other desktop system which is runnning Vista Enterprise w/ Outlook 2007, I don't have this problem.  The default settings work fine there.  Not sure what the issue is with this.  I have gone so far as to do a clean OS install, clean 2007 install (not upgrade) and pulled my Exchange account in and tried this just to make sure it wasn't a bad data file.  Same results.

     

    Hope this gives you what you were looking for.

    Wednesday, March 28, 2007 12:26 PM
  • So unchecking the Exchange mailbox allowed you to find messages in it?

    Are you using that Exchange mailbox in cached mode or not?

    Wednesday, March 28, 2007 4:40 PM
  • Its running in cached mode and unchecking the Exchange mailbox under Instant Search allowed me to find items in the mailbox.
    Wednesday, March 28, 2007 5:49 PM
  • I found a better solution. I uninstalled Vista and Outlook 2007 and went back to a reliable system like XP and Outlook 2003. I just had enough of the problems. Are we all lemmings and follow the almighty Bill Gates? I, for one, had enough.
    Thursday, March 29, 2007 1:04 PM
  • Keep in mind that when you deselect a mailbox in the Instant Search options or through the Indexing Options control panel you are electing to not index it.  This is not fixing the root problem, only masking it.  Outlook search will fallback to the old (slow) search, and search resutls will not be available from the Windows shell.  Granted, having a slow search is better than not having search work at all, but we'd still like to determine why Instant Search is not working for you (and anyone else reporting the problem on this thread).

     

    To determine why Outlook Instant Search may be failing, try enabling logging:

     

    1.  Turn on Outlook logging (Tools -> Options -> Other -> Advanced Options -> Check "Enable logging" -> Reboot Outlook

    2.  Go to your Inbox and modify a mail item (e.g. toggle the Read flag).  This will re-trigger indexing for that item.

    3.  Use Outlook's Indexing Status to wait for the count to get back to 0.

    4.  Try to search again for the modified item (just in case it works this time).

    5.  Go to "%temp%\outlook logging" and look at the log file for your store.  It will have a recent timestamp and will have a name in the form "store.pst.log."  Take a look at that log file, and reply back with any lines including URLs with the Inbox folder in them.  The entire log line is useful, but in particular the second to last column will indicate the specific error code that Outlook is encountering while trying to index.

    6.  Turn off Outlook logging (since it has a performance impact) and restart Outlook.

    Thursday, March 29, 2007 5:24 PM
  • Jonas & co.

     

    I'm running a clean install of Vista and Outlook 2007.

     

    Outlook is running in Cached Exchange Mode and connecting to our Exchange 2003 Server. I only have one account set up in Outlook (my exchange one).

     

    After a default install (which was a few days ago now, so indexing should be over with), when I type anything into the search box at the top of the Inbox it says "Searching" but finds no results... even when searching for names or words that i can SEE in my Inbox.

     

    However, when following the instructions at the beginning of this thread (i.e. going to Tools > Instant Search > Search Options and unchecking my mailbox under "Index messages in these data files") searching DOES work.

     

    BUT, there's one caveat. Now I have to press enter or click the magnifying glass in order to search, whereas before it would just search automatically while typing (except return no results!).

     

    Also, both before the unchecking of my mailbox AND after, my "Start Search" does not return any emails or Outlook items. Why is this? "Microsoft Office Outlook" IS in the Indexing Options control panel, but clearly all of my items haven't been indexed... the Indexing Options control panel says that 955 items have been indexed in total... but i have 933 emails and over 1,000 files in my "Documents" folder.

     

    In Outlook, the "Indexing Status" dialog shows 0 remaining items to be indexed.

     

    What's going on?! Microsoft, why on earth do we have to uncheck the mailbox in order to search it?!

    Thursday, March 29, 2007 5:38 PM
  • Our posts must have crossed each other by a few minutes.  Take a look at my post directly before yours.

     

    To determine why Instant Search is not working, re-enable indexing for your mailbox (by selecting the corresponding checkbox under Tools -> Instant Search -> Search Options) and try the debugging steps in my post to enable logging to help narrow down the problem.

    Thursday, March 29, 2007 5:50 PM
  • I have a bunch of stuff in my inbox, so it'll take a while to index the whole mess.  I did post earlier with selections from the log.  Check up a bit higher, they have the examples of the unique error numbers I had in my log file.  When my box gets done reindexing the load of email I have, I'll dig out some additional entries for you and post them here.

     

    Thursday, March 29, 2007 6:05 PM
  • Ok, there was around 5300 lines in the log file.  Nearly every one ended in FAIL.  There were only two different error numbers listed

    0x80040861

    0x80041206

     

    That help any?

    Thursday, March 29, 2007 6:40 PM
  • Sometimes I wish I could, but when you support such things, its hard to say "Sorry we don't support that" or "we don't know anything about that" to the users who are paying you to know about it.
    Thursday, March 29, 2007 6:42 PM
  • Thanks Michael - yeah I didn't see your post before posting my own.

     

    So, I re-enabled indexing of my Mailbox and restarted, then turned on logging and restarted.

     

    I checked the log file, and it started to build up a few errors, but they are all for spam attachements that are now in the deleted items folder, so no worries there. I checked back in Outlook, and sure enough it's indexing fine now!! Go figure.

     

    Other than restarting a few times (which I've done on and off for the last two weeks, so that alone didn't do it), I've done the following:

     

    > Unchecked the Mailbox in "Search Options" and restarted and then re-checked it and restarted (as you know).

     

    > Run "Microsoft Office Diagnostics" from Start > Microsoft Office > Microsoft Office Tools. Only 1 problem was reported and fixed - under the setup files section. The problem itself wasn't specified though. (I did this about an hour ago, before turning logging on.)

     

    And that's it. So I'm happy that it's working properly now, but clearly something fudgey was going on there...

     

     

    On to my next problem... does anyone know where I can discuss the fact that my "Email" link in the start menu mysteriously stopped working a few days ago? It still says "Microsoft Office Outlook" underneith but the icon changed to a generic-looking envelope. And clicking it brings up an error saying that the shortcut cannot be found. I've confirmed that Outlook has all of its defaults, and I've tried switching the link (Right-click start button > Properties) to Windows Mail (which works fine) and back to Outlook again, to no avail. If you know of one, please point me to the right forum... thanks!

    Thursday, March 29, 2007 7:06 PM
  • Jake, you may have been hitting a known Office 2003/2007 setup issue.  If you install any Office 2003 component after installing Office 2007, Outlook 2007 Instant Seaerch stops working.  You'd have to repair your Office 2007 installation to repair the issue.

     

    In any case, I'm glad to hear you're up and running again.

    Thursday, March 29, 2007 7:31 PM
  • Would "any Office 2003 component" include any of the following:  One Note, Visio, or Project?
    Thursday, March 29, 2007 7:38 PM
  • Thank Michael - that must have been it. One of our websites is managed by FrontPage so I had to install FrontPage 2003 - that was a while ago so i didn't tie the two things together. Well figuered out though!!

     

    Could that also have messed up my Email link on the Start menu?! I've tried repairing my 2007 installation but the Email link is still broken.

    Thursday, March 29, 2007 7:43 PM
  • Correct, if you install any Office 2003 application when Outlook 2007 is installed, Office 2003 setup will incorrectly remove the HKCR\Outlook.Application key and require you to repair the Outlook 2007 installation.  A workaround was introduced into WDS 3.01 to avoid this problem (by looking for the Outlook.Application.12 key), but the problem will persist for anyone else who tries to access Outlook's object model unless they use a similar workaround.  The official recommendation for Office installations has always been to install in chronological order to avoid potential problems like this.
    Thursday, March 29, 2007 9:12 PM
  • Sorry, I'm not familiar with the start menu issue.  There's likely an incorrect reg key somewhere.  Perhaps a full reinstall may help.
    Thursday, March 29, 2007 9:14 PM
  • I had installed Visual Studio 2003 w/ the FrontPage extensions, so I ran a repair on Office2007 and rebooted. Still no joy.  It fully indexed my mail box but still can't find stuff I can see in the inbox.  So the repair didn't fix anything. 

     

    Ideas on next steps?

    Friday, March 30, 2007 12:01 AM
  • I have the same problem Outlook 2007 running in cache mode with exchange server 2003.  I am using sharepoint designer 2007 and made the mistake of unistalling frontpage 2003.  This caused errors in script running on all of my explorer pages.  The fix was to reinstall frontpage 2003.  This cause the problem with outlook search so I ran the Office Diagnostics and Repair which repaired a problem I was having with Outlook Today page.  My Outlook search still does not work unless I unclick the mailbox I want it to search.  But if it does not properly index the files...(and I notice this...sometimes the search works properly and sometimes it does not) it look like I still need help.
    Friday, March 30, 2007 3:44 AM
  • This is the only option that worked for me..  Hard to believe, but it did the trick.
    Thursday, April 12, 2007 3:18 PM
  • Thanks for the post, disabled personal and archive folders within Instant search indexing options and this too cured my problem of no search facility within Outlook 2007 (Running Vista 32 bit upgrade).

    Wednesday, April 25, 2007 3:59 AM
  • I was getting really frustrated by the same problem....and look at this....it was so easy!!! Thank you so much for this advise...uncheck the data files....amazing!


    Thursday, May 03, 2007 2:35 PM
  • I too have a problem with Outlook search and have elected to un-index it.  Can you refer me to a current solution so that my new software works as advertised?  I purchased this with Vista from HP and HP says they cannot fix it.
    Thursday, May 03, 2007 6:01 PM
  • Michael, I am also having horrible results with indexed search.  Month old Vista Ultimate build with Office 2007. 

    Blew away and recreated OST:  No results.

    Installed Outlook patch (KB933493):  No results. 

    Disabled and re-enabled indexing:  No results.

    Set index to rebuild:  No results.

    Logging set to verbose (in tool):  No "valuable" results to point to issue.

    No Office components other than Office 2007 installed.

    Outlook Indexing Status tool:  Indexing always shows 0%.

     

    Issue escalated to Premier:  No results.

     

     

    Indexing in our envirionment has frankly been of extremely poor reliability - with many reported requirements to rebuild the index.  At this point I now have absolutely no search capability whatsoever even though machine was left overnight to index.

     

    Preparing to blow away OS and reinstall XP w/Office 2003.  All plans for deployment of Vista and/or Office 2007 have now been suspended.

     

     

    Tuesday, May 08, 2007 4:41 PM
  • A complement... I saw that the found couter (down left) shows the correct number of founds emails (for example 303), while the screen shows "Pas de message..."

     

    I have Exchange server 2003 and use outlook 2007 as clients. 20 computers on a small network all of them have the same problems, but not systematically.

     

    The solution proposed (uncheck the index of .ost file) works, but it effectively stops indexation on mailboxes. Slow and reduced fonctionnalities are the result...

     

    I also have a problem with a search error (another problem I think). My customers often (several a day) have an error while searching. The list of find mails is correct, but when they click or try to open them, it gives an arror message "Echec de l'opération client". If they open from the Inbox list, it works. If they restart outlook, the search function works again for a while. The problem started from the day I installed 3.01 version of WDS.

    Thursday, May 10, 2007 8:27 PM
  • There is a known bug where some Exchange Online (non-cached) searches say that no results are found, but the status bar shows the correct item count.  Clicking to resort the message view causes the search results to appear.  This should only affect non-cached mailboxes.
    Thursday, May 10, 2007 8:46 PM
  • TheMik's solution worked for me as well.  I dont think that the Indexer is working properly in Outlook 2007 always.  I think that this occurs when you install or use other applications that access your mail profile.  I installed Verizon Wireles's PC Monitor application to forward e-mail from my Exchange Inbox to my Motorola Q phone.  After I installed that application the search feature stopped working.  Even removing the PC monitor application from my workstation did not make the search function work again until I unchecked the Index Data File checkbox.  Now when I search my Inbox folders it seems to work just fine.  Thanks TheMik...you rock.

     

     

     

     

    Wednesday, May 16, 2007 9:26 PM
  • After much searching and pain, the rtf solution has fixed it for me SmileCraig
    Friday, June 08, 2007 1:11 AM
  • I just ran into the indexing problem today - Looks like the same described in this thread. My issue has been with the "search contacts" , whereas this functionality just stopped working - I used it yesterday. If I’m not mistaken, I think that the issue might have started today, once I enabled “MSoffice One Note” or when I authorized “Windows Update” to update my Office & Vista installations. Of course, thanks to this forum and its members, as soon as I disabled the indexing feature in search options, the functionality resumed working - who knows for how long it will work. Nevertheless, a couple of things are still inexplicable:

    1) Although I couldn't do a search while the indexing option was selected, the "string" I was searching for appeared highlighted across the matched contacts. In other words, the search is executed, but the results are never displayed. Spooky !

    2) What the heck do we need the index for ? Till now I've used Office 2003 with NEO (http://www.caelo.com/index.php) to index all my email folders and archives. It worked flawlessly. Unfortunately NEO hasn't a Vista & Office 2007 version yet. Who knows it comes before the patch to fix this absurd issue

     

    Saturday, June 16, 2007 12:38 AM
  • Hello Michael, I've been having these search problems for the last week or so on my main pc, though my laptop still works fine. Both have office 2007, and both have frontpage 2003, though on each, I can't remember which way round they were installed.

    I found this site with a bit of googling, and I've just carried out the instructions you gave, and got the following in the resulting logs:

    The first file is called - "Outlook.pst.log" and is as follows:

    Store File Name: Outlook.pst
    Date|Time|Action|Search Owner|NID|Change Action|Change Semantics|URL|Count Of DocIDs|Next NID Index to add to All Msg folder|Next NID Index to push to FTE|Folder Path|Folder Path ID|HRESULT|Result Status
    2007/06/25|13:55:00:288|SGO_ScProcessCheckpointRollback done|2|||||9||||||OK
    2007/06/25|13:55:00:385|SGO_ScBuildURL done|2|223138|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:386|Failed To Build A URL|2|223138|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:386|SGO_ScBuildURL done|2|2428708|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:386|Failed To Build A URL|2|2428708|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:386|SGO_ScBuildURL done|2|2428708|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:386|Failed To Build A URL|2|2428708|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:387|SGO_ScBuildURL done|2|223138|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:387|Failed To Build A URL|2|223138|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:387|SGO_ScBuildURL done|2|2428708|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:387|Failed To Build A URL|2|2428708|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:388|SGO_ScBuildURL done|2|223138|||||||||0x80040818|FAIL
    2007/06/25|13:55:00:388|Failed To Build A URL|2|223138|||||||||0x80040818|FAIL
    2007/06/25|13:56:18:917|Flushing completed doc|4|223138|Add|Directory|||||||0x80040818|FAIL
    2007/06/25|13:56:18:917|Flushing completed doc|4|2428708|Add||||||||0x80040818|FAIL
    2007/06/25|13:56:18:917|Flushing completed doc|4|2428708|Modify||||||||0x80040818|FAIL
    2007/06/25|13:56:18:917|Flushing completed doc|4|223138|Add|Directory|||||||0x80040818|FAIL
    2007/06/25|13:56:18:918|Flushing completed doc|4|2428708|Add||||||||0x80040818|FAIL
    2007/06/25|13:56:18:918|Flushing completed doc|4|223138|Delete|Directory|||||||0x80040818|FAIL
    2007/06/25|13:56:18:920|SGO_ScProcessCheckpoint done|4|||||18||||||OK
    2007/06/25|13:56:21:586|SGO_ScProcessCheckpoint done|2|||||||||||OK

    The second file is called - "Outlook.pst-qp-904375.log" and is as follows:

    Store File Name: Outlook.pst
    Date|Time|Action|Rows returned|NID|Advance/No Advance|HRESULT|Result Status
    2007/06/25|14:04:23:849|Issue query to the FTE||||0x80040e55|FAIL
    2007/06/25|14:04:23:850|Issue all full text queries||||0x80040e55|FAIL
    2007/06/25|14:04:23:850|Table Restrict||||0x80040e55|FAIL
    2007/06/25|14:04:27:259|Issue query to the FTE||||0x80040e55|FAIL
    2007/06/25|14:04:27:259|Issue all full text queries||||0x80040e55|FAIL
    2007/06/25|14:04:27:259|Table Restrict||||0x80040e55|FAIL
    2007/06/25|14:05:50:772|Issue query to the FTE||||0x80040e55|FAIL
    2007/06/25|14:05:50:772|Issue all full text queries||||0x80040e55|FAIL
    2007/06/25|14:05:50:772|Table Restrict||||0x80040e55|FAIL
    2007/06/25|14:06:43:887|Issue query to the FTE||||0x80040e55|FAIL
    2007/06/25|14:06:43:887|Issue all full text queries||||0x80040e55|FAIL
    2007/06/25|14:06:43:887|Table Restrict||||0x80040e55|FAIL
    2007/06/25|14:06:48:758|Issue query to the FTE||||0x80040e55|FAIL
    2007/06/25|14:06:48:758|Issue all full text queries||||0x80040e55|FAIL
    2007/06/25|14:06:48:758|Table Restrict||||0x80040e55|FAIL

    -------------------

    I have yet to do any follow up here, and though this thread is a few moths old, I hope you get this, and can reply soon, so I'll await with interest if you can help with this problem. An email search
    feature is something I use a lot, and at the moment with my main pc, even the conventional search methods (as per XP) are not returning accurate searches, and the whole thing is totally unreliable... at least I have my laptop to fall back on, which is working flawlessly... touch wood!

    Regards,
    Hillair

    -----------------------

    Edit:

    Mike, sorry if you've yet gone to any trouble, but I've just found the following post by '
    Carlos Brito' on a similar thread:

    Posted By: Carlos Brito - MSFT on 05-11-2007 12:07 AM UTC
    Subject: Re: Outlook 2007 Vista Ultimate Instant Search cannot display
    Message:

     Carlos Brito - MSFT wrote:

    Can you please try the following:

    1. Create Config directory (in %ProgramData%\Microsoft\Search on Vista or “all users profile”\Application Data\Microsoft\Search on XP/2003 Server).

    2. Copy msscolmn.txt file from another machine into Config directory.

    3. Restart the service: net stop wsearch then net start wsearch from elevated command prompt (or reboot the computer).

    4. Restart clients – Outlook, Explorers etc. (may be easier to reboot computer).

    Note 1: do not confuse Config directory with Data\Config. Verify that he copied the file in the right directory.

    Note 2: Data directory may actually be relocated, but Search\Config will remain at the locations mentioned above.

    Thanks,

    -- Carlos



    I tried his fix and it worked...

    Here's a bit of back ground to the whole of my problem (it just might help others): my guess is that I installed Frontpage 2003 over Office 2007, thereby disabling the search as you've suggested. I tried various methods of rebuilding the indexes myself... probably every permutation you could think of; and in so doing, when I finally saw this tread, and repaired my Office 2007 installation, the fact that at some stage I had deleted the
    "%ProgramData%\Microsoft\Search\Config" folder, along with the file "msscolmn.txt" file (misguidedly, thinking all search components would be replaced on re-installs and/or rebuilds), meant I still had serious problems with Outlook instant search.

    Big thanks to Carlos for his fix, and to you for highlighting the Office version discrepancy...

    When Instant Search works right, it really is superb ;-)

    Cheers,
    Hillair
    Monday, June 25, 2007 2:04 PM
  • hi,

     

    I had the same chronic problem, however I had had successfuly solve it. Please read the following article and do the reindexing as described exactly:

     

    http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1256528,00.html 

     

    Alternatively, you can use the following programme: Start > All Programmes > Microsoft Office > Microsoft Office Tools > Microsoft Digonistic, this programme will try to find if there is any error with your office installation and setup and try to amend them.

     

    Also, to scan your personal folder.pst file, please go to the office12 directory there is a handy tool: scanpst.exe and run it, it will try to see if there is any error in your .pst file.

     

    If these all failed to solve the problem, I suggest you to intsall Google Desktop Search, It is a very effictive Search Solution.

     

    Thanks

    Friday, July 06, 2007 11:53 AM
  • hi,

     

    I had the same chronic problem, however I had had successfuly solve it. Please read the following article and do the reindexing as described exactly:

     

    http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1256528,00.html 

     

    Alternatively, you can use the following programme: Start > All Programmes > Microsoft Office > Microsoft Office Tools > Microsoft Digonistic, this programme will try to find if there is any error with your office installation and setup and try to amend them.

     

    Also, to scan your personal folder.pst file, please go to the office12 directory there is a handy tool: scanpst.exe and run it, it will try to see if there is any error in your .pst file.

     

    If these all failed to solve the problem, I suggest you to intsall Google Desktop Search, It is a very effictive Search Solution.

     

    Thanks

     

     

    Ramzi Kudera

     

    Friday, July 06, 2007 12:07 PM
  • hi,

     

    I had the same chronic problem, however I had had successfuly solve it. Please read the following article and do the reindexing as described exactly:

     

    http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1256528,00.html 

     

    Alternatively, you can use the following programme: Start > All Programmes > Microsoft Office > Microsoft Office Tools > Microsoft Digonistic, this programme will try to find if there is any error with your office installation and setup and try to amend them.

     

    Also, to scan your personal folder.pst file, please go to the office12 directory there is a handy tool: scanpst.exe and run it, it will try to see if there is any error in your .pst file.

     

    If these all failed to solve the problem, I suggest you to intsall Google Desktop Search, It is a very effictive Search Solution.

     

    Thanks

     

    Ramzi Kudera

    Friday, July 06, 2007 12:09 PM
  • Okay...I searched all over the net for an answer to this problem...you are the person!  Thanks for your help!!!!

     

    Thursday, August 02, 2007 1:24 PM
  • I've been having the same problem since I started using Outlook 2007, searches finding zero results & it was driving me crazy.  I tried your solution ie unchecking all the files to seach, and it worked!!  What is going on?
    Monday, September 03, 2007 11:49 PM
  • I don't know. What really gets me is that this issue has been going on since I have been running Office 2007 Beta. Microsoft has not made any (known) attempt to fix this. I have uninstalled Office 2007 and am using 2003.

     

    Tuesday, September 04, 2007 12:08 PM
  • switch off the User Control Access in the control Panel.

    Start> Control Panel> User accounts> Turn User Account Control On Off> Uncheck the Box> Restart.

    Friday, October 19, 2007 3:50 PM
  • Hello all,
    I have outlook 2007 + WDS 3.x.
    When I use desktop search I can see results from all folders including Exchange Mailbox.
    However, when I use instant search from outlook 2007 -- it desplays results from only archive folders. I have checked the options and under indexing options exchange mail is selected (I can see the results if I use desktop search). Also, under the search options I have selected all folders.
    I have reinstalled outlook and repared it and all other typical suggestions.

    Thanks,
    Pathak
    Wednesday, November 07, 2007 6:05 PM
  • I have had troubles with searching Outlook and none of the solutions suggested have helped.  But I tried the suggestions at http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1256528,00.html and the indexing is working!
    Sunday, November 11, 2007 8:41 PM
  • I don't know if I can shed any light on this but my search problems only started occuring after I changed my date to 2006 by mistake at one point.

    I have since switched back to the real date but I seem to have developed the same search problems described in this thread. I am not having problems finding things that I created under the wrong date: I am having problems finding items that I used to find without fail, since I made the date switch.

    Incidentally, MSN Live Messenger will also not allow login when operating under the wrong date.

    I never knew that switching the date can have such unexpected results: I now understand why changing the date in Vista is considered a security-critical parameter change.
    Wednesday, November 14, 2007 12:46 PM
  • In Outlook 2003, the search function worked fine. The 'new and improved' search in Outlook 2007 and XP is the biggest piece of programming garbage I've seen yet. (Well, not the biggest, 'Me' tops the list.) Anyway, once again, MS 'fixed' something that was absoulutely working fine. And even when indexing WORKS, it slows my system down to such a crawl w/80 to 100% CPU usage that it's useless anyway. Perfect. Indexing is rocking now! BUT I CAN'T USE MY FRIGGIN COMPUTER. I know, I know. What do I expect, having my cake and eating it too <slapping self>

     

    So how many endless SP's and hotfixes are we looking at this coming year? 1000, 2000? It's too much already. Computers are supposed to be a convenience, not a daily war.

     

    Not only, at a minimum am I going back to XP and Outlook 2003.

     

    I am seriously considering going to a MAC. I'm about 95% there. I've had it!

    Sunday, November 18, 2007 4:04 PM
  • Wow, this make no sense but it actualy works!!!

     

    Thank you VERY much.

     

    rc

    Sunday, November 18, 2007 9:36 PM
  • I had the same problem and solved it entirely on Win XP / Outlook 2007 by completle uninstalling/reinstalling Windows desktop search. This is the only solution that really restores the Instant search. Do not know if you have this option on Vista though.
    Thursday, November 22, 2007 12:55 PM
  • You are the best.  It works!!!

     

    Friday, November 30, 2007 5:47 PM
  • Hi There,

     

    i have exactlly the same problem with Outlook 2007 , when i search in my Inbox, it returns no results. and a note is prompted (not exact words) "search my be not complete due to unfinished indexing..."

     

    by the way: when running Outlook in Safe Mode, the search does work correctly.

     

    can you recommend me some solution?

     

    thx

     

    Eli

     

    Saturday, December 01, 2007 6:47 PM
  • Incredible!

     

    I'm using outlook 2007 on Vista.

     

    To get the search function to work, you really do have to deselect all the data files that you want to search.

     

    Tools >> Instant Search >> Search Options >> "uncheck" the data file you want to be searched

     

    Now that's a bug and a half!

     

    Wednesday, December 05, 2007 8:45 PM
  • Outlook 2007 quick search and advanced search do not find anything even when I can READ the word i am searching for in the message - eg "peter" who I send lots of emails to!

     

    what is wrong and where do I reset the problem?

     

    Ben

    Saturday, January 12, 2008 12:11 AM
  • I am having the same problem after loading FrontPage 2003 on top of Office 2007.  I tried what you recommended and didn't see a file called store.pst.log.  The files I have in the outlook logging file are: archive.pst.log, files.pst.log, firstrun.log, OPMLog.log, and outlook.ost.log.  I double clicked the one called "outlook" and this is all I got:  Store File Name: outlook.ost
    Date|Time|Action|Search Owner|NID|Change Action|Change Semantics|URL|Count Of DocIDs|Next NID Index to add to All Msg folder|Next NID Index to push to FTE|Folder Path|Folder Path ID|HRESULT|Result Status
    2008/01/15|21:22:50:892|SGO_ScProcessCheckpoint done|7|||||4||||||OK

     

    Since I repaired Office, my search started working again but only is pulling up items since the repair.  The Outlook indexing status says it's back to 0.

    Wednesday, January 16, 2008 2:35 AM
  • Thanks for adding the 'map' - I've been wrestling with losing my search function for a week (first I just couldn't get anything from 2008 and then lost everything) and it now works great. I ket going into the Index Options in the Control Panel and that didn't work but the "Tools, etc." did!

     

    Monday, February 11, 2008 10:22 PM
  • Eureka!  I have been having the same problem and tried all of the Tools items several times and nothing worked.  I'm so glad that I stumbled upon y our post!  I did the same thing - deselcting - and IT WORKED!  Go figure.  Thanks for sharing this.

    Cheers,

    Luke

     

    Wednesday, February 27, 2008 12:59 AM
  • I faced the same problem. Here's what I did to solve it:

    1. Restarted my Vista OS in Safe Mode.
    2. Started my Outlook and Checked whether the Instant Search is working in safe mode (it started working)
    3. Restarted my OS again in Normal Mode.
    4. Started my Outlook and allowed it to re-index the mailbox


    And finally I got it working!!!!
    Sunday, March 02, 2008 7:58 PM
  •  Michael Hilsdale - MSFT wrote:

    To determine why Outlook Instant Search may be failing, try enabling logging:

     

    1.  Turn on Outlook logging (Tools -> Options -> Other -> Advanced Options -> Check "Enable logging" -> Reboot Outlook

    2.  Go to your Inbox and modify a mail item (e.g. toggle the Read flag).  This will re-trigger indexing for that item.

    3.  Use Outlook's Indexing Status to wait for the count to get back to 0.

    4.  Try to search again for the modified item (just in case it works this time).

    5.  Go to "%temp%\outlook logging" and look at the log file for your store.  It will have a recent timestamp and will have a name in the form "store.pst.log."  Take a look at that log file, and reply back with any lines including URLs with the Inbox folder in them.  The entire log line is useful, but in particular the second to last column will indicate the specific error code that Outlook is encountering while trying to index.

    6.  Turn off Outlook logging (since it has a performance impact) and restart Outlook.

     

    This is WinXP Pro SP2, about a year old (regularly updated).  Just upgraded to MSO 2007 from 2003.

     

    I have several .pst files, and one .ost (cached mode).  Instant Search is not finding anything in the .pst files at all.  All of the .log files for the .pst files have the same one line in the corresponding .log:

     

    2008/03/06|16:41:50:866|SGO_ScProcessCheckpoint done|3|||||||||||OK


     

    The .ost .log, however, reports numerous errors.  Here are some of the entries:

     

    2008/03/06|16:32:18:082|SGO_ScGetAttachID done|2|14608324|||||||||0x80040818|FAIL
    2008/03/06|16:32:18:082|SGO_ScBuildURL done|2|14608324|||||||||0x80040818|FAIL
    2008/03/06|16:32:18:082|Failed To Build A URL|2|14608324|||||||||0x80040818|FAIL
    2008/03/06|16:32:18:456|SGO_ScGetAttachID done|2|14608804|||||||||0x80040818|FAIL
    2008/03/06|16:32:18:456|SGO_ScBuildURL done|2|14608804|||||||||0x80040818|FAIL
    2008/03/06|16:32:18:456|Failed To Build A URL|2|14608804|||||||||0x80040818|FAIL
    2008/03/06|16:32:18:581|SGO_ScGetAttachID done|2|14609732|||||||||0x80040818|FAIL
    2008/03/06|16:32:18:581|SGO_ScBuildURL done|2|14609732|||||||||0x80040818|FAIL
    2008/03/06|16:32:18:581|Failed To Build A URL|2|14609732|||||||||0x80040818|FAIL
    2008/03/06|16:32:20:641|SGO_ScBuildURL done|2|12627618|||||||||0x80040818|FAIL
    2008/03/06|16:32:20:641|Failed To Build A URL|2|12627618|||||||||0x80040818|FAIL
    2008/03/06|16:32:20:641|SGO_ScBuildURL done|2|12627650|||||||||0x80040818|FAIL
    2008/03/06|16:32:20:641|Failed To Build A URL|2|12627650|||||||||0x80040818|FAIL
    2008/03/06|16:32:20:641|SGO_ScBuildURL done|2|12627682|||||||||0x80040818|FAIL
    2008/03/06|16:32:20:641|Failed To Build A URL|2|12627682|||||||||0x80040818|FAIL
    2008/03/06|16:32:20:641|SGO_ScBuildURL done|2|12627714|||||||||0x80040818|FAIL
    2008/03/06|16:32:20:641|Failed To Build A URL|2|12627714|||||||||0x80040818|FAIL
    2008/03/06|16:32:21:125|OnDataChanged returned an error|2|14516580|Delete||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Calendar/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걤겁곝가||||||0x80040d06|FAIL
    2008/03/06|16:32:21:125|Won't retry for this error|2||||||||||0x80040d06|FAIL

    ...

    2008/03/06|16:32:32:236|OnDataChanged returned an error|2|14414948|Delete||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Deleted Items/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걤곴곛가||||||0x80040d06|FAIL
    2008/03/06|16:32:32:236|Won't retry for this error|2||||||||||0x80040d06|FAIL
    2008/03/06|16:32:32:236|OnDataChanged returned an error|2|14526692|Delete||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Deleted Items/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎곤겨곝가||||||0x80040d06|FAIL
    2008/03/06|16:32:32:236|Won't retry for this error|2||||||||||0x80040d06|FAIL
    2008/03/06|16:32:32:236|OnDataChanged returned an error|2|14528356|Delete||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Deleted Items/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걤겯곝가||||||0x80040d06|FAIL
    2008/03/06|16:32:32:236|Won't retry for this error|2||||||||||0x80040d06|FAIL
    ...

    2008/03/06|16:34:03:847|OnIndexStatusChange - Gatherer|2|14614116|Add||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Deleted Items/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걤곾곞가||||||0x80041201|FAIL
    2008/03/06|16:34:03:847|Won't retry for this error|2|14614116|||||||||0x80041201|FAIL
    2008/03/06|16:34:11:437|OnIndexStatusChange - Gatherer|2|14614756|Add||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎곤가곟가||||||0x80041201|FAIL
    2008/03/06|16:34:11:437|Won't retry for this error|2|14614756|||||||||0x80041201|FAIL
    2008/03/06|16:34:11:562|OnIndexStatusChange - Gatherer|2|14614820|Add||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎갤각곟가||||||0x80041201|FAIL
    2008/03/06|16:34:11:562|Won't retry for this error|2|14614820|||||||||0x80041201|FAIL
    2008/03/06|16:34:16:919|OnIndexStatusChange - Gatherer|2|14614948|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎겤각곟가||||||0x80041201|FAIL
    2008/03/06|16:34:16:919|Won't retry for this error|2|14614948|||||||||0x80041201|FAIL
    2008/03/06|16:34:18:044|SGO_ScBuildURL done|11|12627618|||||||||0x80040818|FAIL
    2008/03/06|16:34:18:044|Failed To Build A URL|11|12627618|||||||||0x80040818|FAIL
    ...

    2008/03/06|16:37:10:576|Doc Not Found|12|1425|||||||||0x8004010f|FAIL
    2008/03/06|16:37:10:576|Doc Not Found|12|1427|||||||||0x8004010f|FAIL
    2008/03/06|16:37:11:778|OnIndexStatusChange - Gatherer|12|14608964|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걄곪곞가||||||0x80041201|FAIL
    2008/03/06|16:37:11:778|Won't retry for this error|12|14608964|||||||||0x80041201|FAIL
    2008/03/06|16:37:11:778|OnIndexStatusChange - Gatherer|12|14608900|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎간곪곞가||||||0x80041201|FAIL
    2008/03/06|16:37:11:778|Won't retry for this error|12|14608900|||||||||0x80041201|FAIL
    2008/03/06|16:37:11:778|OnIndexStatusChange - Gatherer|12|14606756|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎겤곡곞가||||||0x80041201|FAIL
    2008/03/06|16:37:11:778|Won't retry for this error|12|14606756|||||||||0x80041201|FAIL
    ...

    2008/03/06|16:39:37:418|Doc Not Found|12|1252|||||||||0x8004010f|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14614820|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎갤각곟가||||||0x80041201|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14616420|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걤갇곟가||||||0x80041201|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14616388|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걄갇곟가||||||0x80041201|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14616260|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎계갆곟가||||||0x80041201|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14616004|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎계갅곟가||||||0x80041201|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14615364|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걄갃곟가||||||0x80041201|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14615364|Modify||||||||0x80040818|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14615364|Modify||||||||0x80040818|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14614756|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎곤가곟가||||||0x80041201|FAIL
    2008/03/06|16:39:37:418|Flushing completed doc|12|14615428|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎겄갃곟가||||||0x80041201|FAIL
    ...

    2008/03/06|16:39:37:512|SGO_ScEnsureAttachment done|12|14636516|||||||||0x80040818|FAIL
    2008/03/06|16:39:37:512|SGO_ScGetAttachID done|12|14636516|||||||||0x80040818|FAIL
    2008/03/06|16:39:37:512|SGO_ScBuildURL done|12|14636516|||||||||0x80040818|FAIL
    2008/03/06|16:39:37:512|Failed To Build A URL|12|14636516|||||||||0x80040818|FAIL
    2008/03/06|16:39:37:512|SGO_ScEnsureAttachment done|12|14636516|||||||||0x80040818|FAIL
    2008/03/06|16:39:37:512|SGO_ScGetAttachID done|12|14636516|||||||||0x80040818|FAIL
    2008/03/06|16:39:37:512|SGO_ScBuildURL done|12|14636516|||||||||0x80040818|FAIL
    2008/03/06|16:39:37:512|Failed To Build A URL|12|14636516|||||||||0x80040818|FAIL
    ...

    2008/03/06|16:41:19:324|Doc Not Found|13|1015|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1058|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1065|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1124|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1130|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1134|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1137|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1163|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1208|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1210|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1211|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1212|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1236|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1253|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1255|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1260|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1684|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1692|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1700|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1702|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1704|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1706|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1709|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1728|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1736|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Doc Not Found|13|1738|||||||||0x8004010f|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14630916|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎간걀곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14631524|Add||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Drafts/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걤걂곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14630820|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎겤갿곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14630724|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걄갿곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14630756|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걤갿곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14630692|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎갤갿곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14632612|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Drafts/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎겤걆곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14623268|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎갤갢곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14624452|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎계갦곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14624708|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎계갧곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14634660|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Drafts/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎겤걎곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14615140|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걤갂곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14615300|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎간갃곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14615268|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎곤갂곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14615108|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎걄갂곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14636516|Add||||||||0x80040818|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14636516|Modify||mapi://{S-1-5-21-954228201-601818101-482762101-14038}/Mailbox - Ludwig, Mark($77b05227)/0/Inbox/곯가가가곱겋갭갘곊겦값걊겻각걹겎겔겾곈겎곤걕곟가||||||0x80041201|FAIL
    2008/03/06|16:41:19:324|Flushing completed doc|13|14636516|Modify||||||||0x80040818|FAIL
    2008/03/06|16:41:29:932|SGO_ScProcessCheckpoint done|13|||||2020||||||OK

     

    I would appreciate any help!  I totally depend on a good search tool to find e-mail....

    Friday, March 07, 2008 4:54 AM
  • I am using XP SP2 and had the same problem with Outlook 2007.

     

    Open Indexing Options under Control Panel.

     

    Click on Modify

     

    On the Change selected locations, check the folder of your pst file. The click ok.

     

    Check if you can search your emails already.

     

    This worked for me.. hope this works for you.

     

     

     

     

     

    Thursday, April 03, 2008 7:44 AM
  • I am having a similar problem, but for me in Outlook 2007 under Vista, the search now stops at January 2008.  I have rebuilt the index twice.  Desktop search will find later emails, but Outlook search will not.  Any ideas?

     

    Monday, April 28, 2008 1:56 PM
  •  

    Hi,

     

    Do you know how I can redirect my Outlook 2007 Autorchive emails to my share M:drive. instead of

     

    \HKEY_CURRENT_USER\software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\OutlookMail

     

    If you know any script or Group Policy please let me know

     

    Thanks

    Murtaza

    Wednesday, May 21, 2008 2:32 PM
  • Holy *** MS, really? Apparently unchecking the the data file to be searched is the simple fix. I don't know what to say. Index messages in these dat files is the prompt. Clearly I want to uncheck the box for the data file I want to search. That makes perfect sense.

    Wednesday, June 18, 2008 2:36 AM
  •  TheMik503919 wrote:

    OK, now I have seen everything. I have tried every remedy suggested to get my search to work. NOTHING!! Then, as a desparate last try I did unselect the data file to be searched. I couldn't believe it. IT WORKED. I had to do this a few times to believe it.

    Tools >> Instant Search >> Search Options >> "uncheck" the data file you want to be searched



    I am experiencing the same thing.  This is on a Vista box if that makes a difference.  Do we have the real solution yet?  This search is a good bit slower than the instant search.
    Wednesday, June 18, 2008 2:05 PM
  • Everyone here needs to understand something. If you read all of the threads by the Microsoft person you would know this.

    "Unchecking the data file you want to be searched" Turns OFF the instant search feature for that mailbox.

    That's why it works. So for anyone saying they can't understand why this works or that its unbelievable, that is why.

    Instant search is what is broken here, this is just bypassing it, not fixing it. When you are searching after doing this you are NOT using instant search. You are using the old style search.
    Tuesday, July 01, 2008 11:39 PM
  • I have the same problem, where Outlook 2007 won't pick up the search word I entered in the quick search.

    To turn off the instant search actually did what it says, Outlook would not search anything at all.

     

    The solution in my case was that to rebuild the index. It's in the Control Panel -> Indexing Option -> Advanced.

    I was unable to go to the modify button, I would click on it and nothing would happened. So something got messed up there, I did a rebuild and reboot. Outlook 2007 now works!

    This is with Vista Enterprise 64bit, UAC turned off.

    Thursday, July 24, 2008 5:30 PM
  • Thanks a lot... IT WORKS!!!!! I had this issue for months and no support succeeded to help me
    Saturday, July 26, 2008 12:36 PM
  • I was hoping to find a solution with your post (I am XP SP3 , Toshiba Portege, and got the troube juste after havind downloaded DWS version 4): no morre indexing of Outlokk or desktop...

    And what to do if the "index option" is not usable (all options shaded, only 'advanced" clickable but no one option)


    Regards

    Yvee
    yves.bertheau@hotmail.com
    Saturday, August 02, 2008 7:36 PM
  • Even I was not using the "notes part" of your post. The fact I started "enabling logging" restarted my indexing of Outlook 2007.

    Thus TANKS

    Now, since I came to Outlook issues due to a previous Windows Desktop Search stop of indexing, I hope that a new shutdown of my PC will also restart WDS.

    Regards

    Yvee
    Saturday, August 02, 2008 8:25 PM
  • I also have an instant search problem, but with a slight (and bizarre) twist.

    I have Vista Ultimate and run Outlook 2007. Instant search was great until the day I decided to accept Outlook call to 'Archive' my emails/data. I accepted (up to Dec 07). Since then, when I do a search whithin a folder (not one of the archive), the search works fine. When following the prompt to extend my search to 'Try searching again in All Mails Items' the results only retrieve the items in the 'Archives' folder (i.e. the one before Dec '07).

    When checking the search options, under the indexing, both files are ticked (archive and personal). Despite re-indexing (and checking that the index status returns 0), the problem remains.

    How can I fix the problem?
    Tuesday, August 05, 2008 12:35 PM
  • I am running 2 new HP laptops - one with HP32 VISTA, one with HP64 VISTA.  Outlook2007 wouldn't search at all either machine - zero hits - "results incomplete until indexing completes" yada yada.

    Tried most solutions in this thread, to no avail:
    -Control Panel - checking and unchecking the "outlook" index option
    -Rebuilding indices
    -Registry tweaks
    -Safe mode (search worked! but not when rebooting into normal mode afterward)

    I got a clue when - after unchecking the Outlook index option in Control Panel-Indexing options and testing in Outlook (no joy) - then checking back in Control Panel - the Outlook indexing option was checked again(!!!)

    So ... went into Outlook2007 and:

    a.  QuickSearch box
    - "Show InstantSearch Pane Menu" dropdown
    - "Search Options"
    - "Index all messages in these data files" (uncheck all psts)
    - "When searching, show only search results from " ... "Only the currently selected folder"
              (this is my preference - the first search shows the selected folder only, the next search does all Outlook items if needed)

    b.  Then under folder list - the "Search" (magnifying glass) "All Outlook Items"
    - "Search These Data Files"
    - Check which data files are to be searched when you do the second "search all data files" after the clicked-on folder is searched. (I checked all four psts I use)

    Doing step a I believe I **finally** fully disabled Outlook2007 instant search.  I can finally do searches again.  This is adequate for me until QuickSearch is fixed.

    I believe step b fixes
    LeKeuk's problems.

    _________________________

    Edit/Update some hours later.  Searching still random as to if it works or not.  If I uncheck the indexing in control panel-indexing, MS Outlook reinserts the Outlook section in the control panel-indexing when Outlook starts up - but all psts  in the subfolder are un-checked.  Regardless searches in Outlook 2007 randomly fail (no results).  Unchecking the Outlook option in indexing seems to help sometimes.  Seems like I often have to close and reopen Outlook to make searches work.  Given as I am not getting searches to work on occasion this seems to be a clue as to what is happening at least for me.

    I am wondering if an Outlook registry tweak would work to permanently turn off indexing.  Sorry I am not a registry tweak kind of guy, will take any help there!

    Clearly Outlook2007 QuickSearch/indexing is mucked up.

    Hope this helps, KevinM / BahrainKayaker
    Friday, August 29, 2008 8:05 AM
  • I have another unique problem.  I have a user who doesnt use advanced search, just the basic outlook search, and does not have any other searching software installed.  Outlook 2007 SP1.  When he searches his inbox, it does not show emails that are listed there.  Meaning that if I take a word in a subject or email that I am looking at, and plug it into the search box, and search, it may find it or it may not.  There are many things that he has searched that do not come up, but they are there plain as day.  I have no idea what else to try.  There is no indexing options in the control panel, so what I have listed here to try wont work for this.  Also, when I go to tools - instant search - search options, the only things I can select are the deleted items, and the bottom when searching, show results from: and the 2 options.  I have tried both, no dice.  Any ideas??
    Tuesday, October 14, 2008 6:28 PM
  • Search usually fails for me searching my inbox as in drewschwartz' post.  Then I search all outlook items and it seems to work (for all items including inbox).  Not the best solution but better than nothing.
    Tuesday, October 14, 2008 6:48 PM
  • Hi,
    just discovered that running Registry Mechanic disables Outlook Search. To solve the issue, I just had to uninstall Registry Mechanic.
    Friday, October 24, 2008 6:16 PM
  • I'm having this search problem and I tried to follow your directions, but couldn't come up with the log.

     

    Can you help? I'm trying to search in a folder and I see that it's right there yet it doesn't come up. And this doesn't happen all of the time, just some of the time. Unfortunately, since I use the search so often, it's important it works all of the time.

     

    thanks.

     

    Thursday, November 13, 2008 2:36 AM
  • Hi Christina,

    I'm glad you find search so useful and sorry that you are having a problem. However, there are so many posts in this thread that I don't know what your problem is exactly and which is the log to which you are referring! Could you please state your problem in some more detail as well as what you were attempting to do to fix it?

    However, make sure that you have updated to Windows Search 4 as it contains numerous bug fixes and other improvements.

    Best regards,

    -- J.B.

    Thursday, November 13, 2008 3:00 AM
  • Hi Michael,

    When I started ....cut...

    When these conditions are true, the RTF file type is no longer registered
    in Windows Vista. This behavior prevents Outlook 2007 from searching in any
    RTF e-mail message.

    To resolve this issue, follow these steps:

    1.  Click Start, and then click Control Panel. 
    2.  In the view pane, click Classic View. 
    3.  Double-click Indexing Options. 
    4.  In the Indexing Options dialog box, click Advanced.
    5.  On the File Types tab, locate rtf in the Extensions list. 

    ....cut...

    Hope this helps!


    Regards,

    Leon Hao"

    Thanks to Leon Hao.

    Maybe trying this solved the problem.

    Thanks again

    Maybe some new info about this: I work on Vista professional, so no upgrades here (although PST files were used on previous PC with XP/Off97). I got only partial results when searching. 
    When I check the RTF file type under advanced indexing options via Control Panel, I noticed that RTF was checkec. However the two radio buttons for 'How should this file be indexed (properties only and properties and file content) were both blank, none selectec. Does that add anything to the puzzle? I marked the 'props and content' button and try to see what's changed.
    Friday, May 08, 2009 8:56 PM
  • Hey dan

    I am using a search tool which is called lookeen (www.lookeen.com). The search integrated in outlook causes so much problems, I could not work with it any longer. A friend of mine recommended this tool and now I am very happy with it :).

    Matt
    • Proposed as answer by Domini1Banned Tuesday, December 15, 2009 4:15 PM
    Sunday, May 17, 2009 9:37 AM
  • I am sorry Dan, I haven't noticed that you've already answered. It really works out very good, for example the search integrated in outlook indexes very slow, lookeen is much faster, the search results are also displayed in way that is more logical ;).

    Matt
    • Proposed as answer by Domini1Banned Tuesday, December 15, 2009 4:14 PM
    Monday, June 01, 2009 7:27 PM
  • Here is what worked for me:

    My setup:  XP Pro + Office 2007 Clean install
    My problem: Index was never up to date Search was incomplete.

    1: Unselect all data files under Tools, Instant search, Search option
    2: Waited for Windows Search to update it's index (approx 2 hours for me)
    3: Ran scanpst and scanost for each of my data files ( i had errors in all of them)
    4: Reselected each data file under Tools, instant search, search option * One at a time *  Making sure to wait that each file was indexed before selecting the other one. (You have to restart Outlook)
    5: now it's working as it was before!

    Hope it will help you!

    Remanco
    Wednesday, June 17, 2009 2:54 PM
  • Ok, let's take this a step further....

    1.  Turn on Outlook logging (Tools -> Options -> Other -> Advanced Options -> Check "Enable logging" -> Reboot Outlook

    2.  Go to your Notes folder and modify a note.  This will re-trigger indexing for that item.

    3.  Use Outlook's Indexing Status to wait for the count to get back to 0.

    4.  Go to "%temp%\outlook logging" and look at the log file for your store.  It will have a recent timestamp and will have a name in the form "store.pst.log."  Take a look at that log file, and reply back with any lines including URLs with the "Notes" folder in them.

    5.  Try to search for the modified item.  From what you're describing, it doesn't sound like it will work, but it's good to be sure.

    6.  Turn off Outlook logging (since it has a performance impact) and restart Outlook.

    It sounds like the items are failing to be indexed.  If so, this should give us a clue to what's happening.

    I'm having similar problems to everyone else, I have a Vista Pro with Office 2007 build which won't index at all, after enabling logging and flagging an item in the inbox to trigger indexing I saved off the outlook.ost.log which looks like this:

    Store File Name: outlook.ost
    Date|Time|Action|Search Owner|NID|Change Action|Change Semantics|URL|Count Of DocIDs|Next NID Index to add to All Msg folder|Next NID Index to push to FTE|Folder Path|Folder Path ID|HRESULT|Result Status
    2009/07/09|09:43:47:980|OnIndexStatusChange - Gatherer|3|8450|Add|Directory|mapi://{S-1-5-21-3210600024-2843801101-3004091891-1192}/Public Folders($c082ea09)/2/||||||0x80041201|FAIL
    2009/07/09|09:43:47:980|Won't retry for this error|3|8450|||||||||0x80041201|FAIL
    2009/07/09|09:45:30:491|Flushing completed doc|3|8450|Add|Directory|mapi://{S-1-5-21-3210600024-2843801101-3004091891-1192}/Public Folders($c082ea09)/2/||||||0x80041201|FAIL

    Any additional help would be appreciated.
    Thursday, July 09, 2009 9:03 AM
  • OK, now I have seen everything. I have tried every remedy suggested to get my search to work. NOTHING!! Then, as a desparate last try I did unselect the data file to be searched. I couldn't believe it. IT WORKED. I had to do this a few times to believe it.

    Tools >> Instant Search >> Search Options >> "uncheck" the data file you want to be searched


    Worked for me after many attempts to correct the problem.  Outlook 2007 would only search Personal File Folders.  RELIEF! Thanks
    Wednesday, July 22, 2009 12:51 PM
  • You are a GENIUS in my book! That worked! I had been trying for 2 weeks to get my instant search to work and as soon as I tried your idea it worked! thanks a LOT!!!!!!!!!!!
    Friday, August 21, 2009 8:43 PM
  • Thanks for the workaround to uncheck the data files in order for Search to get working. 

    I think the explanation of why it works is right - it basically disables the 'improved' (and broken) search which must have been part of the Automatic Update to Office 2007 SP2. It is definitely slower, but at least it works.

    Outlook search was working fine until I allowed Automatic Update to install Office 2007 SP2 as well as a 'Live Add-in' optional update.

    Thanks to all in the forum for helpiong me solve my problem.
    Wednesday, September 09, 2009 5:35 PM
  • TheMik2, dude you saved my night searching for solution for an annoying issue.

    Thanks it really worked and I'm happy that I can find exact email messages out of thousands of emails.

    Sunday, October 18, 2009 5:32 PM
  • Your simple solution worked for me too!

    I feel like a blond girl in a joke... dahh

    I was desperate! Why the ____ did it stop working...

    Thank you very much.


    Monday, November 09, 2009 4:28 PM
  • OMG! You're right. It did work. I had tried everything as well. This seems counterintuitive to what it should do, but whatever works. Thanks!
    Tuesday, November 17, 2009 3:44 AM
  • Thanks to TheMik2's workaround, I had been able to continue using search in Outlook which had completely stopped working for me, possibly because of some installation issues. Though a strange side-effect, this is par for the Microsoft course - disabling all 'instant-search' data files, disables instant-search and Outlook falls back to its built-in (slower) search. This pointed to something wrong with the index, but just rebuilding the index did not help. MICROSOFT, THIS IS A TERRIBLE BUG!!!

    I had been hoping that one of the innumerable MS Updates would solve this problem, but had pretty much given up on using instant-search in Outlook when instant-search continued to be broken through a year of updates.

    That is, UNTIL I SAW THIS POST IN THIS THREAD - ON HOW TO COMPLETELY REBUILD THE INDEX. THANK YOU Serdar Yegulalp for your link on how to do this: http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1256528,00.html

    Here is the relevant content from that link - too useful to have it get lost!

    Windows Vista's built-in indexer sometimes freezes while attempting to index Microsoft Outlook 2007 content. When it gets stuck, the status messages in Outlook's Tools -> Instant Search -> Indexing Options menu will claim that there are still items remaining to be indexed across all open mailboxes.

    Fortunately, there is a workaround that will unblock this Outlook 2007 indexing logjam:

    1. Close Microsoft Outlook.

       

    2. Open the Indexing Options window for Vista -- you can get to this quickly from the Start menu by typing index in the Start Search panel.

       

    3. Click Modify -> Show All Locations to view all the index search locations. Make a note of everything that's currently flagged for indexing -- you'll need to re-add these items later.

       

    4. Uncheck everything from this list, including Outlook. To quickly go to the locations that you need to uncheck, just double-click any of the entries in the "Summary of selected locations" window.

       

    5. Click Close, and then click Advanced to open Advanced Options .

       

    6. Select Rebuild to completely rebuild the index. Yyou shouldhave "0 items indexed" showing in the main Indexing Options window when you click OK. (The idea is to rebuild the index so that there's nothing in it and nothing being added to it.)

       

    7. Click Modify -> Advanced and re-add the locations that existed before. Note that "Microsoft Office Outlook" may attempt to automatically re-add itself, and that's OK.

       

    8. Click OK to complete the re-indexing process.
    THANKS AGAIN for the solution to a problem that was really, really painful. And Microsoft Support - why the #$%^@, don't you read these forums to better assist your suffering users and fix the search index rebuild BUG??

    -- "If God isn't a Tar-heel then why is the sky tar-heel blue?"

    • Proposed as answer by tar-heel Tuesday, December 01, 2009 6:16 PM
    Tuesday, December 01, 2009 6:15 PM
  • Hi Gang....so I'm having a similar problem trying to get Windows Search to index my emails.
    I am currently running Windows 7 Pro 64-bit and Outlook 2007.   Upgraded from Windows XP Pro (SP3) and Outlook 2003 doing a clean install and then migrating app data over using Windows EZ migration.

    Windows Search (i.e. Federated Search) is able to index my local files, but does not show any email files.
    I've tried all of the following:
    * reindexing as described  in http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1256528,00.html
    * running Microsoft Digonistic
    * running Windows 7 assist utility: Find and Fix Problems with Windows Search
    * Creating new Outlook profile
    * Running scanpst on outlook PST files
    * Confirming that Outlook Instant Search is enabled
    * making sure that Indexing Option File type RTF indicates Rich Text Format

    I do note that, after trying the re-indexing (uncheck/recheck) fix, Windows Search IS able to index individual outlook messages which I have saved in My Documents folder(s), but it does not index my PST files.

    Moreover, when I open up the Search Options in Outlook Instant Search, the "Indexing" and "Search" options are DISABLED/GREYED OUT!  So, I am unable to select any PST files for indexing and/or customize search options.

    Other details to consider which may be affecting:
    * I'm running Office 2007 SP2
    * I originally installed the Office Software under my Windows User Profile (w/ Administrator privileges) by launching the installer using "run as administrator"
    * The PST files are stored on my D: drive (and outlook profile has been set up to do this)


    Any help/assistance towards solving this problem would be greatly appreciated.

    Thx!!
    ~Rx
     
    Saturday, December 12, 2009 8:39 AM
  • That worked great, thanks. 

    Outlook 2007 running Exchange 2007 on SBS2008
    Friday, December 18, 2009 7:34 AM
  • SOLUTION!! (Big thanks to Temp_999 for pointing me to the solution!!)

    After digging around for a week, I finally found the cause of the problem, and was able to fix it.
    See: http://blogs.msdn.com/outlook/archive/2009/06/17/google-apps-sync-disables-outlook-search.aspx

    Google Apps Sync Disables Outlook Search
    The installation of the Google Apps Sync plugin disables Outlook’s ability to search any and all of your Outlook data. When a Google Apps user installs the sync plugin for Outlook , the plugin modifies a registry key which disables Windows Desktop Search from indexing and providing search functionality for all Outlook data , not just the Outlook data being synchronized from GMail. Because Outlook search relies upon the indexing performed by Windows Desktop Search, Outlook search functions are broken as a result. It is also important to note that uninstalling the plugin may not fix the issue .

    Outlook users who are considering the Google Apps Sync plugin should become aware of this issue. If you have already installed this plugin, please take note of the steps below to address the issue.

    For Outlook users who have already installed this plugin or have experienced this issue, the only remedy is to change the registry key that was modified by the plugin (click the link for more detail on the registry key):

    1) Press the Windows Key + R on your keyboard, and type “REGEDIT”. This will open the Windows Registry Editor.

    2) Browse to the following: "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search"

    3) You will manually have to reset the value of “PreventIndexingOutlook” to “0” (without the quotes). To do this, right click on the “PreventIndexingOutlook” key, select “Modify…”, then change the value data to “0”.

    4) Close the registry editor.

    The Outlook team has been made aware of a second issue that affects users of the Microsoft Office Outlook Connector which syncs Windows Live Hotmail with Outlook. When a user has the Outlook Connector installed, then installs the Google Apps Sync plugin, the next time Outlook is started an error message comes up stating that “some functionality will be disabled”. The Google Apps Sync plugin modifies a registry key that is used by the Outlook Connector, which results in users seeing this error message. When confronted with this error message, we recommend that users click “Yes” to enable functionality. The Outlook Connector will then continue to function normally. The Outlook Connector will reset this registry key to the correct value.

    Friday, December 18, 2009 7:48 AM
  • thanks Domini1 and MattVan. That tool solved my search issues also a long time ago... My recommendation if your have problems or are just tired of the OL search...
    Saturday, December 19, 2009 3:43 PM
  • This did the trick.  I guess this means I disabled Instant Search for this mailbox?  That's fine because search is now working again.  Thank you!
    Monday, January 18, 2010 6:12 PM
  • Well, I tried to repair office, and the repair crashed.

    What in the world is wrong with Microsoft? This has been an issue for almost THREE YEARS. They can't put out a patch? They can't add code that at least checks to see if that registry key is missing and displays a notice to the user that they need to repair???
    Thursday, February 25, 2010 5:36 PM
  • This totally worked! Thanks
    Monday, March 15, 2010 9:25 PM
  • THANK YOU. I thought I was going mad trying to search my archive, and nothing worked. Then I stumbled across this and VOILA. It works. I can't believe it either :)
    Tuesday, March 23, 2010 4:03 PM
  • I struggled for months trying to Instant Search to work.  Today I finally realized I was running Outlook 2007 in Administrator Mode.  Must have changed it for some reason.  I removed "Run as Administrator" in compatibility tab and voila - my instant search is working again.
    Saturday, April 10, 2010 8:14 AM
  • Michael I have tried verbatim all that MS has recommended would fix the problem. I have reindexed via control panel, I have also repaired via add/remove software and Advanced find still does not find anything. I am very frustrated at this point.

     

    Can you help me.

    Friday, May 07, 2010 8:35 PM
  • hot dog! I had the same problem, tried this and it worked like a charm. many thanks for sharing!
    Tuesday, May 11, 2010 6:50 PM
  • Hi,

     

    Search Problem is sorted out

     

    Please install KB3178621 new article which is available in www.microsoft.com/office/updates/KB3178621

     

    Hope it will be work

     

    Cheers!

    I hope after long time ThiMick 2 problem is resolve

     

    Be happy man

     


    Microsoft Certified System Engineer
    Thursday, May 13, 2010 7:32 AM
  • that link is not active.
    Wednesday, July 07, 2010 7:30 PM
  • Had a problem with quick searches not working in Outlook 2007 32-bit running on Windows 7 64-bit.  After mucking about a bit, I found that:

    1. de-selecting the Outlook-related objects (in Control Panel, Indexing Options, Modify...)
    2. rebuilding the index (option in the Advanced area of Indexing Options)
    3. re-selecting the Outlook-related objects
    4. then again rebuilding the index

    proved to be the answer for me.  Searches are working great now.

    Monday, August 02, 2010 4:58 AM
  • A few weeks ago Windows Search 4.0 stopped working with Outlook 2007.

    I have tried every single solution in this thread: repair office, uninstall office, uninstall search, take all the search location out of search and then rebuild the index and readd what I had before, etc.  Not a single thing has worked.  And the solution to turn on logging yielded absolutely nothing.  No *.pst.log, no *.ost.log, no folder called "outlook logging" anywhere.  Nor was I able to find a registry key in HKLM referring to "PreventIndexingOutlook"—not that I expected to since I've never installed any Google App items.

    I am running Windows XP SP3 fully-patched to the very latest out-of-band hotfix.

    I am using Office 2007 Professional Plus, also patched to the gills.

    I am working with an Exchange 2003 environment.  It was working great for several weeks and then suddenly stopped.

    I will reiterate: no solution in this thread has worked for me, and I cannot even find any troubleshooting logs for Outlook despite the fact that I have it turned on.

    Is there any way that I can troubleshoot this further?

    Thanks.

    Thursday, August 05, 2010 10:18 PM
  • THANK YOU, TheMik2 (or whoever came up with it)!!!

    Like a lot of persons it seems, I have tried so many things to resolve my issue (mine was: "empty search result"), and even if this appraoch is slower, at least IT WORKS!
    You are saving me hours of works!! Can't live without search with my thousands of e-mails.

    Thursday, August 19, 2010 12:25 PM
  • I'd just like to post to this forum that I have had exactly this issue, and the simplest (right or wrong) solution was to do exactly as TheMik2 suggested.

    I had some ugly issues with an upgrade from 2007 to 2010, which meant i had to do a FULL manual clean of office based on the detailed technet articles (not fun - not fun at all...).

    Afterwards, i reinstalled 2007 (gave up on 2010 for now) and finally all my office programs were working again.

    The strange bit was that i couldn't search emails (not just instant search, ANY search. including desktop search on Windows 7). i unchecked the outlook option. re-checked it, then rebuilt the index from the ground up. afterwards i checked, and the status said there were no more items to be indexed.

    Result? NO search results!

    Then i read this post, and unchecked all the data files.

    Result? instant search works. full outlook search works. Unfortunately Windows 7 desktop search still doesn't. this is a pain as i prefer that search, but hey, i can live with it...

    Thursday, August 26, 2010 1:50 AM
  • I"ve tried your suggestions but the indexing count doesn't go down

    I've left it even running overnight but still no go

    Help!

     

    Dwin

    Tuesday, September 21, 2010 10:54 PM
  • I'd like to try your "mar7aib" suggestion.

    How do I do this?

    dwin

    Tuesday, September 21, 2010 10:56 PM
  • on pt 3 : no it doesn't go to 0

     

    on pt 4: nothing like "store.pst.log."  instead "OPMLog.log"

     

    pt 5: searched but nothing modified

     

    what next? reinstall outlook?

    Tuesday, September 21, 2010 11:04 PM
  • I was trying the 4 step process from Frosty and when I get to step 3 there is no way to re-select Outlook-related objects.  They have been removed from the list.  I don't see how he could have actually done it.

    Also, de-selecting Outlook-related objects will unselect the data file (Mailbox) which is what the very first post says to do.  I think the reason it works now for him is that he did what was suggested in the first post, albeit without realiziing it.   

    Searches are working now for me because there is no Outlook indexing available, but that was possible even before I de-selected the Outlook objects and made them disappear from the list of indexing locations.


    Right after I submit this post I check Indexing Options -> Modify again and there are the Outlook items!  I don't know why they suddenly reappeared.


    OK.  After re-selecting the Outlook objects and rebuilding the index, instant search still does not work (with indexing).  If I disable the indexing then the search works.  (which is what the first post says to do)
    Thursday, September 23, 2010 5:06 PM
  • OK, now I have seen everything. I have tried every remedy suggested to get my search to work. NOTHING!! Then, as a desparate last try I did unselect the data file to be searched. I couldn't believe it. IT WORKED. I had to do this a few times to believe it.

    Tools >> Instant Search >> Search Options >> "uncheck" the data file you want to be searched


    Thanks!!! This resolved my problem after banging my head against a brick wall for the last couple weeks.
    Monday, October 04, 2010 4:00 PM
  • I am having a similar problem to this.

     

    Computer Specs:

    Dell Laptop

    Intel Core 2 Duo T7300 @ 2.0GHz

    1GB Ram

    Windows XP SP3

    Microsoft Office 2007

     

    The issue here is rather strange. This computer is on a corporate network. It can search through its own e-mails (most days) without issue, but when I try to search through a contact list in a data set housed on our server in a different program which is linked to outlook, I get zero results. Given that the contact list is not local, I don't have the option to uncheck the data set and use a slower search function.

    This particular computer was able to search this data set until a few days ago when I installed some windows updates. Now it no longer works. I will try to get server information and a list of the installed updates and post them in a reply later, but I was hoping someone would be able to take this information as it is and let me know what to do.


    "Where's the lesson, God? You're tearing off the wings of all my unprotected dreams, for nothing. I'll keep holding on; but I'm running out of nails over everything that's ever failed within me." - Mesh, "Four Walls"
    Wednesday, October 20, 2010 5:27 PM
  • Great above soloution realy worked for me.

     Thanks  The Mike2

    Friday, October 22, 2010 11:45 AM
  • I couldn't believe it, but this ACTUALLY WORKED!  What I want to know is why, for years, I could do searches just fine, then a couple of days ago it would not pull up a message that I was STARING RIGHT AT.  But when I unchecked the box, it pulled it up.  Spooky.  Why do they make us work so friggin' hard to use their product?

    Thanks for the solution.  I was ready to tear my hair out!!

    Tuesday, October 26, 2010 11:45 PM
  • I have a WinXP SP3 Dell laptop connected and managed by a corporate network, running Office 2007 (including Outlook).  I installed Instant Search because they made Advanced Find so difficult to find (I finally found it, thank you).

    Finding e-mail messages worked well - I have two .pst files at or near 2GB each - and results were very fast.

    The problem I had was with almost everything else I tried to get done.

    Since installing Instant Search, I have had periodic forced breaks (as often as every two hours), stretches of 15 - 30 minutes during which I can do nothing with my PC except watch it raise my bloodpressure as it ignores every means of input I have at my disposal.  Well, almost.  I have not tried to input my foot through the screen, but since this is corporate property that really isn't an option.

    Yesterday, I had to stay at work 20 minutes late as every program I tried to shut down took a full 5 minutes to respond to any click or keystroke I made.

    After uninstalling Instant Search this morning, my PC has regained its former zippy performance level.  I am a developer and a systems manager, so I often have two dozen or more programs open at once, including Outlook, SQL Management Studio, several query windows, etc.

    I can't afford to wait for "Instant Search" to finish whatever thumb-twiddling it is doing in the background every two hours while I'm trying to get actual work done.  It takes me far less time to use the old search tools than to let this hog monopolize my PC 25% of my day.

    I am currently trying this with Instant Search installed but no files selected.  I can search, although Outlook is complaining by coloring its menu area in orange.  I will run some comparisons between this scheme and using Advanced Find with Instant Search uninstalled.  I suspect I will end up leaving Instant Search uninstalled eventually.

    Tuesday, November 16, 2010 5:18 PM
  • This is crazy! I just tried the suggested solution and works perfectly!!! Would this be considered a bug?

     

    Friday, December 03, 2010 1:08 AM
  • You saved my day - thanks for the hint!
    Thursday, December 09, 2010 11:52 PM
  • This works.  I tried everything... this works.   'uncheck' the data file
    Tuesday, January 04, 2011 2:11 PM
  • Thank you so much - nothing like being intuitive!
    Sunday, January 30, 2011 5:40 AM
  •    My one of the client facing the same issue, but my case, the problem is something different. When I am trying to search a mail in MS outlook 2007, it shows as nothing found, even though it is placed in mailbox. Before trying the above troubleshooting steps I would know one thing.

    I could not see the "Microsoft office Outlook" under indexing option in Control panel. Other PC shows the same icon in that location.

    I trying to add it but can't.

    My scenario

    OS: MS XP sp3: WDS 4.0

    The users use MS outlook 2007 and outlook express. He set MS Outlook as a default mail.

     

    Thanks

    Mani S     

     


    Thanks & Regards, Mani S
    Thursday, February 10, 2011 3:43 PM
  • OK, now I have seen everything. I have tried every remedy suggested to get my search to work. NOTHING!! Then, as a desparate last try I did unselect the data file to be searched. I couldn't believe it. IT WORKED. I had to do this a few times to believe it.

    Tools >> Instant Search >> Search Options >> "uncheck" the data file you want to be searched


    OMG!!!! You're a Legend!!! have been baffled by this stupid glitch for months and a simple almost ridiculous solution which defies comprehension has resolved months of unnecessary work. Thanks....happy again!
    Sunday, February 13, 2011 10:54 PM
  • OK, now I have seen everything. I have tried every remedy suggested to get my search to work. NOTHING!! Then, as a desparate last try I did unselect the data file to be searched. I couldn't believe it. IT WORKED. I had to do this a few times to believe it.

    Tools >> Instant Search >> Search Options >> "uncheck" the data file you want to be searched


    Another satisfied customer.  Thanks for pointing out the workaround to this brain dead stupid Outlook bug. 
    Monday, February 21, 2011 7:22 AM
  • Thanks!
    Thursday, April 07, 2011 3:20 PM
  • I hate to be the only one to point this out, but this has been an outstanding problem for 4 years now and persists in the 2010 version.... and Microsoft still has not fixed it.

     

    Seriously?

    Friday, April 22, 2011 2:55 PM
  • WOW.....

    WE TRIED EVERY THING AS SYSTEM SUPPORT TO ENABLE EMAIL SEARCH BUT THIS IS THE ONLY OPTION WHICH WORKED....THANKS A LOT.

     

    Friday, April 29, 2011 4:22 AM
  • Still a problem in 2011.  TheMik2 solution works for me.  Really crazy.  Any one know if there is a patch or KB article?
    Saturday, May 07, 2011 6:09 PM
  • Hey TheMik2 your awesome! This problem has been plaguing me since the time i started using outlook 2007 and have been trying all kinds of fixes and workarounds, got third party addons to fix the search! Nothing worked!!! your fix solved it!
    M.H.S.(CCNA R&S, IINS)
    Wednesday, June 29, 2011 2:28 AM
  • worked first time 'TheMik2' - thanks!
    Wednesday, July 06, 2011 1:32 PM
  • There are several issues which cause the Search option to not work. Usually, due to the installation of plug-ins, it might lead to some problems. Plug-ins on your system may modify the registry key that may disable Windows Desktop search option and also may affect the search and indexing function of data on Microsoft Outlook.

    In order to fix the problem, you can disable plug-ins that cause the Search option to not work. Ensure that the Search option feature is enabled. To enable the Search option you need to open Microsoft Outlook, and go to ‘Mail’ option. Then select ‘Click here to enable Instant Search’ option and thus you can turn on the ‘Search’ feature.

    http://email.iyogi.com/outlook/outlook-2007-search-not-working.html

    http://social.msdn.microsoft.com/Forums/en/windowsdesktopsearchdevelopment/thread/8b7425fd-dcd5-483e-8b15-4d2473606fe0


    Monday, July 18, 2011 4:44 AM
  • I came across this message after a couple of months of frustration. Like TheMik2, the solution makes no sense to me, but it works, and I finally have my Outlook 2007 Search function working again.  
    Wednesday, July 27, 2011 9:32 PM
  • Thanks TheMik2. I wasted a lot of time on this.

    Your solution worked for me too. Ugly, but it works.

    Friday, August 05, 2011 4:42 PM
  • I found a better solution. I uninstalled Vista and Outlook 2007 and went back to a reliable system like XP and Outlook 2003. I just had enough of the problems. What made this better is that all my outlook settings where saved when i re-installed outlook 2003
    Friday, August 05, 2011 7:52 PM
  • Hi All ,Is there any sol. avalible now except uncheck the data files,as it worked for me too. but after that i m able to search only in default data files , mail are present in other data files but they are not searchable,,(using office 07, Vista)
    Thursday, August 11, 2011 8:01 AM
  • Here's what i did

    My setup:  XP Pro + Office 2007 Clean install
    My problem: Index was never up to date Search was incomplete.

    1: Unselect all data files under Tools, Instant search, Search option
    2: Waited for Windows Search to update it's index (approx 2 hours for me)
    3: Ran scanpst and scanost for each of my data files ( i had errors in all of them)
    4: Reselected each data file under Tools, instant search, search option * One at a time *  Making sure to wait that each file was indexed before selecting the other one. (You have to restart Outlook)
    5: now it's working as it was before!

    Hope this will help

    Thursday, August 18, 2011 9:42 PM
  • I have been going crazy trying to find a solution and this worked.  Thanks for going through all that for the rest of us.  :)
    Wednesday, September 07, 2011 11:58 AM
  • I have been trying to fix this issue whitout any luck. Thanks, your solution worked for me. :-)

     


    Alex Garcia
    Wednesday, October 05, 2011 2:03 AM
  • What fixed it for me was disabling the add in for Hotmail Connector. Found under Tools/trust Center/Add-ins. I clicked manage and removed the check on hotmail connector and presto search started working. This took days to find. Hope this helps someone.
    Friday, October 14, 2011 10:19 AM
  • d I unchecked all the Data files and it worked!

     

    Thanks for your help.

     

    DR

    Thursday, October 20, 2011 8:34 PM
  • After 5 hours of indexing, re-indexing, configuring, re-configuring, this is what finally worked:
    Tools >> Instant Search >> Search Options >> "uncheck" the data file you want to be searched

     

    Unbelievable.

     

    Monday, January 16, 2012 4:56 PM
  • Sometimes it happens that search issues occurs in outlook due to the corruption issues. To resolve such problem you can make use of PST repair tool. The tool will resolves outlook corruption issues and thus enhance the performance and stability of outlook. PST repair tool download is the best option to resolve outlook search problems, in the case when outlook gets corrupted and erroneous http://www.pstrepairdownload.com
    Thursday, January 19, 2012 10:21 AM
  • I used the SCANPST.EXE repair tool across 12 large PST files - it said it found errors and corrected them, still instant search didn't work. I, like so many others, have rebuilt my index via the control panel Index Options so many times, yet same old issue of not being able to find anything when using Instant Search within Outlook 2007 running on VISTA Ultimate. OK, I unchecked the PST list in Search Options and guess what, my searches now work. Go figure, I've wasted so many hours on this. Thanks to the person who initially tried this, I would have never thought of it - yippee.
    Tuesday, January 24, 2012 7:35 AM
  • i did a full search in control panel and could find not find indexing anywhere ( Control Panel -> Indexing Options -> Modify ->).  I'm on xp and under tools in outlook i can't even select indexing to turn it on now.  although i had turned it off as when i first turned it on, that's when my search stopped working.  Search doesn't work for mail, contacts or calendar items.  Have tried so many fixes suggested online but haven't found one that works :(  I get a blank search pane with 'cannot display the folder'.  This is a work computer that i have used for 2 years and it is only a cpl months ago when i enabled indexing (as i kept getting prompted which annoyed me so i finally gave in and said yes).  it had worked perfectly before that.

    Tuesday, April 17, 2012 12:35 AM
  • Yes partner, that is the solution. Thanks
    Wednesday, May 09, 2012 11:58 PM
  • To TheMik2,

    Thank you.  I unchecked all boxes for indexing and instant search started working.  

    Strange problem, but you gave the correct solution.

    Cheer,s

    Sunday, June 10, 2012 5:21 PM
  • These all issue can be simultaneously could be solved with the use of MS Outlook in-built tool. However sometime this tool fails to fix severe outlook problems and is also not capable to divide or split large PST files. In order to perform all such job instantly and safely, you are required to download third party PST Repair Tool on your Windows OS.

    Read More at:: http://www.pstrepairtools.net



    Monday, July 23, 2012 11:50 AM
  • TheMik2, thanks for the update of your magic solution. Just came across this problem and luckily just saw your post. Now problem solved, thanks to you.

    Cheers.


    Tuesday, November 06, 2012 3:19 PM
  • I have been having this problem on my Win7Pro 64bit with Office 2007. New installs not upgrades. Had been working fine but stopped working. Have not installed any old office software "over" the 2007.  Have tried things listed here - I can't uncheck my mail file in the index options as it gives me an error after clicking ok after I unchecked it. Tried safe mode and it works fine. Tried new almost empty PST file and still same problem.  Turned on logging and if I did this right, here is the information from the log file.

    Store File Name: Outlook.pst
    Date|Time|Action|Search Owner|NID|Change Action|Change Semantics|URL|Count Of DocIDs|Next NID Index to add to All Msg folder|Next NID Index to push to FTE|Folder Path|Folder Path ID|HRESULT|Result Status
    2012/12/27|20:20:37:646|Failed to connect to the indexer|2||||||||||0x800706be|FAIL
    2012/12/27|20:20:37:646|SGO_ScEnsureConnected done|2||||||||||0x800706be|FAIL
    2012/12/27|20:20:37:646|Entering error backoff|2||||||||||0x800706be|FAIL
    2012/12/27|20:21:28:908|Failed to connect to the indexer|4||||||||||0x800706be|FAIL
    2012/12/27|20:21:28:908|SGO_ScEnsureConnected done|4||||||||||0x800706be|FAIL
    2012/12/27|20:21:28:908|Entering error backoff|4||||||||||0x800706be|FAIL
    2012/12/27|20:22:39:774|Failed to connect to the indexer|4||||||||||0x800706be|FAIL
    2012/12/27|20:22:39:774|SGO_ScEnsureConnected done|4||||||||||0x800706be|FAIL
    2012/12/27|20:22:39:774|Entering error backoff|4||||||||||0x800706be|FAIL

    Any help greatly appreciated!

    Friday, December 28, 2012 2:12 AM
  • Mike, I found a problem after some more searching/reading. I thought to go check my services and the service would not start.  MY event log was showing failure for the windows search to start. After searching some more info related to that I ran the windows repair/fix it program for the windows search and it fixed the problem. Not sure what was wrong but it all appears to be working now.

    Friday, December 28, 2012 2:45 AM
  • thanx - worked!
    Thursday, April 18, 2013 5:54 AM
  • After upgrading to Office 365 I had this issue.  I left outlook running and did a hard stop by unplugging the power cord out of the back of the tower.  Waited 30 seconds, plugged it back in, and after the hard startup it was resolved.  It's worth a try. 
    Wednesday, July 10, 2013 5:56 PM
  • I had the same problem with Instant Search not finding items in my Exchange account. I selected "Cached Mode" in my Exchange account settings, and that fixed the issue.
    Saturday, November 30, 2013 6:05 PM
  • Wow... I have tried everything too.  I saw your post and said " what the heck ".  It worked.  Thanks man! HAHA
    Friday, December 13, 2013 1:04 AM
  • Yeah !!!!! unbelievable !!!! working !!!
    Thursday, May 22, 2014 3:43 AM