none
Active X Not working in IE7[Vista]

    Question

  • Hi,

     

    I have done an ActiveX to get client MAC address as its major part and runs over IE.it is successfully running  in Win2000, Win2003, WinXp and even with IE7 with previously mentioned Window versions.

     

    This ActiveX was developed in VB 6.0.

    This ActiveX gets installed atomatically through a cab file, whenever the application was accessed first time.

     this cab file work fine in WinXP but when we try to run this cab file in vista IE get hang

    Now, we have to support it with IE7 over Vista.

    Please let me know what should I do to make it compatible with IE7 and Vista. I am using Vista Business right now.

     

    When the application was accessed through IE7 for the first time, ActiveX installation dialog appeared. I pressed the Install button but then IE7 threw an error message that "Internet Explorer has stopped working". After that each time, whenever the application was accessed IE7 threw the same error message.

     Cab file i made in VB6 using internet and deploy package wizard,along with cab file we will get one HTM file also to get Object id and code base along with version,even if we try to open this HTM file then also IE get hang.

    I tested by manually registering the ocx, also turned off the Protected Mode and enabled my ActiveX through Manage Ad-on as well, but to no avail.

     

    Please let me know any solution to this problem. 

     

    Looking forward to your response.

    Thank you.

    Monday, April 06, 2009 12:46 AM

All replies