none
How to record from 'Wave' or 'Stereo Mix' in Vista?

    Question

  •  Hi all,

    I wrote the following question in other forum space but some MSFT guy told me to try this forum for my question. I hope I could get right answer as soon as possible here.

    On Windows XP or earlier, I could capture the audio stream to the speacker not from the external device (maybe endpoint device in Vista) like the microphone. In other words, DirectSoundCapture was able to capture from the selected recording device/source line in the Windows record control utility or mixerXXX APIs. And if "Wave Out Mix" or "Stereo Mix" or something similar was selected as recording source line, DirectSoundCapture was able to record the audio stream to the speacker.

    However, I could not find the way to do that in Windows Vista. Windows record control utility in Vista is just showing only external devices (endpoint devices) like mic., line-in or S/PDIF in but I could not find "Wave Out Mix" , "Stereo Mix" or something similar. I thought they were not seen because these kind of recording sources are NOT  "endpoint device" on the user's point of view. So, I wrote a simple test code using "Device Topology API" of Core Audio APIs in Windows Vista SDK, in order to get internal controls of audio device. And one audio device driver (I have two Vista test system) exposes IAudioInputSelector interface. However, there's also NO "wave Out Mix" or similar subunit found.

    Is there another way to capture  the audio stream to the speacker on Vista? Please let me know!!

    Monday, December 11, 2006 2:43 AM

All replies

  • This is an issue I have also experienced. It is excellent for keeping record of any goings-on on your personal or work computer for further study, but seems to be a feature that is lacking/outright missing in Windows Vista (Ultimate as well)
    Monday, December 11, 2006 3:30 AM
  • What APIs did you use for this in XP?  They should continue to work on Vista.

    WASAPI has a special Loopback mode that allows a client to capture the post-mix audio stream, that may help as well.

     

    Tuesday, December 12, 2006 1:27 AM
  • Thanks for your answer, Larry.

    [What APIs did you use for this in XP?  They should continue to work on Vista.]

    As I said in earlier post, I used "DirectSoundCapture" to capture that audio stream on the "source-line" selected in Windows record control utility. As you know, DirectSoundCapture buffer can capture the audio stream through the selected mixer line. For example, If "Mic-in" is selected, DirectSoundCapture buffer will capture the audio comes through Mic.-in line. And if "Line-in" is selected, it will capture the audio stream through Lini-in line.  Yes, I know this should continue to work on Vista.

    However, as the title of this thread saying, I could not find the way to record the audio stream on 'Wave' or 'Stereo Mix' line on Vista? Actually, "Line-in" and "Mic-in" are real external "ENDPOINT devices" but 'Wave' or 'Stereo Mix' line are NOT.

    Actually, on XP or earlier versino of Windows, I could select 'Wave' or 'Stereo Mix' line through ::mixerXXXX() APIs. For example, I used ::mixerGetLineInfo(...) API to get MIXERLINE structure. And if the "dwComponentType" member of MIXERLINE structure is MIXERLINE_COMPONENTTYPE_DST_WAVEIN, then I used ::mixerGetLineControls(...) API to get MIXERCONTROL structure. And if the "dwControlType" member of MIXERCONTROL structure is MIXERCONTROL_CONTROLTYPE_MUX, I could select the wanted record source line (i.e., 'Wave' or 'Stereo Mix') by using ::mixerGetControlDetails(...) or ::mixerSetControlDetails(...) APIs.

    However, the above way using ::mixerXXX APIs makes empty record source line list on Vista. So, as I said, I wrote new code using "Device Topology API" and I could get IAudioInputSelector interface from Mux subunit part. However, this interface also did not give me a solution. IAudioInputSelector interface did not show 'Wave' or 'Stereo Mix' line but it shows only the endpoint devices.

    Ok, to make a long story to short, the problem is...  although DirectSoundCapture buffer can capture the audio stream through the selected record source line, there's no way to select 'Wave' or 'Stereo Mix' record source line which are not real external "endpoint devices" on Vista.

     

    [WASAPI has a special Loopback mode that allows a client to capture the post-mix audio stream, that may help as well.]

    Ok, I'll try writing new code using WASAPI as you said. However, before doing that, could you please confirm that I could capture the audio stream (PCM data) with this API, although there's no 'Wave' or 'Stereo Mix' line in the parts of Device Topologies? (When I first re-wrote the code using 'Device Topology API' for selecting 'Wave' or 'Stereo Mix' record source line on Vista for myself, I though there's no need to change DirectSoundCapture code but I need change only the record line selection code for Vista. However, I failed as I explained. So, if I should use WASAPI instead using 'DirectSoundCapture'+'Device Topologies API', I'd like to get confirmation from you that WASAPI will really sort out my problem or not.)

    Tuesday, December 12, 2006 7:48 AM
  • Hi!
    I was also searching for the stereo-mix for a VERY long time and finally found it. Right click on vistas sound-control-panel and select "show deactivated" You will see the stereo mix device appear. You can activate it, by right click-> activate.
    I use directshow for audiocapture. After activating the stero-mix device I was able to receive it from the AudioCaptureDeviceEnum (or so) Method and was able to capture data the old fashioned way.
    • Proposed as answer by Athul DS Friday, July 08, 2011 11:37 AM
    Tuesday, December 12, 2006 9:48 PM
  • Sorry, but that is useless. There is no "show deactivated" on the sound-control-panel.

     

    Can you please be more specific?

    • Proposed as answer by Athul DS Friday, July 08, 2011 11:36 AM
    Saturday, December 16, 2006 3:38 AM
  • OH! Found it.

    For everyone else...

    Right click on the speaker icon in the tray.

    Select "Recording Devices"

    In the resulting dialog, make sure you have the "Recording" tab selected and in the middle of the empty area, right click and select "Show Disabled Devices".

    oooooop dere it is!

     

     

    Saturday, December 16, 2006 3:53 AM
  • That didn't work for me either.
    Saturday, February 03, 2007 10:33 PM
  • I'm having this same issue as well..

    I want to be able to record the audio playing on the pc plus the microphone port.

    I guess the only quick idea is to buy a mixer and put both inputs into it, then that into the line in on the pc.

     

    In my case I have an asus P5n32sli se deluxe motherboard (AC97) ALC850 Realtek, with latest 6213 drivers for vista.

     

    I also noticed the disabled stereo mix device.. but there was no way to activate it.

     

    Thursday, February 15, 2007 4:56 PM
  • Right now, you have two solutions.

    First off, some audio vendors define a capture audio endpoint named something like "What You Hear".  If you record from that capture device, you'll be recording what's normally output.  This doesn't work for all vendors, however.

    You can also open the render endpoint in "loopback" mode using the AUDCLNT_STREAMFLAGS_LOOPBACK, that will give you a capture stream that taps the audio stream before it goes to the device.

     

    Thursday, February 15, 2007 5:40 PM
  • What did you mean by I could open the render endpoint? (AUDCLNT_STREAMFLAGS_LOOPBACK).. Is this a registry key...

    I'm using Audacity or Nero Trax to record.. frankly I cant get the Microphone audio to be loud enough over the stereo mix audio (when playing say a karaoke track in wincdg pro).. In fact, the karaoke track is far too loud.. lowering the volume on the stereo mix, then makes the microphone audio too low and vice versa..

    Would this be a reg. key to change to do a more direct loop/recording?

     

    Thanks

    Friday, March 02, 2007 5:12 PM
  • It's not a registry key, it's code that you'd have to write.

    Unfortunately, the ability to do what you want is not exposed through any UI in Vista.  If you want this functionality and it's not provided by your audio solution, you've got to rely on your application vendor (either Nero or Audacity) to provide this functionality.  The good news is that Vista exposes this ability, previous versions of Windows did not directly support an application to recording the output of the audio engine, the bad news is that nothing currently takes advantage of this functionality :(

     

    Friday, March 02, 2007 5:46 PM
  • Well, short of writing my own code. I guess that leaves 2 options:

     

    I could either send the audio that is coming out of my PC, back into the LineIn (possibly combined with the Microphone cable), but this would reduce the quality.

     

    Perhaps my best bet is to find a standalone PCI card that will do the job.. My old Audigy used to work fine with the what you hear option in XP.. I no longer have it though.. Anyone have any recommendations on cards that work this way under Vista (with coax/optical out, hoping for coax and optical all on the same card, no daughter board/slot fillters needed)..

     

    Thanks

    Friday, March 02, 2007 6:59 PM
  • All the Creative cards I know of support the What You Hear endpoint, I don't know about others (I know that my older Realtek AC97 adapter on my machine does, for example).

     

    Friday, March 02, 2007 7:14 PM
  •  Larry Osterman wrote:

    All the Creative cards I know of support the What You Hear endpoint, I don't know about others (I know that my older Realtek AC97 adapter on my machine does, for example).

     

     

    I'm wondering if the creative ones still do in x64 Vista.. I'm assuming they would.

    My motherboard is an Asus P5n32sli-se deluxe... it has an AC97 built in sound option, which is where I'm having the issues.. again.. it does let me record anything I play back, say mp3, wav, etc.. but mixing it with the Mic/Line In is hit or miss and sounds pretty bad in Vista.

     

    Friday, March 02, 2007 7:51 PM
  • I just thought of another option..

    I noticed that programs like CoolEdit 2 and Adobe Audition support setting each track's input source individually..

    Wouldnt this be the best option.. to use a program such as this?

     

    Saturday, March 03, 2007 5:04 PM
  • Hey all, I'm also having trouble with this... I have read through the topic, and none of it works. Im on Vista Ultimate and nothing... lol

    When I right clicked in Recording within the Sound Control Panel, anc selected "Show Disabled Devices" etc... Stereo Mix wasn't  there...

    If anyone could help it would be much appriciated, otherwise its partition time and install XP

    Tuesday, March 13, 2007 6:58 PM
  • Haha, yesssss! I won't bore you with the details of how much trouble I went through trying to find it before I stumbled here.  Just wanted to say thanks for that.
    Monday, March 19, 2007 6:36 AM
  • I am having the same problem also.  I read something on a site that involved clicking the "show disabled devices" and "show disconnected devices" of which I tried both.  Nothing was there besides the mic and cd icons.  I then read further down the page.  If you purchased a computer with Vista installed, the soundcard may or may not support wave out (stereo mix) recording.  For those that do not see those options under the "recording" tab on the sound window, this is probably the case.  I contacted my computer manufacturer to rectify this what would be "common" problem.  He took control of my computer from his workstation, and said I needed to contact Microsoft for help.  He then said Vista is designed to prevent piracy, such as recording high-quality streaming audio/video.  I explained that I used music generating software such as virtual keyboards and misc. other sound generating programs.  So it definitely is a Vista related issue.  You would think someone from Microsoft would read these posts and a: explain a fix, or b: tell us we are wasting our time, and that the only way to record by means of stereo mix is by re-installing XP.  Thanks in advance to anyone able to help us.  I paid a lot for this laptop with Vista to do exactly what I can not do.  I agree with scorpio, time for partitioning.
    Wednesday, March 21, 2007 8:03 AM
  • Ok, after extensive research and a phone conversation with a tech at EMU (a company which manufactures soundcards, PCI/bus products, I have a better idea of what microsoft did with vista.  Anti-piracy was a big goal in this software, therefore, excluding the "wave mix" and/or "wave out" recording feature.  I have the home premium software, and do not know about ultimate.  The tech at EMU said that msft changed their sound platform, and the companies which produce soundcards, audio plug-ins, pci ports/busses were not ready for this sudden change.  Beta drivers for updating soundcards will be available by summer, and full product support should be ready by the 3rd quarter.  In the meantime (I know this sucks), for those of you running vista that have the same problem I do, there is an easy fix in the meantime.  There is a cable you can get at radio shack.  It's an 1/8 in. stereo male that runs to RCA cables.  (you can get an 1/8 in. that runs to an 1/8 in. also)  This cord is different though, because it has a place for another 1/8 in. plug to plug into (female) right behind it.  You also need a regular 1/8 in. to 1/8 in. cord, (my cord is 3 in. in length)  Now, insert the 1st cord with the extra 1/8 in. female jack into your "audio out" or speaker output on your computer, and run it to either your stereo, or your computer speakers.  Take the other cord, and plug that into your "microphone out".  The other end of that cord plugs into the back of the 1/8 in. female cord coming out of your computer audio out area.  Once you set your recording preferences in "sound" you can now hear the sound generated by your computer, and also record it using any of the programs you may have used before in XP.  To those with a desktop computer, you won't notice any cosmetic difference, and to those with laptops, it looks a little bit funky, but it works.  I bought an 1/8 in. to 1/8 in. cord that was 3 in. in length, so it's not terribly bad.  Good luck, I know this fix sucks, but remember it's only temporary, unless you decide to pass on the update for your soundcard drivers when they come out. 

    For anyone thinking about partitioning their computer to install XP (I thought about it) there is a lot more involved than you think.  Vista recognizes the SATA hard drive, which is what your computer has if it came pre-installed with Vista.  XP however, does not recognize that SATA HD.  When running the XP installation disk, it will prompt you with "did not find any hard drives.  Please make sure they are properly connected" or something along those lines.  I then went to a website which provided in depth instructions on proper partitioning and steps to obtain a DUAL BOOT of Vista and XP.  Hope this link helps.  http://apcmag.com/5485/dualbooting_vista_and_xp
    Thursday, March 22, 2007 2:15 PM
  • Thank you very much for this 'PhillipBlanton'. it worked perfectly.
    Saturday, March 24, 2007 11:43 AM
  • I did what PhillipBlanton said and it worked (I had to do some more though).

    Right click the speaker icon, choose "Recording Devices", and in the resulting dialog, go to the Recording tab (if not there already), right click in an empty area, and choose Show Disabled Devices. Just like PhillipBlanton said.

    Now, right click the stereo mix and choose "Set as standard" (or whatever it is for you). You might be able to press a button when it is selected.

    After this it worked fine with the built in recording app from Vista.

    I also scrolled down, double clicked the stereo mix to change options, I changed the niveau (second tab, I have a Dutch version of Vista) to 100, and i chose the highest quality on the fourth tab.
    Saturday, March 24, 2007 3:57 PM
  • midimykeys, this change was completely unrelated to any anti piracy measures.

     

    In fact, we added support directly into the audio engine for capturing the output of the audio engine (IIRC, we tap just past the mixer APO before any global audio effects).  Unfortunately, none of the applications built into Vista take advantage of this functionality, but it's there.

     

    When the audio engine is in loopback mode AND there is protected content playing (and ONLY when there is protected content playing), then the loopbacked content is run through a constrictor APO which reduces the quality of the captured stream - that's the only "anti-piracy" part of the audio engine.

     

    Untll Windows Vista, the audio engine in Windows NEVER had directl supported recording from wave or stereo mode.  Vendors have added support to this in their audio solutions, and they can continue to add support for this - for instance, my home machine has a capture endpoint called "What U Hear" which is Creative's version of this - if you capture from that endpoint, you capture the wave or stereo mix.

     

     

    Wednesday, March 28, 2007 2:29 PM
  • If the audio driver does not expose a "What U Hear" or "Stereo Mix" capture device is there a way to capture seperate streams from the individual capture devices at the same time?

     

    -Elias

    Friday, March 30, 2007 2:56 AM
  • I have an Audigy 2 ZS Platinum Pro  and am able to see the
    "What U Hear" option for recording selection in Windows Vista.
    Though this does not help me.I need to be able to record Wave only.
    This option was available in XP but I don't see it anywhere in Vista.
    Does any one know if there is a way to record WAVE only?
    Thursday, April 12, 2007 3:20 AM
  • Great! Many thanks gourmete  for the record mixer info. I have been serching for about 3 weeks now... superb many thanks.

     

    Tuesday, April 17, 2007 4:31 PM
  • I did this thing: Select sound from the control panel. Select the recording tab. Right click on the background of the tab and choose "show disabled devices."  BUT NOTHING HAPPENED ..... WHY??? CHECK OUT THE PIC... Tongue Tied HELP PLEASE..!!!

     

    http://img144.imageshack.us/img144/9839/problem1ap8.jpg

     

     

    Sunday, April 22, 2007 10:16 PM
  • Hello,

     

    I had the same problem. "Stereo Mixer" not present in the recording options (under Windows Vista). I own a N680i mother board with a Realtek ALC885 sound chip.

    I finally found the problem :-)

     

    - I installed the 1.65 driver. No result.

    - I installed the 1.66 driver. No result.

    - Then, i got in my sound card propreties, and found that the installed driver always was the original Microsoft driver. Even after a correct installation of the both new drivers from Realtek ! (to control this: config panel -> device manager -> "your sound card" -> propreties -> driver. The pilot provider name should be "Realtek". If "Microsoft" is shown, the correct driver is not correctly installed.)

     

    Procedure i used to install the correct directory:

    (to do if your are familiar with the driver installation procedure...)

     

    - Download the newest driver from Realtek

    - Unzip it in a directory

    - Go again int the driver tab of the propreties, of your sound card.

    - Chose to update the driver.

    - Show to Windows the path to the correct Vista directory driver (in the directory you previousely unzipped).

    - The driver is then installed. Control that that is OK by controling the pilot provider name.

    - Now, the "Stereo Mixer" should be present in the record options.

     

    That was my experience. Hope it could help.

    Regards,

     

    Polux2

     

    • Proposed as answer by Ayanami9870 Thursday, March 18, 2010 8:03 AM
    Thursday, May 17, 2007 8:41 AM
  • Larry,

     

    I am using wasapi to capture the wave mix.  I am having a little difficulty - I can get the pointer to the stream, but the function GetBuffer() returns the byte array and the number of frames but not the actual size or length of the byte array.  How do I get this information?

     

    thank you in advance for your help on this.

     

    -S

    Tuesday, May 22, 2007 1:32 PM
  • Unfortunately many of the driver solutions don't support analog loopback post-driver.  It is relatively simple to write an application that adds support for this (I wrote one for the AMP Summit last week and it took about 2 hours time to write it).

     

     

    Thursday, May 24, 2007 11:47 PM
  •  

    I would like to do this, can you please provide a sample to help me get started?

     

    thank you

    Friday, May 25, 2007 2:25 AM
  • Hi everybody!
     
    Finally I found this forum. I'm desperate for this problem (I'm a musician and I absolutely need to record from mp3 and microphone).
     
    I've a Sony Vaio notebook (VGN-N11S) with Realtek ALC262 integrated soundcard and Vista Home Premium.
    I've installed the latest drivers directly from Realtek website but I cannot found any stereo-mix device (even if i'm showing all disabled and disconnected devices).
    With XP Media Center Edition everything was OK.
     
    I've contacted Realtek support that answers to me:
     
    Hi,
     
    I'm sorry . This is Sony requirement to turn off "Stereo Mix" item . Our HD Audio driver has supported "Stereo Mix" for recording ( Except ALC861 and ALC660 ) . Because Sony need to turn off it , so we do it . There are many more customization programming for many more machine . Your computer do not support it by Sony requirement . This is not our driver issue . Please try to contact Sony to confirm it .

    I've contacted Sony e-support some days ago but I'm still waiting for an answer.
     
     
    Monday, June 04, 2007 1:29 PM
  • gourmete your the Man/Woman.....At first  the fix did not work..... than i selected make it the default  restarted program and bam! it worked. I have used all kinds of recording software with no luck. Now they all work. Now to decide which one to purchase. Thanx for the super tip......Take Care, patchman10
    Tuesday, June 05, 2007 1:46 AM
  • I am also VERY frustrated with this stereo-out problem. I purchased a Sony Vaio (VGN-AR370) and the stereo-out option is not visible. I absolutely must have it, as I record live/improvised/mixing on my PC, and as of now, it looks like I am being forced to invest money on an external sound card that does something that I know very well my current card can handle. Alternatively, I could just plug a cable into my speaker jack and record what is coming from there, but I feel that is just as weak as trying to capture a video on a screen with a camcorder. It isn't what I need. This is a huge letdown. I cant believe that a $3000 machine with the capability to record stereo-out is purposely disabled, left for the user to figure it out for himself. Obviously there is a way to tweak something to get it to work, but I am not willing to take any chances just yet, as I haven't been able to find any tips for my specific brand. It seems the only threads I can find online that talk about this (and I have been looking for answers for countless hours) give solutions to Dell and Gateway specific models, but I haven't had any luck finding answers for Sony. This "stereo-out" problem on Vista yields hundreds, if not thousands of simliar users looking for solutions. I would like to know what the reason for the intentional disabling.. if it isn't for the reason of DRM.
    Monday, June 11, 2007 4:23 AM
  • Are you using the Microsoft HD Audio class driver or the Sigmatel driver?  I see that Sony has an updated driver on their website for the VGN-AR370... that might be worth a try.

    http://esupport.sony.com/US/perl/swu-download.pl?mdl=VGNAR370&upd_id=2556&os_id=29
    Monday, June 11, 2007 2:58 PM
  • I am using the Sigmatel driver.. I went to go download that updated driver from the Sony website, but still..nothing. Stereo-mix is intentionally disabled. Thank you for trying to help, though. This is just too frustrating :-/ !!
    Monday, June 11, 2007 10:14 PM
  •  
    I received right now a 27 minutes phone call on my mobile from a very kind person from Sony Belgium.
    He promised me he will try to investigate because he thinks that it not really a Sony requirement to "turn-off" the stereo mix device.
     
    In this case, with the drivers downloaded from Realtek site you have to find the device, because Sony can disable this device only via hardware (but in XP the device was present so it's not a hardware lack).
     
    He will call me back in a fwe days
     
     
     
     
     
     
     
     
    Tuesday, June 12, 2007 4:59 PM
  • excellent. looking forward to what the sony person has to say. crossing my fingers
    Tuesday, June 12, 2007 10:09 PM
  •  
    Actually I hope this man from Sony Belgium will call me back.
    A few days before I was contacted by phone from Sony Italy. They promised me to investigate but at the moment I'm still waiting for a feedback (but I know time go slowly if you're Italian :-) )
    Monday, June 18, 2007 7:39 AM
  • I've been having the same problem. I've been on with Sony for days. The keep escalation me and saying that they'll call back. The fact that they disable Stereo Mix and are the only company with which you can't re-enable it is total nonsense. It seems to me, and I'm no techno genius, that if you can disable something, then you should be able to re-enable it, they just don't want you to. UPDATE: I've just been told by Sony that only on the Z Series they can enable it, which is horseshit! I've got the FE series.... Unbelievable. I'm asking them how you re-enable it on the Z series and I'll report back.
    Wednesday, June 27, 2007 2:14 PM
  • sigh. at least its some news. hope to hear what they have to say about reenabling it for the Z.
    Wednesday, June 27, 2007 11:55 PM
  • I've had a problem saving real audio files in real time - something i do to download R4 broadcasts for listening to on my iPod (perfectly OK with the BBC as they issue as podcasts, but i'm needing to listen to a few archive programmes).
    I've searched the web and it seems that Vista disables a lot - very frustrating!
    any help/work-round will be much appreciated
    Joe
    Wednesday, July 04, 2007 5:11 AM
  • Found the solution...Worked for me - Vista Home Premium...
    http://www.downloadsquad.com/2007/01/15/how-to-enable-wave-out-recording-in-vista/

    Mine showed 'Waveout Mix' - Whatever it is, just set as default, and  there you have it - Vista's StereoMix
    Goodluck
    Wednesday, July 04, 2007 1:59 PM
  • Sadly the above solution does not, and never will work with Sony. After too many hours dealing with them and getting nowhere, it seems as though they have permanently disabled "wave" or "stereo out" on their new computers. As far as I can tell there is absolutely no way to re-enable it.  With most Vista computers you can just right click the recording box and re-enable stereo out but not Sony. It's not Vista.... it's Sony! I actually went back to Best Buy and showed them this by re-enabling the Stereo Out on all the Gateways and Compaqs... I can't believe that Sony would do this, I for one will never by another Sony product. And the problem is that Sony's complaint department is non-existent - they just don't care. I hope that once people realize that you can't record streaming audio on Sonys the internet will become inundated with people saying they'll never buy Sony again. Because "Jack" in Bangalore doesn't care.... and he's the only one you can talk to on the phone or by email.

    Thursday, July 05, 2007 11:08 PM
  • I was very sad to discover that the sound card recording was disabled in my Sony Vaio Vista machine, and that it is Sony's decision to do that. I will likely not buy another Sony again because of it. There is another solution. If you search google for "virtual audio cable" or "audio repeater" there are several inexpensive utility programs that will allow you to create recordable ports in your computer. Not ideal, but a fix for anyone else stuck with a Sony Vaio.

     

    Friday, August 24, 2007 6:16 PM
  • Oh man... that tip is awesome! I downloaded a program called "Virtual audio cable" and it works like a charm!! Thank you so much!!!!!!!!!!!!

    Monday, August 27, 2007 12:13 AM
  • Hi All,

    I am working on a project that want to record the voice from microphone and music played by media player

    at the same time (like karaoke). According to Larry's description , I try to use the sample code on http://msdn2.microsoft.com/enus/library/ms679146.aspx

    and set to loopback mode. But it doesn't work on my pc. I record the music only. Sad

    Does anyone try to use loopback mode ?

    Thanks.

    Thursday, September 06, 2007 8:12 AM
  • I've got it working here, recording the microphone and the 'music' using the 'Disabled Devices' fix.  I have a Via AC97 audio controller with the microsoft drivers and I have a "Stereo Mixer" device in the hidden options, now set as the default recording device.

     

    To get the microphone recorded as well as music you have to have the microphone un-muted in the "Playback" tab of the "Sound" options. (You should be able to hear the sound from your microphone coming out of your speakers, even without any 'recording' software running)

     

    To do this:

    Right click on the speaker icon in the tray then selact playback devices, double click on the 'active' (green tick) speakers then go to the 'levels' tab somehere in there should be a 'mic' option, un-mute it and set the level so that it is properly balanced with your 'music'.

     

    Now when you record from the "Stereo Mix" you get "music" and "mic"

     

    Friday, October 05, 2007 1:09 AM
  • Thank you very much gourmete.

     

    This feature is very important to me, as a musician hobbyist, and I thought it was unavailble in VISTA until I read your post.

     

    I posted some free music at www.myspace.com/realambientmovement

     

    goodbye!

     

     

     

    Tuesday, October 30, 2007 4:22 AM
  • If it shows it just double click it and that will take you to the device properites on the bottom select enable device

     

    Tuesday, November 27, 2007 12:08 AM
  • I made it work AHA!

    None of the suggestions worked in this thread for me, but I found out how to avoid software altogether.

    Stereo mix will not appear no matter what I do.

    The virtual audio cable was so complicated I couldn't make that work either.

    I bought 3 pieces at Radio Shack and without any software manipulation it works. Instead of recording over Stereo mix record through the Mic. or Input 1.

    Essentially you'll be looping back your line that goes to your speakers.

    Plug an audio splitter into your sound card, 1 male to 2 female

    plug a 1 foot male to male connector from an open end of the splitter back into the mic, (looping it back)

    Plug the other open end of the splitter into your speakers, its that simple.

     

    If you dont use speakers uh... plug from line out right back into line-in or mic, then set mic as the default recording device.

     

    One caveat, if your volume is too high on the recording software you use you'll get so much distortion you wont be able to listen to it. Just lower the volume and it will record at the correct level.

    Friday, November 30, 2007 6:57 PM
  •  

    Oh I forgot, you only need to buy 2 pieces from Radio shack if you already have a cable between your sound card and speakers.
    Friday, November 30, 2007 7:09 PM
  • Aaaargh... exactly the same poblem as others and a similar response. Having spent an eternity searching the Internet, testing various competitor models, and consulting with various people, the official response from Sony is as follows:

     

    %%%%%%%%%%%%%%%%%%%%%%%%%

     

    We just got a response from our head engineers.

    The Stereo Mix is not available as a recording source on VAIO computers pre-installed with Windows Vista. This is by design as part of an intentional design by Windows Vista.

    I am very sorry that we cannot help you any further with this request.

     

    %%%%%%%%%%%%%%%%%%%%%%%%%%

     

    now... as we all know that is not strictly true. My previous Vista pre-installed laptop (an Acer) worked absolutely fine, and every other make of Vista pre-installed latop I have now tested also has this functionality. It does appear to be an intentional design in Vista to mask the sound card by creating it as a 'hidden' audio device but it is wrong for Sony to blame Vista for disabling it completely, rendering most professional and hobby music production software unusable. It would be worth publicising the fatal limitations of the Sonly machines as widely as possible to avoid other people making the same expensive mistake that I and hundreds of other people appear to have made.

     

    PS. Someone mentioned the possibility of reactivating the device on a 'Z series' machine - what exactly does this refer to? Mine is a Vaio VGN-N31Z - does that make it a Z series or is that a coincidence?

     

    Sony Vaio VGN-N31Z_W
    CPU Intel Core2 T5500 @ 1.66GHz
    BIOS version R0100J4

    windows Vista Home Premium

    Realtek ALC262 High Definition Audio Codec

     

    For anyone who owns a Sony Vaio and has this problem, you might like to add your comments on this forum thread:
    http://club.vaio.sony.co.uk/clubvaio/GB/en/forum/viewthread?thread=42625

     

     

    Friday, January 04, 2008 6:11 PM
  • i read this some place if it can help spme one i'll be happy thats the site i read this in there is more over there ,thats the link so plz let me know if it helped you ,,, http://www.timetiger.com/gene/blog/blog.html#fixdigout i did dowloded this fix but it did not helped me on my vista ultimate its a smal fix like about 4 kb good luck to all

    Creative X-Fi forgets Digital Out setting on reboot

    Thu, 1 Feb 2007 00:16:00 -0400

    Well this post in no way has anything to do with my BlueVoice project (my Creative X-Fi isn't even in the same machine) but I really have nowhere else to put this right now so here it goes...

    My brand new Creative X-Fi, with its brand new drivers, which I bought because my last sound card was so brutally unstable and had such crappy drivers, doesn't remember its Digital Out checkbox setting when the machine is rebooted. This is definitely a driver issue because the old drivers apparently don't have this problem, and Creative definitely knows about this problem because there are dozens of posts about this in their support forums, but to date there hasn't been a resolution available.

    This problem will probably go away when Creative gets around to fixing it in the next driver release, but in the meantime, if this bugs you (because it bugs the hell out of me), put my nifty little 3 KB solution in your Startup folder and watch your problems disappear. I've even posted the source code so that you can satisfy yourself that this isn't going to reformat your hard drive or anything. Having said that, no promises that this fix is going to work for you as I've hardcoded the control ID of the little Digital Out checkbox and I have no idea whether the ID varies between driver versions, card revisions, etc. For what it's worth, I've got the X-Fi ExtremeMusic.

    If you use Microsoft Visual Studio you can build the executable yourself using this command:

    cl /MD fixdigout.cpp /link wimm.lib

    Another thing to remember: since this is going into your Startup folder this won't actually do anything until you log in (and the stuff in Startup actually gets executed). If you absolutely must have this fix in place PRIOR to logging in (like when the machine starts up and waits for you to hit Ctrl-Alt-Del) you need to look into running this as a service or scheduling it or something. I'll leave that to your imagination.

    All this program does is use the Windows Mixer API to (effectively) uncheck and then re-check the Digital Output setting for the X-Fi. This nudges whatever needs to be nudged to turn Digital Output back on after a system reboot.

    Please enjoy and good luck. As always, no promises or guarantees but it works great for me!

    Wednesday, January 09, 2008 1:28 PM
  • It isn't just Sony!!  I have a Gateway desktop, recent model, and there is no stereo mix record option on it, either, when running Vista.  The same computer has the option in WinXP with the same sound card, so it is a Vista issue...or a Vista driver issue.  I, too, think that it is deplorable that the option to record from stereo mix has been disabled.  Intel is writing the drivers for the Sigmatel sound on the computer but they may be taking orders from Microsoft on what to include.

     

    Wednesday, January 16, 2008 10:42 PM
  •  

    Intel is writing the drivers for the Sigmatel sound on the computer but they may be taking orders from Microsoft on what to include.  hiiiiiiiiiiiiiiiiiiiiiiii rene... and thanks in advance for that report on intel just how do i go about getting this drivers your talking about i have one of the latests desktops in the world from gateway with windows ultimate and i cannot play music in paltalk witout this stereo mix i have creativ sound card its an xfi sound blaster and i did many things like to stop the on board card from vista and installed the fix i was talking about and still nothing i will and do appriciate this new drivers as soon as they ready or u have info about where i can get them thnks again uzistar...
    Monday, January 28, 2008 11:12 PM
  • latest reply from Sony is as follows...

     

    %%%%%%%%%%%%%%%%%%%%%%%%%%

     

    We are still reviewing this issue with Sony Europe and Sony Japan who would ultimately make the decision regarding this. Microsoft have defined that OEMs must disable this capability, the method used depends on the OEM some do set this as a disabled device and a workaround is to show disabled devices and enable this manually. This method can be used on some manufacturers computers but it is not possible with the Vaio. 

     

    %%%%%%%%%%%%%%%%%%%%%%%%%%

     

    Tuesday, January 29, 2008 8:43 AM
  • Hey, I clicked show disabled devices but I,m not seeing any new devices

     

    Friday, February 01, 2008 2:37 AM
  • After choosing "Show disabled devices" nowhere can I find "Stereo Mix". Please specify.
    Wednesday, February 13, 2008 12:46 AM
  • I had the same problem when I installed a new Motherboard and Vista (old motherboard was running XP).

    After 3 hours yesterday of trying to find and enable Stereo Mixer and CD-ROM Audio devices I visited the Motherboard Manufacturers Website and downloaded an Update for the Realtek HD Audio Drivers.

    Problem solved.

     

    Rang my Computer Tech and it ws mentioned that some hardware manufactures were not very quick at updating their hardware & resources drivers when Vista was released and are only just catching up.

     

    It may pay to check your system Manufacturer or Motherboard Manufacturer Website for HD Audio updates.

     

    Cheers

     

    Johnny_au

    Saturday, March 08, 2008 4:16 AM
  • ATTENTION - for those Dell users with Sigmatel audio who cannot get stereo mix to appear when you select 'show disabled devices', some genus has found a solution!!!!

    Basically just go to the dell driver download site, and instead of getting the vista driver, get the windows xp driver. Right click on the install file and go to properties. Under compatibility, tell it to run it in xp service pack 2 compatibility mode. Install it, fiddle a bit and you will have stereo mix!!!!

    I highly recommend this tip.

    original thread was at http://www.techimo.com/forum/showthread.php?t=160431&page=2
    Monday, March 10, 2008 2:01 AM
  • ATTENTION - for those Dell users with Sigmatel audio who cannot get stereo mix to appear when you select 'show disabled devices', some genus has found a solution!!!!

    Basically just go to the dell driver download site, and instead of getting the vista driver, get the windows xp driver. Right click on the install file and go to properties. Under compatibility, tell it to run it in xp service pack 2 compatibility mode. Install it, fiddle a bit and you will have stereo mix!!!!

    I highly recommend this tip.

    original thread was at http://www.techimo.com/forum/showthread.php?t=160431&page=2
    Monday, March 10, 2008 2:03 AM
  • Thank you very much ^_^
    Monday, March 10, 2008 4:35 PM
  •  Larry Osterman wrote:

    You can also open the render endpoint in "loopback" mode using the AUDCLNT_STREAMFLAGS_LOOPBACK, that will give you a capture stream that taps the audio stream before it goes to the device.

     

    Dear Larry,

    By "render endpoint" you mean "streaming audio renderer", e.g. completely before user mode service layer (all APOs), or something different?

    Regards

    Monday, March 24, 2008 1:01 AM
  • A "streaming audio renderer" is a MediaFoundation component - it takes the output of MediaFoundation and renders it to the selected audio device.

     

    An "audio endpoint" is what we call the thing to which you render or capture audio - it roughly corresponds to a piece of plastic (speakers, microphone, line in, etc) connected to your audio device.  A "render endpoint" is the device to which you render audio, a "capture endpoint" is the device you capture from.

     

     

    Monday, March 24, 2008 12:30 PM
  • Phillip,

     

    Excellent Discorvery!  Geez, I was complaining to HP (because of using Conexent "MODEM" chips instead of actual Sound Chips for this!  (Since Conexant Claims to ONLY make MODEM Hardware Devices and NOT Actual Full Audio Chips).  I also complained to Pinnacle (a Video Capture/Editing Software Manufacture).

     

    Your, Exact Descriptive Answer, Solved my Problem!  Thanks Buddy!

     

    Wednesday, April 09, 2008 5:38 PM
  • I finally found an answer that will work if you cannot find the Stereo Mix in Vista.  Just look at this site:

     

    http://lifehacker.com/software/dual-boot/dual-boot-windows-xp-on-a-pre+installed-vista-pc-248936.php

    Monday, April 21, 2008 6:47 PM
  •  

    I'm still having trouble with my setup (under sp1):

     

    In my case I have an asus P5n32sli se deluxe motherboard (AC97) ALC850 Realtek...

     

    I can see the stereo mix.. howeever.. if i'm using a microphone (analog, plugged into the microphone jack), if i have microphone enabled, the stereo mix becomes "currently unavailable"..

     

    If i disable the microphone then its back.. so in cooledit if i choose the stereo mix or wave mapper as the recording device.. i can get the audio from say an mp3 to record, but the volume on the microphone is about 40% of what it should be.  I've tried playing with sliders and all.. but i can get it any louder...

     

    Am i just out of luck if using an analog microphone.. IE:  i'd need to get say a plantronics microphone, usb style, (as i can see my other usb microphones that are part of web cams work at the same time)?

     

    Or i guess i'd have to just chuck it and go with a creative card that actually fully worked with analog microphones..

     

    Anyone else ran into this?

    Wednesday, April 30, 2008 6:52 PM
  • Brilliant!  This solved the problem I was having.  Well Done and thank you.

     

    Tuesday, May 27, 2008 3:50 PM
  •  markm75c wrote:
    I can see the stereo mix.. howeever.. if i'm using a microphone (analog, plugged into the microphone jack), if i have microphone enabled, the stereo mix becomes "currently unavailable"..


    This could happen if the card only has a single ADC and the two inputs are MUXed... which is not uncommon.
    Wednesday, May 28, 2008 4:43 PM

  • >I am also VERY frustrated with this stereo-out problem. I purchased a Sony Vaio (VGN-AR370) and the stereo-out option is not visible....
    >I would like to know what the reason for the intentional disabling.. if it isn't for the reason of DRM.

    Yes! After having myself spent hours of reading on forums, I can conclude that the only reason that major computer builders suppressed "Wave-Out" or "Stereo Mix" is to please her majesty the RIAA. And, it is possible that the RIAA has been convincing $$$.

    All this stinks and sucks!!!!

    Maybe it is the time that the people stand up? Maybe it's the time for a class action? Being a Canadian, I won't start it but I surely would follow it.
    <!--[if !supportLineBreakNewLine]--><!--[endif]-->

    Pierre


    Thursday, June 12, 2008 11:59 PM
  •  

    I am suffering with this problem also(no ability to record what you hear/stereo mix etc), I'm sorry to see many others having this anoying problem.

    I have a HPdv6000, vista home premium, the sound card seems to be a Conexant High Definition Smart Audio 221.

    I have done the 'show diabled devices', no luck. It seems the only recordable option is from the mic'. I have tryed updating the drivers. I reckon i could do the hard wire option, but this seems silly as im sure i must be able to do it on board.

    Do any of you kind Tech' type people have any advice?

     

    Thanks

    Sunday, June 22, 2008 9:42 PM
  • it dosen't work with me too and nothing appear

    Monday, June 30, 2008 3:19 AM
  • For those of you with sigmatel audio and an intel based motherboard, the latest driver update for the sigmatel on the intel site has enabled the stereo mix on the sound card.  This is a new development, so if you haven't updated your drivers in a while, go to the intel site, find your motherboard and the sigmatel driver that applies to your sound chip.  After updating, you should be able to see and choose stereo mix for your input for recording.  It took way too long, but it is finally working.  (I have a Gateway computer and had to find the comparable motherboard that was made for Gateway by Intel.)
    Friday, July 04, 2008 8:15 PM
  • Hey JoRene! I having trouble finding the sound chip downloads through the intel site. can you point me in the right direction??
    I have an intel core 2 duo T7250 CPU on my Sony vaio VGN-FZ240.
    Monday, July 07, 2008 5:26 PM
  • Frustrating isn't it...? I've been back and forth with Sony over it and they've been incredibly unhelpful - suffice to say it isn't possible and there's nothing they want to do about it.

     

    I have a Vaio VGN-N31Z laptop running Vista Home Premium

    Intel Core Duo T5500

    Intel Mobile 945GM Express Chipset

    Realtek High Definition Audio

     

    Does anyone know if there's a driver update or fix that might enable the stereo mix as an audio device?

     

    Guess I've given up hope of a solution... but if you know otherwise, make my day

     

    Monday, July 07, 2008 7:42 PM
  • I bought an HP laptop April, 2008 preloaded with Windows Vista.  It has the exact same problem.  It will only record through the microphone.  I have worked with a HP case manager and several HP support people.  Nobody has been able to resolve my problem.  I then contacted MicroSoft.  The support sperson at MS has not been able to resolve my problem but she did direct me to this forum.  So its not a just a Sony problem or an HP problem.  It is a MS Windows Vista problem.  In typical MS fashion they rushed this operating system out into the marketplace without throughly testing it and maybe figured they would work out the bugs in the future.  I believe the Virtual Audio Cable solution mentioned in the first few posts in this  thread will work, but it costs $30 for that program and it really gets my goat because I used my economic stimulation check to by a laptop to use primarily for recording music, and it doesn't (and my computer is even called the HP Pavillion Entermainment PC.)  Even worse, my version of Vista came preloaed with Windows Sound Recorder, which doesn't work at all.  I don't think it was by design that the stereo mix doesn't work with Vista.  I think there is a compatibilty issue with Vista and certain popular sound cards. My sound card is the Conexant High Definition SmartAudio 221.  I have read that there a large number of other devices that do work properly with Vista also.
    Monday, July 21, 2008 3:56 AM
  • unfortunately, I don't think that's going to work. You can download the virtual cable type programmes in free trial mode, but when you install them you will probably find that you get the error message 'no sound card installed' or similar. In effect, your laptop with Vista has no way of knowing that it has a sound card (i.e. it is not a 'disabled' device, it simply isn't visible). The sound is presumably integral to the motherboard (custom made by Intel for your laptop manufacturer) and what you probably need is a new driver for the motherboard that will make the sound output visible in Vista. I believe Intel have been working on some, although sadly not mine.

     

    Of course if you only want to do the 'illegal' stuff that the manufacturers presumably don't want you to do, like record internet streaming, then that's easy - just use the latest version of Real Player, which works. However, if like me you want to do completely legal things like record Skype telephone interviews (part of my job) or bounce audio and MIDI tracks around (another part) then you're f****d. Hopefully that irony isn't lost on the manufacturers!

     

     

    Monday, July 21, 2008 7:54 AM
  • Latest response from Sony... no possible solution... Does anyone know what is the 'method of getting around this issue' whch they cannot tell me???

     

    *** NOTES 21-Jul-2008   Action Type: Info 
     
    Thank you for your reply. 
      
    You are correct to assume that it has been disabled in Vista to prevent the possibility that people may use it to illegally record sound. It is not just Sony that have had to do it, but all manufacturers. 
      
    We are sorry that it affects users who are trying to use it for honest purposes like yourself, but we are bounded by law the same as other makes. 
      
    I can not predict that there will ever be a change in the policy. We are aware tough that there are 3rd party software/methods of getting around this issue, however we cannot advise or recommending using them.  
      
    Should you have any further queries, please do not hesitate to update your case. If you would prefer an e-Support agent to contact you by telephone, please update your case with your preferred contact number & a suitable time frame between the hours of 8:00 to 18:00 Monday to Friday. 
     
    Regards, 
     
    Harry 
    Sony Vaio-Link Team

    Monday, July 21, 2008 6:54 PM
  • Pier 3d-
    The RIAA maintains the position that any recording of any copyrighted works is a violation of copywrite law and therefore illegal.  However, the United States Supreme Court begged to differ with that viewpoint in Sony Corp. of America v. Universal City Studios, Inc., 464 U.S. 417 (1984), also known as the Betamax case, when it ruled that the making of individual copies of complete television shows for purposes of timeshifting does not constitute copyright infringement, but is fair use.  The same principal would also protect the recording of internet radio and other media, although the Supreme Court has not ruled specifically on this issue, but the Court does follow stare decisis, the principle that former court decisions must be followed.  The ruling contemplated that the person taping was receiving the television show from a legitimate source, so such a ruling would not and does not give legal support or justification for downloading music or movies from a source who is not entitled to disseminate such media.
    So when you watch a magor league baseball game on TV and late in the game it is announced that “This copyrighted telecast is presented by authority of the Office of the Commissioner of Baseball. It may not be reproduced or retransmitted in any form, and the accounts and descriptions of this game may not be disseminated without express written consent.”  Whoa!  You can legally tape this game and watch it later at your convenience, so rules the U.S. Supreme Court.  And that part that "the accounts and descriptions of this game may not be disseminated without express written consent" I guess this means that if I try to tell you what I saw on the televised game last night I am violating their copyright, so Magor League Baseball maintains.  So much for a little thing called the First Ammendment.  I do not think that in spite of digital rights management (DRM), that the reason that certain sound cards are not supporting the stereo mix option (I have a new HP dv6810us notebook with a Conexant High Definition SmartAudio 221 sound card) is the RIAA (although they probably would very much like to limit our ability to record with our computers in any manner).  I believe it is a MicroSoft problem and that MS rushed out Vista, a flawed operating system that conflicts and is incompatible with a lot of different hardware peripherals.  And just last week I got a Windows Vista update concerning my sound card, the Conexant High Definition SmartAudio 221.  Of all the sound cards in the world, MicroSoft was updating mine!  I was so excited that they were finally fixing the no stereo mix problem.  So I downloading the update, rebooted the machine, and of course the update did not fix the problem.  I don't know what it fixed, but it didn't  fix my problem.  I can't record with my computer (except with the microphone) and yes, i have gone to the volume icon in the system tray, right clicked, then clicked on recording devices, then right clicked in the white space, and both the "show disabled devices" and "show disconnected devices" are checked, and no, I still have no stereo mix or wave.  And I have spent numerous hours with HP support and MicroSoft support, and no, they have not offered any solutions.  Let me restate that.  They have offered numerous suggestions, and none of them have worked. I am frustrated and pissed off.
     
    Monday, July 21, 2008 8:11 PM
  • For some reason this forum would not allow me to login again under my first name, but yes, I am the poster From the Edge of America (1 and 2).  I just thought i would post the (not) helpfull message I received back from MicroSoft Support.
     

    Dear Sam,

     

    Thank you for contacting Microsoft Online Support. My name is Kane and I am an Escalation Engineer for the Windows Vista Support Team. In order to better serve you and resolve this issue more efficiently, I have taken ownership of your Service Request. To contact me, please send emails to v-30kayu@mssupport.microsoft.com or srxmail@css.one.microsoft.com and make sure the title includes SRX1073084054 in the subject line.

     

    I appreciate that this matter has been ongoing for some time, and understand the frustration this would cause. I greatly appreciate your cooperation and apologize for any inconvenience. Please be assured that I will work closely with you to resolve this matter as soon as possible.

     

    From the case log, I understand that we have very limited sound recording capability with the Conexant High Definition Smart Audio in Windows Vista. You have installed several driver updates but the issue persists.

     

    If I am not accurate in my understanding of this case, please feel free to let me know. 

     

    Please be assured that I fully understand any inconvenience the issue may have caused and I will try my best to help you.

     

    The issue we have is obviously a driver quality and hardware limitation problem.

     

    As we know the Conexant High Definition Smart Audio is built in sound chipset so that it’s hardware capability is very limited. On the other hand, its manufacturer, Conexant, also does not plan to built powerful driver support for it. Therefore, its recording feature is very limited. (Please understand that the recording feature Must be developed in the sound device driver. The Operating System only provide the platform to link it with other programs.)

     

    Based on the current situation, I am sorry to say that Microsoft will not be able to help you on this issue as it is a hardware problem. Please be assured that our Product Team will forward the customer feedbacks to Conexant in the conference call. However, it will be Conexant to decide whether or not to add the features in the sound card driver.

     

    Of course, there are some 3rd party programs that can make up the lack of sound card driver’s features. You can use them as we were unable to add a PCI sound card to a Laptop.

     

    As far as I know, manufacturers like Creative have some USB external sound devices powerful enough to work independently from the built-in Conexant sound chipset. If you are interested in them, you can call the pre-sails of Creative for more information.

     

    If you have any further questions, please don't hesitate to let me know.

     

    If there is no further issues, I would like to ask for your permission to close this case. Again, I am sorry that we cannot resolve the hardware issue for you. But I still hope that my explain and information are helpful.

     

    I look forward to your reply.

     

    Sincerely,

     

    Kane
    v-30kayu@mssupport.microsoft.com
    Microsoft Windows Vista Escalation Support Professional

     

    Satisfied customers are my top priority. Please let either myself or my manager know what you think of the level of service provided. You can send feedback to my manager, Sophie Wang at v-30swan@mssupport.microsoft.com.


    Let's see, there is no hardware problem when this Conexant High Definition SmartAudio 221 sound card works properly with Windows XP, but which doesn't work with Windows Vista and therefore it is a hardware problem for which MicroSoft is entirely not responsible. Apparently it is MicroSoft's position that although this sound card worked perfectly well with Windows XP and supported recording with Stereo Mix and Wave with XP, it is the sound cards manufacturer's problem that it is not compatible with Windows Vista.  I agree it is a driver problem but Conexant does not deal with and has no means for contact with consumers and users, only with OEM's (original equipment manufacturers). So HP claims it is a MS problem, and MS  claims it is the sound card manufacturer's problem.  Meanwhile I have a computer I bought mainly for recording that does not record.  It is a $600.00 doorstop.


     

    Wednesday, July 23, 2008 4:02 PM
  • I'm not sure that just having an intel processor will allow the driver to work.  You would need to have the intel sound chip on your motherboard.  I have a Gateway desktop with an Intel motherboard (though it is an OEM board made for Gateway.)  It uses the regular intel drivers and the newest sound driver for my motherboard was what enabled the inline sound option.  I don't know who makes the Sony motherboard or whether it uses the sigmatel sound chip that intel has on its motherboards.  If it is a sigmatel chip, you might be able to use their driver.  You need to first look at the motherboard section on intel and find the closest to yours.  Under the motherboard you can select driver downloads.  Some of the motherboards MIGHT also use Realtek sound chips.

     

    Monday, July 28, 2008 1:37 AM
  • HEY GUYS!  I need help.  I have been searching and searching for a solution to my problem, but everywhere I turn the below mentioned FIX - SHOULD FIX THE PROBLEM!  However, in terms of my VISTA PC, the below mentioned fix does NOT help.  When I click "show disabled devices" there is NO waveout mix or any variation thereof. 

     

    I actually have MICROPHONE / LINE IN / MICROPHONE.

     

    That's it - nothing else.

     

    PLEASE PLEASE PLEASE HELP!

     

     

     PhillipBlanton wrote:

    OH! Found it.

    For everyone else...

    Right click on the speaker icon in the tray.

    Select "Recording Devices"

    In the resulting dialog, make sure you have the "Recording" tab selected and in the middle of the empty area, right click and select "Show Disabled Devices".

    oooooop dere it is!

     

     

    Thursday, July 31, 2008 9:34 AM
  • What is the brand of your computer and the soundchip that is on the motherboard...or the sound card?  I mentioned in an earlier post that the latest sound drivers, IF AVAILABLE for your sound chip, might solve the problem.  I have an intel soundchip and am using the IDT sound drivers that are available on the intel site. They have finally enabled the "stereomix" as an option for recording.  However, if you have some other sound chip and no updated drivers, you may be out of luck. 

     

    Tuesday, August 05, 2008 11:15 PM
  • I did follow many treads on all kind of forums concerning that issue. Here what I think is the fact.

     

    As with others wich had contact Dell about this issue, they say they cant fix it, its a vista support issue. Several insider say stereo mix was intentionaly been removed.

     

    In some case installing a XP driver for the right sound card may show the stereo mixer (need to be in xp compatibility mode while installing). This fix do not work for any sigmatel audio as far as I know. If ever the mixer show with one driver its not functioning. The Vista code had change so its always disable. I did check with reg edit and it is block in a different way then in xp. It can only be enable by a driver.

     

    Most sound card company are aware of this and they all have a loopback possibility. Some, if not all, also implement some copy protection. In my sound card witch is the same as the one I had in xp, there a pop noise that come every sec or so. I suspect this noise is a number encription to retreive the user. This probably put your unique processor number and add it to the recording. It might look paranoid but it would not be the first time industy try to introduce hidden record protection. It was done a few year ago on cd but was cancell by court on a lawsuit.

     

    One can say its might be a cheap sound card that produce this noise but I have at least one open souce program that give me a wave out without noise??? This program it tapping the sound card before vista do it.

     

    To all that looking for audio mix good luck. Unless there a case fill about it, no one will move on it. If its an industrial decision and we are not in par with them since its very subtile way to discourage recording. Excuse can run forever. That all I had so far.

     

    When I try to have answer on this issue, Dell send me to microsoft and vice-versa. They are all aware but play it dumb. They understand but passing the bucket.

     

    By the way, loop back is a solution (having a y adapter in the input) but this require you to choose mic intead of line since loop back add a resistance to the circuit (8,16,32, ohms). This is call impedance. Less there is, less amplification you need. You will then have to put amplification to the input.

     

    Other solution is to find some program that have wave out or similar function.

    It is strange most did not add it yet, since Now it would be a ¨Feature¨

    Audacity per example do have a wave out but only when recording.(open source) This problem also affect usb tv tuner (maybe all type ). I had search and try many program and drivers and only one program have wave out up to now, is call Castor tv(open source). Please note that if I record the with supply tv program,  sound is record but not play in same time as with audacity. Recording required that your mic or line in is set as DEFAULT recording device in same tab name.

     

    Its also interesting to note there no Hack for the missing wave out or stereo mix. I have one program that do have a wave out, so its possible under vista. (castor tv)

     

    For musician and power user, Vista made it imposible what was a standard feature since 30 year, My old Amiga had it! All previous window also.

     

    An answer from Microsoft, like that it was disable to help less tech user, is inapropriate since this feature had to be enable in xp. It was already hard to find. So it was not bothering low tech user.

     

    I think our only option is ubutu or other op sytem.  Does Mac still support it?

     

    By the way its not possible to go back on xp on laptop. Xp do not support serial ata hd drive wich is now what is in Vista notebook. If you have a new Vista ready computer your in that case.

     

    Sorry for the lenght but I did try to put all my finding on this subject, for all to read.

     

    Policy dont let me say out loud what I think of Vista and Dell but you should figure it out.

    We are well protect by big bros company.

     

    There some lawsuit fill and report by some user in other non microsoft discussion group.

    That the only pressure MS have but none is public yet and more maybe need. Hope some media will catch up on that. Its a good new for all, we cant record no more and listen while doing so. There no place where ms say some standard feature was removed. I have now a more powerfull but less usefull pc. I use my old one its better.

    Thank you Microsoft for protecting me!

    Monday, August 11, 2008 10:25 PM
  • Thanks, 

    It worked for me. 

    Had to set  "Stereo Mix" as the default device before it it would record from the line-in.
    Tuesday, August 12, 2008 3:02 AM
  • Hi

     

    I'm an Korean, so I can't speak English VERY fluently - but I can read all of the posts and I am understanding the problem. (If I have few spelling mistakes, if so, please just pass it on.)

     

    From google search, I found that Computer makers (ex: sony) are shutting down 'stereo mix'

    to prevent illegal recording - (maybe like songs from iTunes or something : songs that have DRM(non copyable music files). (so, people are just turning on the song, and record it, and make it to a free-DRM file.))

     

    So, some notebook makers disabled recording from computer's direct streaming audio.

    -> Like you said, It is not a hardware problem, because it works fine on XP - it means that exTongue TiedONY has blocked 'stereo mix' somehow on their pre-installed Vista.

     

    Here is my help.

     

    Before you start anything, turn on a music file - raise your volumes up and up!!!!

    Test if sound is coming out of your speakers!! (If not, your speaker is a problem)

     

     

    Download Virtual Audio Cable (search google or something - it is not a freeware - but try it first, then find a crack)

     

    Install Virtual Audio Cable (VAC) on your computer.

    (When installing ---- Vista -> Popup named like "do you want to install this driver?" (red letters) pops out -> click ok or something, you NEED to install the driver)

     

    Taskbar -> Go to the playback devices (right-click the speaker icon) - Select the 'Playback' tab.

    There will be a new option named 'Line 1' or 'VAC 1' or SOMETHING that is similar like this.

    Make that 'Line 1'  Default. (There is a button named 'Set Default' below the window.)

     

    Close all programs (specially programs that have sound - itunes, realplayer, windows media player)

     

    Then, run the program Audio Repeater (Included in the VAC that you installed-  search the start->all programs or the search program files in CSmile

     

    Set 'Wave in' to 'Line 1'

    Set 'Wave out' to "SPEAKER" (or your computer's original default selection - mine is Vaio VGN-CR220E and it is named 'Speaker/HP', so select this)

    After this, click 'Start' tab below.

     

    Then, turn on any music(ex: an mp3 file- a long one should be good so you can test on it) on your computer.

    You should hear the sound from your speaker.

     

    NOW, If you want to record this mp3 stream, just follow the bottom part.

     

    You will see 'Line 1' on the recording tab. (Go to sound manager (right-click the speaker icon on your taskbar-> recording devices) -> 'Recording' tab -> make 'Line 1' Default)

     

    Run Audacity (or any recording programs)

    Run Audacity -> Edit -> Preferences -> Audio I/O tab -> See 'Recording'  and make 'device' into 'Line 1'

     

    Enjoy Recording computer's stereo!

     

    p.s

    Here is the problem -> you have to make Audio Repeater to the above settings every time you reboot, so

    use it only when you need it! (So, : After Recording stereo from computer, change back to the normal notebook's settings)

     
    Thanks for reading - hope it will work,

    (Mine Vaio Notebook Labtop works this way)

    • Edited by BCDE123 Monday, March 23, 2009 10:17 AM
    Wednesday, August 13, 2008 2:13 PM
  •  

    THANK YOU! Kam sa ni da!

     

    This has been plaguing me for ages.  I never thought a "virtual audio cable" existed.  This has saved me endless hours of frustration. 

    Saturday, August 23, 2008 3:42 PM
  • Hi "From the edge of America" aka sam houston,

    I, too, have the Conexant high definition smartaudio 221 (on a Compaq C751NR laptop). Best solution I've found so far is Total Recorder from Highcriteria. Free trial, $18 to buy.

    Unfortunately you can't record directly into Audacity, etc. with it (at least I haven't been able to), but it allows you to save to PCM/WAV, FLAC, mp3, wma or ogg, so you can save losslessly or to a high-bitrate compressed format and then open with your editing program.

    I'm sure Virtual Audio Cable works, too, but TR is a little cheaper, so thought I'd mention this as an option.

    If HP/Compaq had any sense, they'd give people who requested it a coupon for one of those programs. Might be less expensive for them in the long run than loss of sales/goodwill or a possible class-action suit.

    Saw your post over at the HP forum when I was researching this. Not much help there, huh?

    Best of luck with it.
    Sunday, August 24, 2008 9:21 AM
  • This really sucks big time!

    And they shoot themselves in the foot again: How can you ever expect that serious audio users won't buy a Mac in the end?

     

    Hopefully soon someone enables this again, till then I'll see what virtual audio cable can do for me.

     

    Thanks for all the posts, good to know I'm not alone with this problem!

    Monday, August 25, 2008 11:55 PM
  • If you don't have an intel board or one made by intel, this might not work for you.  Do you have a Sigmatel or ITD audio chip?  I have a desktop, not a laptop, which I think you might have.  Search on the intel site for "audio drivers" or "sigmatel".  The driver seems to be good for quite a few different boards, so you might just try installing one that seems to match your audio chip (Check in device manager to see what you have.)  Good luck. 

     

    Tuesday, August 26, 2008 2:10 AM
  • Thanks mssquash for the info about Total Recorder but....see the following exchange with the High Criteria team (creators of Total Recorder)

    To:  Support@highcriteria.com

    I am considering buying Total Recorder Standard Edition and if I like it I may even upgrade to the Professional Edition.  I have a HP Pavilion notebook running Microsoft Windows Vista with a AMD Turion 64 bit processor.  Can I run your programs with a 64 bit processor?
    Respectfully,
    Sam Houston

    From:  High Criteria Support Team.

    Dear Sam Houston,
    Regretfully, Total Recorder has not been tested with Windows 64-bit, so we cannot guarantee it will work properly.

    If Win64 provides compatibility with 32-bit applications, then Total Recorder will work if installed without its driver. However, the driver was designed specifically for each version of Windows OS and the current version of the driver could be incompatible with Win64.

    But we are working on developing of a driver specifically for Windows Vista 64-bit. Perhaps, Total Recorder will provide such functionality in the nearest future.

    Kind regards,

    High Criteria Support Team.

    Friday, August 29, 2008 9:36 PM
  • Why is it that my laptop that has Vista has the Stereo Mix and my desktop with Vista does not?  Man, this is some weird *** and highly unlikeable.  Is there something I can copy from my laptop to my desktop to get the stereo mix in there?
    Tuesday, September 02, 2008 10:26 AM
  • It probably depends on what sound chip is on your laptop as compared with your desktop and also what drivers are installed on each.  Some drivers may have the stereo mix enabled and others may not make them available.  It could also be a function of the maker of the computer and whether they have agreed to go along with all the requirements to lessen the chance of piracy.  I doubt you can copy anything from the laptop to the desktop to enable the stereo mix on the desktop but you may be able to find newer drivers for the soundchip/card on the desktop that might enable it.  Good luck!

     

    Tuesday, September 02, 2008 6:16 PM
  • I have an Acer Aspire 6920 with Realtek HD Audio, and the simple solution for recording audio from all internal sources is to just disable the mic. Whne you do this you can record and mange any audio content you can play. problem solved.
    Monday, September 08, 2008 6:58 PM
  • No that doesn't work either.  It worked in my Acer laptop with Vista but it doesn't work in my Sony VGC-LT35E.  I tried looking at the "disabled" items ... nothing there.  Tried disabling my mic...that didn't work either.
    Monday, September 08, 2008 7:46 PM
  • I tried the Virtual Audio Cable option and unfortunately didn't work, I could hear everything fine but it simply didn't record.
    Disabling the microphone had no changes either.
    I also tried installing the XP controller but again, it didn't work.
    I'm now considering a downgrade because so far the only method that has worked is using REPLAY AV which takes ages to load and doesn't record more than 5 minutes (the trial).

    This is what I'm using: Compaq Presario F70000 with a Conexant High Definition SmartAudio 221 that also says DEV_5051.

    Tuesday, September 09, 2008 3:37 PM
  • Atta boy, Dave!

     

    "inside joke" just 'cos ur name reminded me of sum-1, but ur prolly not him, so prolly don't get it.

     

    Just checkin'  Big Smile

     

    Formerly Joy G. now Joy D. in TX

    Friday, September 12, 2008 4:48 PM
  • Atta boy, Dave!

     

    "Inside joke" just 'cos Ur name reminded me of sum-1, but Ur prolly not him so prolly don't get it.

     

    Just checkin.  Big Smile

     

    Formerly Joy G. now Joy D. in TX

    Friday, September 12, 2008 4:50 PM
  • FINALLY!!!!!! Not exactly what I wished for but it works!

    I installed this thing:

    http://applian.com/sound-recorder/

    All I had to do was install it for Internet Explorer (didn't work with Mozilla) having it open while something was playing, click "record" and it did the job!, recorded everything I could hear!.

    I still think I might downgrade to XP, there's no need for these things with a new and expensive computer just because Microsoft decided to be cool.

    Hope it helps!.
    Saturday, September 13, 2008 9:13 PM
  • I too have had the same previous options available on Toshiba w/XP

    and now that I have a "new" Sony VAIO w/VISTA, I too have the same LACK of audio options.

    I have spent the last 2 days reading and have tried a couple low tech fixes and

    have heard the same story over and over from 5 different forums.

     

    I used to use Audacity to record through the streo mix that now does not exist.

    I found the suggestion above to use a product from Applian on another forum and as I already had

    a couple of their products (Media Catcher for recording streaming video &

    Converter for converting video formats to use in my video editing program(s))

    I trusted their site to download. I downloaded their Replay A/V ($49.49) and

    was discounted to $19.49 as I already had one of their products (Converter).

     

    This works just fine, records the file in original quality, and once saved,

    allows me to then import the file (song) into my Audacity program for editing, etc.

     

    I have a working sloution for the moment but I am intending to use the

    dual boot download to run Vista AND XP from my one machine. I think this will also

    allow me to use old programs that I have not been able to use on my new VISTA

    so I am hoping that the dual boot will solve this and other problems that, yes, I think

    VISTA producers are real stinkers for throwing us all into a black hole with problems of this

    nature. We have been allowed to use options for years, have grown acustomed to

    setting up our methods of opperating our various programs and then after spending

    a lot of $$$ on the "lateset" technology, we are reduced to frustrated users crawiling around the net

    looking for a seemingly simple solution to a problem

    that eventually we find out was actually intentional.

     

    Good luck and keep at it. One of these days one of us will come up

    with the fix and we can move on to another mundane but seemily

    unsovleable Windows problem.

     

    Rick in Phoenix, AZ

    Monday, September 22, 2008 4:30 PM
  • I am trying to figure out why Microsoft did this.  What do they think they are achieving by doing this????  And why is it that my laptop that is running Vista has the option of recording from the sound card and my desktop does not?  It doesn't make any sense to me at all.  Products are suppose to get better...not WORSE.  I just bought a brand new Kodak printer as well.  Easy to use?  Um......NO.  It doesnt have HALF the options of my 10 year old printer has...I can't even print in Grey Scale...its B&W or Color.....no inbetweens.  I hate paying good money for *** and I won't ever buy Kodak again.
    Monday, September 22, 2008 11:20 PM
  • "WAV OUT / STEREO MIX"  FIX!!!

    Recently I was in the same situation, but I found the solution for anyone from dell, sony, and gateway has always been shady to me. 


    I didn't read thru this whole blog, but I discovered the reason was due to copyright laws or some ***.  Funny how they are like, "maybe they won't notice."

    So, this software named "Virtual.Audio.Cable." will be able to give you a internal i/o feed.  You can probably download a crackd torrent of it.  I got version 4.09 and it works fine. 

    - Virtual Audio Cable v 4.09 -

    When you install it.  Just go to your playback & recording device tabs in your sound settings from the taskbar.  If you want to bypass the mic; go to the recording device tab and enable line 1 ; virtual audio cable. do the same thing with the playback device and something like audacity will record fine.

    I use pcdjvj to record mixes on audacity.  i had to loop it through a stereo system back into the mic and it sounded like butt.  so i found a solution.

    I have a sony vaio running home prem. 

    oh yeah, im sure you already know, but be sure to right click on the playback&recording device tabs and make sure to show disabled devices / show disconnected devices.  And you should change back the settings after recording.

    Line 1 is just the same as wav out or stereo mix, and once you enable the device, it will be available in your recording software.   Just select it for the i/o devices.

     
    Tuesday, September 23, 2008 7:07 AM
  • oh yeah, and i have a sigmatel high definition audio codec . if that matters. ill try to check back to see if i did a good job.
    Tuesday, September 23, 2008 7:13 AM
  • PhillipBlanton

    Which verison of windows vista you have and is it 32 or 64 bit? i tried what you wrote but when i check the show disabled devices tab nothing happens

     

    Thanks

     

    Thursday, October 02, 2008 9:09 AM
  • A Solution!  I have a 64 bit processor, but whether its 32 or 64 bits has nothing to do with the problem.  You have hit the problem on the head, that when you check the "show disabled devices" and "show the disconnected devices" nothing appears.  That is because your sound card does not support "Stereo Mix" or "Wave" and therefore you cannot record with that sound card and its drivers, and this is a big Vista problem.  But a few weeks ago someone from Vista Pro Audio Application Development gave me an answer (not completely perfect but it works). But first, check the simplest thing. Right click on the audio icon in the lower right system tray, then select recording devices, and you might just see "Microphone". Under that in the empty white area right click and make sure that "show disabled devices" and "show disconnected devices" are both checked. If they are and nothing else appears under "Microphone", that is, you still don't have Stereo Mix or Wave, then you are just like me and you can't record with anything other than the microphone. But now I have the answer. It is called Freecorder and you can download for free at
    http://applian.com/sound-recorder/
    The Vista Development guy said he couldn't get it work in Firefox, only with Microsoft Internet Explorer, but it works in both for me. Freecorder has its own drivers and does not rely on the drivers of your hardwired sound card (the flawed Conexant 221). It installs a toolbar in your browser (and if you are not using the toolbar or are tired of looking at it, just go to "View", then "Toolbars", and uncheck it, so you don't have it cluttering up the page, but when you want to record just go back to "View" then "Toolbars" and recheck it). One setting you should be sure to do in Freecorder is go to Settings (its on the toolbar) and Under the Audio Recording Configuration check "Record From Freecorder Audio Drive" and check "Record From Freecorder Input Audio Drive" and be sure that "Record From Windows Input Device" is unchecked. Then you are using Freecorder's drivers and now you can record.  And you are very welcome.
    Friday, October 03, 2008 6:13 PM
  • Mine is 32 bit. 

    Are you sure you that Virtual Audio Cable installed correctly?  It seemed so easy when I did it.  But if it isnt showing the disabled/disconnected devices when you right-click and check those options; my only guess is that Virtual Audio Cable didn't install correctly.  Have you looked at your I/O options in your recording or playback software?  There also may be some settings that need to be configured in V.A.C to work correctly.  If this doesnt work.  I'll re-install v.a.c. and type step-to-step what I did.  This really is the best solution I found with 2 hardcore days of trying to get around stupid copyrights. 

    Feedback is great tho.  I would like to know if this works for everyone else; as it did for me. 

    l8s

    p.s. sorry about the delayed reply.  I forgot to check it after while.  The reason Im posting this is bc another forum gave me the answer, and I wanted to spread the info bc i had so much trouble.  I wish I saved that link now.
    Sunday, November 02, 2008 10:05 PM
  • Free Recorder seems to serve the same function and ability as Virtual Audio Cable.  But yeah, I said what he said; So if you read his post and the 4th post back; you should be able to solve any problem.  I dont think it gets more cut and dry than this.  Be sure to spread the answer to other ppl having this problem.  For recording musicians, this is the most frustrating thing i've ran into. 

    Be good guys. and drop that bass!
    Sunday, November 02, 2008 10:14 PM
  •  

    thank u sooooo much for being more detailed
    Friday, November 28, 2008 5:43 PM
  •  

    Hi everyone. I joined this forum to answer the question for some of you with the same or similar sound card as mine .

    I currently have the x-fi  titanium sound card and coundn't get it to record my stream audio . I purchase this sound card as my former audigy 2zs was faulty at time with vista . I have vista home premium 64bit and after installing the software in it's entirety i didn't see any 'what u hear' icon or equivalent. i have 3 hard drives (not raid) and one of them has xp pro 32 bit so i installed the entire software and had the wave recording option which was recording very well with the wavestudio 7. I read and read and came up with something that someone said here, only i went a little bit further.

     

    solution:

    1. I went to Creative and manually selected my sound card from the x-fi category. if you allow the auto updat option to search for teh drivers it will get the vista version . Next go to the bottom

    of the page and choose the language then windows xp pro x64 edition (for those of you with vista 64bit) or choose xp (for those of you with vista 32bit) then choose 'all' then hit the submit button.

    2. you will now get a list of drivers including the beta driver 'Creative Sound Blaster X-Fi Titanium Beta Driver' . Download only this driver by hitting teh word "Download " and then extract it to a folder of your choice.

    3. Next enter that same folder and  look for the setup file.

    4. right click on the file and choose properties in the setup properties box that now is open.

    5. click on the compatibility tab and in the section that says 'compatibility mode' click in the empty box so that a check marks go in it and make sure that the option listed there is to 'run windows in compatibility mode for: windows xp (sevice pack 2)'

    6. hit the apply button, then the ok button.

    7. Now right click this setup file and choose 'open' and a creative update drive window will now open. make sure the selected option under update is 'driver installation & under 'driver type' choose wdm drivers. now put a check mark in the empty box which states: overwrite existing shared creative audio driver files. then hit ok.

    8. allow the process to go through and when it's finished it will want to restart. allow your computer to restart or you should manually restart but you must wait till the installation is properly finish, so wait for the restart message.

    9. after the restart go to start-control panel-sound-recording -> there you should have the 'what u hear' icon.

    10. right click on the 'what u hear' icon and choose set as default device.

     

    That's it. now try using the wavestudio7 or your recording program of choice and see what happens  . mine works great.

    p.s if you have a different sound or onboard card just follow what i have stated but go to your respective soundcard manufactures site and get the similar software as i have mentioned and just follow ad closely as possible what i have written and hopefully yours should work. all the best.

    Tuesday, December 02, 2008 9:08 AM
  • OK this is a follow up of my previous post. I just went and got the same beta driver from creative for the vista 64bit beta drivers in the same manner which i mention in my previous post (manually) and i went ahead a installed it to see if it would work and it did. however after the installation (which is the exact proceedure as i showed in the first post) u might have to right click on a blank area under the recording tab in the sound window from the control panel. then choose 'show disabled devices.' you should now see the 'what u hear' icon.

    if this doesn't work then just go back to my previous post and install the xp 64 bit version and u should be good.

    they both work for me so i'm hoping that if u follow what i have mentioned then u should be ok too.

    Tuesday, December 02, 2008 10:34 AM
  •  okdoit wrote:

    4. right click on the file and choose properties in the setup properties box that now is open.

    5. click on the compatibility tab and in the section that says 'compatibility mode' click in the empty box so that a check marks go in it and make sure that the option listed there is to 'run windows in compatibility mode for: windows xp (sevice pack 2)'

    6. hit the apply button, then the ok button.



    Right then, 'okdoit' has for me solved the problem, see his previous post.

    So it comes down to this; the driver and it's associate sub-programs provided by the hardware manufactor are at the heart of this, not I'm afraid Microsoft.

    By installing the XP version of the driver and running the set-up in 'compatibility mode' puts back the functionality that has been lost, I've sent two weeks working on this on and off and finaly got it to work, I seem to remember similier problems when 2000 first came out!

    So now with my Dell 755, using the Soundmax XP driver set & Adobe Audition 3; not only can I record (which to be fair I could do previously) but I can now hear the recording from my external source of a mixer & Technics 1210.  Plus I can happily record radio problems.

    Happy recording everyone
    Friday, December 05, 2008 11:42 AM
  • I was trying this forever and nothing worked for me. A key step that was left out in the directions is that after enabling stereo mix, you need to make it default (the check should move from the microphone to the live mix). After that you should be able to hit record in Audacity and other programs after you set the preferences to stereo mix. Hope this helps.
    Thursday, January 01, 2009 9:03 PM
  • The Vista way to record what you hear is to use WASAPI loopback capture; this works even if the audio driver doesn't expose a "what you hear" endpoint.

    http://blogs.msdn.com/matthew_van_eerde/archive/2008/12/16/sample-wasapi-loopback-capture-record-what-you-hear.aspx

    Matthew van Eerde
    Monday, January 05, 2009 5:20 PM
  • Regarding the Sony issue ... my AW came with 2008 sound drivers which didn't allow Stereo Mix.  I got the November 2006 generic Realtek Vista drivers and installed these.  Now I have Stereo Mix appearing in the recording devices and it works just as the old XP device used to. 

    So it seems the Sony 'fix' is not necessarily permanent and it's not a hardware issue, simply a driver mod.  If you can get earlier Vista drivers it may solve the problem.
    • Proposed as answer by blurg Friday, October 30, 2009 2:03 AM
    Tuesday, March 31, 2009 2:29 AM
  • Thanx to Gourmete
    Your reply worked!!!


    A little guide for the rest:

    Go to Control Panel
    Open Sound
    Select Recording Tab

    Right Click Anywhere
    Select Show Disabled Devices
    Look for devices which are shadowed/faintly displayed
    Select the Stereo Mix of the Audio Device you currently use.
    Right Click on it and select Enable

    That should do the trick!
    • Proposed as answer by LiNKiNbOi Sunday, April 05, 2009 3:07 PM
    Sunday, April 05, 2009 3:04 PM
  • The point is, almost all computers used to come with the option to record what you hear, even in the 90's. Now, the Vista era computers, especially Dell and Gateway laptops with Sigmatel drivers, make it impossible to use a "stereo mix" feature no matter what version of Windows you have. It's obvious this was done to appease the RIAA. What's ironic is that I'm a musician and find it much harder to make songs without a stereo mix.
    • Proposed as answer by movetomac Wednesday, May 20, 2009 12:55 AM
    Thursday, April 16, 2009 12:27 AM
  • Thanks for the help linkinboi!
    Sunday, April 19, 2009 10:24 PM
  • This is one of many frustrating issues I've found with Vista. Obviously designed to take away control in case we use this for copyright infringement. On XP, I wanted to record the stereo mix. I could select it from the record mixer. Simple. Now this can't be done. ONE SOLUTION. MOVE TO MAC!!! I've done it, and now I can record whatever I can hear, and have been happy happy happy ever since!
    Wednesday, May 20, 2009 1:00 AM
  • Worked for me ;-)
    Thanks

    Friday, June 26, 2009 6:07 PM
  • I have done this and still only see Microphone in the list.
    http://img.photobucket.com/albums/v77/4thgenaccord/Junk/ScreenShot.jpg
    Monday, July 27, 2009 2:57 AM
  • I have done that but still only see Microphone in the list.

    http://img.photobucket.com/albums/v77/4thgenaccord/Junk/ScreenShot.jpg
    Monday, July 27, 2009 2:59 AM
  • Purchase the replay suite... or just replay music 3.  It's the only one I found that works.  It actually splits the tracks for you instead of a 70 minute file.  Also enters the name of the song.  Set it and forget it and it will capture Rhapsody, etc.


    Thursday, August 20, 2009 5:31 AM
  • Oh man I was having the same issues so I installed Linux.

    Everything is working fine now.
    • Proposed as answer by psytek7 Monday, August 24, 2009 12:22 AM
    Monday, August 24, 2009 12:21 AM
  • basically its hidden u have to go on the recording tab and right click it and find show disabled devices but ive been doing that and i cant find the wave out mix and its bugging me alot so maybe ull have better luck
    Wednesday, August 26, 2009 2:56 PM
  • Very thanks, t-bon3! That is what I was searching!!!
    Wednesday, October 21, 2009 1:56 AM
  •  VVAIO AW is right!  Realtek HD Audio has stereo mix if you use old enough generic drivers.  A poster on another site used this driver from 2007 on his Toshiba.  It worked on my VAIO too.  You just have use the "show disabled devices" trick after installing the driver.




    • Proposed as answer by Atomictop Saturday, November 14, 2009 12:21 PM
    Friday, October 30, 2009 2:28 AM
  • 1. Great site – many hands make light work – and this one’s been a bit a a B…….
    2. This is how I solved this stereo-mix problem for VAIO VGN-AR71S laptop running Vista Home Premium.
    3. If you have a VAIO (add you own appropriate cuss expressions here) and tried VAC and backdated drivers without success there may be some hope for you yet.
    4. The following worked on this VGN-AR71S Sony machine and may work on other Sony machines or other brands – Please note: I got this idea from another thread or maybe even this thread  - bear with me here I'm in a hurry - where someone used a loop between the sound card speaker out and mic in – I have just added a Y-extension so that one can hear sound and not have to record in the deaf so to speak. Anyway, whoever you are - thanks mate.
    5. Get yourself the following: One 3.5mm stereo Y-extension cable (2 female jacks connected to 1 male jack) – google ebay for this.
    6. One 3.5mm stereo male to male extension cable ( 2 male jacks at each end) – google ebay for this.
    7. Place the male jack of Y- extension into sound card headphones socket.
    8. Place one jack of male to male extension in sound card microphone socket and the other male jack in one of the female jacks of the Y-extension.
    9. If you now play a video or mp3 file you will not hear any sound because the sound card has a jack in the earphone socket -  which in this case is looped to the microphone socket.
    10. In order to hear sound connect your earphone or external speakers male jack to the other female jack of the the Y-extension.
    11. You should now be able to hear sound and use Camstudio, Audacity etc, etc as normal – but here is the payoff - You should now get PLAYBACK WITH SOUND.
    12. If your playback sound is distorted or if you have no playback sound check out the following.
    13. Controls / Sound / Playback – make sure speakers/headphones is default. Click properties/levels tab – check that speaker/headphones speaker icon is not disabled. Check that speaker/headphone volume is not set too high. Check that the microphone speaker icon is not disabled. Check that the volume is not set too high. Do same for PC Beep.
    14. Now go to the recording tab – microphone should be default – highlight microphone and click properties/levels. Check that microphone speaker icon is not diabled, Check that the volume is not set too high on microphone and especially microphone boost.
    15. Test sound and recording playback – hopefully everthing should be OK.
    16. By connecting only the green (not pink) speaker jack of my headset to the female jack of the Y-extension (the male jack of the Y-extension is connected to the sound card headset socket) I was able to record voice.
    17. This was through Camstudio - other programs may produce better results.
    18. Voice by itself was OK but over Youtube video voice playback was not satisfactory - could hardly hear it.
    19. Obviously a software fix would be ideal but I haven't manage that on this VGN-AR71S machine.

    • Proposed as answer by Timssims Wednesday, September 14, 2011 8:06 PM
    Saturday, November 14, 2009 11:26 PM
  • 1. A last VITAL UPDATE - refer post by atomictop 
    2. For BEST screen recording and playback sound: DISABLE microphone in the control panel /sound/playback/properties/levels Tab - blue microphone icon should have a red icon next to it.
    3.Go over to the control panel/sound/recording/properties/levels Tab - make sure that microphone boost is set to min (0.0dB) and that the microphone icon is not checked out with a red icon next to it.
    4. Should have tested more before posting but I am busy and have other machines.

    PS: By connecting the green jack (or sound out jack) of a headset to the other Y-extension female jack I was able to record voice but the playback was very soft. I was using Camstudio. I only use this machine for screen recocording so this method is a quick fix with little hastle and fiddle. The the ideal fix, of course, would be a sofware solution that does not require having to reset everything again after bootup.
     
    Sunday, November 15, 2009 6:28 AM
  • 0. Got this software from Billaboard's post on MSDN forum.
    1. Installed a full-featured-non-expiring trial copy of Total Recorder VideoPro (see Billaboard's post above or MSDN forum) on the Sony VAIO - Vista machine.
    2. I got screen captures of Youtube WITH SOUND, so it does the trick !
    3. No fiddling in control panel looking for lost stereo-mix mojo, it bypasses all that - gallons of fine technical details on the vendor page.
    4. It's a bit of a fiddle to setup but has a comprehensive set of features and functions like screen capture, video editing, automatic screen area mapping, customizable presettings etc, etc. 
    5. I got a playback of voice but did not manage in to get voiced dubbed over video, though it should be possible.
    6. Price: $53.95. Here is the link: <a href="http://www.totalrecorder.com/productfr_trVideoPRO.htm" taget="_blank">Click Here</a> If the link does not work copy and paste: http://www.totalrecorder.com/productfr_trVideoPRO.htm.
    7. The full-featured-non-expiring trial will give anyone unlimited time to figure if it's worth buying.

    PS: In the trial version a short noise is inserted into each recording every 1 minute.
    Sunday, November 15, 2009 5:42 PM
  • 1. Can across another software solution re the VAIO stereo-mix problem.
    2. Replay Video Capture by Applian technologies is the name of the product.
    3. Demos available - here is a copy and paste link: http://www.applian.com/replay-video-capture/index.php 
    Sunday, November 15, 2009 10:26 PM
  • Im curious, what model VAIO do you have, and more importantly, where did you find this driver? the Realtek generics on their site only seem to list 2009 releases.

    Cheers!
    Thursday, December 17, 2009 3:50 PM
  • another excellent option, which works on my Gateway Vista computer, where none of the other options above work:
    NCH SoundTap
    http://www.nch.com.au/soundtap/index.html

    $35


    Tuesday, December 29, 2009 12:19 AM
  • two free options which work on Vista with a blocked soundcard:
    • applian freecorder. although it's a browser plugin, it actually records all pc sounds. you can even close the web-browser after you launch the recorder.
      Applian Freecorder
    • loopback-capture. 18 KB. uses vista's new wasapi (window audio session api). i expect more apps will appear soon, which take advantage of the wasapi.
      loopback-capture
      more info
      (note, this app terminates when it hears an audio "glitch", which can be a problem if your computer is "glitchy".
    Thursday, December 31, 2009 4:42 AM
  • Hi ive been having the same problem I use my pc to stream my own tv station.Ive used various programs webcammax manycam and the adobe media encoder to stream.All worked fine with xp pro but since ive upgraded to windows extreme r2 edition vista ive been unable to stream my audio without a mic.This problem has really been buggiing me for the past few days and ive read many forums with simular issues.

    So this is how I got on I found out that the mixer is hidden and disabled.By clicking on the sound icon on the tray at the bottom second mouse click recording devices.It will fetch up the current devices shown.By clicking the second mouse again it says show disabled devices and show disconnected devies.This brought up everything so I simply tryed enabling it but even though it was it said currently unvailable.But today ive just found the answer my mic was at the top of the list so i disabled that and it moved to the next one.As I disabled the others it worked its way down the list of devices.Now my stereo mix says working instead of currently unvailable and has a green tick.I can say that this has solved the problem for me im using 32 bit windows  socket775 asus p5ld2 se motherboard.Hope this will help someone with the same problem peace.  :)
    Monday, January 25, 2010 12:56 AM
  • OK.... Finally found a solution for this. Open up sound from the control panel,  I right clicked on the sound dialogue box to show the disabled devices and after a lot of messing about enabled the mixer. However having done this it still didn't work - it appeared to have been disabled. However I found that if you click mixer then properties then advanced the  default setting for sample rate and bit depth is 2channel 16bit 48000hz. As soon as I chaneged this to 2 channel 16bit 44100hz the mixer started working! The next problem was a horrible background noise that was present all the time the mixer was enabled. However by taking the level meter down to 7 under the levels tab, I was able to resolve this problem as well et voila! It all works and I can happily stream my soundcard output - spotify etc to my streamium which is connected to my stereo and I can record any stream at all.

     

    This has taken me about two weeks to resolve so I thought I would share!

    Wednesday, January 27, 2010 7:01 PM
  • RIP Vinyl can also record from what you hear:
    http://www.ripvinyl.com

    Make sure you set your audio output format to 44.1Khz 16 bit stereo on the control panel.
    Friday, February 05, 2010 10:43 AM
  • Thanks Thanks Thanks, bueniiiiisimo me estaba volviendo loco, graaaacias.
    Saturday, March 13, 2010 1:33 AM
  • I signed up just to post the answer to this question in case you missed Polux2's solution. I too, have suffered the indignity of having my Stereo Mix/Wave Out removed upon upgrading to W7, which was how I recorded "what I hear" via Audacity.

    Vista/W7 users THAT HAVE SOUND CARDS, your answer is obvious. Right click the Sound icon or open it in Control Panel, then "unhide" or show the disabled/disconnected devices. Clearly that has worked for you.

    However, this solution doesn't work for everyone else WITHOUT SOUND CARDS, whose computers are laptops/netbooks or have integrated sound in the motherboard. They don't have the hardware to have a Wave Out/Stereo Mix. The solution? Software driver upgrade, courtesy of Realtek! Chances are Vista/W7 is using its internal drivers to produce sound from the integrated audio board, and all you have to do is replace it with the REALTEK HD AUDIO DRIVER, which HAS STEREO MIX/WAVE OUT as a recording device. As long as you get the latest one from Realtek, it should work.

    Here are the steps I took:
    1) visit http://www.realtek.com.tw/downloads/ and choose "High Definition Audio Codecs (Software)".
    2) tick the checkbox and agree to their conditions, press Next.
    3) download the ZIP file for Vista/W7 drivers (should be 55MB)
    4) when the download completes, extract the contents of the ZIP file to a folder of your choice.
    5) Right-click the sound icon and goto "Playback Devices".
    6) Select your Speakers and click the Properties button.
    7) Click Properties again in the box Controller Information and go to the Driver tab.
    8) Press "Update Driver" and "Browse my computer for driver software"
    9) Browse to the folder where the Realtek driver was extracted to and press OK, then Next.
    10) Wait for the driver to finish updating, then close the Speakers Properties window.
    11) Go to the Recording tab in the Sound window and right-click to show disabled/disconnected devices.
    12) Stereo Mix/Wave Out should be available now; enable and test in desired audio software.

    Now you can record again, just like good old XP.
    • Edited by Ayanami9870 Thursday, March 18, 2010 8:09 AM typo
    • Proposed as answer by JeffB84 Tuesday, November 02, 2010 8:31 AM
    Thursday, March 18, 2010 8:02 AM
  • YOU ARE A GENIUS! I have been trying to figure this out ever since I upgraded to Windows 7 Home Premium. I did exactly what you suggested, and by George, there it was! I can now record streaming audio directly from the computer using Audacity!

    THANK YOU SO VERY MUCH!

    Carlton Flowers

    The Carlton Zone Blog

    Monday, March 22, 2010 4:10 AM
  • I have tried to do as you suggested, but to no avail.  I had it operational at one time, but when I went to record this evening, it would not let me.  I am not sure whether there was an update that undid/reversed what I had done before, but now it does not work.  I use a program called "GoldWave" which allows me to capture whatever is streaming through the soundcard, but I cannot get it to do so now.  I downloaded the Realtek Vista/W7 driver(s) and when I tried to install them, it indicated that my drivers are already up to date.  When I tried to run the program that I downloaded, it indicated that there were no applicable drivers.  Go figure!  What would you suggest?
    Friday, April 23, 2010 3:48 AM
  • I took the liberty of copying an above entry and added several steps that produced success in Windows 7-64 bit on a new HP laptop.

    Here are the steps I took:
    1) visit http://www.realtek.com.tw/downloads/ and choose "High Definition Audio Codecs (Software)".
    2) tick the checkbox and agree to their conditions, press Next.
    3) download the ZIP file for Vista/W7 drivers (should be 55MB)
    4) when the download completes, extract the contents of the ZIP file to a folder of your choice.
    5) Right-click the sound icon and goto "Playback Devices".
    6) Select your Speakers and click the Properties button.
    7) Click Properties again in the box Controller Information and go to the Driver tab.
    8) Press "Update Driver" and "Browse my computer for driver software"
    9) Browse to the folder where the Realtek driver was extracted to and press OK, then Next.
    10) Wait for the driver to finish updating, then close the Speakers Properties window.
    11) Go to the Recording tab in the Sound window and right-click to show disabled/disconnected devices.
    12) Stereo Mix/Wave Out should be available now; enable and test in desired audio software.
    13) If the new drivers do not "take" the first time around, go into "Device Manager" and UNINSTALL BOTH existing sound drivers, then run "Setup.exe" again.
    14) NOTE !! DO NOT allow Microsoft to re-install their audio drivers again, if you get an indicator showing "updates available" make sure the updates ARE NOT for the audio device.
    • Edited by Researchman Sunday, May 09, 2010 12:23 PM more info
    Sunday, April 25, 2010 2:38 PM
  • yeah this happened to me too. One day I just became relentless to find the solution. I looked at a bunch of settings and did some stuff and bam! I can see the radio mix thing in recording devices. unfortunately, I can't remember what I did, and also, I still cannot record sound on my computer without a microphone:(
    Sunday, May 16, 2010 8:49 PM
  • OH! Found it.

    For everyone else...

    Right click on the speaker icon in the tray.

    Select "Recording Devices"

    In the resulting dialog, make sure you have the "Recording" tab selected and in the middle of the empty area, right click and select "Show Disabled Devices".

    oooooop dere it is!

     

     


    Thanks a lot! Your answer is very useful.
    Sunday, September 05, 2010 12:13 AM
  • ok with windows 7 and realtek drivers I can get stereo mix to work but only when Speakers is selected as the playback device on my laptop.. if the playback device is set to "Realtek Digital Output" (which is what i normally use.. ie 1/8th optical output going into my logitech z-680s).. Stereo Mix no longer works =\

     

    why is stereo mix not working when optical output is selected??

    Tuesday, September 14, 2010 4:26 PM
  • > why is stereo mix not working when optical output is selected??

    Stereo Mix is a feature provided by the driver; it's usually powered by an "analog mixer."

    Realtek is in the best position to explain why their analog mixer doesn't include signal that goes over the optical output.

    WASAPI loopback recording should work for digital outputs, though, provided you're not streaming to a hardware decoder (like playing a DVD to an AC-3 capable receiver over S/PDIF or HDMI.)


    Matthew van Eerde
    Wednesday, September 15, 2010 3:08 PM
  • Phillip you the man! I was gonna wip my computer savy friend Butt but you saved him.

    Tuesday, November 23, 2010 2:10 PM
  • The commnts on this subjecct are awesome. Thanks. I want to save my recording and don't see a way to do this. Can you provide a little more awsomeness on this subject?

    Thanks

    Thursday, November 25, 2010 6:23 PM
  • Hey, people!

     

    You can use the Virtual Audio Cable to record directly from your soundcard. This software repeats the audio and redirects it (without loss of quality) to any device you select. It installs virtual devices on the playback and record devices options. Just select them as defaults and execute the Audio repeater, so you can hear what you record. But... the software isn't free.


    Friday, July 01, 2011 2:19 AM
  • I was just a scrub the 5 and a half years ago I responded to this subject back when I was a Dell tech support guy.

     

    Wow. Times have changed.

     

    Anyway, for most people the answer is to download an appropriate driver. The Stereo Mix is entirely provided by the driver, so you need to know what type of audio chip is on your device and find a version on the internet that has Stereo Mix enabled.

     

    For recording the actual sound itself if you're cheap I'd recommend the program Audacity.

     

    Glad this thread wound up helping so many other people. 150 replies. Wow.


    MCSE 2003, Exchange. MCTS Vista, 7. Administrator of awful, neglected website http://timssims.net
    • Proposed as answer by Timssims Wednesday, September 14, 2011 8:06 PM
    • Edited by Timssims Wednesday, September 14, 2011 8:08 PM
    Wednesday, September 14, 2011 8:06 PM
  • my goal to voice over a pre paid TV program. I am working with other technical people who are handling this aspect of the project. I am the "Sales/Marketing" end. I would like to understand the nuts and bolts of how to do this only to be more knowledgeable of the process. Your answer seem the best to me (most comprehesible) When time please email back. Thanks
    Sunday, December 25, 2011 8:59 PM
  • Thanks so much, Gourmete. You found an answer that I have been looking for a long time as well...!! :-)
    Tuesday, January 03, 2012 10:23 AM
  • Same result with a different route... Thanks as well, Phillip...!! It REALLY made my day! :-)
    • Proposed as answer by stereomix Thursday, November 29, 2012 12:01 AM
    • Unproposed as answer by stereomix Thursday, November 29, 2012 12:01 AM
    Tuesday, January 03, 2012 10:24 AM
  • Stereo Mix - Solved for Sony Vaio VGN-TT with Realtek HD Audio

    My setup:
    Vaio VGN-TT laptop
    ALC889 codec chip
    Windows 7 64 bit

    After chasing down the numerous suggestions here and elsewhere with no luck, it came down to this:

    No Realtek HD Audio Vista driver version from v 1.93 up to the present (v 2.70) would expose either the Stereo Mix device or the Realtek Audio Manager applet on my laptop.

    But Bingo! v 1.85 (~ early 2008) does work, as well as earlier versions for Vista.

    They are available in the drivers.softpedia.com archives.

    My guess for what happened is sometime in 2008 with v 1.93 or so Realtek started to respect requests from Sony, maybe Dell, maybe others, not to expose the loopback 'Stereo Mix' device. So more recent software looks to see whether it's running on a Sony/Dell machine, and if so does not expose Stereo Mix and does not allow the Manager cpl applet to run.

    Thursday, November 29, 2012 12:03 AM
  • We (Microsoft) have been asking drivers to expose only audio inputs and outputs that correspond to physical devices; this helps to keep things simple and prevent user confusion.

    Windows provides "Stereo Mix" functionality via the WASAPI loopback capture API, so there is no longer a strict need for drivers to provide a Stereo Mix.  (Stereo Mix does provide compatibility with legacy applications, but at a cost of potential user confusion.)

    If you want to use an application that is not WASAPI loopback aware, on a driver that does not provide a Stereo Mix, there are third-party solutions available such as Eugene Muzychenko's Virtual Audio Cable.

    http://software.muzychenko.net/eng/vac.htm

    I would advise against installing drivers from collaborative websites.  There's a lot of malware out there.  For safety, I would stick with Windows Update or your PC's official support site for drivers for your physical audio devices.


    Matthew van Eerde

    Thursday, November 29, 2012 12:29 AM