none
Solution: Installing Win SDK after VS2008 breaks XAML Intellisense

    General discussion

  • Several VS 2008 and Windows SDK users have reported that Intellisense stops working for XAML projects  after installing the Windows SDK for Windows Server 2008 and .NET Framework 3.5.   The Windows SDK Team and the Visual Studio 2008 team has been able to repro the issue and the cause has been identified.  A Visual Studio registry value is being incorrectly reset after the Windows SDK is installed, causing this failure. 

     

     How to determine if  you are experiencing this issue

    1.       Please review the article, Windows registry information for advanced users before using regedit.

    2.       Using regedit, look at the key:  

    ·         On X86 machines: HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

    ·         On X64 machines: HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

    3.       If (Default) is empty you are experiencing this issue

     

    We suggest two workarounds: repair Visual Studio 2008 or register TextMgrP.dll manually. 

    Repair Visual Studio 2008:

    1.       From the Start button, open the  Control Panel

    2.       Click on Program and Settings (Add/Remove Programs on non-Vista machines)

    3.       Click to select Visual Studio 2008 and click Change (at the top of the window)

    4.       When the change dialog box launches, select Repair 

     

     Register TextMgrP.dll manually

    On an X86 machine:

    1.       Open a Windows CMD window as an Administrator (On Vista: Start, All Programs, Accessories, right-click on command prompt and  choose to Run as Administrator)

    2.  Type: regsvr32 "%CommonProgramFiles%\Microsoft Shared\MSEnv\TextMgrP.dll"

     

    On an X64 machine:

    1.       Open a Windows CMD window as an Administrator (On Vista: Start, All Programs, Accessories, right-click on command prompt and  choose to Run as Administrator)

    2.  Type: regsvr32 "%CommonProgramFiles(X86)%\Microsoft Shared\MSEnv\TextMgrP.dll"

     

    Restart Visual Studio and Intellisense should be working correctly again.

     

          K a r i n   M e i e r

    Windows SDK | Samples & Community PM

    http://blogs.msdn.com/KarinM

                                                            

    Friday, February 22, 2008 8:09 PM

All replies

  • I'm sorry but I tried the method above and it doesn't work. I suffered a lot without the intellisense for the XAML files. Any other suggestion?

    Thanks.
    Wednesday, March 19, 2008 9:51 AM
  • I can understand how you feel.  Intellisense is such a great tool.  Can you tell me more, please?

     

    1.       Which of the above workaround methods did you try?  Did you try to Repair Visual Studio or did you Register TextMgrP.dll manually?

    2.       Did you use Regedit to look at this key HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32 to see what the (Default) value was?

    3.       What is your machine platform architecture? (X86, X64 or IA64)

    4.       Is Visual Studio 2008 your only version of Visual Studio you have on the computer?

    5.       Which did you install first, VS or the Windows SDK?

     

    --Karin

     

    ||Karin Meier||Windows SDK PM||Build Environment.Samples.Community|| http://blogs.msdn.com/KarinM||

     

     

    Wednesday, March 19, 2008 2:28 PM
  • Hi,

     

    Which editor are you using?

    I noticed that you don't have Intellisense if you open the xaml file with Visual Studio's Xml Editor (for instance if you have complex xaml that the designer cannot render or if it takes forever to load) .

    I have juste logged an issue on connect

    https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=333690

     

    Tony.

    Thursday, March 20, 2008 12:44 AM
  •  

    Thanks for your help, Karin and A.Guerot. I think I have the same problem with you, A.Guerot. I have no intellisense if XAML is opened by the XML editor. However, I noticed in machines without the "Windows SDK for Windows Server 2008 and .Net Framework 3.5" installed the intellisense of the XML editor and XAML Designer both work.

     

    My SDK is installed after the Visual Studio 2008. I uninstalled Visual Studio and SDK and re-installed them in the order of SDK first and then Visual Studio. It still didn't work. Perhaps we have to wait for the Visual Studio Team to have a look into this issue.

     

     

    Friday, March 21, 2008 2:15 AM
  • I've tried the second solution "Register TextMgrP.dll manually" (on X86, SDK v6.1) -- it works!

    Thanks Karin!



    Wednesday, March 26, 2008 5:31 PM
  • Great news, Maxim!  I’m so glad this workaround fixed your problem.  Thanks for letting me know.

     

    --Karin

          K a r i n   M e i e r

    Windows SDK | Samples & Community PM

    http://blogs.msdn.com/KarinM

     

    Wednesday, March 26, 2008 5:39 PM
  • I changed the Default value in the registry manually and it fixed the problem. For some reason, running regsvr32 as outlined above (with the correct path and all, I double-checked) gave me an error message about not finding a module.

    Thanks for figuring that all out! I had gotten really frustrated by the disappearance of auto-complete. I did install the Windows SDK after C# Express 2008 and I think that is indeed when the problem started.
    Thursday, March 27, 2008 1:40 AM
  • Djdanlib, I’m glad you got XAML Intellisense working again.  Did you use the reg key editing solution Brett Kilty posted at Solution: Intellisense broken in all WPF Projects after installing SDK/MSDN?  I don't really know why manually running regsvr32 didn't work for you.  Strange.

     

    I agree that this issue probably started when you installed the Windows SDK, but the actual issue is with DExplore, the document explorer app that ships with lots of products (including the Windows SDK). 

     

    The DExplore team will have this issue fixed in future releases.  I’m sorry you ran into this problem!

     

    --Karin

     

    ||Karin Meier||Windows SDK PM||Build Environment.Samples.Community||http://blogs.msdn.com/KarinM||

     

     

    Thursday, March 27, 2008 5:27 PM
  • The problem with the manually running regsvr32 is quite simple as I found -- the last quotation mark of the command is wrong for some reason.
    It is instead of "
    Monday, March 31, 2008 1:34 PM
  • Thanks for the feedback, Maxim.  I’ve fixed the punctuation from smart quotes to non-formatted quotes.  I appreciate your post!

     

    --Karin

     

    ||Karin Meier||Windows SDK PM||Build Environment.Samples.Community|| http://blogs.msdn.com/KarinM||

     

     

     

    Monday, March 31, 2008 4:09 PM
  • I have tried both of the above methods and with no luck my XAML intellisense is still broken. I should note that the Registry reference was not broken to begin with. Another possible problem (guess) is that I also have VS 2005 installed for lagacy applications. I tested 2005 and its XAML intellisense is fine.


    Any help?
    Friday, May 02, 2008 9:29 PM
  • Ok I talked to a coworker and we figured the issue out. In VS 2005 you did not need to do this but this worked great. I like to look at XAML without the Designer. So I had defaut set to  XML editior which as it turns out has no intellisense. I had to set it to Windows Presentation Foundation Designer as default and disable the Designer part in Options, Text Editior, XAML, MISC, Always open XAML documents in full XAML view.

    YAY : ) !
    Monday, May 05, 2008 3:43 PM
  • My registry setting was good. But I had to re-register the dll and restart VS 08.

    Thanks

    Thursday, August 21, 2008 4:13 PM
  • I tried repairing VS 2008 several times and also tried to register dll manually. The problem still exists. Any other solution?

     

    Friday, October 03, 2008 9:25 PM
  • CoderAnnie, have you confirmed that you are experiencing the issue described in this thread?  (Please review the article, Windows registry information for advanced users before using regedit.)

     

    Use Regedit to look at the key HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32 to confirm that the (Default) value was empty?   If you have a different scenario please provide details.

     

    --Karin

     

    ||Karin Meier||Windows SDK PM||Build Environment.Samples.Community||http://blogs.msdn.com/KarinM||

     

     

    Monday, October 06, 2008 3:34 PM
  •  

    I have  confirmed that default value is not empty. The value is: C:\Program Files\Common Files\Microsoft Shared\MSEnv\TextMgrP.dll.

     

    Also, this issue starting happening after I updaed VS 2008 to SP1.

    Monday, October 06, 2008 5:20 PM
  • I am also having this problem on a 64 bit machine (Fresh install running Vista Business, SQL Server 2008, .NET 3.5SP1 and Visual Studio SP1).  I installed .NET 3.5SP1 first, then SQL Server 2008, then visual studio.

    This is an error I get in the output window when I try and view XAML:

    The Microsoft.VisualStudio.Xaml ({E58C2A8B-BCC4-4559-AD59-D62EB6D58A22}) did not load because of previous errors. For assistance, contact the package vendor. To attempt to load this package again, type 'devenv /resetskippkgs' at the command prompt.

    If I try to go to Tools > Options > Text Editor > I can click on General and Tabs.  However if I click on Formatting or Miscellaneous then I get the error: "An error occured loading this property page".

    What I have tried as of now:

       1. When I run '%systemroot%\syswow64\regedit' the Default is 'C:\Program Files (x86)\Common Files\Microsoft Shared\MSEnv\TextMgrP.dll'.  This file exists locally.
       2. I have tried to register (as an administrator with 'regsvr32 "%CommonProgramFiles(X86)%\Microsoft Shared\MSEnv\TextMgrP.dll"' to which I receive the prompt 'DllRegisterServer in C:\Program FIles (x86)\Common Files\Microsoft Shared\MSEnv\TextMgrP.dll succeeded.'
       3. I have tried repairing Visual Studio.
       4. I have tried uninstalling and reinstalling visual studio.

    Anything else work for anybody else?
    Wednesday, October 15, 2008 1:45 PM
  • CoderAnnie, have you confirmed that you have the same issue that this workaround was written for?  This problem is caused when installing the Windows SDK for Server 2008 on top of Visual Studio 2008. You can confirm that you have this issue by checking to see if the default value for the registry key HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32 is empty.  If the key has a value you do not have this issue and the workarounds will not help you. 

     

    How to determine if  you are experiencing this issue

    1.       Please review the article, Windows registry information for advanced users before using regedit.

    2.       Using regedit, look at the key:  

    ·         On X86 machines: HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

    ·         On X64 machines: HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

    3.       If (Default) is empty you are experiencing this issue

     

    Are you using the XAML Designer or the XAML Editor to view your files.  The XAML editor does not support Intellisense.  You might try setting Windows Presentation Foundatio Designer as your default.  Disable the Designer using the pull down menu Options, Text Editor, XAML, Misc.  Then try to open your XAML document using full XAML view.  Does that help?

     

    Are you using Visual Studio 2008 SP1?

     

    --Karin

     

    ||Karin Meier||Windows SDK PM||Build Environment.Samples.Community||http://blogs.msdn.com/KarinM||

     

    Wednesday, October 15, 2008 3:57 PM
  • I have  the same problem as Eric Kaufman.

     

    However, I'm using WIndows XP sp3, VS 2008 Pro (a load of updates) and it also occurs with VB 2008 Express (sp1).  I don't have the problem with VC# 2008 express.

     

    I too have un-installed, repaired etc.  But still a problem.

     

    Any suggestions?

     

     

     

    Friday, October 24, 2008 1:18 PM
  • I have VistaHome64, SQL 2008 Developer, VS2008SP1, Expression Studio, Silverlight2 SDK

    And...

    No Intellisense on XAML in VS2008
    No Ajax nor WPF Components (see screen shots)
    No Tools->Options->XAML->Formatting properties

    I also have lots of screwy stuff going on (it could be since VS SP1 but I haven't confirmed that).

    If I had the Ajax controls showing up I could live w/o Intellisense.

    Here's a link to some screen shots:  http://picasaweb.google.com/MarownIOM/VS#

    BTW:  My registry key is populated and just for kicks I re-registered TextMgrP.DLL from DOS run as Administrator.  The only thing I haven't re-installed is VS2008.  From other posts they have done the same with no better results so I didn't bother.

    I'm considering creating a VM to see if I can reproduce this problem.
    Sunday, November 02, 2008 2:04 AM
  •  

    Could someone please help me...I've taken all the suggestions listed in this thread, plus several more found via google...still no joy.  I've uninstalled and reinstalled everything more than twice and spent the better part of 4 days trying to fignure this out.  It's driving me CRAZY!
    Tuesday, November 04, 2008 11:37 PM
  • CoderAnnie, you DO NOT have the issue described in this thread, so this workaround will not help you.  You have another problem, not caused by installing the Windows SDK.  I recommend you look at another thread on this issue, such as this one on the WPF Forum: http://social.msdn.microsoft.com/Forums/en-US/vswpfdesigner/thread/053dc5c3-27fe-4ea2-a7f5-5c6cf35000bb. 

     

    How to tell if you are experiencing the issue described in THIS THREAD:

      

    Use Regedit to look at the key HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32 to confirm that the (Default) value is empty.  If the value is empty, you have the problem described in this thread and can use the fix recommended at the top of this thread.  If the value IS NOT EMPTY, you  have a different scenario and should start another thread on the Visual Studio forum, such as this one on the WPF Forum: http://social.msdn.microsoft.com/Forums/en-US/vswpfdesigner/thread/053dc5c3-27fe-4ea2-a7f5-5c6cf35000bb(Please review the article, Windows registry information for advanced users before using regedit.)

     

     --Karin

     

    ||Karin Meier||Windows SDK PM||Build Environment.Samples.Community||http://blogs.msdn.com/KarinM||

     

     

     

    Wednesday, November 05, 2008 12:27 AM
  •  

    Ok, thanks for the update. Like you mentioned, InProcServer32  is set. But I have tried other solutions mentioned in several other threads including the one you mentioned. Still does not seem to work. Thanks anyways.
    Wednesday, November 05, 2008 3:15 AM
  • I’m trying to understand what other issues could be causing your problem and will update this thread when I find them.  Feel free to start up another thread on the WPF designer forum http://social.msdn.microsoft.com/Forums/en-US/vswpfdesigner/threads/. I understand that this is very frustrating for you and will try my best to find an answer from other teams.

     

    --Karin

     

    ||Karin Meier||Windows SDK PM||Build Environment.Samples.Community ||http://blogs.msdn.com/KarinM||

     

     

    Wednesday, November 05, 2008 4:43 AM
  • There is a new hotfix out.


    See if this helps.
    Wednesday, November 05, 2008 5:02 AM
  • This hotfix is for .NET 3.0 and Server 2003. I have .NET 3.5 and Vista.

     

    Wednesday, November 05, 2008 5:43 PM
  • James Osborne wrote re: Intellisense for XML config files broken in VS 2008?
    on 11-05-2008 6:05 PM

    If you are still hitting this, I just found a fix.  Using cmd, navigate to the Visual Studio 2008 (9.0) folder in the Program Files folder.  cd to Common7\IDE.  Type, "devenv.exe /setup"

    You can open taskmgr to monitor the devenv process.  When it's done, just reopen visual studio and xml should start rendering.  At least it worked for me.  Good luck.



    I done this and secceeded.

    Wednesday, November 12, 2008 6:30 AM
  • I found this.
     
    James Osborne wrote re: Intellisense for XML config files broken in VS 2008?
    on 11-05-2008 6:05 PM

    If you are still hitting this, I just found a fix.  Using cmd, navigate to the Visual Studio 2008 (9.0) folder in the Program Files folder.  cd to Common7\IDE.  Type, "devenv.exe /setup"

    You can open taskmgr to monitor the devenv process.  When it's done, just reopen visual studio and xml should start rendering.  At least it worked for me.  Good luck.

     

    It works.
    Wednesday, November 12, 2008 6:41 AM
  • I have the very same problem, but after trying the manual method described, it still does not work. I looked at another machine at it has an wpf editor in the open with dialog box. Where can I get the wpf editor?

    Thanks Bob
    Sunday, November 16, 2008 1:05 AM
  • Hi Karin,

     

    I have tried all the above mentioned method 2-3 times.

    But not able to resolve the issue.

    Very much disapponted with VS 2008.

     

    Thanks,

    Krishna

     

    Wednesday, December 10, 2008 2:37 PM
  • By issue got resolved by registering TextMgrP.dll manually

    Thanks,
    Mahesh


    Mahesh. MCP
    Monday, December 22, 2008 6:13 PM
  • Moose, it sounds like you have a different problem, and it’s one that I had myself.  You can see if you can get the WPF designer back by quitting Visual Studio then running “devenv /resetskippkgs” in case you had package load failures in the past which you may have suppressed. Then check if the WPF designer shows up again in the list of available designers.

     

    You need to run that command from the Visual Studio Command Prompt (Run as Administrator on Vista), which you can find in the start menu under Microsoft Visual Studio 2008->Visual Studio Tools.  I assume that you have installed Visual Studio 2008 SP1.  If not, you’ll need to do that first. 

     

    If that doesn’t work for you I recommend you search the MSDN Forum for Visual Studio WPF Designer.  If you run the resetskippkgs command and get back an error message, search on that error message in the WPF Designer forum. 

     

    --Karin

     

    ||Karin Meier||Windows SDK PM||Samples.Community|| http://blogs.msdn.com/KarinM ||

     


    Karin Meier
    Monday, December 29, 2008 5:46 AM
  • Vista Ultimate x64 SP1, VS 2008 SP1 and regsvr solution worked. Thanks!
    Information Systems and Custom Software Development
    Friday, January 23, 2009 7:42 PM
  • I experienced this after installing the Windows 7 SDK on Win7 Beta after VS2008.  Manually setting the registry key back to TextMgrP.dll fixed it! Thanks!
    Thursday, January 29, 2009 7:00 AM
  • Sorry to say, but this solutions was absolutly useless for me. I've described my problem here: http://social.msdn.microsoft.com/Forums/en-US/vswpfdesigner/thread/6c7a9c6c-d565-46ae-83ed-d39998c0fd41/
    Monday, February 16, 2009 1:52 PM
  • Same problem, same solution. Thanks!!
    Xml MVP
    Thursday, February 19, 2009 1:02 PM
  • I tried the above and it did fix the problem for me.

    Now I am having a problem in my XAML when I try to create a Command binding.

    'CommandValueSerializer' ValueSerializer cannot convert from 'System.String'.

    I looked on the forum but have not found anything of value are these two issues related.  I am trying to create a command in my Main XAML window and I have other commands that work fine.

    Here are my command bindings

        <Window.CommandBindings>
            <CommandBinding Command="New"
                            Executed="Command_FileNewView"
                            CanExecute="Command_CanFileNewView"/>
            <CommandBinding Command="Open"
                            Executed="Command_FileOpen"
                            CanExecute="Command_CanFileOpen"/>
            <CommandBinding Command="Save" 
                            Executed="Command_SaveView"
                            CanExecute="Command_CanSaveView"/>
            <CommandBinding Command="Exit" 
                            Executed="Command_ExitApplication" 
                            CanExecute="Command_CanExitApplication"/>
    
        </Window.CommandBindings>
    

    It is only failing on the last one.

    Any help is greatly appreciated.

    Thanks,
    -ja

    Thursday, May 07, 2009 9:34 PM
  • Hey man.. thanks a lot... your solution worked for me.. I struggled lot due to this thing... at Last it worked thanks....
    Wednesday, July 22, 2009 8:48 PM
  • I opened regedit.exe, navigated to the key, found Default empty and copied the path to TextMgrP.dll to the value and then IntelliSense worked for me again. :)

    Thanks a lot for providing a simple solution to a problem so obscure to mortals that it would've sent me through hours of googling and probably reinstallation of VS2008!
    Monday, August 24, 2009 12:00 PM
  • I have the problem when i add a reference to my solution
    The problem is caused by Microsoft.Practices.Composite.Wpf.dll (runtime version v2.0.50727)
    when i add this as a reference to my solution i have no intellisence.
    What to do?
    Tuesday, November 24, 2009 8:11 AM
  • Hi,

    I am seeing this problem on a brand new  Windows 7 x64 computer with VS 2008 SP1 and silverlight 3.

    I don't get any intellisense  for wpf  XAML files or SIlverlight generated XAML files 

    I have tried all the suggestions:
    1. regsvr32 "%CommonProgramFiles(X86)%\Microsoft Shared\MSEnv\TextMgrP.dll"
    2.  devenv /setup 
    3.  devenv /reset....  option 

    totally reinstalled Visual Studio 8.  I get the problem without installing anything else.  I get the problem if I manually open a file with the WPF designer (from within Visual studio)

    To be explicit,  the problem I get is no syntax help in the intellisense (.  ie no help in filling out the code as I type.     Coloring seems to be Ok

    Is there some  new conflict with Windows 7 or especially windows 7 x64? 

    Thanks

    David

    Wednesday, January 13, 2010 1:11 AM
  • Hi David,

     

    If you’re seeing this problem without installing the Windows SDK for Server 2008 and the recommended registry key update didn’t fix, you have a completely different problem.  Do you have any Windows SDK installed?  You might get a speedier reply on the WPF forum of the Silverlight (formerly WPF/E) Developer Issues forum, if you haven’t already tried.

     

    I haven’t heard of any issues like this one.  The issue described in this post was caused by a component that the Windows Server 2008 installed – the Document Explorer Help Viewer. 

     

    --Karin

     

    ||Karin Meier|| Program Manager||Windows C++ Team|| Windows SDK


    Karin Meier
    Wednesday, January 13, 2010 3:01 AM

  • regsvr32 "%CommonProgramFiles(X86)%\Microsoft Shared\MSEnv\TextMgrP.dll"
    didn't work.

    I tried
    devenv /resetskippkgs
    Bingo!

    thank you Karin.
    namhyuk
    Saturday, January 30, 2010 7:33 PM
  • Thank you. I tried installing the dll itself using the Command Prompt as Administrator and that worked. Now i am happy.

     

    Friday, April 16, 2010 3:03 PM
  • Visual Web Developer 2008 Express Edition.

     

    My PC:

    Following is my PC, Windows XP Home Edition (X86).

     

    Problem:

    Am new to silverlight 3. After went through this nice SL3 Getting started video http://www.silverlight.net/learn/videos/silverlight-videos/getting-started-with-silverlight-development/. Thought of do the same at my pc. Somehow or rather I expect the same intellisence guide in the MainPage.xaml. but I didn’t find any intellisense guide there.

     

    Solution I have tried:

    1. Repair Visual Studio
    2. Register textMgrP.dll manually
    3. See the Default value under HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32. if not fill up with C:\Program Files\Common Files\Microsoft Shared\MSEnv\TextMgrP.dll.
    4. VS2008 Express Edition and Silver light 3, try installed this two vice versa

     

    Scenario:

    Same scenario happen in two machine windows server 2003 and xp home edition. In both machine I first install vs2010, silverlight 4 and .netframework 4. Because of some problem targetFramework="4.0" in the IIS. I choose to downgrade to vs2008EE and test the samples. ____ my bad time struck in this very basic XAML Intellisense issue for more than two days. Situations give me less confidant to proceed further.

     

    Conclusion:

    After follow this thread carefully and tried all the solution nothing seems works and it took almost 2 full days. Disappointed and create situation like silverlight may be tuff. I saw few people having this issue and no proper answer to this solution. Is it because vs2010EE is free? 

     

     

     

     

     

    Why this problem can not be solved since Friday, February 22, 2008 8:09 PM


    StephenMas
    Wednesday, May 05, 2010 7:10 AM
  •  

    Visual Web Developer 2008 Express Edition.

     

    My PC:

    Following is my PC, Windows XP Home Edition (X86).

     

    Problem:

    Am new to silverlight 3. After went through this nice SL3 Getting started video http://www.silverlight.net/learn/videos/silverlight-videos/getting-started-with-silverlight-development/. Thought of do the same at my pc. Somehow or rather I expect the same intellisence guide in the MainPage.xaml. but I didn’t find any intellisense guide there.

     

    Solution I have tried:

    1. Repair Visual Studio
    2. Register textMgrP.dll manually
    3. See the Default value under HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32. if not fill up with C:\Program Files\Common Files\Microsoft Shared\MSEnv\TextMgrP.dll.
    4. VS2008 Express Edition and Silver light 3, try installed this two vice versa

     

    Scenario:

    Same scenario happen in two machine windows server 2003 and xp home edition. In both machine I first install vs2010, silverlight 4 and .netframework 4. Because of some problem targetFramework="4.0" in the IIS. I choose to downgrade to vs2008EE and test the samples. ____ my bad time struck in this very basic XAML Intellisense issue for more than two days. Situations give me less confidant to proceed further.

     

    Conclusion:

    After follow this thread carefully and tried all the solution nothing seems works and it took almost 2 full days. Disappointed and create situation like silverlight may be tuff. I saw few people having this issue and no proper answer to this solution. Is it because vs2010EE is free? 

     

     

     

     

     

     

    Why this problem can not be solved since Friday, February 22, 2008 8:09 PM


    StephenMas


    StephenMas
    Thursday, May 06, 2010 1:43 AM
  • This flavor worked for me as well.  Thank you! Bob
    Wednesday, May 12, 2010 1:32 AM
  • And when you think to solve this MAJOR problem...never?

     

     I followed every single step in tutorial for configuring VS2008sp1 for silver light and in the end auto complete doesn't work...Why for god sake??

    Sunday, August 22, 2010 9:25 PM
  • And when you think to solve this MAJOR problem...never?

     

     I followed every single step in tutorial for configuring VS2008sp1 for silver light and in the end auto complete doesn't work...Why for god sake??

     

    It seems that different updates break intellisense. I tried all above with no help.

    What finally worked is reinstalling Silverlight_Developer.exe.

    Tuesday, September 21, 2010 6:26 PM
  • Hi Karin,

    I had faced a similar issue, but in SSMS 2008.  Intellisense was working fine first, but after I installed TFS 2008 (part of VS 2008), Intellisense in SSMS 2008 stopped working.  I upgraded my SSMS to 2008 R2, but that didn't resolve the issue.

    I came across this post then and tried registering TextMgrP.dll.  It failed with a error code 0x80070005, but my SSMS 2008 Intellisense started working again.  Not sure what happened, but this helped, so I thought I would say Thanks!

    Thank you,
    Suthan

    Thursday, December 23, 2010 5:27 AM
  • I've tried the second solution "Register TextMgrP.dll manually" (on X86, SDK v6.1) -- it works!

    Thanks Karin!




    Thanks for your message!
    Thursday, January 27, 2011 10:55 PM

  • regsvr32 "%CommonProgramFiles(X86)%\Microsoft Shared\MSEnv\TextMgrP.dll"
    didn't work.

    I tried
    devenv /resetskippkgs
    Bingo!

    thank you Karin.
    namhyuk

    Thanks Namhyuk, I did the same and bingo too!!!

    If register TextMgrp.dll does not work, open the command and type:     devenv /resetskippkgs

    It works  :)      

    Monday, June 13, 2011 3:04 AM

  • regsvr32 "%CommonProgramFiles(X86)%\Microsoft Shared\MSEnv\TextMgrP.dll"
    didn't work.

    I tried
    devenv /resetskippkgs
    Bingo!

    thank you Karin.
    namhyuk

    Thanks Namhyuk, I did the same and bingo too!!!

    If register TextMgrp.dll does not work, open the command and type:     devenv /resetskippkgs

    It works  :)      

    OrElse try this,

    Type 'regedit' in your 'Run' and search for

          ·         On X86 machines: HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-                      D07AFD52F395}\InProcServer32

    ·         On X64 machines: HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

     

    if you find the 'default' value(data) empty then search for the TestMgrP.dll in your machine and set that path as the value(data)..

    I got this issue but now its fixed..

     

    Thanks To Karin Meier

     



    Thursday, August 25, 2011 12:07 PM
  • Yeah me too. C:\Program Files\Common Files\microsoft shared\MSEnv\TestMgrP.dll

    This is the correct path for me. The path when VS gave error was Microsoft Shared(see uppercase). I found TestMgrP.dll on windows explorer and copied the exact path, pasted it. Done!

    Wednesday, September 07, 2011 6:13 PM
  • Thanks Karin. Registering the TextMgrP.dll manually worked a treat.
    Thursday, February 16, 2012 11:01 AM