none
Unable to change permissions in regedit in Vista despite using administrator account

    Question

  • How do you work around this? The only thing that happens is that a message appears that Windows Security is unable to save permission changes and that access is denied.
    Monday, April 02, 2007 6:36 PM

All replies

  • You may not have the permissions to change the ACL on that key by default, even as admin.

    You could still take ownership of the key and then give the administrators group sufficient access, but if the key is protected this way, there could be a good reason. You'll be modifying its content at your own risks...

     

    Wednesday, April 04, 2007 2:07 AM
  • I am having the same problem and still have not seen or heard of the way around it.
    Thursday, April 19, 2007 11:51 PM
  • right-click the key, click security, click advanced, click owner, click other users or groups, click advanced, click find now, select your account, click ok, click ok, select your account, click ok, now you can set permissions as you wish. do this for every key you want.
    • Proposed as answer by SamAgain Thursday, December 02, 2010 10:25 AM
    Saturday, October 27, 2007 11:10 AM
  • LvD, thx man, i would have nevr thought of that, its really annoying but its the only way to override the security thing.

    • Proposed as answer by belcherman Friday, June 03, 2011 7:32 PM
    Sunday, October 28, 2007 10:41 PM
  • I am simply trying to remove all the foreign fonts I will never use to get it to a basic set so I can use a 3rd party font manager. Vista has over 90 fonts in the font folder and will not allow me to delete them.

    I am signed on as an administrator and when I try to change permissions to allow full control, I get "Access Denied," and permission reverts back to "Read & Execute."

    Any leads would be appreciated...thank you,
    Jamie
    Monday, December 10, 2007 6:35 PM
  • Hi Team,

     

    Please perform the following steps to reset the permissions in registry.

     

    1. Download and install the SubInACL utility.

    Link: http://www.microsoft.com/downloads/details.aspx?FamilyId=E8BA3E56-D8FE-4A91-93CF-ED6985E3927B&displaylang=en

     

    2.Create a new text file named fix_registry_permissions.bat and add the following text to it and save it.

     

    cd /d "%programfiles%\Windows Resource Kits\Tools"

    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f

    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f

    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f

    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f

    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f

     

    3. Run the file from the elevated command prompt.

     

    You can also try the following command if the above mentioned steps doesnt help you.

    a) secedit

    b) icacls

     

    Please let me know if this fixes the issue.

     

     

     

     

    • Proposed as answer by Schreibman Tuesday, August 10, 2010 5:39 PM
    Monday, December 17, 2007 4:08 PM
  •  

    Hello,

     

    I just now saw your site and discussions and need help. I have a Blackberry Curve 8310 and cannot get the desktop manager to launch on my Toshiba satellite laptop. The version I  need to use is desktop mgr 4.3 without Media Mgr. After 3 days of trying to get this to work I am ready to throw the phone in the trash!!!

     

    I even talked to the very own RIM (BB) experts for over an hour and they gave up and told me it is a Vista problem so I need to talk to Microsoft folks. She directed me to the SubInAcl tool. However, my laptop will not let me open it for security reasons. I have Vista Ultimate. So now what do I do????????

     

    Please help anyone...

     

    Paula

    Tuesday, July 08, 2008 10:39 PM
  • Tried all sorts. Rateesh's fix worked for me!

     

    Thursday, September 04, 2008 6:46 AM
  • Thanks LvD. Tried your suggestion but still does not work,

    I face a problem where all my files stored in a portable HDD failed to be opened. I managed to open them in Win2K and Win XP previously without any encryption. Now, I notice my files suddenly have the attribute AE when I checked the properties in Windows Vista. I wonder why. If I have not encypted them before, how could I decrypt them now?

     

    I treid to effect a take ownership registry as advised by my laptop manufacturer but still fail to open any. Called Microsft but my lines were cut off a couple of times while waiting in queue. I am desperate to open these Office 97 and 2003 files in my portable HDD. Anyone can help?

     

    Thank you.

    Friday, September 05, 2008 5:35 AM
  • Hi Rateesh,

     

    Nope. It does not work on my laptop. Any other options?

     

    Thank you.

     

    Kwan

     

    Friday, September 05, 2008 6:20 AM
  • Thanks a lot for suggestion. i was struggling for this . At last i was able to change the permission in the Windows Vista 64 bit
    Wednesday, September 17, 2008 7:12 AM
  • Thanks to Pai's for his post, its help me to solve my problem.

     

    Wednesday, September 17, 2008 4:02 PM
  • Rateesh,

    I'm having similar problems. I tried this & it didn't work. I'm using Vista Home Basic. Recently when I've tried to update or reinstall certain programs, I get this kind of permission error & the operation rolls back, even tho I'm the administrator for this machine. I started getting errors in Excel ("Cannot use object linking and embedding") that prevented it starting. So from my company I got a CD to reinstall it. I intended to uninstall before reinstalling, but couldn't find a way to uninstall. Anyway, during reinstallation I get Error 1402 saying I don't have permission to change UNKNOWN\.wll\Word.Addin.8\ShellNew. I tracked down that key & followed instructions from this forum & elsewhere to change permissions on the key. But no permission change sticks. I get "Unable to save permission changes on ShellNew. Access is denied." If I click "Retry" I get "ShellNew cannot be opened. An error is preventing this key from being opened. Details: Access is denied." I even get messages saying I'm not authorized to look & see who's the owner of the key.

    I got similar errors recently when trying to update iTunes. Different key, of course, but none of my attempts to change permissions on the offending keys have worked.

    Any other things I can do?

    Pat
    Saturday, October 18, 2008 4:13 PM
  •  

    Hi,

    Thank you Pai! This fixed a problem on a friends XP Pro machine!

     

    For some reason FLASH stoped working on a friends XP Pro. It wouldn't install. Registry keys were not accessable, and the Registry didn't know or could not calculate permissions and would not allow changing permissions.

     

    The SubInACL utility and your batch file fixed it. After downloading SubInACL and running your batch file, I was able to run a downloaded install for FLASH, (wouldn't install off their web page).

     

    Thank you Pai for postin! This was on XP!!!

     

    Andy

    Sunday, November 02, 2008 12:47 PM
  • I did this on two different programs with on changes.  On the internet account.  I now have 4 groups and there are only 3 people who use this pc.  On the cookies properities when I go to advanced; I am blocked by the security warning.

    I believe I have put these restrains on.  We didn't want to get a bunch of yuch; so we put on restrictions.  But I can't even get a screen name for me or my husband.  I don't have the authority.  I would like to reset my controls so we all have access to everything.  We are all over 35!   Is that possible?
    Tuesday, December 16, 2008 8:13 PM
  • Nope Doesn't work.Vista is the worst point blank.
    Friday, December 18, 2009 11:59 AM
  • Pai's response DID allow me permissions access to regedit on Vista SP1.  However, the *.exe solution that's worked for so many people at http://www.winhelponline.com/articles/105/1/File-association-fixes-for-Windows-Vista.html  still doesn't work when I restart my machine.  I've tried disabling Norton anti-virus, although it's not even working b/c it's an exe file, and still I get the dreaded "Open With" window when clicking on exe files.  Maybe I have a virus?  Any other explanations?  ANYBODY??
    Tuesday, January 12, 2010 6:56 AM
  • You may not have the permissions to change the ACL on that key by default, even as admin.

    You could still take ownership of the key and then give the administrators group sufficient access, but if the key is protected this way, there could be a good reason. You'll be modifying its content at your own risks...

     


    Try going to KB313222

    You will get the resolution

     

    Sunday, July 11, 2010 8:01 PM
  • < cd /d "%programfiles%\Windows Resource Kits\Tools"

    subinacl /subkeyreg "HKEY_LOCAL_MACHINE\.\.\"  /grant=administrators=f /grant=system=f > is working for me. After all I could delete the Keys.

     

    Thanks.

    Friday, September 17, 2010 12:26 AM
  • right-click the key, click security, click advanced, click owner, click other users or groups, click advanced, click find now, select your account, click ok, click ok, select your account, click ok, now you can set permissions as you wish. do this for every key you want.

    To summerize, find the key you want to access, right click -> Permissions -> Advanced -> Owner ( select the specific owner or group you want and click ok) -> then you can do whatever you want to the key. This works for me.
    Please mark the right answer at the right time.
    Thanks,
    Sam
    Thursday, December 02, 2010 10:27 AM
  • It worked for me! Thank you very much.

     

    Wednesday, December 22, 2010 12:21 PM
  • it still doesn't work for me ! it says " Unable to set new owner on data.Access is denied." Please help me ! i really need to do that as SOON as POSSIBLE !
    Wednesday, October 12, 2011 11:49 PM
  • Has this proiblem ever been solved?
    Saturday, January 21, 2012 7:17 PM
  • Thanks Pai_s - this fixed the problom - HOWEVER, I had to run the batch file in safety mode for it to work

    Thursday, March 07, 2013 7:45 PM