locked
Autoplay dialog box not appearing

    Question

  • Vista Home Premium - I place blank media in the CD/DVD drive - but I do not get the dialog box with the burn options. I get nothing. Same for blank CD and DVD.

    Even from the drive, selecting the "Open Autoplay" option I get nothing - no response at all.

    The media type is recognized - a "CD-R" symbol representing the media I am using shows up on the drive image.

    Optical drive is a Samsung SH-S182M. No problem with the drive reading CD/DVD's.

     

    Anyone having this problem?

    Saturday, March 03, 2007 2:24 AM

Answers

  • Hello DWillett!

    I have not heard of an issue like this before.

    If you open my computer with a blank piece of media in the drive and double click on the device, do you get any dialog box? 

    To make sure I read that correctly: you're saying you DO get autoplay when you put in a piece of pre-recorded media?

    thanks,

    garrett jacobson
    SDE, Optical Platform Group

    Monday, March 12, 2007 2:54 PM

All replies

  • Hello DWillett!

    I have not heard of an issue like this before.

    If you open my computer with a blank piece of media in the drive and double click on the device, do you get any dialog box? 

    To make sure I read that correctly: you're saying you DO get autoplay when you put in a piece of pre-recorded media?

    thanks,

    garrett jacobson
    SDE, Optical Platform Group

    Monday, March 12, 2007 2:54 PM
  • I to have this problem, (not reading Blank media, no autorun box) just doesnt "see" blank media (any type) System says everything is running fine
    Thursday, March 15, 2007 3:51 PM
  • The same problem with Samsung TSSTcorp SH-S183A with blank media.

    Preformatted media works just fine.

    Also writing to a preformatted (in another computer) CD-RW works fine.

    Is it hardware, firmware or software problem?

    Is there a way to bring up the formatting dialog manually?

    Saturday, March 31, 2007 10:42 AM
  • Right click on cd-rw/dvd drive and go to properties. Under properties u will find option of auto play. there will be a checkbox what u can select to enable auto play option. Please let me know if this works.

    Thanx

    Wednesday, April 18, 2007 10:57 PM
  • Vista cannot read a blank disk, no AutoPlay option, no Format available

     

    I have had this problem on 4 machines that I built using Windows Vista, based on Gigabyte motherboards (1 GA-P35C-DS3R, 3 GA-P35-DS3R.)  The problem on my machines turned out to be a bad driver written by a company named JMicron (jmicron.com) and supplied with the motherboards by Gigabyte.  I do not know if the bad JMicron driver ships with other Gigabyte motherboards as well, but I suspect so.  It is possible that JMicron supplies drivers to other motherboard manufacturers.  I don’t know what the effect of this driver is on Windows XP systems.

     

    The Symptoms:

    1)      Inserting a blank CDR (or CDRW) or DVDR (or DVD +/- RW) does not bring up AutoPlay dialog.

    2)      Attempting to use the disk in windows explorer generates the error “Windows cannot read the disc in drive X. Make sure that the disc uses a format that Windows recognizes.  If the disc is unformatted, you need to format it before using it."

    3)      In Device Manager, under DVD/CD-ROM drives, the CD/DVD device says it is “SCSI”, even though it is not a SCSI device.  It should say “ATA”.

    4)      In Device Manager under Storage Controllers there is a device named “Gigabyte GBB36X Controller.”

     

     

    The Issue:

    JMicron supplied a device driver to Gigabyte that has something to do with support for PATA drives.  They based it off a SCSI device driver, but failed to fully re-write it for PATA. The device driver reports to windows that the device is a SCSI device, and hands other bad data to Vista.  Because of the bad data supplied by the faulty device driver, Vista fails to identify that there are valid CD/DVD PATA device(s).

     

     

    The Solution:

    Go to Control Panel/Device Manager.  Click on “Storage controllers”.  Double-click on the “Gigabyte GBB36X Controller.”  Select “Roll Back Driver”, and Yes/OK any dialogs asking to confirm.  Afterwards the “Gigabyte GBB36X Controller” will be gone.  Check under DVD/CD-Rom drives.  The device(s) should now show up as ATA, not SCSI.  The device should now work properly.

     

    Note: On two machines I did not reboot after doing this and subsequently had a blue-screen crash (after which everything was fine.)  On the other two machines I did a reboot after rolling back the device and had no crash.

     

     

    Microsoft is aware of the issue and is working with Gigabyte to correct the problem.

     

     

     

    Tuesday, December 18, 2007 4:10 AM
  • mr_andrew...

     

    could you please email me at optissue -at- microsoft -dot- com (of course, fill in as appropriate Smile) ... i'd like to speak with you about this issue....

     

    thanks!

    Tuesday, December 18, 2007 9:31 PM
  • There is a drver on the JMicron page that can be used to fix this problem - see here, and the ftp link at the bottom to the actual driver. it does support Vista 32 and 64. Not sure if / when the Gigabyte driver will be updated with the newest JMicron version.

    When installing, chooose the IDE part of the driver.

    Friday, January 18, 2008 6:22 PM
  • I'm having a similar AutoPlay problem. The AutoRun dialog no longer appears when I connect portable devices. It used to work but not anymore. I need help resolving this. I'm running Vista Home Premium.
    Saturday, February 09, 2008 12:06 AM
  • This just started happening.  When I first got this machine in November 2007, I could put in software CD/DVD and the dialog would come up and I could install.  Tonight i put in a brand new Adobe Lightroom CD and nothing.  When I navigate in explorer to the CD/DVD and click, it asks me if I want to format it.  Same thing happens with the install CD for the Sony Alpha camera.  Nero's info tool kit can read and says the CD are ok, and have the software I expect them to have.
    I can still burn new blank DVD, but I suspect Nero is bypassing things.

    I've got Windows Vista home basic.  Currently in the process of downloading Service Pack 1.

    TSSTcorp CDDVDW SH-S202N ATA Device
    Driver date 6/21/2006
    Driver Version 6.0.6000.16386
    (Roll back driver is greyed out)

    This needs to be fixed very quickly.  It's obvious that one of the automatic hotfixes I let the machine handle has screwed up the driver.  Up until now I've had no real complaints about Vista.


    Tuesday, April 01, 2008 4:10 AM
  • Yes, I also have this problem with my SanDisk Cruzer Micro (Flash Drive). When I plug my Flash Drive into my computer the folder pops up, but i want the AutoPlay Prompt to pop up. Is there anyway to get this back? On all the Content Types (in autoplay tab) i chose "Prompt me each time to choose an option". I restarted my computer and plugged it back in and no Auto Prompt pop up. Please Help Me Out.

     

    Thank you,

    Tyler J. Wilkerson

    Wednesday, July 16, 2008 11:08 PM
  •  

    This forum focuses on OS level topics and is primarily intended for application developers. It is not intended for discussion of user-level optical issues observed in concrete applications, such as DVD Maker or Windows Explorer. Please use other support channels for user-level issues (e.g. http://support.microsoft.com for Microsoft products).

     

    In addition, Windows Vista discussion groups (see http://windowshelp.microsoft.com/communities/newsgroups/en-us/default.mspx) are another good place for discussions of issues that are outside the scope of this forum.


    This thread will be locked.
    Sunday, July 20, 2008 4:51 AM