none
Install Fails with Error "Setup has failed. Make sure Terminal Services are enabled before re-running setup.

    Question

  • Name of setup file is WindowsDesktopSearch-KB917013-V301-XP-x86-enu.exe which I downloaded directly from Microsoft.com today.

    Besides I have Remote Access (TS) turned on in my Windows XP SP2 system, what could be causing this problem?
    Friday, June 22, 2007 2:43 PM

All replies

  • I have the same issue.

     

    Evidently, the service "TermService" must be enabled and running before Windows Desktop Search (WDS) will install.

     

    I have the service disabled on my laptop because I don't have any reason to remotely control my laptop.

     

    I would like to understand why WDS needs terminal services to function.

     

     

    Friday, June 22, 2007 3:05 PM
  • Windows Search runs as a service under the SYSTEM account. It has a dependency on the Terminal Service, which is use to allow creating process (SearchProtocolHost.exe) under the logged on user to index their data (Microsoft Outlook email for example).
    Friday, June 22, 2007 10:47 PM
  • Hi Eric,

    Not sure if you were talking to me but I have Remote Connections checked (TS on) so I shouldn't get that error anyway.

    My laptop running Vista Business, which I believe uses WDS 3.x, has a very fast search and I'm happy with it. But my development machine is XP SP2 and the Google Desktop Search index files were getting out of hand so I started look at WDS again. The last time when I install Outlook 2007 was not a good experience and it continues on now apparently. I've switch to Copernic and so far I'm happy. The interface is clean and you have more control over the index.
    Saturday, June 23, 2007 4:58 AM
  • Remote Connections being checked doesn't necessarily imply that TS is on. Try going to Control Panel->Administrative Tools -> Services and finding "Terminal Services" in the list. Make sure that its status is "Started". If it's not, right-click on it, select "Properties", and click the "Start" button.
    Monday, June 25, 2007 5:36 AM
  • Well TS is disabled which explains the error, and that it was correct ;-)

    I still don't understand the dependency of WDS and TS. And why I have to enable a service I don't want on just to get a desktop search installed.

    BTW my positive experience with copernic is, unfortunately, falling quickly. The completed index is about 2.5gb vs 11gb with GDS. But search results take about 1.5 - 2 seconds and the email linking is little screwy. I'm going to turn it off and install WDS now that I know the problem and how to resolve it. I hope WDS is all that and a box of donuts too.

    Thanks to the MSFT staff for replying. I would appreciate any other links or information on why WDS requires TS to be turned on.

    Monday, June 25, 2007 6:57 AM
  • Let me try to rephrase the explanation for WDS's dependency on TS.

     

    WDS is a service, so it must run under SYSTEM account. However, some of the data that WDS is supposed to index are private, so it can be accessed only by a given user (i.e., by a process that has the credentials of a user to whom these data belong). In other words, a  SYSTEM process cannot access these data directly.

     

    What is the solution? WDS uses TS to start another process with the credentials of the user who has the right to access the data. This process handles the user's data and passes the results to the main service process (SearchIndexer.exe). The latter stores the results into the index.

    Monday, June 25, 2007 8:08 AM
  • Seems an odd way to go about it but ok.

    Ok so I've had it installed overnight and things seem ok. Search in taskbar is snappier than CDS and outlook search is back to normal.

    But it seems my original pet peeve with WDS is back and going strong as ever. When you tell it to SNOOZE INDEX it says it's snoozing but my diskactivity light and filemon says it's going right ahead with indexing, why?

    Why is it indexing when I've told it to snooze? I need this to behave or I have to uninstall it AGAIN and go back to the beast of GDS.
    Monday, June 25, 2007 12:29 PM
  • I'm getting the same message when I try to install this app, but when I go and try to enable TS in the services it isn't there. I'm running Windows Media Center SP2. My guess is that Media Center cannot act as a host for TS? I don't even see the "Remote" tab under the System Properties.

    Any insight on this would be greatly appreciated.
    Friday, February 29, 2008 2:39 PM
  • I have the same situation with Media Center SP3...   Is there any solution to this problem of not having terminal services avail...

     

    Monday, August 25, 2008 4:45 AM
  •  

    I have exactly the same problem. XP Media Center SP3 and cannot install because of the disabled Terminal Services which I can't enable....

     

    Please help!!

    Tuesday, November 25, 2008 1:20 PM
  • Hello Frank,
    try the following!

    Resolution

    To resolve the problem, make sure that Terminal Services are started and running. Follow these steps:

    • Click Start, Run and type Services.msc
    • Double-click Terminal Services
    • Make sure that its Startup type is set to Manual
    • Close Services MMC
    • Restart Windows and try installing Windows Desktop Search now.

    Note

    1. If the Terminal Services entry is missing in the Services MMC listing, download termservice.reg file available at the end of this article. Save the file to Desktop, right-click on the file and choose Merge. Restart Windows for the changes to take effect.
    2. If Terminal Services startup type is already set to Manual and if remains in a stopped state, try starting the service by clicking the Start button. Note down the error messages if any.

    • Proposed as answer by AlexanderMai Friday, August 28, 2009 5:55 PM
    Sunday, January 04, 2009 5:00 PM
  •  

    It worked perfectly! Thanks!
    Sunday, January 04, 2009 10:04 PM
  • Hello Frank,
    try the following!

    Resolution

    To resolve the problem, make sure that Terminal Services are started and running. Follow these steps:

    • Click Start, Run and type Services.msc
    • Double-click Terminal Services
    • Make sure that its Startup type is set to Manual
    • Close Services MMC
    • Restart Windows and try installing Windows Desktop Search now.

    Note

    1. If the Terminal Services entry is missing in the Services MMC listing, download termservice.reg file available at the end of this article. Save the file to Desktop, right-click on the file and choose Merge. Restart Windows for the changes to take effect.
    2. If Terminal Services startup type is already set to Manual and if remains in a stopped state, try starting the service by clicking the Start button. Note down the error messages if any.


    Yepp it¨s work great! thanks and have a fun with win search 4.0 ;))
    Thursday, May 14, 2009 12:02 PM
  • Dear Friend,

    I wasn't able to download the file.
    I couldn't find the link for the file termservice.reg
    Please send it to me at: is_erayo@hotmail.com

    I will apreciate it.

    Regards,

    Djalmar Enrique Rayo
    Monday, November 09, 2009 1:36 AM