none
unable to register a control on a clean vista box

    Question

  • Hi,

      I have a control that registers with no issues on my development box (vs2005, vista business)...but on my clean test box (vista ultimate), it generates this error:

     INFO: Manifest Definition Identity is (null).
     INFO: Reference: Microsoft.VC80.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762"
     INFO: Reference: Microsoft.VC80.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762"
     INFO: Reference: Microsoft.VC80.ATL,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762"
    INFO: Resolving reference Microsoft.VC80.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762".
     INFO: Resolving reference for ProcessorArchitecture x86.
      INFO: Resolving reference for culture Neutral.
       INFO: Applying Binding Policy.
        INFO: Find publisher policy at C:\Windows\WinSxS\manifests\x86_policy.8.0.microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.312_none_91939f3c671de810.manifest
        INFO: No binding policy redirect found.
       INFO: Begin assembly probing.
        INFO: Did not find the assembly in WinSxS.
        INFO: Attempt to probe manifest at C:\Windows\assembly\GAC_32\Microsoft.VC80.CRT\8.0.50727.762__1fc8b3b9a1e18e3b\Microsoft.VC80.CRT.DLL.
        INFO: Attempt to probe manifest at C:\Windows\system32\Microsoft.VC80.CRT.DLL.
        INFO: Attempt to probe manifest at C:\Windows\system32\Microsoft.VC80.CRT.MANIFEST.
        INFO: Attempt to probe manifest at C:\Windows\system32\Microsoft.VC80.CRT\Microsoft.VC80.CRT.DLL.
        INFO: Attempt to probe manifest at C:\Windows\system32\Microsoft.VC80.CRT\Microsoft.VC80.CRT.MANIFEST.
        INFO: Did not find manifest for culture Neutral.
       INFO: End assembly probing.
     ERROR: Cannot resolve reference Microsoft.VC80.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762".
    ERROR: Activation Context generation failed.
    End Activation Context Generation.

     

    I got this by using sxs tracing while running regsvr32 on the component.  I have installed the vs2005 redistributable and tried rebooting...no luck.  any ideas?

     

    this thread seemed close, but I don't understand how changing the manifest file would fix this. 

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1049783&SiteID=1

    The manifest file is generated during a build of the component and I only copied the .dll file over anyways.

    -dave

    Friday, March 30, 2007 6:05 PM

Answers

  • I was able to resolve by installing the correct vcredist_x86.exe (the one off my vista dev box)

     

    not sure which version i was installing vs. what the correct version is...but check that first if you run into this issue.

    Friday, March 30, 2007 6:49 PM