none
Cannot Open Command Prompt in Administrator Mode

    Question


  • Greetings all.

    While trying to update Vista to SP1, I found I had lost the ability to start a command prompt in Administrator mode

    I am the only user, and have administrator privileges.  Neither right clicking on the command prompt icon and selecting "Run As Administrator", nor entering "command" in the run box, then ctrl-shift-enter, has any effect - - in fact, nothing happens at all.

    No problems getting the standard command prompt to open - - unfortunately, I'm unable to successfully run several processes that require administrator privileges.

    Nothing in the KB that's helpful, and nothing on Google.  Your brains are my last hope.

    Thanks
    Thursday, March 20, 2008 2:52 AM

Answers

  • Merlin,

     

    did you try to change GP settings for UAC?

    Maybe it will help.

    open GP console (gpedit.msc)

    Navigate to: Computer Configuration/Windows Settings/Security Settings/Local Policies/Security Options

    Go to end of list and you will see lots of User Account Control: settings.

    Tell me what your settings looks like...

     

    Robert

    Saturday, March 22, 2008 8:29 PM

All replies

  • Hm.  What happens if you try to open the Device Manager in the Control Panel?  Prompt, no prompt?

     

    In task manger, in the 'services' tab - is Appinfo listed as 'running'?

    Thursday, March 20, 2008 4:43 PM

  • Hi - - David. Thanks for the reply. 

    No problems opening the Device Manager - - UAC security prompt pops up, and I tell it to permit access - - device manager shows all.

    Application Information is listed as "Started" in the "Computer Management - Services" and App Info shows as "Running" in the task manager.  Startup type was listed as "Manual" - - I changed that to "Automatic" - - no change.  Still can't run command prompt with administrator privileges.

    Merlin

    Saturday, March 22, 2008 8:06 PM
  • Merlin,

     

    did you try to change GP settings for UAC?

    Maybe it will help.

    open GP console (gpedit.msc)

    Navigate to: Computer Configuration/Windows Settings/Security Settings/Local Policies/Security Options

    Go to end of list and you will see lots of User Account Control: settings.

    Tell me what your settings looks like...

     

    Robert

    Saturday, March 22, 2008 8:29 PM
  • Hi - - Robert:

    Unfortunately, MicroS - - t elected to disable the Group Policy Editor for Vista Home Premium.

    I even ran the management console (MMC) and tried to add the Policy Editor snap-in, but ran afoul of a little nastygram informing me that because I only had a baby version of vista, the only policy editing I could do was via the control panel (basically nothing).

    I am currently signed in as the only user with administrator privileges.

    I opened up the registry editor and went to
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    but couldn't make much out of the entries there.  All the keys seemed to be at defaults.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
    "ConsentPromptBehaviorAdmin"=dword:00000002
    "ConsentPromptBehaviorUser"=dword:00000001
    "EnableInstallerDetection"=dword:00000001
    "EnableLUA"=dword:00000001
    "EnableSecureUIAPaths"=dword:00000001
    "EnableVirtualization"=dword:00000001
    "PromptOnSecureDesktop"=dword:00000001
    "ValidateAdminCodeSignatures"=dword:00000000
    "dontdisplaylastusername"=dword:00000000
    "legalnoticecaption"=""
    "legalnoticetext"=""
    "scforceoption"=dword:00000000
    "shutdownwithoutlogon"=dword:00000001
    "undockwithoutlogon"=dword:00000001
    "FilterAdministratorToken"=dword:00000000

    Didn't see anything that would let me configure administrator privileges at the command window.

    I may try spooling up ERD-Commander to see if that will let me edit group policies in an XP environment - - however I am more than a little fearful of making any changes to a Vista registry using an XP compatible OS.

    Merlin

    Sunday, March 23, 2008 1:32 AM

  • More wierd insights:

    I went to the Windows\System32 folder and changed ownership of CMD.EXE from "Trusted Installer"
    to "Administrators".  NOW I can right click on the .EXE file, select "open as administrator" and it WORKS!

    I also went to the Start\All Programs\Accessories\Command Prompt link, right clicked and altered the properties so that it will always run as an administrator.  That works too.

    However, if I type CMD in the search box, then press Ctrl-Shift-Enter, the start dialog vanishes, and Nothing Happens.

    Now Functional, but scratching my head.  Guess I'll take what I've got and just get over it. 

    Merlin.  
    Sunday, March 23, 2008 3:24 AM