none
TTF Font Installation in Vista

    Question

  • Hello all,

    I'm trying to make my Font Installtion Program Vista compatible. Installation of a TTF file doesn't work anymore as described in http://msdn2.microsoft.com/en-us/library/ms533960.aspx.
    Copying to the windows\fonts directory ends in a "Access denied" error. Can anybody give me a hint how to install a font permanently in vista.

    Thanks
    Michael
    Thursday, November 09, 2006 3:10 PM

All replies

  • You'll need to be elevated to do that; if you're doing this manually, run a cmd prompt as administrator and then try.  If you're doing this from a program, you can move the font installation into the installer - assuming that runs elevated - or separate the functionality from the main app exe into something manifested with requireAdministrator.
    Thursday, November 09, 2006 9:35 PM
  • I'm having the same issue.  I use an installer that is has an embedded manifest which says to run as an administrator, yet my fonts do not get installed in to the font directory.  Any ideas?
    Thursday, November 16, 2006 10:13 PM
  • I have recently upgraded to vista and i am dual booting. I wanted to move ttf fonts from my old xp to vista, by moving the file into the windows/font directory, but when I do this I get an error message up saying "the font < a load pof chinese writing> is not a valid font file and cannot be installed" Then i click ok and the same message pops up with a different string of chinese letters, to which I click ok again and then it stops installing. I have taken this font directly from my xp fonts directory. Is this problem normal

    Tobyb

    Sunday, February 25, 2007 9:19 PM
  • Not sure if this is related to this post or not, I was attempting to drag and drop ttf fonts from a mapped network drive and receiving the error "The File (path name) is not a valid font file and cannot be installed." for all the fonts. Vista asked me for permission via UAC which I assumed was providing the elevated permissions, but still no luck.

    My workaround was to copy the fonts to the C:\ Drive First, then drag them to the C:\Windows\Fonts Directory. Everything worked fine then.

    • Proposed as answer by zgrm Tuesday, March 31, 2009 8:44 AM
    Tuesday, February 27, 2007 4:44 PM
  • Did you ever find a solution to installing TTF fonts in Vista?  I am also trying to transfer a TTF file to Vista from XP, and am getting the same error message.
    Monday, March 05, 2007 11:24 PM
  • If you go into your windows font folder, and then right click, at the bottom of the drop-down list is "install a new font" selct this and at the bottom navigate to the folder that has the new font(s) in it, and then select the font and press install. To copy all of your fonts press selct all, and then install, though this takes a while because you have to decide wether or not to replace the fonts that already exist but you can obviously just press and hold "n" so that it automatically doesn't replace them. You will need administrator privilages to do this.

    Toby b

    Tuesday, March 06, 2007 8:31 PM
  • When I follow the procedure in tobyb121's post for installation on a Vista machine, I get the following error message:  "The file xxxxxx is not a valid font file & cannot be installed." 

    I have successfully installed the same font file on an XP machine.  The file is True Type Lucida Casual, if that makes any difference.

    Thanks for any ideas.

    TJ

    Wednesday, March 07, 2007 2:09 PM
  • Try copying the fonts first to you local hard drive that vista is installed on (C: by default.) Then drag and drop them into your "C:\Windows\Fonts" Folder. Vista would not let me install fonts from a network drive or second hard drive. I had to move it to a folder on the C: Drive first, then install the fonts.
    Wednesday, March 07, 2007 2:36 PM
  • I tried the suggestion from Defining Websites, without success.  I tried drag/drop from the C: drive, and from within the Windows folder.  Same error message as earlier.  But, thanks.

    I am thinking that there is a copyright issue with the TT fonts that has required MS to block their use with Vista.  The font file I am trying to install is a legacy file from older HP Deskjet printer software (on floppies), but  I think I recall that the font was included in the versions of Windows (or Office) from the mid 90s.  I have been using it since about 1996-7.  Anyway, it is a puzzle that Vista rejects the font while XP accepts it.

    TJ

    Wednesday, March 07, 2007 3:53 PM
  • To EVERYONE reading this thread:

    Defining Websites' message above was the MOST helpful advise from this entire thread. I was having this annoying TTF-font-not-installing-problem for the last week! I could not figure why some of my TTF and PFM (or was it PFB) fonts in the transfer to Vista... Every time I'd go to open my files, I'd be getting messages about my missing fonts. I finally went to the web for help. This guys' suggestion was what finally worked for me.

    So. You have to move the fonts to a folder on the C Drive: Drive first, then install the fonts from there.

    Yay! My fonts are baack.... :)

    Good luck, Everyone.

    Thursday, March 15, 2007 7:02 AM
  •  SayRed wrote:

    To EVERYONE reading this thread:

    Defining Websites' message above was the MOST helpful advise from this entire thread. I was having this annoying TTF-font-not-installing-problem for the last week! I could not figure why some of my TTF and PFM (or was it PFB) fonts in the transfer to Vista... Every time I'd go to open my files, I'd be getting messages about my missing fonts. I finally went to the web for help. This guys' suggestion was what finally worked for me.

    So. You have to move the fonts to a folder on the C Drive: Drive first, then install the fonts from there.

    Yay! My fonts are baack.... :)

    Good luck, Everyone.

    yeah...but why the heck did they change the way it worked before....(inside the mind of microsoft engineers) Let's break it to make it better!!!!!!!!!!

    woo frickin' hoo!

    Friday, March 16, 2007 6:38 PM
  • Please see my earlier posts on this thread.

    I have not been able to install TTF fonts by the Defining Websites' method.  The same font files that install with Windows XP will not install with Vista.  I must be missing something.

    TJ

    Friday, March 16, 2007 8:51 PM
  •  TJ Ham wrote:

    When I follow the procedure in tobyb121's post for installation on a Vista machine, I get the following error message:  "The file xxxxxx is not a valid font file & cannot be installed." 

    I have successfully installed the same font file on an XP machine.  The file is True Type Lucida Casual, if that makes any difference.

    Thanks for any ideas.

    TJ

     

    I was having a similar problem as you were.  I had a selection of TTF fonts that would not install in Vista, though I was using them in XP presiously.  What finally worked was going to the fonts folder, and going to File (you may need to hit alt first to make the bar apear) then "Install New Font...".  The wizard is clearly old, as the menu for selecting location looks like it came out of windows 3.1.  Find your fonts in there, and select them all and add them (the Select All button may be very useful).  Note: you cannot choose No to All or Yes to All for replace, so you may want to try to avoid duplicate files.  It let me install the fonts that way that it otherwise rejected.

    I hope that helps.

    Saturday, March 31, 2007 9:33 PM
  • I have had the same problem. Tried everything metioned in this topic and nothing helped. I solved the problem today by using a freeware fontmanager: http://www.fontfrenzy.org.

    Hope this helps!
    Sunday, April 01, 2007 12:36 AM
  • I finally found a work path that allowed installation of the font files referred in my earlier messages.  The font files had installed successfully in an XP machine, but would not install on a VISTA machine.  I copied the installed files from the XP machine, and installed those files on the VISTA machine. 

    I have no idea how or why this worked, but work it did.  What can happen to the font files in this sequence of installations that changes the outcome?

     

    TJ

    Monday, April 09, 2007 4:20 PM
  • The simple answer.

    In vista, even to so much OPEN the font files (whether they are .ttf or opentype files!) they MUST reside on the C:\ drive.

    Simple as that. I had the same problems noted throughout this thread and when I moved my newly-downloaded fonts from D:\ to C:\ I was able to open and install them without any issues at all. Unfreakinbelievable.


    Tuesday, April 24, 2007 11:01 PM
  • Thanks for your posts here.  I've had the same issues trying to install TT fonts that came with an HP printer in the mid-90s.  Lucida Casual is a font that I particularly like, and like you I have been dragging it into the font folder in previous versions of Windows.

    Following this last suggestion of yours I tried the Vista control panel font installer function, located the font files on my old XP drive in C:\Windows\Fonts and successfully installed Lucida Casual.  Assume this will work for the other fonts that I got from HP.

     

    Friday, August 03, 2007 10:02 PM
  • Jusr right-click on the .ttf file and choose Install.
    • Proposed as answer by ElaineJoy Monday, August 09, 2010 10:05 PM
    Friday, August 10, 2007 7:13 AM
  • Hiya..

     

    I'm Using Windows Vista and wish to install fonts from www.dafonts.com.

     

    Would It Be Possible for any of you to tell me how as I can't seem to understand or work the TTF file way.

     

    Many  Thanks.

     

    Chloe-ann

     

    Saturday, September 22, 2007 7:13 PM
  • I had absolutely no problems at all with installing ttf fonts. No matter where I had them (network drives, another PC, etc.), all I had to do is select the ones I wanted, right click, then install. The only messages I got were a duplicate warning, but all else went flawlessly.

     

    Sunday, November 18, 2007 3:26 PM
  • I cannot install TrueType fonts because Vista doesn't even see the fonts in the folder.

     

    I copied my fonts from my XP machine onto an external HD. I took the drive and plugged it into the Vista Machine. Opened the folder with the fonts and my TT fonts were not listed. I unplugged the device, went back over to the XP machine, plugged it in and the fonts were listed.

     

    I have tried copying the folder onto the Vista, only to find the same results. I am using Vista Home Premium (which is worthless crapola).

     

    So far, I hate Vista and wish MS would give us all our money back. If I can't fix this I'm going to buy a Mac and all new software.

     

    Wednesday, November 21, 2007 8:03 PM
  •  

    Try double clicking your font to open the font viewer. Click the Properties button, then click the Unblock button. You can now drag your font straight into the Fonts directory.

     

     

    Saturday, December 15, 2007 7:34 AM
  • i download fonts from a torrent and had to physically open rar files and add to the font folder (talk about time consuming).... does anyone have a quicker way to do this?
    Monday, December 17, 2007 2:49 AM
  • to install ttf's on vista they need to be saved on your hardrive, they dont seem to work if on an a remote computer. so if its another computer on the network, just copy and paste the ttfs fron that pc to your vista pc's desktop, then just drag and drop them into the fonts folder. i cant understand the need for this but it works and thats all that matters. hope this helps.

     

    Thursday, January 10, 2008 2:52 PM
  • I have a slightly different problem - I can get TTF fonts to install just fine in Control Panel\Fonts, but once I log off/log on, the fonts show up in CP\Fonts but don't show up in Word or any other app (MS or otherwise).  I can reinstall but once I log off, they disappear from apps again.

    Anyone else seeing this?
    Thursday, January 10, 2008 7:57 PM
  • Have you tried taking owner ship of the file, and of the folder, you have to use cmd in evelated mode,
    (right click run as admin. ) then, folow these steps:

    1. First you need to take ownership of the file.
        Run takeown /f  "path and file name" to take ownership
        from a command prompt.
      
    2. Next, you need to give your account full control
        permissions on the file.
        Run cacls "path and file name" /G <your username>:F to get
        full control from a command prompt.

    (excuse me if someone has already posted this....)
    Wednesday, February 20, 2008 9:04 PM
  • I'm wondering if my problem is related. I have a collection of fonts from "Intellitype" that I bought in the mid-90's that have been perfectly happy with every version of Windows up to now. Even after copying them to the hard drive, attempts to install them lead to an error message "not a valid font."

    Here's some data on one of them:
    Typeface name: Quadrat
    File size: 58 KB
    Version: Altsys Fontographer 3.5 1/25/93
    Copyright Brendel Informatik Cologne FRG & SoftMaker

    Any notions?

    Thanks.
    Wednesday, May 28, 2008 5:43 PM
  •  SayRed wrote:

    To EVERYONE reading this thread:

    Defining Websites' message above was the MOST helpful advise from this entire thread. I was having this annoying TTF-font-not-installing-problem for the last week! I could not figure why some of my TTF and PFM (or was it PFB) fonts in the transfer to Vista... Every time I'd go to open my files, I'd be getting messages about my missing fonts. I finally went to the web for help. This guys' suggestion was what finally worked for me.

    So. You have to move the fonts to a folder on the C Drive: Drive first, then install the fonts from there.

    Yay! My fonts are baack.... Smile

    Good luck, Everyone.

     

     

    AGREED AGREED AGREED!!!!!  This worked for me too.  Thank you!

    Thursday, May 29, 2008 11:35 PM
  • This worked perfectly.  Thank you so much for the suggestion.  If anyone else is having issues installing fonts, definitely give http://www.fontfrenzy.org a try.
    Sunday, September 14, 2008 7:30 PM
  • I used the copy to c: drive first and then drag to font directory - worked a treat

    Thursday, October 09, 2008 7:52 PM
  • I do not know what is the real problem! LAzy to read! Duh!

     

    -Saved the .ttf file somewhere (i.e. c:\)

    -Control Panel/Fonts

    -Right click and "install fonts"(las option on the drop down)

    -point to c:

    -TaDa!

     

    Was this the problem or I am missing it?

    Tuesday, December 02, 2008 9:15 PM
  • Wow, thanks so much for this invaluable tip (to copy the fonts into a folder on the C drive, and THEN transfer to the Fonts folder).
    I thought I was going nuts - thank god for this forum!
    Why does Vista have this strange problem with TTF fonts?
    Tuesday, March 10, 2009 1:19 AM
  • Yes, it works fine.
    The workaround is not limited to the C: drive, but works fine with any LOCAl and NON-REMOVABLE drives.
    If the TTF file is located either on a network drive (aka the usual way to share specific fonts on a network) or on a USB drive, this will not work. Part of the so-called Vista enhanced security ???

    Anyway, saved the day. And had to add a script to the logon script to copy fonts locally, then copy them again to the Fonts directory, then erase the local copy. Faster then going to each and every workstation on our network. But, if your users are not local admins, forget it, you will still have to go on each workstation and logon as an admin. Pain in the neck.

    Guess what? We are considering re-deploying XP on all workstations :-(
    Tuesday, March 31, 2009 8:50 AM
  • incredible, it worked for me, why it works. how did u think to try such a thing
    Saturday, April 04, 2009 1:02 AM
  • Hello all,

    I'm trying to make my Font Installtion Program Vista compatible. Installation of a TTF file doesn't work anymore as described in http://msdn2.microsoft.com/en-us/library/ms533960.aspx.
    Copying to the windows\fonts directory ends in a "Access denied" error. Can anybody give me a hint how to install a font permanently in vista.

    Thanks
    Michael

    hey mate

    not sure if you tried already, but right click on the TFF file (wherever it is on your hdd) and select 'install'... works for me when click and drag to my fonts folder didnt. hope it helps.
    peace.
    Saturday, August 29, 2009 11:39 PM
  • All of the above failed for me. 
    I had to disable UAC and that seemed to work for me.

    ARRRGGGGHHHH! 

    God Vista P(!@#$ me off!!!

    ARRRGGGGHHHH! 

    Back to work.... 
    Saturday, October 24, 2009 9:13 PM
  • I tried what Defining Websites instructed, and it totally works. you see, windows Vista uses the Opentype file fonts, and i guess its just a matter of associating the foriegn truetype fonts with your computer. so just move them into your Local Disk (C:) and then cut then from there and move them to your windows/fonts folder. thank you Defining websites!

    Saturday, January 09, 2010 6:49 PM
  • Hey Defining Websites, that totally worked thanks!
    Thursday, April 08, 2010 1:44 AM
  • If none of those method worked (they didn't work for me) then drag it onto your desktop then right click and viola! it is installed.
    Friday, May 14, 2010 2:55 AM
  • If anybody can install this font:

    http://www.urbanfonts.com/fonts/raiders.htm

     in Vista, please do let me know how you did it.

    I've tried all the methods described up to this point and every time I go to install, it keeps saying it's not a valid font file. I have the Administrator rights so that's not an issue. Anyhow, if someone can truly get this font installed in Vista...they deserve a medal of some kind. LOL!

     

    Sunday, July 11, 2010 10:51 PM
  • Yes , I was also having difficulty in installing TTF in windows vista (such as using copying and pasting or installing the fonts from a network directory, each time vista was complaining about invalid font format.) But once I copied the fonts to the local drive and tried to install from there, everything went well.

     

    Thanks zgrm for your helpful tips!

     

     

    Tuesday, July 13, 2010 3:48 AM
  • Thanks ,and this is really works ....

    And i wanna a say good luck 2 Every1.

     

    Tuesday, January 24, 2012 11:41 AM