none
Windows 7 "Could not reconnect all network drives" at boot up

    Question

  • Hello,

    I have  a home network with a mix of windows XP pro, Windows Vista and Windows 7 pro plus a Buffalo NAS drive. My problem is the Windows 7 Pro machine, everytime I boot I get a notification that is "Could not reconnect all network drives" I then go to Computer and there is a red X on the mapped NAS drive. When I double click on the Red X I get the directory listing of the mapped drive and the red X goes away. This problem only happens on the Windows 7 computer.

    I have been all over the forums and tried the power settings, turning off the firewall, making a batch file to disconnect and reconnect the drive (NET USE) and none of them worked.

     

    HELP!!! Please  this error at boot time is a major pain in the @#$%$ :)

    Thank you,

    Chris

    • Moved by Sean Jenkin Monday, April 18, 2011 4:14 PM Wrong Forum (From:MSDN, TechNet, and Expression Profile and Recognition System Discussions)
    Saturday, April 16, 2011 6:38 PM

All replies

  • 1. Goto Control Panel -> All control Panel Items -> Credentials Manager
    2. Next to the heading "Windows Credentials" click on the link "Add a Windows credential".
    3. Enter the name of your server and the appropriate credentials.
    4. Reboot and enjoy :)
    I've noticed that logging in takes few seconds longer, but I think it isn't annoying.
    • Proposed as answer by Banus PRO Sunday, May 01, 2011 8:43 AM
    Sunday, April 17, 2011 3:38 PM
  • Hey there, I am having the same problem. I start my computer up and it gives me a pop-up that says "Failed to reconnect network drives." When I go into My Computer, there is an icon under Network Locations that has a disc icon with a red X over it and reads: "downloads (\\192.168.0.11) (T:)" I already tried disabling my anti-virus / windows firewall, and I also tried the suggestion above about adding a windows credential - still not working! Please help.

     

    P.S. I am running Windows 7 and my network driver is an Atheros AR9285

    Tuesday, September 13, 2011 4:35 AM
  • Wrong. This is not the solution Ivan. All that does is add credentials which He already has. The problem is windows not mapping the drive correctly at boot, not because it does not have proper username and password for the share. Most home users who use stand alone NAS devices, including myself have this issue with windows. Linux, Unix, works just fine.
    Tuesday, February 14, 2012 10:27 PM
  • still does not work, and I dont even believe it is a credential issue, since it does not ask for credentials when clicking on it...

    it tries to map the drives before the network connection is available...

    Friday, May 18, 2012 8:44 PM
  • still does not work, and I dont even believe it is a credential issue, since it does not ask for credentials when clicking on it...

    it tries to map the drives before the network connection is available...

    I agree this is the issue.  Has anyone found a resolution for this?

    Saturday, June 30, 2012 7:22 AM
  • "it tries to map the drives before the network connection is available..."

    I believe you answered your own question without realizing it.I'm not entirely sure why this is happening but try this for a fix.

    Start > Run > type "gpedit.msc" (without quotes) click ok.

    Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon > Always wait for the network at computer startup and logon

    set this to Enable then reboot.

    this solved the annoyance for me.


    you could also try right clicking the networked drive in My Computer and, in the context menu, select "always available offline" .
    • Edited by G33k3d Friday, July 06, 2012 3:17 PM
    • Proposed as answer by MTFquadra Saturday, July 21, 2012 2:10 PM
    Friday, July 06, 2012 2:59 PM
  • Thanks for this fix, it worked for me. I think it's pretty abysmal that Windows still has issues with this. Why would they set it up to try to connect network drives before connected to the network?? Am I the only one that thinks it says a lot about their development skills that this made it into ANY released version of Windows?
    Sunday, July 15, 2012 2:27 PM
  • Start > Run > type "gpedit.msc" (without quotes) click ok. Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon > Always wait for the network at computer startup and logon set this to Enable then reboot.
    This also worked for me.

    "you could also try right clicking the networked drive in My Computer and, in the context menu, select "always available offline" .

    I would not recommend enabling "offline files". A connection failure can lead  to caching issues and a world of quirkiness. 

    To re-initalise the offline files database cache on Windows 7 Pro add the following registry sub key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CSC\Parameters

    Key Name: FormatDatabase

    Key Type: DWORD

    Key Value: 1

    WARNING: You must use DWORD 32. Flushing the cache will delete any cached files!

    A reboot is required.

     

    My preference is to have offline files disabled. This way a connection failure is more obvious and you can be certain that your files are going where you tell them. Do the following to disable offline file.

    Start > Run > type "Services.msc" (without quotes) click ok.

    ensure Offline Files service is disabled.

    Start > Run > type "gpedit.msc" (without quotes) click ok.

    under Computer Configuration > Administrative Templates > Network > Offline Files

    disable "Allow or Disallow use of the Offline Files feature". A reboot is required for the setting to take effect.

    Monday, September 10, 2012 1:25 AM
  • thanks Ivan

    sorted the problem first time!

    Wednesday, September 19, 2012 8:48 AM
  • I still have this problem, only mine is slightly different.

    I get the "cannot connect....." but clicking on them brings up a login box, the credentials do not work and they are set. The only way I have found to get back into my NAS is to "disconnect" the drive in my computer, then use the provided app from DLink to re map them, windows refuses to map them, just bringing up a username/password promt, then will not accept the credentials which I have checked at least 20 times both on windows and in the NAS.

    The only thing that I can see that changes is the username for example would be "admin" to connect to the Nas drives but after  initial connection windows will add my user name for the PC to the NAS username, i.e. WINDOWSUSER/admin, which I believe is normal. trying to re log to the NAS as plain old admin also fails, can login to NAS fine via http for admin of the unit, but this is purely for control of the device not reading the drives/folders.

    Friday, September 21, 2012 8:21 AM
  • I have been trying to solve this for months and found a solution online that has worked for me on 3 separate computers.  It's easy, too!

    1. disconnect your existing mapped drives (you'll add them later)

    2. go into control panel / credential manager

    3. delete your existing windows credentials for your mapped drives

    4. add a new windows credential.  username and password only - don't have to specify my machine name or domain, just name

    5. view that credential, and it should now show it as an enterprise persistence instead of log on.

    6. remap your network drives - input username/password if requested - reconnect at login - do not check 'use other credentials'

    I hope this helps some people!  It works for all our machines on our small office network.

    Thursday, November 01, 2012 10:09 PM
  • Still no joy here, I had given up and resided myself to just inputting details when I want to access the 2 drives in my NAS.

    Until today when I wanted to use the printer which is connected to my NAS via usb due to the unreliable wifi printing, but thats another matter.

    Anyway because of this inability to reconnect to the NAS at boot without me inputting details the printer will not work either, ok for me but others in the household are not as savvy and therefore always on my case about printer not working again.

    I tried with XP on this same system with no issue at all it just works.

    I have tried every "solution" I have found from both the NAS side and Win7 side, non make the slightest difference, reformat, factory resets, different OS's that do work, trouble is I need win7.

    I recently setup a new pc and server at my work residence using win7 on the DT and xp on the server, I ran into network issues with that too, namely extremely slow network transfer speed in one direction, changed to win7 on both even worse slow in both directions, changed to XP on both and speed is as it should be in both directions. As it is with win7 and server2008, win7 will only produce gigabit speeds if connected to server2008 machine. (or possibly newer win server platforms which I do not have to test). Various versions of Linux like Ubuntu gave same results, ok with XP or themselves, no good with win7.

    I have come to the conclusion win7 is just full of bugs/restrictions that seemingly are never going to be fixed, and worse are put there on purpose, a general pc user would never run into these sorts of problems, only because of DLNA etc becoming common place is it showing up.

    Anyone tried win8 that has had these issues and if so are they fixed?

    Reluctant to buy another MS OS now, thinking of going for linux on the server side of things and just having a win7 partition on my DT for the stuff I cannot run on the others properly.

    • Proposed as answer by crash12345 Sunday, December 23, 2012 1:42 AM
    Saturday, December 01, 2012 3:03 PM
  • This is quite simple. Windows tries to connect to network locations BEFORE it has a chance to load the drivers for the network card thus the network connection is not yet available. There are plenty of workarounds to resolve this on google
    Sunday, December 23, 2012 1:50 AM
  • This solution worked for me also.

    From above: "Start > Run > type "gpedit.msc" (without quotes) click ok. Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon > Always wait for the network at computer startup and logon"

    Two additional considerations:

    1) This problem is more pronounced on computers with fast boot times. (SSD Boot drive for example).

    2) Booting with a default admin account without a password will also make this problem appear. (Admin account with no password might be used during a new system setup).

    Hope this helps.

    Wednesday, January 02, 2013 2:08 AM
  • It really frustrates me when people post this as an answer. Google brought me to this post to begin with.

    If enough people answer every question with "google it" there's going to be one giant loop of googling, going to a message board, being referred to google, etc.

    If you don't know the answer or are to lazy to actually help, please refrain from posting anything. "Google it" is worse than not posting anything.

    Wednesday, January 02, 2013 2:41 PM
  • 1. Goto Control Panel -> All control Panel Items -> Credentials Manager
    2. Next to the heading "Windows Credentials" click on the link "Add a Windows credential".
    3. Enter the name of your server and the appropriate credentials.
    4. Reboot and enjoy :)
    I've noticed that logging in takes few seconds longer, but I think it isn't annoying.

    INCORRECT....

    Is not a credentials shortfall. .....

    Problem is at startup, the process to connect mapped drives occurs BEFORE the process to establish network.

    This is one of the many Microsoft programming ignorances that have befallen Win7 & Win8.

    Systems engineering is seriously lacking.

    There are other correct solutions to this on the forums.

    Thursday, January 10, 2013 4:21 PM
  • Well I would sure do with someone who knows where a solution is please place a link here. Searching for "could not reconnect all network drives" just produces this thread.

    The gpedit.msc doesn't work for me as i've got Windows home premium. which apparently means diddly.

    If it wasn't for games i wouldn't even have a need for windows no more.

    • Proposed as answer by EdwardLange Tuesday, April 09, 2013 1:18 AM
    • Unproposed as answer by EdwardLange Tuesday, April 09, 2013 1:18 AM
    Thursday, February 14, 2013 7:13 PM
  • To correctly fix this problem after reading this forum and having this same issues.

    Silly me for over thinking this:

    First click on start -> run -> cmd ->

    second -> type inside the prompt "net use".

    C:\Users\nukedcrap>net use
    New connections will be remembered.


    Status       Local     Remote                    Network

    -------------------------------------------------------------------------------
    Unavailable  LPT2:     \\nukedcrap-PC\Home-Printer
                                                   Microsoft Windows Network
    The command completed successfully.


    C:\Users\nukedcrap>

    third -> delete the device you are seeing disconnected.

    C:\Users\nukedcrap> net use /delete device name and is all else fails issue "net use /delete *" all with quotes of course.

    Cheers,

    Edward Lange

    Tuesday, April 09, 2013 1:24 AM
  • I found this solution from marstech1 fixed the problem for me - use a fixed ip address for the local machine. It then connects fine every time.

    http://www.youtube.com/watch?v=XQZanQD-wG8

    Tuesday, April 09, 2013 8:12 AM
  • +1

    Monday, April 22, 2013 4:05 AM
  • I believe you are partially correct but also believe Ivan is also. When I tried Ivan's fix it immediately fixed my problem but on reboot the problem persisted. When I applied RogerRamjets solution along with Ivan's, all worked flawlessly. When I tried RogerRamjets on its own, it did not resolve my issue. I believe the problem is at startup but if you don't also set the credentials the problem would persist. That has just been my experience and am now on my sixth machine that has been resolved this way.

    • Edited by stardock76 Tuesday, April 23, 2013 3:37 PM
    Tuesday, April 23, 2013 3:36 PM
  • I found the fixed ip address and the regedit work from Scorpio_Milo in this thread as a solution.

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/48f5ca04-6561-404d-b3ab-897320593aa6/

    Steps: 
     
    a. Click Start, click Run, type REGEDIT, and then click OK.

    b. Locate and click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache

    c. Click Edit, point to New, and then click DWORD Value.

    d. Type SilentForcedAutoReconnect , and then press ENTER to name the value.

    e. Double-click SilentForcedAutoReconnect .

    f. In the Value data box, type 1, and then click OK. 


    • Proposed as answer by Datanode Thursday, May 09, 2013 3:41 PM
    • Unproposed as answer by Datanode Thursday, May 09, 2013 3:41 PM
    Thursday, April 25, 2013 7:12 PM
  • This issue has been addressed with some positive results by others, However I am using WIN 7 HOME PREMIUM.... and the suggested corrective methods offered are not able to be utilized with Home Premium due to its lack of certain registry tools and options.

    This problem does not appear to be universal, in that not everyone with identical equipment (Both Home Premium and a Buffalo NAS) see this exact problem. so I am hoping that a corrective method is known that will restore my ability to utilize my Network NAS.

    The issue is virtually identical to others posts, so here is the exact issue:

    My network consists of Windows Home Premium plus a Buffalo NAS drive. Every time I boot I get a notification that is "Could not reconnect all network drives" I then go to Computer and there is a red X on the mapped NAS drive. When I double click on the Red X,  I get the directory listing of the mapped drive and the red X goes away.

    There must be a way to solve this without upgrading to a different version of Windows....  

    Wednesday, July 31, 2013 1:57 PM
  • well if you know where it is cant you reference it somehow, instead of just leaving your 2 cents and posting?

    My Computer is a HP Pavilion DV2615nr

    Thursday, September 12, 2013 1:17 AM
  • Great idea crash12345 :( .. my vote was a negative one!

    Seriously, seems like this problem is most likey to occur when you have SSD's. If you start-up your PC, and then wait until you log in, the network drives are all connected.

    But where is Microsoft, there's got to be a simple solution for this, windows should of course not try to connect before the network is up!!!

    • Edited by Steel Show Monday, December 09, 2013 1:59 PM
    Monday, December 09, 2013 1:50 PM
  • "it tries to map the drives before the network connection is available..."

    I believe you answered your own question without realizing it.I'm not entirely sure why this is happening but try this for a fix.

    Start > Run > type "gpedit.msc" (without quotes) click ok.

    Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon > Always wait for the network at computer startup and logon

    set this to Enable then reboot.

    this solved the annoyance for me.


    you could also try right clicking the networked drive in My Computer and, in the context menu, select "always available offline" .

    This is the correct fix for this annoying issue.  Thank you sir!
    Thursday, December 19, 2013 3:48 PM
  • Thanks ivans.software, this worked perfectly for me. My NAS shares now map automatically at startup based on the credentials I added here. I didn't even have to reboot for it to take effect!

    I was previously under the impression I needed to get a 3rd party client/server security certificate to automatically authenticate my Windows account with the NAS, however this proved not to be the case thanks to your suggestion.

    Much appreciated!

    Monday, December 30, 2013 1:36 AM
  • I've painfully researched this problem for months trying every solution from login scripts, batch files, schedules, mapdrive, net use, group policy drive maps, a Microsoft hotfix  etc but time and again the drives come up with the dreaded red X when I boot up, along with a tray message telling me that it could not reconnect all my network drives.

    Some research told me to ignore it, it wasn't a problem but in my case where I'm copying music to my NAS the software just would not recognise the drives without me going in to explorer and "waking up" the drive first, a time consuming and frustrating exercise. Frankly I was at the point giving in to the problem and waiting for the next service pack.

    This morning however I had an epiphany. I have never used Sync Center, as I had no need, but I thought what if I synchronise one folder / file in each of my mapped drives to force the pc to recognise it at start up.

    I created a folder in each of my mapped drives with a tiny txt file in it (in my case called sync.txt) and enabled Sync Center and set up a partnership with this tiny file in each mapped drive. I then rebooted and hoped.

    Voila, no tray message telling me it couldn't connect and no red X. My audio and video software works perfectly and many reboots later it is still working perfectly.

    I know it is a sort of workaround but I hope this works for you too. This problem has been a constant pain since I first mapped the drives. Time now to move on to the next item in event viewer....

    Saturday, January 25, 2014 2:23 PM
  • The problem as discussed in this forum, seems to be caused because the network drive mapping request is done before the network adapter is fully initialized. The solution that worked for me, was to disable the mapped drive from windows explorer so windows won't try to map the drive at startup and instead create a custom script that would map the drive, after waiting some seconds for the network adapter to initialize:

    1. Disconnect the mapped drive from Windows Explorer (right click on drive->Disconnect).
    2. Goto Start->All Programs, right click the Startup folder and click "Explore all users".
    3. Create a .bat file (whatever name you want) with similar code to the following:
    timeout /t 10
    net use q: \\192.168.0.65\Public /persistent:no

    In my case, I had to wait 10 seconds upon startup (try more if you want to be safer) and then map the drive \\192.168.0.65\Public to a local drive Q: . Also, it is important to map it without persistence, so windows won't remember the mapping and try to connect automatically at next startup.


    Sunday, January 26, 2014 3:17 PM