none
Windows 7 does not go into standby due to driver \FileSystem\srvnet

    Question

  • I suffered the problem that Windows 7 did not went into Sleep/Standby mode after the defined time period. It worked for months and suddenly it did not.
    What felt strange was, that if I went to the Windows shutdown menu and chose Standby then it worked. But once the computer waked up for a backup or a scheduled TV recording, it did not went into standby again.

    But I found a solution:

    1)
    First thing that came to my mind was the just installed Acronis Backup solutions or any Windows update. But I could not believe that this is the problem. Nevertheless I deinstalled Acronis but still suffered the problem. As deinstalling Windows updates is quite a hard task, I gave up the idea to deinstall them.

    2)
    So I checked system -> device manager if a driver where marked as damaged or not working. Instead the "NEC USB 3.0 Root Hub" driver was automatically replaced by Windows with a driver named "Renesas Electronics USB 3.0 Root Hub". The driver did not work and the device was marked as "not started properly". After I manually changed the driver back to NEC everything worked. But the standby issue was still not resolved.

    3)
    I opened a cmd-console with admin rights (Windows menu -> enter "cmd" into the search box -> right click on cmd and choose run as administrator) and entered "powercfg -energy". After one minute the report said that the driver \FileSystem\srvnet made a request to avoid the standby of the system. Furthermore most of my USB devices denied to go into standby which could influence the CPU power management. I ignored the USB issues as I already activated selective USB power management in the computer's energy policy and I expected that the system will force a power down if needed. So my concentration was up to the driver \FileSystem\srvnet .

    4)
    But how to avoid that the driver \FileSystem\srvnet sends requests to avoid system standby? I asked Dr.Google and found a lot of hints that the network sharing for media and documents should be disabled and that the membership on a network homegroup could be the reason. So I deactived media sharing and streaming and I left the network homegroup. But still no progress - the computer still denied to go into standby by itself.

    5)
    Once again I started a cmd-console with admin rights and I entered "powercfg -request". Also here a got the result that \FileSystem\srvnet sent a request. But where could I configure Windows 7 to ignore this driver?

    The solutions is quite simple. In a cmd-console with admin rights I entered "powercfg /?" and identified the -requestsoverride option. Could this be the solution? In fact it is! I just entered "powercfg -requestsoverride driver \FileSystem\srvnet system" and now my system's automatic standby is working again.

    6) Unclear to me is why the requests of the driver \FileSystem\srvnet became activated and why this did not stopped e.g. after a reboot? 
    I also checked, if I had open network shares: but nothing. I also rebooted various times, but no change.
    I do not know what the driver \FileSystem\srvnet is for and how the override could influence my system. Any help is welcome!

    Cheers,
    Matt.12

    Wednesday, September 01, 2010 2:50 PM

All replies

  •                This thread helped me also.  I just want to share a couple of DOS Batch files I created to easily implement this.  I know some of you aren’t old enough to be familiar with making DOS batch files.  I am old enough to remember typewriters, vacuum tubes, analog computers, and DOS batch files.  Batch files can still be very useful in some cases.  I used to be a wiz with these things, but I’m so old now that this is the best I can do on short notice.

                   Just open a text document for each file and save it with the .BAT extension.  To change it, don’t double-click because it is an executable.  Right click and select edit.  You can just copy and paste in the text below. 

                   The filenames I chose are preceded by Admin to remind me that they must be executed as administrator.  Besides issuing the command it displays some text to remind me what is going on and why.

     

    First batch file: “Admin-AutoSleep-Allow.bat”

    PROMPT $G

    REM  ---------------!!MUST run as Administrator!!-------------------

    C:\Windows\System32\powercfg /requestsoverride DRIVER srvnet System

    REM      Sometimes an active remote client sends requests over the

    REM  network for no apparent reason. In that case, the command

    REM  C:\WINDOWS\SYSTEM32\POWERCFG /REQUESTS will confirm.

    REM      This prevents the condition in which this computer will not go

    REM  into SLEEP mode automatically when another machine on this network.

     

    REM      To enable requests again, execute (as administrator):

    REM   ADMIN-AUTOSLEEP-KEEPAWAKE.BAT.

    REM  ---------------!!MUST run as Administrator!!-------------------

    Pause

     

    Second batch file:  Admin-AutoSleep-KeepAwake.bat

    PROMPT $G

    REM  ---------------!!MUST run as Administrator!!-------------------

    C:\Windows\System32\powercfg /requestsoverride DRIVER srvnet

    REM      Sometimes an active remote client sends requests over the

    REM  network for no apparent reason. In that case, the command

    REM  C:\WINDOWS\SYSTEM32\POWERCFG /REQUESTS will confirm.

    REM      This allows requests and thus allows them to prevent this

    REM  computer from going into SLEEP mode automatically when another

    REM machine is on this network.

     

    REM      To enable requests again, execute (as administrator):

    REM   ADMIN-AUTOSLEEP-ALLOW.BAT.

    REM  ---------------!!MUST run as Administrator!!-------------------

    pause

     

     

     


    Gary Burton
    • Proposed as answer by techniq1 Tuesday, June 28, 2011 5:37 PM
    Tuesday, January 18, 2011 4:42 AM