none
regedit on Vista error unable to save permission changes on CLSID access denied

    Question

  • I get an error with Server.CreateObject("ADODB.Recordset") which faila on Vista with IIS7 and ASP installed

    The error is '8002801d'

    The Microsoft article http://support.microsoft.com/kb/274038 gives the solution as editing permissions in the Registry

    But using Regedit to follow the instructions, you are not allowed to change or add to the permissions - you are given the error unable to save permission changes on CLSID access denied

    How do you change the permissions using Regedit

    The instructions are as follows
    1. Find the line of code that is failing, for example:
      Server.CreateObject("MSWC.BrowserType")
      						
      The text string, "MSWC.BrowserType", is the ProgID (Program ID).
    2. On the Start menu, click Run. At the command prompt, type the following command to start the registry editor:
      RegEdt32.exe
    3. In the HKEY_CLASSES_ROOT window, click to expand the ProgID key, and then click CLSID. Record the UUID value of this key. For example, the ClassID for "MSWC.BrowserType" is {0ACE4881-8305-11CF-9427-444553540000}.
    4. In the HKEY_CLASSES_ROOT window, click to expand the CLSID key, and then select the ClassID entry (UUID). On the Security menu, click Permissions. Make sure that the Everyone entry has Read permission; if not, add this permission entry.

    TypeLib

    Find TypeLib

    Expand the ClassID entry from the preceding step 3, and locate the TypeLib entry beneath it. Record the UUID value, and then proceed to the "Change Permission for TypeLib" section.
    Friday, April 03, 2009 7:33 PM

All replies

  • Hi,

    I think you shall type in “regedit” instead of “RegEdt32.exe”.  The RegEdt32.exe is the Registry Editor Utility, which probably is used in cases when small types of problems might occur in the Windows® Registry.

    If we instead type “regedit” we will start the Windows® Registry Editor, and what changes you make there will all be saved.

    So, do as I told and apply the security permission settings, and make a restart of the PC, or just close the regedit.

    I hope this helps…

    Have a nice day…

    Best regards,
    Fisnik


    Coder24.com
    • Proposed as answer by Fisnik Hasani Friday, November 13, 2009 7:28 PM
    Saturday, October 24, 2009 11:27 AM
  • Hi,

    How is the situation on your side?
    Is this thread solved or NOT?

    Please tell me!

    Have a nice day...

    Best regards,
    Fisnik
    Coder24.com
    Thursday, October 29, 2009 10:26 AM
  • Hi David:

    How is the situation on your side?
    Is this thread solved or NOT?

    Please tell me!

    Have a nice day...

    Best regards,
    Fisnik
    Coder24.com
    Friday, November 13, 2009 7:28 PM
  • Hi again:

    How is the situation on your side?
    Is this thread solved?

    Please tell me!

    Have a nice day...

    Best regards,
    Fisnik
    Coder24.com
    Sunday, December 27, 2009 10:27 AM
  • Hi again:

    Is this thread solved or NOT?
    Please tell me!

    Have a nice day...

    Best regards,
    Fisnik

    Coder24.com
    Saturday, January 02, 2010 2:23 PM
  • Neither works for me.  My registry is all screwed up and I can't merge in the needed .reg file to fix it because of permissions errors.  I AM the damn administrator and regedit won't allow me to make changes.  When I use start>run>regedit or regedt32, I get the error "Application not found" but when I do a search for system files, I can easily find it and open regedit by right-clicking and selecting "run as administrator".  I have Vista.  Can anyone help??
    Tuesday, January 12, 2010 4:55 AM