none
Debugger detected

    Question

  • While trialling Vista RC2 (5744) I went to install and run my favorite screen saver "Cuckoo Clock 3D " from 3Planesoft I got this error

    Debugger detected [97]

    The install seems to work fine, it's when I try and run the thing or change any settings that the error appears. It worked fine in RC1 (5600).

    Any devs/enthusiast know what is new that is causing this? and better still can it be fixed before rtm?

    Regards
    Monday, October 09, 2006 3:51 AM

Answers

All replies

  • I've forwarded your question to 3planesoft.

     

    Monday, October 09, 2006 9:21 PM
  • I get the same problem with message "Debugger detected [97]" after installing Internet Download Accelerator v.5.1 (IDA) from Westbyte. The installer goes OK but trying to run the App fails. Unistalled and installed again using the compatibility mode wizard. Same problem: Debugger detected [97] when trying to run the app.

    The strange thing is that I have Vista RC1 5600 installed on other 2 PC's and there IDA runs 100% OK!

    Saturday, November 11, 2006 11:08 AM
  • I get the same problem with message "Debugger detected [97]" after installing Internet Download Accelerator v.5.1 (IDA) from Westbyte. The installer goes OK but trying to run the App fails. Unistalled and installed again using the compatibility mode wizard. Same problem: Debugger detected [97] when trying to run the app.

    The strange thing is that I have Vista RC1 5600 installed on other 2 PC's and there IDA runs 100% OK!

    Saturday, November 11, 2006 11:09 AM
  • I have the exact same problem with my screensaver too. It will install okay but get "Debgger detected [97]" error code when it trys to run. This is starting to get me angry. I think I'll just dump Vista, reformat my HD and put XP back on.
    Monday, November 20, 2006 7:32 PM
  • Seems like all those applications are protected by EXECryptor of Strongbit.com.

    Seems like a antidebugging routine creates a false alarm under Vista.

     

    Thursday, July 24, 2008 11:12 AM
  • Debugger 97 Detected is A Virus! My Friend is having it removed!  Now you should Remove it A.S.A.P. (AVG 8.5 Pro - UNDETECTED) Yeah, It slipped pass Avg.
    Wednesday, September 02, 2009 6:48 AM
  • How are they removing it???
    Wednesday, September 02, 2009 3:41 PM
  • It's most probably not a virus, just an overzelaous developer 'protecting' their application from imagined harm, using an overzealous 'anti-debugging' toolkit.

    Sometimes these things generate false positives from antivirus tools.

    Friday, September 04, 2009 6:58 PM
  • I'm sorry to report but "Debugger Detected 97" is a virus and a very stubborn on.  It modified the registry to redirect .exe extension from working.  I have deleted the file ddesote.ext in the system32 directory and it has re-installed itself.  Not the signs of just an overzealous 'anti-debugging' toolkit.  I'm am still trying to remove it from one of our laptops.
    • Proposed as answer by singh09 Saturday, September 19, 2009 1:43 AM
    Tuesday, September 08, 2009 8:45 PM
  • i have the solution for this problem "Debugger detected [97]"

    Download .EXE  Extention - Registry Fix  for Vista Users

    http://www.mediafire.com/download.php?1ywjzynzmze


    Double Click to run That Reg fix then restart computer to see weather it works for u or not

    It works for me






    Saturday, September 19, 2009 1:52 AM
  • went to this site ://www.mediafire.com/download.php?1ywjzynzmze as mentioned by singh09, worked for me!!  you rock, thank you!!

    Thursday, October 01, 2009 2:13 AM
  • While trialling seven RTM build 7600 x64 I went to install and run my favorite screen saver "Lagoon 3D Screensaver " from 3Planesoft I got this error

     

    Debugger detected [97]

     

    The install seems to work fine, it's when I try and run the thing or change any settings that the error appears. It worked fine in Xp pack 3

     

     

    Monday, April 12, 2010 3:54 AM