none
WDS 4 Unable to index other users mailboxes within Outlook 2003 and Exchange 2003 SP2

    Question

  • I just upgraded WDS 2.6.6 to WDS 4 and discovered that when I go to Modify and expand Outlook my other Users Mailbox folders are showing but are faded out.  When I put my mouse over them this message pops up " Indexing of this email store has been disabled by the System Administrator"

    WDS 2.6.6 had no problems indexing other mailboxes.  Is this a bug or is there a GPO I have to create to allow indexing?

    Thanks

    John
    Friday, March 28, 2008 2:02 AM

Answers

  • Jynphoto - actually you want to keep the policy above disabled, but you also want to enable this one - 'enable indexing of online delegate mailboxes' - again do the gpupdate /force and let me know what you see

     

    Tuesday, April 08, 2008 6:47 AM

All replies

  • A couple of questions here - are you using mail in online mode or cached local mode? Are the other mailboxes opened to you by way of delegate mailbox access?

    If your scenario is online - WS4 does have a GPO to 'enable indexing of online delegate mailboxes' - also the GPO template is installed by default so to navigate to it you can run 'gpedit.msc' - open up Computer Config > admin templates > Windows Components > Search - and check to see if this policy is disabled. You want to change this to enabled.

     

    Friday, March 28, 2008 6:07 AM
  • Mail is in cached mode.

    The mailboxes have been accessed via giving full permission to mailbox via Exchange Advanced, mailbox rights and adding myself  with full permission to to that users mailbox.  I then go into Outlook, email accounts, advanced and add the users mailbox in cached mode.  I then have full access to their mailbox.

    John
    Friday, March 28, 2008 8:44 AM
  • So with Outlook 2003, it is not possible to cache delegate mailbox access locally - therefore I assume that whether knowingly or unknowingly you appear to have online delegate access, and to get that indexed in WS4, you need to enable the GPO to get this done - can you try that out and let me know if if solves your issue?

     

    Monday, March 31, 2008 3:56 AM
  • Thank you for the reply,

    So just so I understand what you are saying I just want to verify.

    So under Outlook 2003, email accts, Exchange Server, Change, More settings and Advanced I have 4 other accts listed.  Under that window that lists the accts there is a section that says Cached Exchange MOde settings and "Use Cached Exchange Mode" is checked.

    So even though that is checked these additional accts are not Cached?

    I decied to go ahead and install the GPO template and disabled 

    Prevent Indexing uncached Exchange Folders

    I did a gpupdate  /force , logged the server off and logged back on.

    I then logged off the workstation and logged back in, no change in my options for desktop search


    John

    Monday, March 31, 2008 7:30 AM
  • I have the same issue but am using Outlook 2007 and Exchange 2007 as the back end, any ideas would be great.

     

    Norman

     

    Monday, March 31, 2008 7:57 PM
  • Jynphoto - actually you want to keep the policy above disabled, but you also want to enable this one - 'enable indexing of online delegate mailboxes' - again do the gpupdate /force and let me know what you see

     

    Tuesday, April 08, 2008 6:47 AM
  • I was having the same problem, with a slight variation.  I can find other users mail using the normal WDS, but not the instant search in Outlook.  Kind of annoying, but workaroundable.
    Wednesday, April 09, 2008 2:21 PM
  • dansherman - this behavior is expected - let me try to explain more here:

     

    Outlook instant search supports cached local stores that are indexed locally - by default when you search the root store you are in, such as your own inbox, it's only going to search your inbox. You can upscope this in the Outlook search settings to search your whole mailbox which includes only the indexed items that are cached local - and search via Outlook 2007 to the cached local index is fast. This is when Outlook fully takes advantage of the WDS created index. However for delegate stores which are in online mode they are not included in the core 'all mailbox' search since Outlook by default only includes the indexed cached items. 

    You can however navigate to the additional mailbox folder and search from there to find these items - but search will be sent to the exchange server and hence may be slower to render. (When you fully run in online mode with Outlook, searching within Outlook will be the same slower experience as Oulook does not use the local index created by WDS when you run in online mode, whereas the WDS search experience directly in our explorer UI obviously does.)

    So when you do have WS4 on your machine and have activated the GPO to enable indexing of online delegate mailboxes, you now tap into the full local index of the online store and the cached local stores - and so a search from WDS will be expected to find everything in one go.

     

    Thursday, April 10, 2008 11:34 PM
  • That makes sense.  Are there any plans to integrate the two more closely?  It'd be nice, but using WDS directly isn't that big of a deal.
    Friday, April 11, 2008 5:46 PM
  • I have looked under Computer config/admin templates/windows components/Windows search and I do not see any option for : "'enable indexing of online delegate mailboxes"

    Thanks

    John
    Friday, April 11, 2008 5:52 PM
  • OK, got it figured out.  I had the GP Template for Search 3.0 not 4.0.  Everything is working well now.

    My users thank you.  :-)

    John
    Saturday, April 12, 2008 1:41 AM
  • Does this mean you can not cache delegate mailbox in Outlook 2003? I have the GPO enabled as well to allow index of delegate mailbox but its still not indexing it. Does the delegate mailbox have to be cached for it to index within WD4? I am having trouble with this right now, any help or assistance would be greatly appreciated, thanks.
    Thursday, May 07, 2009 5:36 PM