none
Installing HDInsight on Windows 7 - a few remarks

    Question

  • I have now managed to get HDInsight up and running locally on my Windows 7 Enterprise machine. A few remarks on the process that may (or may not) prove helpful to others:

    1. It seems that ASP.NET 4.0 is needed. I did not have this and the Dashboard did not install: just three icons on desktop, just basic Hadoop running). This was not obvious to me and no errors were reported, but maybe that is just me.
    2. I had to install HadoopWebApi and HadoopDahsboard manually as described in the thread 'Tip - Supported Windows Server versions (for a local install)'. There were two minor twists, though: the package stuff was on the E: and not C: drive (no idea why) and the singlenodecreds.xml was in the root on C:, not in C:\Hadoop.
    3. I had to change the Identity of the HadoopAppPool in the IIS Manager; I chose AppliationPoolIdentity but others will probably work too. I am guessing that a a local hadoop user was created on my machine but removed automatically according to the general settings where I work. Failure to do so gave the 'HTTP Error 503. The service is unavailable' when opening the Dashboard as desribed in the thread 'Issue with HadoopAppPool Identity after istall'.

    Good luck.

    PS Sorry for not providing links to the other threads; for some reason I am not allowed to do so.

    Wednesday, November 21, 2012 11:51 AM

All replies

  • Sorry for the difficulty you encountered here.  We're working on an update which should address a number of the dashboard/API setup issues.

    --matt


    Program Manager -- hadoop -- http://blogs.msdn.com/mwinkle

    Monday, November 26, 2012 5:39 PM
    Owner
  • Greetings, has an official workaround been created?

    or has the installer been updated to counter the issues mentioned above?

    thanks


    Cheers and 73s. Evan Cutler Master Chief(ret.) KC2ZUX


    Friday, December 07, 2012 8:07 PM
  • sorry..forgot to click "Alert"

    Cheers and 73s. Evan Cutler Master Chief(ret.) KC2ZUX

    Friday, December 07, 2012 8:08 PM
  • Yes, we've updated the installer.  Please uninstall HDInsight, as well as the Hortonworks Data Platform and then re-install.

    Program Manager -- hadoop -- http://blogs.msdn.com/mwinkle

    Monday, December 10, 2012 11:27 PM
    Owner
  • I was having similar problems and in case anybody is interested, I put together a PowerShell script to update the password and identity of the Hadoop services as well as the ASP.NET AppPool identity.  The script can also switch to a different identity if the GPO does not allow local users, but will need a small edit.

    **** script *****

    $user="hadoop"
    $password="<<pick a password>>"

    $de = [adsi]"WinNT://./$user,user"
    $de.SetPassword($Password)
    $de.SetInfo()

    write-host "password set for [$user]"

    Get-Service |
    Where-Object { $_.DisplayName -imatch ".*apache.*" } |
    ForEach-Object {
        write-host "Processing service [$($_.DisplayName)]"
        Stop-Service -Name $_.Name
        $service = gwmi win32_service -filter "name='$($_.Name)'"
        $dummy = $service.change($null,$null,$null,$null,$null,$null,".\$user",$password)
    }

    write-host "service identities set"

    #   set the identity of the application pool

    $pool = Get-Item IIS:\AppPools\HadoopAppPool

    $pool.processModel.userName = $user
    $pool.processModel.password = $password

    $pool.Stop()
    $pool.Start()

    Set-Item -Path IIS:\AppPools\HadoopAppPool -Value $pool

    write-host "asp.net application pool identity set"

     

    Thursday, March 14, 2013 6:25 PM
  • Thanks for the thread and your answer.

    HadoopAppPool 4.0 is not working some how which has Identity "<<hostname>>\hadoop"

    I've changed it to apppool ASP.NET 4.0 with Identity "ApplicationPoolIdentity". now its working

    Thanks,
    Ratnakar Dutt
    RatnakarDutt@gmail.com


    Thursday, October 24, 2013 8:37 AM