none
Azure Website

    Question

  • I create a website with create database option. Then I messed around and deleted the SQL database. When I did that my website went away. Now when I tried to recreate it with the same DNS name it says it's available but it keeps failing.

    Here is what I'm seeing. I removed any data I felt was personal and shouldn't be posted.

    **** Error Message ****

    Try again. Contact support if the problem persists.


    Browser: 5.0 (Windows NT 6.2; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5
    User language: undefined
    Portal Version: 6.0.6002.18488 (rd_auxportal_stable.120618-1348)

    Last 10 Requests

    message: Failure: Ajax call to: Websites/CreateWebSite. failed with status: error (500) in 1.064 seconds. x-ms-client-request-id was: 
    dateTime: Mon Jun 25 2012 23:42:01 GMT-0400 (Eastern Daylight Time)
    durationSeconds: 1.064
    url: Websites/CreateWebSite
    status: 500
    textStatus: error
    referrer: https://manage.windowsazure.com/#Workspaces/WebsiteExtension/websites
    host: manage.windowsazure.com
    response: {"message":"Try again. Contact support if the problem persists.","ErrorMessage":"Try again. Contact support if the problem persists.","httpStatusCode":"InternalServerError","operationTrackingId":"","stackTrace":null}

    message: Complete: Ajax call to: Websites/IsSiteNameAvailable. completed with status: success (200) in 0.437 seconds. x-ms-client-request-id was: 
    dateTime: Mon Jun 25 2012 23:41:58 GMT-0400 (Eastern Daylight Time)
    durationSeconds: 0.437
    url: Websites/IsSiteNameAvailable
    status: 200
    textStatus: success
    referrer: https://manage.windowsazure.com/#Workspace/WebsiteExtension/websites
    host: manage.windowsazure.com


    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Tuesday, June 26, 2012 3:45 AM

All replies

  • Hi Bobby,

    What is the name of the site you are trying to create?

    Wei can you please look into this issue?

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, June 26, 2012 3:52 AM
  • Hi Bobby,

    We are investigating a similar issue. Can you please let us know your site name?

    Also, can you check that SQL and Web sites are under the same subscription?

    Thanks,

    Wei

    Tuesday, June 26, 2012 7:41 AM
  • bigguns is the site name that shows up as available but fails to create.

    I also had biggunsgym on a trial subscriptions that I would rather have but it's says the name says it's taken. I deleted the site from the trial subscription assuming it would free up the name. Is there anyway we could free up the my original name?


    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Tuesday, June 26, 2012 12:22 PM
  • Hi Bobby,

    Look at the last 10 requests, IsSiteNameAvailable returns 200, so the site name should be ok. You can try to create a blank web site without database to confirm.

    BTW, can you create web site with new SQL database?

    thanks,

    Wei

    Thursday, June 28, 2012 1:07 AM
  • I just tried to create the site without a database at 06/27/12 10:53 PM EDT and it failed. This is how I have been attempting to create the site "bigguns".


    Thanks,
    Bobby Cannon
    BobbyCannon.com


    Thursday, June 28, 2012 2:53 AM
  • I just tried to create the site with a database at 06/27/12 10:56 PM EDT and it failed.

    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Thursday, June 28, 2012 2:56 AM
  • Hi Bobby,

    We are able to reproduce and find out the cause. Can you please confirm that your password contains special char like ', ", ;, =.

    if so, please reset the password without these chars and try again.

    thanks,

    Wei

    Thursday, June 28, 2012 3:19 AM
  • Sorry, forget to mention. it is the SQL database password.
    Thursday, June 28, 2012 3:22 AM
  • Sorry, forget to mention. it is the SQL database password.
    My passwords don't contain symbols so this shouldn't be the issue.

    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Friday, June 29, 2012 4:32 PM
  • I went ahead and tried it again to create the site with and without the database. Both methods failed. I double checked my passwords and none of them have symbols.
    Friday, June 29, 2012 4:36 PM
  • Hi Bobby,

    What name did you use this time?

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Saturday, June 30, 2012 12:03 AM
  • BigGuns. I tried again today wondering if my time away would have given the system time to "clean up" but it still failed. I'm only continuing to try and use this name to help you guys troubleshoot the issue. It seems to me this is an obvious bug but that's just my guess.

    Are you guys wanting to continue to troubleshoot the issue? 


    Friday, July 06, 2012 6:27 PM
  • BTW, is there any hope getting my BigGunsGym account transfer my trial subscription to my real subscription? I only care about the name not any content because there was none.
    Friday, July 06, 2012 6:28 PM
  • Hi Bobby,

    I was able to create site with BigGuns name. I deleted that now. I dont think your issue is with the name of the site. Are you able to create any site (with different names)? Please try out simple quick create site and let me know what you get.

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, July 06, 2012 7:10 PM
  • I recommend you call Azure Support for this transfer request and see if that can help you with this. AFAIK, currently they should be able to transfer entire cloud assests from one subscription to another, which means all your instances of webrole, DB etc will move. I am not sure if Azure Websites are already part of this move, but please call support and find out if they can help.

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, July 06, 2012 7:12 PM
  • I created "BobbyBigGuns" with no problem. I still cannot create "BigGuns".
    Friday, July 06, 2012 7:22 PM
  • I recommend you call Azure Support for this transfer request and see if that can help you with this. AFAIK, currently they should be able to transfer entire cloud assests from one subscription to another, which means all your instances of webrole, DB etc will move. I am not sure if Azure Websites are already part of this move, but please call support and find out if they can help.

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.


    I deleted the assets before cancelling the subscription. They should be "deleted".
    Friday, July 06, 2012 7:23 PM
  • Ok, I think I am getting confused here. Please help me understand the situation bit better so I can provide more accurate answer.

    You have 2 subscriptions. One is Trail and One is Real. You have deleted the assests and cancled a subscription. Which Subscription did you cancle? Which subscription is BigGunsGym site currently running? Which Subscription you had tried to create BigGuns and deleted? and Which one are you trying it from now?

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, July 06, 2012 7:39 PM
  • Ok, I think I am getting confused here. Please help me understand the situation bit better so I can provide more accurate answer.

    You have 2 subscriptions. One is Trail and One is Real. You have deleted the assests and cancled a subscription. Which Subscription did you cancle? Which subscription is BigGunsGym site currently running? Which Subscription you had tried to create BigGuns and deleted? and Which one are you trying it from now?

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    I had a trial subscription that I created a website named "BigGunsGym" on. I then purchased MSDN and created my real subscription. After I had my real subscription I went back to my trial subscription and deleted all the artifacts (VMs, Databases, Servers, Websites, Etc). Before I cancelled that subscription all the menu items had "0" beside them.

    I then switched over to my MSDN subscription and tried to created the website "BigGunsGym". To my surprise it was taken. Boo. I decided for testing I would create "BigGuns" and work on getting the other name transferred. 

    I succesfully created "BigGuns" and a database. I messed around and deleted the database. When I did the website disappeared. I was confused but decided to recreate everything. I can no longer create "BigGuns" or "BigGunsGym".

    Friday, July 06, 2012 7:47 PM
  • Got it. Thanks much for the explanation.

    How did you cancle the trial subscription? Did you call Support or you used self help to get rid of it?

    When I go to http://biggunsgym.azurewebsites.net/ I am getting "The service is unavailable." error. I remember at one point while working on this post, I was able to browse to it and it rendered the page. While I can create a site with BigGuns name, it tells me BigGunsGym is taken. Do you remember, which DataCenter did you create BigGuns in?

    Let me do some research on biggungym site and see it's status and which subscription it's under.

    Do you mind working with me offline over email? japurva at hotmail dot com

    Just send me an email from your account and we will try to sort this out offline and update this thread.

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, July 06, 2012 7:55 PM
  • Got it. Thanks much for the explanation.

    How did you cancle the trial subscription? Did you call Support or you used self help to get rid of it?

    When I go to http://biggunsgym.azurewebsites.net/ I am getting "The service is unavailable." error. I remember at one point while working on this post, I was able to browse to it and it rendered the page. While I can create a site with BigGuns name, it tells me BigGunsGym is taken. Do you remember, which DataCenter did you create BigGuns in?

    Let me do some research on biggungym site and see it's status and which subscription it's under.

    Do you mind working with me offline over email? japurva at hotmail dot com

    Just send me an email from your account and we will try to sort this out offline and update this thread.

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    I sent you an email. I will follow up with more details as soon as I can.
    Friday, July 06, 2012 7:57 PM