none
Azure: problem with 'Test Connectivity'

    Question

  • When I try to test connectivity to a new Azure SQL database I get:

    Invoke operation 'TestConnectionToDatabase' failed. Exception of type 'System.ServiceModel.DomainServices.Client.DomainOperationException' was thrown.

    Thanks

    • Moved by Yi-Lun Luo Tuesday, February 21, 2012 5:29 AM Off Topic. (From:Windows Azure Development)
    Monday, February 20, 2012 3:42 PM

Answers

  • Resolution:
    I just found a cause for this error.

    My SQL Server administator login was using a disallowed '@' character, since I entered the name in email format.  Likely there are other characters that could cause this same symptom.

    Azure unfortunately accepts the invalid admin user name, and throws the below error when using the Test Connectivity button.

    Invoke operation 'TestConnectionToDatabase' failed. Exception of type 'System.ServiceModel.DomainServices.Client.DomainOperationException' was thrown.

    When trying to sign in with via the browser with the Manage URL, you get the error:

    "There was an error connecting to the server."
    "Server name cannot be determined.  It must appear as the first segment of the server's dns name (servername.database.windows.net).  Some libraries do not send the server name, in which case the server name must be included as part of the user name (username@servername).  In addition, if both formats are used, the server names must match."

    Since I've never connected to the DB, it was simple enough to select the DB in the Windows.Azure.com portal, and select "Drop" from the toolbar.  Make sure you don't confuse the "Drop" button in the Server section with the same button in the Database section....

    • Proposed as answer by SeattleParaglider Wednesday, February 22, 2012 1:08 AM
    • Marked as answer by tinplate200 Wednesday, February 22, 2012 8:45 AM
    Wednesday, February 22, 2012 1:08 AM

All replies

  • Hi,

    Assuming that you are testing connectivity to the SQL Azure database through SQL Server Management Studio, please verify that you have put all the required local and server firewall rules in place for connecting to SQL Azure.


    If you found this post useful, Please "Mark as Answer" or "Vote as Helpful". Thanks! Vaibhav Gujral.

    Monday, February 20, 2012 6:33 PM
  • Many thanks.  I was trying with via the Management Portal and I get a different error message with the SSMS. 
    Monday, February 20, 2012 6:34 PM
  • I have checked my firewall settings and as far as I can see they are all correct.  I still have the problem both with the Management Portal and the SSMS. 
    Monday, February 20, 2012 6:48 PM
  • I too am getting this error.

    Created new SQL DB about 2 hours ago.

    • Using Windows.Azure.com portal
    • Cick the Database tile in the lower left pane.
    • Expand my subscription, expand server name, and see master and MyDB.
    • Select MyDB.  Database information shows Web edition and current size = 920KB.  State=online.
    • Click Test Connectivity toolbar button and enter password.

    Result:

    Error:
    Invoke operation 'TestConnectionToDatabase' failed. Exception of type 'System.ServiceModel.DomainServices.Client.DomainOperationException' was thrown.

    Tuesday, February 21, 2012 8:39 PM
  • Hi,

    I Have the same error with new SQL DB created about 3 hours ago. In the exactly same scenario.

    But... i can connect to the DB on SQL Management Studio.

    It's surely a bug in the Silverlight azure portal ?

    Sorry for my bad english, i'm french :-)


    http://www.nicolasesprit.com

    Wednesday, February 22, 2012 12:14 AM
  • Hi,

    It works now, I assume that the error was caused by an ongoing deployment. Although I do not see the connection between the deployment of a Web Role and the SQL Azure DB...


    http://www.nicolasesprit.com


    Wednesday, February 22, 2012 12:18 AM
  • Resolution:
    I just found a cause for this error.

    My SQL Server administator login was using a disallowed '@' character, since I entered the name in email format.  Likely there are other characters that could cause this same symptom.

    Azure unfortunately accepts the invalid admin user name, and throws the below error when using the Test Connectivity button.

    Invoke operation 'TestConnectionToDatabase' failed. Exception of type 'System.ServiceModel.DomainServices.Client.DomainOperationException' was thrown.

    When trying to sign in with via the browser with the Manage URL, you get the error:

    "There was an error connecting to the server."
    "Server name cannot be determined.  It must appear as the first segment of the server's dns name (servername.database.windows.net).  Some libraries do not send the server name, in which case the server name must be included as part of the user name (username@servername).  In addition, if both formats are used, the server names must match."

    Since I've never connected to the DB, it was simple enough to select the DB in the Windows.Azure.com portal, and select "Drop" from the toolbar.  Make sure you don't confuse the "Drop" button in the Server section with the same button in the Database section....

    • Proposed as answer by SeattleParaglider Wednesday, February 22, 2012 1:08 AM
    • Marked as answer by tinplate200 Wednesday, February 22, 2012 8:45 AM
    Wednesday, February 22, 2012 1:08 AM
  • Thanks so much, that's fixed it
    Wednesday, February 22, 2012 8:45 AM
  • Thanks, this was also the case for me.   Deleting the database and then recreating a new one without the @ symbol worked for me as well.
    Wednesday, March 28, 2012 7:58 PM