none
New Co-Admin using Eclipse deployment gets 403 error

    Question

  • Hi,

    I added a collegue as a Co admin on our account. We are following the instructions at heading "To deploy your application to Windows Azure" on http://msdn.microsoft.com/en-us/library/windowsazure/hh690944%28VS.103%29.aspx

    Biut when he gets to step 5 it gives a 403 error, we do not understand what else is needed to authenticate his deployment? Any ideas?

    Regards,

    David

    Friday, November 02, 2012 1:42 PM

Answers

  • Hi,

    This turned out to be the difference between Linux recognising that the BIOS clock and the OS clock are 2 distinct things, it appears Windows OS does not. They were set to different values and Windows was running in a VM, so it must have setup the X.509 cert with a timestamp that was not yet valid timewise.


    StpDave

    Friday, November 09, 2012 10:50 AM
  • I think it is more confused for me now. You said you just add timestamp in his certificate and this make it work now?

    Anyway, you have resolved it yourself.

    • Marked as answer by stpdave Monday, November 12, 2012 9:28 AM
    Friday, November 09, 2012 11:21 AM
  • Simply aligned OS and BIOS clock times. Fixed

    StpDave

    • Marked as answer by stpdave Tuesday, November 13, 2012 10:24 AM
    Monday, November 12, 2012 9:28 AM

All replies

  • Anyone?
    Monday, November 05, 2012 10:39 AM
  • OK, I think I know roughly what is going on. We use git, I check in my webapp project with all of the deploy files, there is no information that I can find that tells you specifically which ones are required for individuals to be able to connect to Azure via the management APIs. So my colleague checks out of git. When he goes to deploy there is some config file in there that tells the Eclipse plugin that everything is fine and setup, including the certificate. So it fails because the certificate is not setup on his PC.

    So you think OK, let me export my certificate and he can import it. But the export does not allow export of the private key for Azure, so that is a dead end.

    So next step, what does he delete from his checked out project so that the deploy wizard says, "oh I need to setup a ceritifcate for this guy to use". Anybody know which file he needs to delete to make the deploy wizard go through the process of setting up his certificate and key?

    Thx.

    David



    • Edited by stpdave Monday, November 05, 2012 12:27 PM
    Monday, November 05, 2012 11:38 AM
  • Biut when he gets to step 5 it gives a 403 error, we do not understand what else is needed to authenticate his deployment? Any ideas?

    Hi David,

    First, please make sure your colleague was following the tutorial strictly. Second, make sure he has permission to deploy his project to your account (you can check this by click SETTINGS -> ADMINISTRATORS on Azure Portal). 

    Tuesday, November 06, 2012 1:56 AM
  • Hi,

    This turned out to be the difference between Linux recognising that the BIOS clock and the OS clock are 2 distinct things, it appears Windows OS does not. They were set to different values and Windows was running in a VM, so it must have setup the X.509 cert with a timestamp that was not yet valid timewise.


    StpDave

    Friday, November 09, 2012 10:50 AM
  • I think it is more confused for me now. You said you just add timestamp in his certificate and this make it work now?

    Anyway, you have resolved it yourself.

    • Marked as answer by stpdave Monday, November 12, 2012 9:28 AM
    Friday, November 09, 2012 11:21 AM
  • Simply aligned OS and BIOS clock times. Fixed

    StpDave

    • Marked as answer by stpdave Tuesday, November 13, 2012 10:24 AM
    Monday, November 12, 2012 9:28 AM