none
Access Page in VM Image from IE , Not Page from VM Role

    Question

  • One Quick QS :

    one quick QS : I have my VM image with Sharepoint 2010 deployed to Azure , have create VM role hosted service to access it. What URL should I give to access page in my VM Image and not VM Role.by default it gives a URL for VM role that just opens the IIS page but my actual application is installed in VM Image.

    Thanks,
    Pinto


    Pinto

    Tuesday, April 24, 2012 1:11 PM

Answers

  • Sharepoint hosting in Windows Azure is NOT supported nor recommended at this time. The stateless nature of the Windows Azure virtual machines makes is exceedingly difficult to reliable operation SharePoint in that envionment.

    I highly recommend you abandon the current line of thinking and re-evaluate the scenario. Otherwise you are likely setting yourself up for a long and painful road that ultimate will be less than optimal.

    Tuesday, April 24, 2012 1:24 PM
    Moderator
  • Hi,

    You can set Sharepoint page as the default page in IIS (Thread: http://forums.asp.net/t/1366144.aspx), or write it in web.config's System.WebServer section. If you have multiple web applications in your project, please set the Sharepoing as the startup project with 80 port.

    Another thing is if you want to use Sharepoint in Azure, you need extra lisences of SP.

    Hope this helps.


    Please mark the replies as answers if they help or unmark if not. If you have any feedback about my replies, please contact msdnmg@microsoft.com Microsoft One Code Framework

    Wednesday, April 25, 2012 2:55 AM
    Moderator

All replies

  • One Quick QS :

    one quick QS : I have my VM image with Sharepoint 2010 deployed to Azure , have create VM role hosted service to access it. What URL should I give to access page in my VM Image and not VM Role.by default it gives a URL for VM role that just opens the IIS page but my actual application is installed in VM Image.

    Thanks,
    Pinto

    Tuesday, April 24, 2012 1:07 PM
  • One Quick QS :

    one quick QS : I have my VM image with Sharepoint 2010 deployed to Azure , have create VM role hosted service to access it. What URL should I give to access page in my VM Image and not VM Role.by default it gives a URL for VM role that just opens the IIS page but my actual application is installed in VM Image.

    Thanks,
    Pinto


    Pinto

    Tuesday, April 24, 2012 1:20 PM
  • Sharepoint hosting in Windows Azure is NOT supported nor recommended at this time. The stateless nature of the Windows Azure virtual machines makes is exceedingly difficult to reliable operation SharePoint in that envionment.

    I highly recommend you abandon the current line of thinking and re-evaluate the scenario. Otherwise you are likely setting yourself up for a long and painful road that ultimate will be less than optimal.

    Tuesday, April 24, 2012 1:24 PM
    Moderator
  • Yes thats right , am not looking at Sharepoint to Maintain state,am using some of the features in My complex app.Moreover SP has been installed on my base image,so even if it reboots I dont have an issue. Lets say I want to display my default page in VM Image - IIS and not VM role IIS how can I achieve this

    Pinto

    Tuesday, April 24, 2012 2:41 PM
  • Hi,

    You can set Sharepoint page as the default page in IIS (Thread: http://forums.asp.net/t/1366144.aspx), or write it in web.config's System.WebServer section. If you have multiple web applications in your project, please set the Sharepoing as the startup project with 80 port.

    Another thing is if you want to use Sharepoint in Azure, you need extra lisences of SP.

    Hope this helps.


    Please mark the replies as answers if they help or unmark if not. If you have any feedback about my replies, please contact msdnmg@microsoft.com Microsoft One Code Framework

    Wednesday, April 25, 2012 2:55 AM
    Moderator
  • Pinto,

    the VM machine has a name - right?  Use this name in your path to sharePoint sites and site collections and that should do it.

    Wednesday, May 09, 2012 4:42 PM