none
Azure 1.3, Clean Install (no upgrade): Unable to start debugging on the remote server

    Question

  • Hi, I've installed visual studio 2010 and the azure sdk and i'm trying to create a hellocloud application. Pretty simple stuff. 

    However when I try and run the application I get an error saying that it is Unable to start debugging on the remote server. I found this thread and followed all the instruction in there to no avail: http://social.msdn.microsoft.com/Forums/en-US/windowsazuredevelopment/thread/45e01c3d-7c16-4ca7-999b-46cb20b38c1d

    I can create an ASP.NET application and debug that.

    If i try removing the sites node in ServiceDefinition.csdef instead of getting a message box the attempt to run the webrole is stopped with no other explanation other than 'Operation cancelled' in the status bar.

    Does anyone have any ideas?

    ed

    Wednesday, January 12, 2011 4:47 PM

Answers

  • Ok answering myself here for the benefit of others.

    One thing i didn't mention is that I'm using IIS7.

    There were a number of issues. Most of them could be solved by running without the debugger attached. My advice is to get the app working without the debugger and then run it with the debugger. The debugger gives no information on why it can't attach.

    First Issue

    The first issue was a permissions problem caused by the network service not having access to my roaming profile stored on a network drive.

    Second Issue

    The second issue is that the development fabric seems to create app pools named after guids to host applications in. These are setup by default to use 'integrated managed pipeline mode'. This causes a warning to be raised that is displayed as an error in IIS. The error gives helpful advice on how to change the app pool. However, every time you run the development fabrc with your web role the app pool is regenerated with 'integrated managed pipeline mode'. This means you'll have to go and edit the application pool each time (the setting is under advanced settings on the right click menu).

     

    Instead you can disable validation by using the following in your web.config: 

     

    <system.webServer>

         <validation validateIntegratedModeConfiguration="true" />

      </system.webServer>

     

     

    I'm not 100% clear on the impact of this at the moment.

    Third Issue

    The third issue was exceptions being thrown (with or without the debugger attached). The excexption text is:

    "The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state."

    This problem seems to be caused by having the project on a drive other than the system drive. I.e. on D: instead of C:. When i moved the project to the system drive the website was displayed correctly both with and without the debugger being attached.

     

    It's pretty poor that I had to fight so hard to get this up and running. And this was after i abandoned attempts on windows home 7 premium. Anyway there you go, hopefully this will help someone else save 2 days of wasted effort.


    • Marked as answer by Mog Liang Thursday, January 20, 2011 9:21 AM
    Wednesday, January 12, 2011 7:23 PM